Subject: [Simple] MSRP connection problem

From: Stallman <[email-masked]>
Date: Fri, 12 Aug 2005 22:01:22 +0800

hello, everyone.
 I occur an hard problem with MSRP session.
 I act as a conference server, I INVITE alice join my conference, 
but alice behind a firewall or alice in a private network, 
how can connect to alice ?
 
-- 
_______________________________
Reply mail in one business day.
Email: [email-masked]
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 12 Aug 2005 11:21:06 -0400

If Alice is in such a situation, then her UA should be configured to use 
an MSRP relay that may be accessed thru the firewall.

	Paul

Stallman wrote:
> Email: [email-masked] <mailto:[email-masked]>
> 
> 
> ------------------------------------------------------------------------
>

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 12 Aug 2005 13:34:32 -0400

I'm responding to simple too because maybe others want to discuss this.

If you were behind a residential NAT, you might need to use the services
of a relay out in the open internet - maybe its a free one, or maybe you
have to contract for service.

If you are in an enterprise, you probably have your own relay in the DMZ.

Either way, it works because you can connect to it, and it is in a place
where it can both make and receive connections. It sounds like you may
not have seen the MSRP relay draft.It is
draft-ietf-simple-msrp-relays-05.txt.

	Paul

Stallman wrote:
 > the real thing is there are many PC clients use NAT access to Internet.
 > they can not control the NAT policy,
 > does there need a relay and how to initial connection,
 > can you give me an example,? Thanks in advanced.
 >
 >
 > On 8/12/05, *Paul Kyzivat* <[email-masked]
 > <mailto:[email-masked]>> wrote:
 >
 >      > Email: [email-masked] <mailto:[email-masked]> <mailto:
 >     [email-masked] <mailto:[email-masked]>>
 >      >
 >      >
 >      >
 > 
 >      > [email-masked] <mailto:[email-masked]>

---

From: wangxiao <[email-masked]>
Date: Tue, 16 Aug 2005 20:49:28 +0800

Hi, Paul
I think of your meams is that relay is a proxy used to transmit the message.
The user behind a NAT,he can connect relay which provides service for him.
Because of use TCP,so connect relay successful,both relay and user can send 
data cross NAT. But there has another problem,MSRP uses INVITE and its
response
to exchange SDP(offer/answer).The INVITE how to cross NAT?( whether or not
the user must use TCP to receive INVITE?)

Thanks

Thank for 

Sean Wang

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Paul Kyzivat
Sent: Saturday, August 13, 2005 1:35 AM
To: Stallman
Cc: [email-masked]
Subject: Re: [Simple] MSRP connection problem

	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 16 Aug 2005 19:39:00 -0400

> I think of your meams is that relay is a proxy used to transmit the message.

Its not a SIP Proxy, but you could consider it a proxy in the generic sense.

> the user must use TCP to receive INVITE?)

There is extensive discussion of this subject on the SIP, SIPPING, and 
SIP-IMPLEMENTORS lists, as well as various drafts.

This subject is essentialy the same as for a voice call. The MSRP relay 
can be considered to be the SIMPLE equivalent of the TURN server that is 
used to relay RTP if NATs prevent something simpler.

	Paul