Subject: RE: [Simple] Clarification on XCAP path seperator ~~

From: "Fridy Sharon-Fridman" <[email-masked]>
Date: Thu, 25 Aug 2005 16:49:22 +0300

Hi Ted, 

It helps as it clarifies one can use percent-encoded and get translation
that will lead correctly to the XCAP resource. It was an issue of
interoperability between XDMS (OMA XCAP Servers) and clients vendors, in
latest OMA Fest 9.5.

Would you consider, at this RFC queue stage of XCAP, clarifying this
within XCAP I/D, explicitly? (now it appears as a possible consequence
from chapter 13 security discussion, and here in your E-Mail...)

Thanks,
--Fridy / Followap

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Ted Hardie
Sent: Wednesday, August 24, 2005 11:07 AM
To: Zisimopoulos, Haris, VF-Group; Simple WG
Subject: Re: [Simple] Clarification on XCAP path seperator ~~

At 3:43 PM +0100 8/24/05, Zisimopoulos, Haris, VF-Group wrote:
>Hi,
>
>I have question regarding whether the separator "~~" in XCAP may be
>escaped or not. This is important for interoperability.
>
>It is shown in all the examples as non escaped ~~ and not escaped
>(%7E%7E).
>
>However, in security section 13, it is mentioned that XCAP documents
may
>be identified (e.g. by firewalls) with the presence of ~~ in the URL,
>but this is just hint as URL procedures of RFC 2396 or RFC 3987 may
>apply, suggesting a possibility of escaping. Specifically RFC 2396
shows
>"~" as not a special character, and allows encoding (like for any other
>character).

The percent-encoded form would be just as identifiable; how would
this help?
		regards,
			Ted

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ted Hardie <[email-masked]>
Date: Thu, 25 Aug 2005 09:54:47 -0700

>from chapter 13 security discussion, and here in your E-Mail...)

Clarifying text can be added during AUTH48 if it implies no normative
change.  Do you have suggested text?
			regards,
				Ted Hardie