Subject: AW: [Simple] tel URIs in common policy

From: "Tschofenig, Hannes" <[email-masked]>
Date: Mon, 8 Aug 2005 15:55:37 +0200

hi martin, 

i think that we do not need a list. here are the reasons: 
we don't need to differentiate between sip and sips since we already do this with the identity conditions in the authorization policies. 
with regard to something like mailto and other application domains someone has to write a document how the authorization policies apply to their particular protocol and application domain anyway (similar to what jonathan did with the presence authorization policies). 

within the common-policy document we only need to indicate that there is an additional attribute that goes along with the id element (and a request for an iana registry). introducing the tel uri scheme (as a value in this newly defined attribute of the id element) would be done in the presence authz document since it makes sense there. 

ciao
hannes

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Martin Thomson
Gesendet: Montag, 8. August 2005 03:14
An: Henning Schulzrinne; [email-masked]
Betreff: RE: [Simple] tel URIs in common policy

You might want to make the scheme attribute a list: 
<one scheme="sip sips mailto impp" id="[email-masked]" /> 
After all, scheme implies a URI scheme and sip and sips are different (irrespective of any higher level decisions that may suggest otherwise).  If you want it simpler, then use a different name.
-----Original Message----- 
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henning Schulzrinne 
Sent: Monday, 8 August 2005 12:20 AM 
To: [email-masked] 
Subject: [Simple] tel URIs in common policy 

In a side conversation, Hannes suggested a solution to the tel URI 
problem we discussed during the WG meeting, akin to what's done in the 
geopriv coordinate system parameter, namely to have a parameter that 
identifies the scheme, as in 
<one scheme="tel" id="+1-212-555-1234"/> 
or 
<one scheme="sip" id="[email-masked]"/> 
if you really only want to match SIP identity sip:[email-masked]. 
The default with no scheme parameter is "matches any user@domain scheme". 
In order to complete finishing the section of the spec, I'd value quick 
feedback on the idea. 
Henning 
_______________________________________________ 
Simple mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/simple 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 10 Aug 2005 16:02:29 -0400

Brian,

Brian Rosen wrote:
> Paul
> 
> Not sure yet what I think of the basic idea, but
>    sip:[email-masked];user=phone
> should be equivalent to
>    tel:+1-232-1234

Well, I am suggesting that, when the purpose is identifying a caller for 
purposes of authorization.

According to 3261, only someone responsible for the foo.com domain can 
decide that these are equivalent. If you are not responsible for that 
domain then you are not permitted to conclude they are equivalent. So I 
am in some sense advocating violating 3261 in this case.

Unless we plan to change 3261, or look the other way while people 
violate it, this is a fundamental problem with using sip;user=phone 
address forms.

> So I think you CAN convert it to "enum" form.

According to sip routing rules, if you are not responsible for the 
foo.com domain, you *definitely* can't do this to route the sip address! 
You must simply route it based on the domain name.

I see this as a key difference between the two forms. With the tel form, 
anybody can just go to the PSTN, or use enum to find possible ways of 
reaching it. With the sip form, you can only reach the address via sip.

> You might have more problems with
>    sip:[email-masked]
> 
> That may be equivalent to
>    tel:1234;phone-context=foo.com
> but you don't know that a priori.

There is certainly nothing written down anywhere that would lead you to 
believe you could do that. If it can be done, it is only on a 
domain-specific basis, and so can only be done by someone responsible 
for the domain.

	Paul

> Brian
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Paul Kyzivat
> Sent: Wednesday, August 10, 2005 2:19 PM
> To: Aki Niemi
> Cc: [email-masked]; ext Henning Schulzrinne
> Subject: Re: [Simple] tel URIs in common policy
> 
> Aki,
> 
> 
> 
> Aki Niemi wrote:
> 
>>Hi,
>>
>>I kind of grew fond of the idea Cullen and I came up with in a private 
>>conversation, namely treating telephone numbers as domains similar to 
>>when issuing a DNS ENUM query.
>>
>>In essence, to match +1-232-555-1234, you'd have an identity conditions 
>>such as:
>>
>><many domain="4.3.2.1.5.5.5.2.3.2.1.e164.arpa" />
> 
> 
> Then what do you do with sip:[email-masked];user=phone ?
> 
> I don't think you can convert it to:
> 
>     4.3.2.1.5.5.5.2.3.2.1.foo.com
> 
> and if you could then it it wouldn't match the e164.arpa form.
> 
> 
>>This has an interesting additional property of being able to match based 
>>on country code, area code, etc. For example, to match all Finnish 
>>telephone numbers, you'd have:
>>
>><many domain="8.5.3.e164.arpa" />
> 
> 
> It only does if you declare that a domain matches anything it is the 
> tail of. You may sometimes want that, but I don't think you do in general.
> 
> 	Paul
> 
> 
>>Not being an expert on ENUM or E.164 in general, I suspect this is 
>>horribly broken, but it pleases the aesthethic eye.
>>
>>Cheers,
>>Aki
>>
>>ext Henning Schulzrinne wrote:
>>
>>
>>>In order to complete finishing the section of the spec, I'd value 
>>>quick feedback on the idea.
>>>
>>>Henning
>>>