Subject: [Simple] SIP multisubscription (some more details)

From: [email-masked]
Date: Tue, 9 Aug 2005 09:25:52 +0200

Hi all again,

I'd like to add some more detailed view on the problem I'm trying to solve.

I'm using specification draft-ietf-sipping-config-framework-06 that in section 4.6 allows to subscribe arbitrary AUID. This means, I'm sending to server a request in form (only significant headers listed)

SUBSCRIBE sip:[email-masked] SIP/2.0
To: "Example" sip:[email-masked]
From: "Example" sip:[email-masked];tag=12345
Call-ID: 1@localhost
CSeq: 1000 SUBSCRIBE
Event: sip-profile;profile-type=application;app-id=resource-lists
Accept: message/external-body, application/sdp

This means, I'm not specifying particular document, so the server retrieves all documents owned by user in request and subscribes them. The server sends exatly one response (200 OK) if all documents were subscribed correctly. Then, the server sends multiple NOTIFY requests, one for each of subscribed documents. The established dialogue then lasts until some of the created subscriptions is in different state than "terminated". The problems with this solution were stated in my previous email.

Martin Hynar

Senior Developer

TietoEnator
Czech Software Centre

Direct +420 599 096 022
E-mail [email-masked]

Technologicka 372/2
CZ-708 00 Ostrava

www.tietoenator.com

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 09 Aug 2005 08:52:38 -0400

Martin,

OK, that is different than I thought. Your question is then specifically 
about the sip-profile event type, not about the subscription mechanism 
in general.

	Paul