Subject: RE: [Simple] tel URIs in common policy

From: "Martin Thomson" <[email-masked]>
Date: Mon, 8 Aug 2005 11:13:42 +1000

You might want to make the scheme attribute a list:

<one scheme="sip sips mailto impp" id="[email-masked]" />

After all, scheme implies a URI scheme and sip and sips are different
(irrespective of any higher level decisions that may suggest otherwise).  If
you want it simpler, then use a different name.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Henning Schulzrinne
Sent: Monday, 8 August 2005 12:20 AM
To: [email-masked]
Subject: [Simple] tel URIs in common policy

In a side conversation, Hannes suggested a solution to the tel URI 
problem we discussed during the WG meeting, akin to what's done in the 
geopriv coordinate system parameter, namely to have a parameter that 
identifies the scheme, as in

<one scheme="tel" id="+1-212-555-1234"/>

or

<one scheme="sip" id="[email-masked]"/>

if you really only want to match SIP identity sip:[email-masked].

The default with no scheme parameter is "matches any user@domain scheme".

In order to complete finishing the section of the spec, I'd value quick 
feedback on the idea.

Henning

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 08 Aug 2005 03:35:54 -0400

Martin Thomson wrote:
> (irrespective of any higher level decisions that may suggest 
> otherwise).  If you want it simpler, then use a different name.

Yes, that was the intent. I'm doubtful of the utility of distinguishing 
sip and sips, but that's a separate issue.