Subject: Re: [Simple] Does IMS must using IPv6?

From: Cullen Jennings <[email-masked]>
Date: Fri, 21 Oct 2005 21:58:45 -0700

I've been puzzled by this too - I'm sure the answer is complicated and
involves understanding the many different IMSsz but as far as I can tell,
the short answer is that, in theory it does but in practice it does not.

On 8/30/05 7:56 AM, "Cheney Stallman" <[email-masked]> wrote:

> This problem puzzled me, Does IMS must using IPv6, or paritial using IPv6,
> or some other restriction?
>  
> Thanks in advanced.
>  
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Wed, 26 Oct 2005 13:51:25 +0300

Hi,
 
Originally IMS (the 3GPP version of it, I think that is the original one ;-) was specified exclusively on top of IPv6. The thinking was that mobile operators have no choise but to deploy v6 since in a few years there will be hundreds of millions of IP-equipped devices using their networks. Also, it was understood that the e-2-e media sessions would not work without a global address space.
 
However, in practice most GRPS/CDMA/WCDMA access networks still only provide IPv4+NAT. In practice all IMS products thus need to support v4 (some of them ALSO support v6), and most deployments have been done with v4. This, and the need for NAT traversal, has been noticed then also in the standards world, and consequently v4 support has been added to IMS on paper too, and currently 3GPP and ETSI TISPAN (who has adopted 3GPP IMS) are defining B2BUA/SBC-based solutions for NAT traversal. (SBCs seem to be much more popular among the operators than the IETF solutions such as STUN, TURN, ICE. Too bad...)
 
Markus

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of ext Cullen Jennings
Sent: 22 October, 2005 07:59
To: Cheney Stallman; [email-masked]
Subject: Re: [Simple] Does IMS must using IPv6?

I've been puzzled by this too - I'm sure the answer is complicated and involves understanding the many different IMSsz but as far as I can tell, the short answer is that, in theory it does but in practice it does not. 

 
Thanks in advanced.

  _____