Subject: [Simple] problem with filters and resource lists

From: [email-masked]
Date: Fri, 10 Feb 2006 11:09:16 +0100

Hello, 

In draft-ietf-simple-event-filter-funct par. 4.1. is described how rls server handles filters in subscription to resource list. Following situation is not clear to me:

I have 2 lists in one RLS (name it RLS1): 
	[email-masked] ([email-masked], [email-masked])
	[email-masked] ([email-masked], [email-masked])

Then I have subscribe with filter:

SUBSCRIBE sip:[email-masked] SIP/2.0
   ...
   <?xml version="1.0" encoding="UTF-8"?>
   <filter-set xmlns="urn:ietf:params:xml:ns:simple-filter">
     <filter id="999" uri="sip:[email-masked]">
	...
     </filter>
     <filter id="8439" uri="sip:[email-masked]">
	...
     </filter>
   </filter-set>

My current understanding is that the filter for alice will NOT be propagated and will be lost, because:
1/ it will not be propagated in the subscribe to list2, because list2 is under administrative control of RLS1.
2/ it will not be applied by the RLS1, because it is not under it's administrative control

This is similar to the example in the draft, but in the draft the lists are in different RLSs - therefore the filter for alice is propagated in the subscribe to list2.

This seems like an error to me, because the result is different for 2 lists in the same RLSs and in 2 different RLSs.

Can someone explain this? 

Thank you,

Silvestr Peknik
Software Specialist

TietoEnator
Czech Software Center
Phone +420 599 096 027
E-mail [email-masked]  
 
Vystavni 292/13
CZ-709 16 Ostrava
 
www.tietoenator.com

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Hisham Khartabil <[email-masked]>
Date: Fri, 10 Feb 2006 12:54:48 +0100

I guess you are referring to the following text:

"If the URI indicated by the filter is for one resource whose URI is
    NOT under the RLS administrative control, the RLS propagates the
    filter to all the fanned out subscriptions sent to destinations
    outside the administrative domain of the RLS."

This seems to have the limitation you mention below.

Would the following text fix it? would it break anything else?

"If the URI indicated by the filter is for one resource whose URI is
    NOT under the RLS administrative control, the RLS propagates the
    filter to all the fanned out."

Hisham

On Feb 10, 2006, at 11:09 AM, [email-masked] wrote:

> Hello,
>
> In draft-ietf-simple-event-filter-funct par. 4.1. is described how rls 
> server handles filters in subscription to resource list. Following 
> situation is not clear to me:
>
> This is similar to the example in the draft, but in the draft the 
> lists are in different RLSs - therefore the filter for alice is 
> propagated in the subscribe to list2.
>
> This seems like an error to me, because the result is different for 2 
> lists in the same RLSs and in 2 different RLSs.
>