Subject: [Simple] Filtering - 'include' element

From: <[email-masked]>
Date: Mon, 27 Feb 2006 15:57:16 +0100

Hello,

I have again some questions on event notification filtering and I will be very glad if someone could answer/comment them.

1. if some element is "included" (using an filter-set/filter/what/include element), does it mean that all its child-nodes are included as well? Example:

Suppose the "original" presence document to be:

<presence ...>

  <tuple id="1">

    <status><basic>open</basic></status>

  </tuple>

</presence>

I subscribe with the following filter:

<filter-set>

  <filter id="f1">

    <what>

      <include type="xpath">/presence/tuple[id='1']</include>

    </what>

  </filter>

</filter-set>

Will the resulting document look like this?:

<presence ...>

  <tuple id="1">

    <status><basic>open</basic></status>

  </tuple>

</presence>

What if I 'include' the namespace instead of xpath? Is the result same as above?

Thanks very much, in advance.

Best regards,

Michal Burda

Software Specialist

TietoEnator a.s.

Czech Software Centre

Direct: +420 599 096 020

Fax: +420 599 096 110

E-mail: [email-masked]
Výstavní 292/13

CZ-709 16 Ostrava

CZECH REPUBLIC

www.tieotoenator.com <http://www.tieotoenator.com/> 

Please note: The information contained in this message may be legally privileged and confidential and protected from disclosure. If the reader of this message is not the intended recipient, you are hereby notified that any unauthorised use, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify us immediately by replying to the message and deleting it from your computer. Thank you.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Hisham Khartabil <[email-masked]>
Date: Mon, 27 Feb 2006 16:15:22 +0100

You only include whatever is mandatory according to the schema in order 
for the xml document to be valid.

Hisham

On Feb 27, 2006, at 3:57 PM, <[email-masked]> wrote:

>
> Hello,
>  
> I have again some questions on event notification filtering and I will 
> be very glad if someone could answer/comment them.
>  
> 1. if some element is „included“ (using an 
> filter-set/filter/what/include element), does it mean that all its 
> child-nodes are included as well? Example:
>  
> Suppose the „original“ presence document to be:
>  
> <presence ...>
>   <tuple id=“1“>
>   <filter id=“f1“>
>       <include type=“xpath“>/presence/tuple[id=‘1‘]</include>
>     </what>
>   </filter>
> </filter-set>
>  
>   <tuple id=“1“>
> What if I ‚include‘ the namespace instead of xpath? Is the result same 
> as above?
>  
>  
> www.tieotoenator.com
> Please note: The information contained in this message may be legally 
> privileged and confidential and protected from disclosure. If the 
> reader of this message is not the intended recipient, you are hereby 
> notified that any unauthorised use, distribution or copying of this 
> communication is strictly prohibited. If you have received this 
> communication in error, please notify us immediately by replying to 
> the message and deleting it from your computer. Thank you.
>