Subject: [Simple] XCAP Etag constraint with HTTP

From: "Arjun Roychowdhury" <[email-masked]>
Date: Thu, 23 Feb 2006 15:37:29 -0500

Hi,
Suppose I am using HTTP with XCAP to pass along auth. policies

HTTP does not mandate that requests have If-Match, however, in my case, I
want to accept the PUT only if it had If-Match

So

a) on receving a perfectly formed PUT without If-Match, can I return a 412
or is that return code only possible if the PUT had If-Match in the first
place.
If a) is not a possible solution:

b)
11.1 of xcap-08 allows me to respond to PUT with <uniqueness-failure> where
'uniqueness constraint' is an application defined criteria.
Can I return a 409  error with <uniqueness-failure> in the xcap-error body ?

regds
arjun

--
Arjun Roychowdhury
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Arjun Roychowdhury" <[email-masked]>
Date: Thu, 23 Feb 2006 17:21:17 -0500

Sorry, please replace <uniqueness-failure> with <constraint-failure>
regds
arjun

On 2/23/06, Arjun Roychowdhury <[email-masked]> wrote:
> 11.1 of xcap-08 allows me to respond to PUT with <uniqueness-failure>
> where 'uniqueness constraint' is an application defined criteria.