Subject: [Simple] Filtering - trigger evaluation

From: <[email-masked]>
Date: Fri, 24 Feb 2006 09:14:26 +0100

Hi everybody,

I'm working on some topics related to Event notification filtering and I have reached an issue, which solution is not completely defined in specification. Could someone answer me some questions?

The problem is as follows:

1. Client A subscribes to the presence document of client B. Client A sends a filter with trigger in a body of the SUBSCRIBE request.

2. Client A receives notification.

3. Client B's presence state changes, so the notification has to be sent, but the filtering trigger blocks that notification, so nothing is sent to client A.

4. Client B's presence state changes again...

Which "old" presence document has to be used together with the fresh one in order to evaluate filtering triggers? Is it a notification body that was produced (but has not been sent) in step 3? Or is it the last notification that was really sent to client A (notification from step 2)?

Thanks for any suggestions

Best regards,

Michal Burda

Software Specialist

TietoEnator a.s.

Czech Software Centre

Direct: +420 599 096 020

Fax: +420 599 096 110

E-mail: [email-masked]
Výstavní 292/13

CZ-709 16 Ostrava

CZECH REPUBLIC

www.tieotoenator.com <http://www.tieotoenator.com/> 

Please note: The information contained in this message may be legally privileged and confidential and protected from disclosure. If the reader of this message is not the intended recipient, you are hereby notified that any unauthorised use, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify us immediately by replying to the message and deleting it from your computer. Thank you.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Hisham Khartabil <[email-masked]>
Date: Fri, 24 Feb 2006 12:49:48 +0100

The filter was built according to what the subscriber has, so I would 
say the last notification that was really sent to client A 
(notification from step 2) is the one used.

Hisham

On Feb 24, 2006, at 9:14 AM, <[email-masked]> wrote:

>
> Hi everybody,
>  
> I'm working on some topics related to Event notification filtering and 
> I have reached an issue, which solution is not completely defined in 
> specification. Could someone answer me some questions?
>  
> 1. Client A subscribes to the presence document of client B. Client A 
> sends a filter with trigger in a body of the SUBSCRIBE request.
> 3. Client B's presence state changes, so the notification has to be 
> sent, but the filtering trigger blocks that notification, so nothing 
> is sent to client A.
> Which "old" presence document has to be used together with the fresh 
> one in order to evaluate filtering triggers? Is it a notification body 
> that was produced (but has not been sent) in step 3? Or is it the last 
> notification that was really sent to client A (notification from step 
> 2)?
>  
> www.tieotoenator.com
> Please note: The information contained in this message may be legally 
> privileged and confidential and protected from disclosure. If the 
> reader of this message is not the intended recipient, you are hereby 
> notified that any unauthorised use, distribution or copying of this 
> communication is strictly prohibited. If you have received this 
> communication in error, please notify us immediately by replying to 
> the message and deleting it from your computer. Thank you.
>