Subject: [Simple] MSRP with Deferred-delivery Messaging

From: "이장원" <[email-masked]>
Date: Sat, 4 Feb 2006 01:02:37 +0900

Hi, everyone.

My question is :
- MSRP is session-based.
- SMS/MMS is somewhat kind of page-mode messaging.
- Can MSRP support SMS/MMS nicely?

MSRP may be unsuitable for serving SMS/MMS, in particular, mobile environment.

Most mobile handset cannot support multi-socket.

Assuming that MSRP serves deferred-delivery messaging such as SMS/MMS,
resources(e.g. TCP connection) must quickly be released as soon as the completion of sending a message.

But MSRP connection is released only if user actively performs BYE.

Is there any method to quickly disconnect MSRP session without waiting for user's intervention
in the case of deferred-delivery(SMS/MMS)?

Or, is MESSAGE-based mechanism more desirable for this case?

---------------------------------------------------
Jang-Won Lee / Senior
Data N/W Development Team, Network Group, KTF
M) +82-10-3010-1866
L) +82-31-909-0670
Fax) +82-31-909-0661
---------------------------------------------------

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Hisham Khartabil <[email-masked]>
Date: Mon, 6 Feb 2006 10:32:58 +0100

>   - Can MSRP support SMS/MMS nicely?

What do you mean by support? Do you mean mimic the SMS/MMS service or 
interwork through a GW?

> Or, is MESSAGE-based mechanism more desirable for this case?

Yes. Although some have showed interest in using MSRP for MMS like 
service when the content of the message is large.

Regards,
Hisham