Subject: [Simple][MSRP]Is a MSRP message with both an empty body and a Content-Type a correct massage?

From: "Xiang Ting" <[email-masked]>
Date: Wed, 5 Apr 2006 21:10:49 +0800

It is said in the draft about MSRP that "If the request has a body,
   it must contain a Content-Type header field."  Now, I have a question to ask.
Is a MSRP message with both an empty body(only CRLF appears) and a
Content-Type a correct massage?

e.g.
"MSRP tdsaff34r35d SEND\r\n"
"To-Path: msrp://10.70.110.158:7654/sfasf439;tcp\r\n"
"From-Path: msrp://10.71.106.33:33322/afd43rfes;tcp\r\n"
"Message-ID: dsdf34r\r\n"
"Content-Type: text/plain\r\n"
"\r\n"
"\r\n"
"-------tdsaff34r35d$\r\n"

"MSRP tdsaff34r35d REPORT\r\n"
"To-Path: msrp://10.70.110.158:7654/sfasf439;tcp\r\n"
"From-Path: msrp://10.71.106.33:33322/afd43rfes;tcp\r\n"
"Message-ID: dsdf34r\r\n"
"Status: 000 200 OK\r\n"
"Content-Type: text/plain\r\n"
"\r\n"
"\r\n"
"-------tdsaff34r35d$\r\n"

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Wed, 5 Apr 2006 08:18:34 -0500

It depends on the content-type value. A lone CRLF is a legal content  
for text/plain. It would not be legal for all possible MIME types.

Hope this helps!

Ben.