Subject: [Simple] draft-ietf-simple-xcap: how to PUT attribute with namespace

From: <[email-masked]>
Date: Thu, 13 Apr 2006 17:34:27 +0200

Hello, 

is it possible to PUT an attribute with namespace? 

Example:
I have document "index":

<?xml version="1.0"?>
<root>
	<list/>
</root>

I send following request:
 
PUT /.../index/~~/root/list/@ns:uri?xmlns(ns="ns_url") HTTP/1.1
...
   
"uri"

Will it result following document?

<root xmlns:ns="ns_url">
	<list ns:uri="uri"/>
</root>

Thank you, 

Silvestr Peknik
Software Specialist
TietoEnator

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 18 Apr 2006 10:37:45 -0400

inline.

> is it possible to PUT an attribute with namespace? 

The namespace attribute can appear in a PUT, but its only purpose is to 
define namespace bindings for the matching operation on the URI.

> Will it result following document?

No. The xcap server would insert the attribute ns:uri="uri", but then 
when it verifies that the r-uri selects the thing that was just 
inserted, it will find that it doesnt since the ns prefix is not 
defined. Thus, the request will fail with a 409.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com