Subject: [Simple] Merging PIDF documents from multiple sources

From: "Noga Tor" <[email-masked]>
Date: Thu, 27 Apr 2006 14:51:35 +0300

Hi

Im trying to understand what should be the strategy when merging doucments
that were published from different sources.

Should all published person\tuple\device elements be sent to the Watcher as
received?

Or should a merge strategy be implemented?

How should the Notify message look like? (assuming the watcher did not add
any filters to the subscription)
Should it contain all the published elements? (multiple person/device
elements)

Or should it contain merged publish elements? (one person/device element)

Or should it contain just the last published elements? (one person/device
element)

Thanks

Noga Tor
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 27 Apr 2006 15:14:47 +0100

I believe this was intended to be covered by:
 
draft-rosenberg-simple-presence-processing-model-01.txt
 
which expired in February and is therefore no longer on the i-d area.
 
It can however be found here:
 
http://www.softarmor.com/wgdb/docs/draft-rosenberg-simple-presence-processing-model-01.txt <http://www.softarmor.com/wgdb/docs/draft-rosenberg-simple-presence-processing-model-01.txt> 
 
regards
 
Keith

-----Original Message-----
From: Noga Tor [mailto:[email-masked]]
Sent: 27 April 2006 12:52
To: [email-masked]
Subject: [Simple] Merging PIDF documents from multiple sources

Hi 

Im trying to understand what should be the strategy when merging doucments that were published from different sources.

Should all published person\tuple\device elements be sent to the Watcher as received?

How should the Notify message look like? (assuming the watcher did not add any filters to the subscription)

Should it contain all the published elements? (multiple person/device elements)

Or should it contain just the last published elements? (one person/device element)

Thanks

Noga Tor