Subject: Re: [Simple] srtp negotiation on SIP (sdp message)

From: Adam Roach <[email-masked]>
Date: Tue, 21 Mar 2006 18:58:55 -0600

이종필 wrote:

>I want to find some draft or document for srtp key negotiation for sip
>by using sdp messages.
>  
>

The issue is extremely complicated at the moment; there are 11 competing
proposals right now for ways to negotiate encryption keys for RTP.
Relevant documents include:

RFC 3830
RFC 3711
draft-ietf-mmusic-kmgmt-ext-15
draft-ietf-mmusic-sdescriptions-12
draft-ietf-msec-mikey-rsa-r-02
draft-ietf-msec-mikey-dhhmac-11
draft-ietf-msec-newtype-keyid-05
draft-mcgrew-srtp-ekt-00
draft-baugher-mmusic-sdp-dh-00
draft-zimmermann-avt-zrtp-01
draft-tschofenig-avt-rtp-dtls-00
draft-fischl-sipping-media-dtls-00
draft-fischl-mmusic-sdp-dtls-00
draft-rescorla-tls-partial-00
draft-modadugu-dtls-short-00
draft-lehtovirtya-srtp-rcc-00
draft-fries-msec-applicability-00
draft-wing-mmusic-sdes-early-media-00

Dan Wing did the work to put together this list. He has also done a very
good job analyzing the current situation. See:

http://www3.ietf.org/proceedings/06mar/slides/raiarea-1.ppt

/a

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 6 Apr 2006 06:29:30 -0500

I agree with Adam's summary, and can only add (from my impression of the 
discussion around 
http://www3.ietf.org/proceedings/06mar/slides/raiarea-1.ppt#21) that none of 
the 11 competing proposals are so obviously the right answer that we should 
pick one existing proposal and forget the other 10 proposals...

Spencer

----- Original Message ----- 
From: "Adam Roach" <[email-masked]>

RFC 3830
RFC 3711

/a