Subject: [Simple] route set handling for forked SUBSCRIBEs

From: "Jeroen van Bemmel" <[email-masked]>
Date: Sun, 23 Apr 2006 21:34:04 +0200

Hi,

A question about RFC3265 regarding route set handling: Suppose I have a setup with a Subscriber (S), a forking proxy (P) and two notifiers (N1 and N2). S sends a SUBSCRIBE, P forks it to N1 and N2 while adding a Record-Route header specific for each notifier.

P will receive a 2xx response from both N1 and N2. Whichever response is received first will be passed on to S, the second response is discarded (since P forks, it must behave transaction statefully). P then receives 2 NOTIFY requests, one from N1 and one from N2. It forwards both to S, which creates a new dialog for each.

Question is now: how does S establish the correct route set for the NOTIFY, for which no 2xx response was received?

According to RFC3265 P is required to Record-Route all NOTIFYs resulting from a forked SUBSCRIBE, probably because that enables S to construct the route set for each subscription. The rule should then probably be something like "if 2xx was received for SUBSCRIBE, use the route set from that, else use the route set found in the first NOTIFY"

However, RFC3265 is silent on this

Best regards,

Jeroen van Bemmel
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: 이종필 <[email-masked]>
Date: Mon, 24 Apr 2006 08:47:41 +0900

Hi.
 
In my experience, that situation will be happened freequently, and have
to solve that routing route for each UA.
 
SUBSCRIBE and NOTIFY is request method. 
 
So at that case,  receiver side have to make route set regarding as
request message.
 
BEST, JP.

-----Original Message-----
From: Jeroen van Bemmel [mailto:[email-masked]] 
Sent: Monday, April 24, 2006 4:34 AM
To: [email-masked]
Subject: [Simple] route set handling for forked SUBSCRIBEs

Hi,
 
A question about RFC3265 regarding route set handling: Suppose I have a
setup with a Subscriber (S), a forking proxy (P) and two notifiers (N1
and N2). S sends a SUBSCRIBE, P forks it to N1 and N2 while adding a
Record-Route header specific for each notifier.
 
P will receive a 2xx response from both N1 and N2. Whichever response
is received first will be passed on to S, the second response is
discarded (since P forks, it must behave transaction statefully). P
then receives 2 NOTIFY requests, one from N1 and one from N2. It
forwards both to S, which creates a new dialog for each.
 
Question is now: how does S establish the correct route set for the
NOTIFY, for which no 2xx response was received?
 
According to RFC3265 P is required to Record-Route all NOTIFYs
resulting from a forked SUBSCRIBE, probably because that enables S to
construct the route set for each subscription. The rule should then
probably be something like "if 2xx was received for SUBSCRIBE, use the
route set from that, else use the route set found in the first NOTIFY"

Best regards,
 
Jeroen van Bemmel