Subject: some confusion//Re: [Simple] I-D ACTION:draft-ietf-simple-imdn-00.txt

From: Lunjian Mu <[email-masked]>
Date: Thu, 01 Jun 2006 16:39:28 +0800

Hi Burger & Khartabil,
I have some confusion about the draft:
1.in MSRP section, it said: " For SEND requests that are IMDNs, the sender MUST NOT request a
   delivery report (an MSRP REPORT to a SEND request).  I.e.  It MUST
   populate the request with a Failure-Report header field with the
   value "no" and with a Success-Report header field with value "no" (or
   alternatively leave out that header field since it defaults to "no").". I do not know what the reason is?
   By my understanding the SIP MESSAGE can support that both delivery report and IMDN can be requested in a SIP MESSAGE.

2.After  the MSRP SEND have request a read report and the response is not come, but the MSRP channel is disconnented, how the receiver can response the read report? can using SIP MESSAGE, or reconnet the MSRP channel?  It is common scenario for Store and Forward IM.

Best regards,
 
Lunjian Mu

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, May 31, 2006 6:50 AM
Subject: [Simple] I-D ACTION:draft-ietf-simple-imdn-00.txt

>A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the SIP for Instant Messaging and Presence Leveraging Extensions Working Group of the IETF.
> 
> Title : Instant Message Disposition Notification
> Author(s) : E. Burger, H. Khartabil
> Filename : draft-ietf-simple-imdn-00.txt
> Pages : 27
> Date : 2006-5-30
> 
> Instant Messaging (IM) refers to the transfer of messages between
> users in real-time.
> 
> This document extends Message/CPIM message format to enable endpoints
> to request, create and send IM Disposition Notifications (IMDN),
> including delivery and read notifications, for page-mode as well as
> session mode instant messages.  This document also describes how SIP
> and MSRP entities behave using this extension.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-simple-imdn-00.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in the body of the message.  
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> 
> Internet-Drafts are also available by anonymous FTP. Login with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> "get draft-ietf-simple-imdn-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> [email-masked].
> In the body type:
> "FILE /internet-drafts/draft-ietf-simple-imdn-00.txt".
> 
> NOTE: The mail server at ietf.org can return the document in
> MIME-encoded form by using the "mpack" utility.  To use this
> feature, insert the command "ENCODING mime" before the "FILE"
> command.  To decode the response(s), you will need "munpack" or
> a MIME-compliant mail reader.  Different MIME-compliant mail readers
> exhibit different behavior, especially when dealing with
> "multipart" MIME messages (i.e. documents which have been split
> up into multiple messages), so check your local documentation on
> how to manipulate these messages.
> 
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

--------------------------------------------------------------------------------

> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
>

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Hisham Khartabil <[email-masked]>
Date: Wed, 14 Jun 2006 15:06:00 +0200

This version of the Instant Messaging Disposition Notification draft 
represents consensus from the design team (with very few open issues). 
The authors would appreciate some review and comments before the next 
IETF meeting in Montreal in order to allow us to properly discuss any 
open issues that are raised.

Thanks,
Hisham

On May 31, 2006, at 12:50 AM, [email-masked] wrote:

> This draft is a work item of the SIP for Instant Messaging and 
> Presence Leveraging Extensions Working Group of the IETF.
>
> Content-Type: text/plain
> Content-ID: <[email-masked]>
>

---

From: Hisham Khartabil <[email-masked]>
Date: Wed, 14 Jun 2006 16:16:55 +0200

On Jun 1, 2006, at 10:39 AM, Lunjian Mu wrote:

>    alternatively leave out that header field since it defaults to  
> "no").". I do not know what the reason is?
>    By my understanding the SIP MESSAGE can support that both delivery  
> report and IMDN can be requested in a SIP MESSAGE.

MSRP draft defines delivery report in the draft itself while SIP  
MESSAGE RFC does not. The IMDN draft indicates that.

>
> 2.After  the MSRP SEND have request a read report and the response is  
> not come, but the MSRP channel is disconnented, how the receiver can  
> response the read report? can using SIP MESSAGE, or reconnet the MSRP  
> channel?  It is common scenario for Store and Forward IM.

The read report is like any other SEND request. You would follow the  
procedures defined in MSRP base draft to reconnect and send. I guess  
the read question is: should the reports still be sent even if the TCP  
connection was lost? I'm on the fence on that one. Any comments by  
others?

Hisham

---

From: Lunjian Mu <[email-masked]>
Date: Thu, 15 Jun 2006 08:02:08 +0800

----- Original Message ----- 
From: "Hisham Khartabil" <[email-masked]>
To: "Lunjian Mu" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, June 14, 2006 10:16 PM
Subject: Re: some confusion//Re: [Simple] I-D ACTION:draft-ietf-simple-imdn-00.txt

> MESSAGE RFC does not. The IMDN draft indicates that.

What my question is: why the MSRP can not support both delivery report and IMDN in one MSRP SEND?