Subject: [Simple] Could you review my draft please?

From: Harrison Zhou <[email-masked]>
Date: Fri, 23 Jun 2006 09:46:55 +0800

Dear sip experts,

I've written a draft and this draft describe a new method for the Presence
Server to process presence in inter-domain scenarios .
The new method void duplicated messaging between Presence Servers.
I am interested in SIMPLE and will work on it. This is my first draft and I
hope someone can review my draft and give me some comments. Thanks!

you can fetch a copy from:
http://www.ietf.org/internet-drafts/draft-zhou-simple-hierarchical-presence-
00.txt

Regards,
Hong

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Rohan Mahy" <[email-masked]>
Date: Mon, 26 Jun 2006 07:57:38 -0700

Hi Zhou,

I may want to advertise different presence to different watchers.
Some commercial presence systems already offer a primitive version of
this ability now where the presentity advertises availability to one
group (typically close friends or coworkers) and advertises that they
are busy to the rest of their watchers.  Similarly, I may want to
provide very basic presence to most watchers, but very rich presence,
possibly with geolocation information, to more trusted watchers.

thanks,
-rohan

I can't do this if only one PIDF document is sent between

---

From: Dave Cridland <[email-masked]>
Date: Mon, 26 Jun 2006 16:37:52 +0100

The below looks similar to a discussion happening in Jabber's 
Standards JIG, aimed at streamlining presence stanzas between domains 
in XMPP, which is pretty much the same issue tackled by Zhou's draft 
here, and I understand things.

It might be useful to examine what is being considered there.

-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade

---

From: Harrison Zhou <[email-masked]>
Date: Tue, 27 Jun 2006 09:31:55 +0800

Hi Rohan,
I think this is a good issue.
I doesn't know how to achieve the function you mentioned in currently SIMPLE
presence. Maybe a feasible method is : the UA has its policy to different
watchers, and UA tell its policy to its Presence Server, So the Presence
Server can show different state to different watchers. Is it right? So in my
draft, the Presence Server can tell UA's policy to another Presence Server.

Regards,
Hong

-----Original Message-----
From: Rohan Mahy [mailto:[email-masked]] 
Sent: Monday, June 26, 2006 10:58 PM
To: Harrison Zhou
Cc: Robert Sparks; [email-masked]; Jonathan Rosenberg; Spencer
Dawkins; [email-masked]; [email-masked];
[email-masked]; Simple WG
Subject: Re: [Simple] Could you review my draft please?

Hi Zhou,

thanks,
-rohan