Subject: [Simple] I-D ACTION:draft-ietf-simple-messaging-requirements-00.txt

From: [email-masked]
Date: Fri, 23 Jun 2006 10:50:01 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the SIP for Instant Messaging and Presence Leveraging Extensions Working Group of the IETF.

	Title		: Advanced Instant Messaging Requirements for the Session Initiation Protocol (SIP)
	Author(s)	: M. Isomaki, J. Rosenberg
	Filename	: draft-ietf-simple-messaging-requirements-00.txt
	Pages		: 11
	Date		: 2006-6-23
	
Session Initiation Protocol (SIP) supports the basic instant
messaging service in both page and session mode.  This document
defines a set of requirements for instant messaging capabilities that
are beyond the scope of the baseline specifications.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-simple-messaging-requirements-00.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-simple-messaging-requirements-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-simple-messaging-requirements-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: <[email-masked]>
Date: Wed, 28 Jun 2006 17:50:26 +0300

Hi,

I have taken the editorship of the Advanced Messaging Requirements document. The purpose of the document is to cover all the messaging related requirements that SIMPLE WG is planning to work on (or in some cases has already worked on) beyond the basic page or session mode functionality provided by SIP MESSAGE and MSRP. Currently this includes the following items: 
- IM dispostion notifications (IMDN) 
- Is-Composing
- Content capabilities
- Page-mode groups

The -00 version of the WG document has just been submitted. The baseline for the WG document was an old draft by Jonathan Rosenberg, draft-rosenberg-simple-messaging-requirements-01 that has been expired for quite a while now.  The update was based on discussion within an ad hoc design team formed during IETF 65: myself, SIMPLE chairs, Eric Burger, Ben Campbell, Sean Olson, Paul Kyzivat, Aki Niemi and Salvatore Loreto. The main purpose at this point was to remove all the requirements that we did not think SIMPLE anymore had interest to address. At the moment the draft represents the rough consensus within the team, and now a wider review and discussion within the SIMPLE WG is expected.

The main changes compared to the original draft are listed below. Please review the draft and comment, especially if you think there are messaging related functions that you think SIMPLE should work upon and that are not covered in the current draft.

---

Here are the main things I tried to do:
- Remove all the requirements that we think we won't even try to address. In case this was not clear based on the discussion so far, I marked the requirement as an open issue.
- Point out the cases where there are already existing specifications (RFCs or mature WG drafts) that provide solutions to the requirements. In practice these include MSRP, is-composing and multi-recipient MESSAGE request specs.

More specific changes since the version I received from Jonathan:
- Added myself as a co-author. I kept Jonathan's name there as well, since a lot of text is from him. It's up to Jonathan if he wants to remain as a co-author.
- Made small changes in abstract and intro to explain that the document mainly lists requirements that are not addressed by baseline SIP MESSAGE or MSRP specs but are on more advanced messaging capabilities. Also explained that in some cases the specifications meeting the reqs actually already exist, and in that case those specs are called out in the relevant sections.
- Added references to is-composing and multi-recipient MESSAGE specs in sections where reqs met by them are presented. Also pointed out that MSRP itself already addresses the req about maximum message size.
- Section 2
  - Renamed delivery notifications as disposition notifications
  - Removed reqs 9, 14, 18, 19, 20
  - Reworded most of the other reqs. Some of this is just new terminology, but there are also other changes. Please review!
  - There are open issues related to four requirements. The most important of them is related to aggregation.
  - Note that there are now no reqs related to session-mode IMDN
- Section 3
  - Requirements remained untouched. I just added a comment that req 8 is not addressed by the existing is-composing RFC. So, should it be removed?
- Section 4
  - Reqs were untouched. Added a comment that req 1 is already met by MSRP. Req 2 is an open issue.
- Section 5
  - Requirements were untouched. I believe multi-recipient MESSAGE supports all of them.

---

Regards,
	Markus

-------------------------------
Markus Isomäki
[email-masked]
-------------------------------

>-----Original Message-----
>From: ext [email-masked] [mailto:[email-masked]] 
>Sent: 23 June, 2006 17:50
>To: [email-masked]
>Cc: [email-masked]
>Subject: [Simple] I-D 
>ACTION:draft-ietf-simple-messaging-requirements-00.txt
>
>This draft is a work item of the SIP for Instant Messaging and 
>Presence Leveraging Extensions Working Group of the IETF.
>
>	Title		: Advanced Instant Messaging 
>Requirements for the Session Initiation Protocol (SIP)
>	Filename	: 
>draft-ietf-simple-messaging-requirements-00.txt
>	Pages		: 11
>	Date		: 2006-6-23
>	
>messaging service in both page and session mode.  This 
>document defines a set of requirements for instant messaging 
>capabilities that are beyond the scope of the baseline specifications.
>
>
>
>To remove yourself from the I-D Announcement list, send a 
>message to [email-masked] with the word 
>unsubscribe in the body of the message.  
>Internet-Drafts are also available by anonymous FTP. Login 
>with the username "anonymous" and a password of your e-mail 
>address. After logging in, type "cd internet-drafts" and then
>http://www.ietf.org/shadow.html or 
>ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
>	"FILE 
>/internet-drafts/draft-ietf-simple-messaging-requirements-00.txt".
>