Subject: [Simple] FW: clarification regarding 'Require' header usage in draft-ietf-simple-event-list-07.txt

From: "Shetti Shrinivas-Q16945" <[email-masked]>
Date: Tue, 13 Jun 2006 13:40:03 +0800

can some one please clarify this?

________________________________

From: Shetti Shrinivas-Q16945 
Sent: Friday, June 09, 2006 2:51 PM
To: [email-masked]'
Cc: Kelley Sean-Q12059
Subject: FW: clarification regarding 'Require' header usage in
draft-ietf-simple-event-list-07.txt

In the scenario I've mentioned, the assumption is that  UACs do have
knowledge about whether they are subscribing to list URI or NOT. 
So, is there any harm if  UAC uses  'Require:eventlist', when  it knows
that the request URI is a list URI?
 
thanks,
Shetti

________________________________

From: Shetti Shrinivas-Q16945 
Sent: Friday, June 09, 2006 2:12 PM
To: [email-masked]'
Cc: Kelley Sean-Q12059
Subject: clarification regarding 'Require' header usage in
draft-ietf-simple-event-list-07.txt

hi,
above draft has following statement in section 4.2
------------------------------------------------------------------------
   Including "eventlist" in a "Require" header field in a SUBSCRIBE
   request serves no purpose except breaking interoperability in certain
   cases, and is consequently NOT RECOMMENDED.
------------------------------------------------------------------------
Can anyone clarify why do we discourage use of 'Require' header?
My perception about this header being used in SUBSCRIBE is that, it is
not going to cause any harm or issue. I might be missing something.
I have following scenario in mind.
All the presence SUBSCRIBE messages land at a proxy. The proxy server
decides to route the request to either 'RLS server' or 1-1 presence
server.
Now, if client can use 'Require: eventlist', this is definite indication
for the proxy to route the request to RLS server. Rest of the
subscriptions can go to 1-1 presence server.
thanks and best regards,
Shetti
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Gadigeppa Malagund" <[email-masked]>
Date: Tue, 13 Jun 2006 12:03:21 +0530

Your suggestion is appropriate and enhances performance of the n/w.

When "Supported: eventlist" is included in subscribe, proxy by default
forwards request to 1-1 presence server depending on "Event: presence".
For this if request URI is Group URI, then proxy gets "404 not found"
response from the 1-1 PS.
Proxy sees whether there is header "Supported: eventlist" and then forwards
to RLS.

So if "Require: eventlist" is included then proxy can directly forward this
request RLS.

So this RECOMMENDTION is not specific to presence group subscribe however
more to do with usage of "Require" header by the client.

Note that incoming NOTIFYs from RLS have MUST "Require: eventlist" header
NOT "Supported"

Regards,
Gadi

On 6/13/06, Shetti Shrinivas-Q16945 <[email-masked]> wrote:
>  ------------------------------
> *From:* Shetti Shrinivas-Q16945
> *Sent:* Friday, June 09, 2006 2:51 PM
>
> *To:* [email-masked]'
> *Cc:* Kelley Sean-Q12059
> *Subject:* FW: clarification regarding 'Require' header usage in
> So, is there any harm if  UAC uses  'Require:eventlist', when  it knows that
> the request URI is a list URI?
>
> thanks,
> Shetti
>
>  ------------------------------
> *From:* Shetti Shrinivas-Q16945
> *Sent:* Friday, June 09, 2006 2:12 PM
> *To:* [email-masked]'
> *Cc:* Kelley Sean-Q12059
> *Subject:* clarification regarding 'Require' header usage in
> My perception about this header being used in SUBSCRIBE is that, it is not going to cause any harm or issue. I might be missing something.
>
> All the presence SUBSCRIBE messages land at a proxy. The proxy server decides to route the request to either 'RLS server' or 1-1 presence server.
>
> Now, if client can use 'Require: eventlist', this is definite indication for the proxy to route the request to RLS server. Rest of the subscriptions can go to 1-1 presence server.
>
> thanks and best regards,
>
> Shetti
>
>

--