Subject: Re: [Simple] Applying the Policy Authorization Rules

From: "Noga Tor" <[email-masked]>
Date: Thu, 20 Jul 2006 16:33:27 +0300

I mean

Main Uri
======
pres:[email-masked]

Alias Uri
======
im:[email-masked]

a subscription is generated:
FROM: im:[email-masked]
TO: im:[email-masked]

while the Bob's Authorization policy contains a rule referring
pres:[email-masked]

On 7/20/06, Tschofenig, Hannes <[email-masked]> wrote:
>
>  Hi Noga,
>
> you seem to be talking about the common policy draft.
>
> What is an "alias" for you when it comes to an authenticated identity?
>
> Ciao
> Hannes
>
>
>
>  ------------------------------
> *Von:* Noga Tor [mailto:[email-masked]]
> *Gesendet:* Donnerstag, 20. Juli 2006 13:20
> *An:* [email-masked]
> *Betreff:* [Simple] Applying the Policy Authorization Rules
>
>
>
>  Hi
>
> I have a question regarding the Policy Authorization Rules:
>
> If we match a rule's identity (<one>,<id>) against the wacther identity,
> how do we handle aliases:
> 1) do we consider the rule matched only if the common-policy document
> contains a uri that equals exactly to the alias used by the watcher?
> 2) do we need to determine the global uri of the watcher and/or the global
> uri of the policy's rule and see if they both refer to the same Presentity?
>
>
> Thanks
> Noga
>
>
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Tschofenig, Hannes" <[email-masked]>
Date: Thu, 20 Jul 2006 15:56:23 +0200

Hi Noga, 
 
if the authorization policies indicate [email-masked] and someone
shows up with [email-masked] then the rules do not fire. You need to list
both identities in the authorization policies. 

You would have todo this anyway even with an alias since otherwise there
wouldn't be a way for the server to figure out what todo. 
 
Ciao
Hannes

________________________________

	Von: Noga Tor [mailto:[email-masked]] 
	Gesendet: Donnerstag, 20. Juli 2006 15:33
	An: Tschofenig, Hannes
	Cc: [email-masked]
	Betreff: Re: [Simple] Applying the Policy Authorization Rules

	I mean 
	 
	Main Uri
	======
	pres:[email-masked]
	 
	Alias Uri
	======
	im:[email-masked]

	 
	On 7/20/06, Tschofenig, Hannes <[email-masked]>
wrote: 

		Hi Noga, 

		What is an "alias" for you when it comes to an
authenticated identity?
		 
		Ciao
		Hannes

________________________________

			Von: Noga Tor [mailto:[email-masked] ] 
			Gesendet: Donnerstag, 20. Juli 2006 13:20
			An: [email-masked] 
			Betreff: [Simple] Applying the Policy
Authorization Rules

				Hi
		 
		I have a question regarding the Policy Authorization
Rules:
		 
		If we match a rule's identity (<one>,<id>) against the
wacther identity, how do we handle aliases:
		1) do we consider the rule matched only if the
common-policy document contains a uri that equals exactly to the alias
used by the watcher?
		2) do we need to determine the global uri of the watcher
and/or the global uri of the policy's rule and see if they both refer to
the same Presentity?

		Thanks
		Noga