Subject: RE: [Simple] I-D ACTION:draft-ietf-simple-imdn-00.txt

From: <[email-masked]>
Date: Fri, 7 Jul 2006 15:03:37 +0300

Hi,

I read the draft, and have a couple of comments as follows: 

- it is said in section 5/ 2nd paragraph that "In this case, the
intermediary MUST add a CPIM Original-To header to the CPIM message
populating it with the address of the sender.". Shouldn't the  header
field rather be populated with the address of the original recipient
(which is basically the address of the intermediary as well as the
address of the entity forwarding the message)? If there are several
intermediaries, is the Original-To header set by the first one?

- 9.1.4. <original-recipient-uri>: it is said that this carries the URI
of the final recipient. Shouldn't this be the URI of the recipient in
the originated IM?

- 10.2. (Intermediary behaviour): it is said for the read notification
that the intermediary forwards it. Shouldn't similar text be written for
"positive-delivery" notifications (generated by an endpoint)?

- 10.2. If the intermediary generates the IMDN then also other
quidelines should be given than only how the <recipient-uri> is
populated, e.g. reference to the subsection 4.2.1.

BR, Eva 

>-----Original Message-----
>From: ext Hisham Khartabil [mailto:[email-masked]] 
>Sent: 14 June, 2006 16:06
>To: [email-masked]' WG
>Subject: Re: [Simple] I-D ACTION:draft-ietf-simple-imdn-00.txt 
>
>This version of the Instant Messaging Disposition Notification draft 
>represents consensus from the design team (with very few open issues). 
>The authors would appreciate some review and comments before the next 
>IETF meeting in Montreal in order to allow us to properly discuss any 
>open issues that are raised.
>
>Thanks,
>Hisham
>
>On May 31, 2006, at 12:50 AM, [email-masked] wrote:
>
>> A New Internet-Draft is available from the on-line Internet-Drafts 
>> directories.
>> This draft is a work item of the SIP for Instant Messaging and 
>> Presence Leveraging Extensions Working Group of the IETF.
>>
>> 	Title		: Instant Message Disposition Notification
>> 	Author(s)	: E. Burger, H. Khartabil
>> 	Filename	: draft-ietf-simple-imdn-00.txt
>> 	Pages		: 27
>> 	Date		: 2006-5-30
>> 	
>> Instant Messaging (IM) refers to the transfer of messages between
>> users in real-time.
>>
>> This document extends Message/CPIM message format to enable endpoints
>> to request, create and send IM Disposition Notifications (IMDN),
>> including delivery and read notifications, for page-mode as well as
>> session mode instant messages.  This document also describes how SIP
>> and MSRP entities behave using this extension.
>>
>>
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-ietf-simple-imdn-00.txt
>>
>> To remove yourself from the I-D Announcement list, send a message to
>> [email-masked] with the word unsubscribe in 
>the body of 
>> the message.
>> You can also visit 
>https://www1.ietf.org/mailman/listinfo/I-D-announce
>> to change your subscription settings.
>>
>>
>> Internet-Drafts are also available by anonymous FTP. Login with the 
>> username
>> "anonymous" and a password of your e-mail address. After logging in,
>> type "cd internet-drafts" and then
>> 	"get draft-ietf-simple-imdn-00.txt".
>>
>> A list of Internet-Drafts directories can be found in
>> http://www.ietf.org/shadow.html
>> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>>
>>
>> Internet-Drafts can also be obtained by e-mail.
>>
>> Send a message to:
>> 	[email-masked].
>> In the body type:
>> 	"FILE /internet-drafts/draft-ietf-simple-imdn-00.txt".
>> 	
>> NOTE:	The mail server at ietf.org can return the document in
>> 	MIME-encoded form by using the "mpack" utility.  To use this
>> 	feature, insert the command "ENCODING mime" before the "FILE"
>> 	command.  To decode the response(s), you will need "munpack" or
>> 	a MIME-compliant mail reader.  Different MIME-compliant 
>mail readers
>> 	exhibit different behavior, especially when dealing with
>> 	"multipart" MIME messages (i.e. documents which have been split
>> 	up into multiple messages), so check your local documentation on
>> 	how to manipulate these messages.
>> 		
>> 		
>> Below is the data which will enable a MIME compliant mail reader
>> implementation to automatically retrieve the ASCII version of the
>> Internet-Draft.
>> Content-Type: text/plain
>> Content-ID: <[email-masked]>
>>
>> _______________________________________________
>> Simple mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/simple
>
>
>_______________________________________________
>Simple mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/simple
>

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Hisham Khartabil <[email-masked]>
Date: Fri, 28 Jul 2006 13:53:07 +0200

Hi Eva,

Thanks for the comments and apologies for the late reply. Comments 
inline...

On Jul 7, 2006, at 2:03 PM, <[email-masked]> wrote:

> address of the entity forwarding the message)?

You are correct, there was a typo. It is now fixed to say the the 
Original-To header is populated with the intermediary address.

>  If there are several

Yes. I added text saying that an intermediary MUST NOT add an 
Original-To header if one already existed.

> of the final recipient. Shouldn't this be the URI of the recipient in

Again you are correct. copy/paste error.

> "positive-delivery" notifications (generated by an endpoint)?

Yes. Text added.

> populated, e.g. reference to the subsection 4.2.1.

The text already references 4.2.1.

Thanks,
Hisham