Subject: Re: [Simple] Question about sending SUBSCRIBE before sending REGISTER

From: xupeili 18916 <[email-masked]>
Date: Sun, 28 Jan 2007 21:09:52 +0800

Hi Liou,

I am not very clear about your deployment senario, but according to RFC3261, it's not necessary to do registration before the user agent sending SUBSCRIBE. Since the SUBSCRIBE request will setup a dialog, the server can deliver the notification based on the route set of this dialog.

There may have some specific system requires the user agent to do registration before any further action. In this case, that system can require sending some specific error response. 

Cheers.
Peili

----- Original Message -----
From: Ren-Huang Liou <[email-masked]>
Date: Sunday, January 28, 2007 5:45 pm
Subject: [Simple] Question about sending SUBSCRIBE before sending REGISTER

> Dear all,
> 
> If the user agent sends SUBSCRIBE request to the server before the
> registration, what response will the server send?
> 
> Namely, the location database don't have the contact information of 
> thisAOR.
> 
> Thanks in advance,
> Ren-Huang Liou
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Vikas Tandon" <[email-masked]>
Date: Tue, 30 Jan 2007 11:37:31 +0530

Hi Peili, Liou,

How do you ensure that the requesting UE is a valid user for subscribing to
that event in case you don't make it mandatory to have a subscription.

Regards,
Vikas 

-----Original Message-----
From: xupeili 18916 [mailto:[email-masked]] 
Sent: Sunday, January 28, 2007 6:40 PM
To: Ren-Huang Liou
Cc: [email-masked]
Subject: Re: [Simple] Question about sending SUBSCRIBE before sending
REGISTER

Hi Liou,

I am not very clear about your deployment senario, but according to RFC3261,
it's not necessary to do registration before the user agent sending
SUBSCRIBE. Since the SUBSCRIBE request will setup a dialog, the server can
deliver the notification based on the route set of this dialog.

There may have some specific system requires the user agent to do
registration before any further action. In this case, that system can
require sending some specific error response. 

Cheers.
Peili