Subject: Re: [Simple] Is there any Document (and Naming Conventions) to specify AUIDs in XCAP Server?

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 26 Feb 2007 15:51:20 -0500

I don't understand the question. The xcaps-caps AUIDs are the AUIDs 
understood by the server, which would be either in the IETF tree or in 
the vendor proprietary tree. In the former case, the AUIDs are defined 
in their respective RFCs. In the latter case, they are proprietary, so 
there is no public definitions of what they mean.

-Jonathan R.

Eduardo Martins wrote:

> Hi, is there any document definition for each of xcap-caps AUIDs (and a 
> path relative xcap root?), where all its properties are defined, or 
> should this kind of info, like the AUID's mimetype for example, be 
> unavailable externally?
> 
> Regards
> 
> Eduardo
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Eduardo Martins" <[email-masked]>
Date: Mon, 26 Feb 2007 22:47:50 +0000

Hi Jonathan, I was looking for a document schema that would specify a App
Usage in a XML file but I think it doesn't exist. If this existed it would
be interesting to set a app usage (or maybe reuse the caps one) where all
app usage documents could be stored in the xcap doc tree.

Best regards,

Eduardo Martins

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 26 Feb 2007 18:07:30 -0500

Are you talking about schema for the documents for a particular app 
usage? For example, xcap-list-usage has schema for resource lists and 
RLS services documents. Do you want an app usage that contains the 
schema for those? I still don't understand what you are asking for.

-Jonathan R.

Eduardo Martins wrote:

> Hi Jonathan, I was looking for a document schema that would specify a 
> App Usage in a XML file but I think it doesn't exist. If this existed it 
> would be interesting to set a app usage (or maybe reuse the caps one) 
> where all app usage documents could be stored in the xcap doc tree.
> 
> Best regards,
> 
> Eduardo Martins
> 
> 
> On 2/26/07, *Jonathan Rosenberg* < [email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>>  [email-masked] <mailto:[email-masked]>
>     [email-masked]
>     <mailto:[email-masked]>                              FAX:   (973)
>     952-5050

---

From: "Eduardo Martins" <[email-masked]>
Date: Mon, 26 Feb 2007 23:17:13 +0000

Seems I can't explain it well, in my idea it would be a XML Schema that
would define a XML document for specifying every App Usage. Maybe an example
of what such a XML doc could be:

<app-usage>
    <description>IETF SIMPLE Presence Rules</description>
    <auid>pres-rules</auid>

<default-document-namespace>urn:ietf:params:xml:ns:pres-rules</default-document-namespace>
    <mimetype>application/auth-policy+xml</mimetype>
    ...
</app-usage>

Best regards,

Eduardo Martins

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 27 Feb 2007 09:21:45 -0500

OK, though I'm not sure what it would be used for. What was your use case?

-Jonathan R.

Eduardo Martins wrote:

> would define a XML document for specifying every App Usage. Maybe an 
> example of what such a XML doc could be:
> 
> <app-usage>
> On 2/26/07, * Jonathan Rosenberg* <[email-masked] 
>     <mailto:[email-masked]>
>>  <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>>     [email-masked] <mailto:[email-masked]>
>>     <mailto:[email-masked]
>     <mailto:[email-masked]>>                              FAX:   (973)
>>     952-5050
>>     http://www.jdrosen.net
>     <http://www.jdrosen.net>                         PHONE: (973) 952-5000
>>     http://www.cisco.com
>>
>>
>>
>>
>     <https://www1.ietf.org/mailman/listinfo/simple>
> 
>     --

---

From: "Eduardo Martins" <[email-masked]>
Date: Tue, 27 Feb 2007 14:47:52 +0000

It's not much important and I don't miss it much, at the time I sent the
first mail it just seemed to make sense, in a xml protocol that deals with
xml documents, to have app usages specified by xml too. And have those app
usage xml docs available in the public XCAP root.

Anyway, I guess the app usage contraints, out of scope for schemas, would
make those docs incomplete, regarding full app usage specification.

For  the XCAP Server, it would be great to implement an app usage just
considering data on xml documents, this would mean it could be completely
independent of app usages "installed".

Best regards,

Eduardo

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 28 Feb 2007 18:09:03 -0500

Sure, but this is a localized configuration. You could choose to define 
app usages using your own proprietary XML format, and that would be 
fine. We have no requirements to exchange such documents between servers 
or from client to server; its merely a tool for configuration.

-Jonathan R.

Eduardo Martins wrote:

> first mail it just seemed to make sense, in a xml protocol that deals 
> with xml documents, to have app usages specified by xml too. And have 
> those app usage xml docs available in the public XCAP root.
> 
> Anyway, I guess the app usage contraints, out of scope for schemas, 
> would make those docs incomplete, regarding full app usage specification.
> 
> considering data on xml documents, this would mean it could be 
> completely independent of app usages "installed".
> 
> Best regards,
> 
> Eduardo
> 
> On 2/27/07, *Jonathan Rosenberg* <[email-masked] 
>      > <mailto: [email-masked] <mailto:[email-masked]>>> wrote:
>      >
>      >     <mailto: [email-masked] <mailto:[email-masked]>>
>      >>  <mailto:[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>> wrote:
>      >>
>      >     <mailto: [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>      >>     <mailto:[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]>>>                              FAX:   (973)
>      >>     952-5050
>      >>     http://www.jdrosen.net <http://www.jdrosen.net>
>      >     <mailto: [email-masked]