Subject: [Simple] Possible ambiguous interpretation in xcap diff

From: Martin Hynar <[email-masked]>
Date: Wed, 07 Feb 2007 09:57:30 +0100

Hello, 

I have read last version (04) of the XCAP Diff Format and there is one
thing in the schema that might cause ambiguous interpretation. In the
text, there is clearly explained that <xcap-diff> is the root element
with <document> elements as children. However, the way how the elements
are defined in the xml schema allows to start with <document> element,
omitting the intended <xcap-diff> element as a root.

Both <xcap-diff> and <document> elements are defined on the same level
using <element name="..."> declaration. This causes that these are equal
in a way that they can be used as root. I would propose to change schema
to define "type" of the <document> element on the top level:

<xs:complexType name="documentType">
  ...
</xs:complexType>

and then define <xcap-diff> element as follows:

<xs:element name="xcap-diff">
  ...
  <xs:element name="document" type="documentType"/>
  ...
</xs:element>

This way, there will clear which of the two elements is the root.

br, Martin

+-------------------------------------+ 
  Martin Hynar 
  Software Specialist

  TietoEnator 
  Czech Software Center 
  Phone: +420 597 459 713 
  Mobile: +420 724 432 817 
  E-mail: [email-masked]

  Vystavni 292/13 
  CZ-709 16 Ostrava

www.tietoenator.com

Please note: The information contained in this message may be legally
privileged and confidential and protected from disclosure. If the reader
of this message is not the intended recipient, you are hereby notified
that any unauthorized use, distribution or copying of this communication
is strictly prohibited. If you have received this communication in
error, please notify us immediately by replying to the message and
deleting it from your computer. Thank You.
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 09 Feb 2007 17:21:16 -0500

This seems fine to me. I'll make the change.

THanks,
Jonathan R.

Martin Hynar wrote:

> *+-------------------------------------+*
> *  **Martin Hynar*
>   Software Specialist
> 
> *  **TietoEnator*
>   Czech Software Center
>   Phone: +420 597 459 713
>   Mobile: +420 724 432 817
>   E-mail:*_ [email-masked]*
> 
>   Vystavni 292/13
>   CZ-709 16 Ostrava
> 
> *_www.tietoenator.com <file://www.tietoenator.com>_*
> 
> 
> /Please note: The information contained in this message may be legally 
> deleting it from your computer. Thank You./
> 

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com