Subject: Fw: [Simple] I-D ACTION:draft-ietf-simple-interdomain-scaling-analysis-01.txt

From: Avshalom Houri <[email-masked]>
Date: Fri, 6 Jul 2007 08:38:29 +0300

The excel file I have used for the computations is in:

http://www.nostrum.com/~rjsparks/SIMPLE_message_computation.xls

Thanks to Robert for hosting it.

--Avshalom

----- Forwarded by Avshalom Houri/Haifa/IBM on 06/07/2007 08:36 -----

[email-masked] 
06/07/2007 03:15

To
[email-masked]
cc
[email-masked]
Subject
[Simple] I-D ACTION:draft-ietf-simple-interdomain-scaling-analysis-01.txt

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.
This draft is a work item of the SIP for Instant Messaging and Presence 
Leveraging Extensions Working Group of the IETF.

                 Title                           : Presence Interdomain 
Scaling Analysis for SIP/SIMPLE
                 Author(s)               : A. Houri, et al.
                 Filename                : 
draft-ietf-simple-interdomain-scaling-analysis-01.txt
                 Pages                           : 49
                 Date                            : 2007-7-5
 
The document analyses the traffic that is generated due to presence
   subscriptions between domains.  It is shown that the amount of
   traffic can be extremely big.  In addition to the very large traffic
   the document also analyses the affects of a large presence system on
   the memory footprint and the CPU load.  Current approved and in work
   optimizations to the SIMPLE protocol are analysed with the possible
   impact on the load.  Separate documents contain the requirements for
   optimizations and suggestions for new optimizations.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-simple-interdomain-scaling-analysis-01.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of 
the message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then 
"get draft-ietf-simple-interdomain-scaling-analysis-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
                 [email-masked].
In the body type:
                 "FILE 
/internet-drafts/draft-ietf-simple-interdomain-scaling-analysis-01.txt".
 
NOTE:            The mail server at ietf.org can return the document in
                 MIME-encoded form by using the "mpack" utility.  To use 
this
                 feature, insert the command "ENCODING mime" before the 
"FILE"
                 command.  To decode the response(s), you will need 
"munpack" or
                 a MIME-compliant mail reader.  Different MIME-compliant 
mail readers
                 exhibit different behavior, especially when dealing with
                 "multipart" MIME messages (i.e. documents which have been 
split
                 up into multiple messages), so check your local 
documentation on
                 how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
ftp://[email-masked]/internet-drafts/draft-ietf-simple-interdomain-scaling-analysis-01.txt
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Willekens, Marc" <[email-masked]>
Date: Tue, 17 Jul 2007 01:19:45 +0200

Hi Avshalom,
 
Can you check the formulas for S03 and S08?
For No NOTIFY opt, I had values of S03/2 and S08/4
For NOTIFY opt, S03/2 and S08/2/
For Other protocol: OK
For NOTIFY and partial: S03/2 and S08/2
 
Some remarks:
1. With the "Other protocol", do you mean XMPP?
2. The figures indicate that the influence of the optimizations become
smaller when the status change traffic increases.
3. For the very large network peering model with a frequency of status
updates of 5sec, the required bandwidth between the domains becomes very
high both for the SIMPLE and the XMPP approach: i.e. ca. 1,24 Tbps and 1
Tbps!
 
br,
Marc.

________________________________

From: ext Avshalom Houri [mailto:[email-masked]] 
Sent: vrijdag 6 juli 2007 7:38
To: [email-masked]
Subject: Fw: [Simple]I-D
ACTION:draft-ietf-simple-interdomain-scaling-analysis-01.txt

http://www.nostrum.com/~rjsparks/SIMPLE_message_computation.xls
<http://www.nostrum.com/~rjsparks/SIMPLE_message_computation.xls>  

--Avshalom

----- Forwarded by Avshalom Houri/Haifa/IBM on 06/07/2007 08:36 ----- 

[email-masked] 

06/07/2007 03:15 

To
[email-masked] 
cc
[email-masked] 
Subject
[Simple] I-D
ACTION:draft-ietf-simple-interdomain-scaling-analysis-01.txt

                Title                                  : Presence
Interdomain Scaling Analysis for SIP/SIMPLE
                Author(s)                 : A. Houri, et al.
                Filename                 :
draft-ietf-simple-interdomain-scaling-analysis-01.txt
                Pages                                  : 49
                Date                                  : 2007-7-5

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-simple-interdomain-scalin
g-analysis-01.txt

Send a message to:
                [email-masked].
In the body type:
                "FILE
                
NOTE:                 The mail server at ietf.org can return the
document in
                MIME-encoded form by using the "mpack" utility.  To use
this
                feature, insert the command "ENCODING mime" before the
"FILE"
                command.  To decode the response(s), you will need
"munpack" or
                a MIME-compliant mail reader.  Different MIME-compliant
mail readers
                exhibit different behavior, especially when dealing with
                "multipart" MIME messages (i.e. documents which have
been split
                up into multiple messages), so check your local
documentation on
                how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
ftp://[email-masked]/internet-drafts/draft-ietf-simple-interdoma
in-scaling-analysis-01.txt______________________________________________
_
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Avshalom Houri <[email-masked]>
Date: Wed, 25 Jul 2007 00:12:54 +0300

Sorry for late reply and many thanks for reviewing.
See comments below.

Comments inline.

> For NOTIFY and partial: S03/2 and S08/2
I have looked at the formulas again and they look OK.
Can you provide more details?
Also if you can, please look at
http://www.nostrum.com/~rjsparks/SIMPLE_message_computation.xls

and see if there is an error in the formula.

> 
> Some remarks:
> 1. With the "Other protocol", do you mean XMPP? XMPP is one example.

Proprietry protocols that are used in consumber networks and in 
enterprises is another example.

> 2. The figures indicate that the influence of the optimizations 
> become smaller when the status change traffic increases.
> 3. For the very large network peering model with a frequency of 
> status updates of 5sec, the required bandwidth between the domains 
> becomes very high both for the SIMPLE and the XMPP approach: i.e. 
> ca. 1,24 Tbps and 1 Tbps!
> 
> br,
> Marc.
> Subject: Fw: [Simple]I-D ACTION:draft-ietf-simple-interdomain-
> scaling-analysis-01.txt

> This draft is a work item of the SIP for Instant Messaging and 
> Presence Leveraging Extensions Working Group of the IETF.
> 
>                 Title                                  : Presence 
>                 Filename                 : draft-ietf-simple-
> interdomain-scaling-analysis-01.txt
>                 Pages                                  : 49
>                 Date                                  : 2007-7-5
> 
>                 "FILE /internet-drafts/draft-ietf-simple-
> interdomain-scaling-analysis-01.txt".
> 
document in
this
"FILE"
>                 a MIME-compliant mail reader.  Different MIME-
> compliant mail readers
>                 "multipart" MIME messages (i.e. documents which havebeen 
split