Subject: [Simple] Comments on draft-roy-simple-presencerss-00.txt

From: Qian Sun <[email-masked]>
Date: Thu, 12 Jul 2007 15:36:55 +0800

Hi, Arjun

This idea is very good! In fact, there are already some primary representations of your idea. I know a website http://www.onlinestatus.org/, which lets you put a small image on a web page (e.g. your blog) to show if you are online on ICQ, Jabber, MSN Messenger, or Skype etc. Address to your status indicator is like this: http://osi.techno-st.net:8000/msn/[email-masked]
And you have to set your preference to allow everybody to see your status. Or else your status indicator is always offline.

Many people must worry about privacy. But some users don't mind anybody to see their some presence information, e.g. online status, song title they are listening, mood. These information are not sensitive, it is no problem to post them on the web.

To precise location information, I don't think it is suitable to publish on the web, unless the web is restricted to the visitor. For example, only your family members have right to access the webpage containing your location data.

Cheers,
Qian

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Arjun Roychowdhury" <[email-masked]>
Date: Thu, 12 Jul 2007 06:49:02 -0400

Hi Qian,
thanks for your comments. It is also important to note that the focus
of the draft is to justify the motivation of representing presence as
a feed (RSS or ATOM) which in turn leads to easier web based
application deployment. Many of the current web based representations
do not use standardized feed formats (example, "I am online now" - the
Yahoo button").

I have a working example of the concept proposed in the draft at
http://rsspresence.googlemashups.com/

regds
arjun

-- 
Arjun Roychowdhury

---

From: Qian Sun <[email-masked]>
Date: Fri, 13 Jul 2007 10:32:24 +0800

Hi Arjun,
Yes, a standard interface should be defined, RSS/ATOM may be a good choice.

I suggest a simpler and easier example: Show presence information on blog.
Alice publishes her presence information to Presence Server;
Bob visits Alice's blog webpage, the blog server requests Alice's presence info via HTTP;
The gateway translates HTTP request into SIP SUBSCRIBE (expires=0, maybe using anonymous identity); 
Presence Server returns Alice's presence (normally not full information, just for anonymous) to gateway by NOTIFY, gateway translates PIDF document into RSS feed;
Blog server displays the blog page with Alice's presence (e.g. mood, online status...).

The blog page may refresh automatically the presence (AJAX is good to do this) every some minutes, or provide a "refresh" button.

Cheers,
Qian

-----Original Message-----
From: Arjun Roychowdhury [mailto:[email-masked]] 
Sent: Thursday, July 12, 2007 6:49 PM
To: Qian Sun
Cc: Arjun Roychowdhury; [email-masked]
Subject: Re: [Simple] Comments on draft-roy-simple-presencerss-00.txt

Hi Qian,

regds
arjun

-- 
Arjun Roychowdhury