Subject: RE: [Simple] I-D (Updated): Motivation for converting Presencedocuments to RSS Feeds

From: "Goix Laurent Walter" <[email-masked]>
Date: Fri, 6 Jul 2007 16:29:30 +0200

Hi Arjun,

Very nice idea indeed!

We are heavily interested in interactions between the Telco world and the Web2.0 world, focusing on user-generated content/mashups/services, open APIs, etc.

I fully agree with your vision of exporting Presence info towards a feed representation (RSS/Atom) to improve integration between both worlds. 

On the architectural side, yours is one option. I could imagine also a watcher (or the presence server itself) acting as gateway to export Presence info as RSS, thus easily supporting privacy concerns by still relying on the mechanisms provided by SIMPLE. 

On the use case side, i believe they are quite fine, although they could be simplified. Probably reference to the back-end providers is not needed as a motivation: having track-it example simply exporting my buddies' presence info to a "plain" RSS reader would be enough.

Regards
Walter

-----Original Message-----
From: Arjun Roychowdhury [mailto:[email-masked]] 
Sent: martedì 5 giugno 2007 17.39
To: Simple WG
Cc: [email-masked]; Henry Sinnreich
Subject: [Simple] I-D (Updated): Motivation for converting Presencedocuments to RSS Feeds

Hi,
I have submitted a new draft discussing the motivation of converting Presence documents to RSS feeds.

Till it appears on the list,
http://arjunrc.googlepages.com/draft-roy-simple-presencerss-00.txt

As a working example of the benefits, I've published a mappable presence feed example using GoogleMashupEditor at http://rsspresence.googlemashups.com/ using concepts proposed in this draft.

Comments are welcome.

Abstract:
RSS Feeds have always played an important role in providing users content related updates typically of Websites without having to visit
  those websites manually. Typical examples of RSS usage include users
   'subscribing' to the RSS feed of a website, say, CNN.com and
thereby   automatically receiving 'news headlines' then the content
changes. Recently, there have been significant innovations (such as
Yahoo   Pipes and Google Mash-up Editor) where RSS feeds from
different    sources have been combined to produce new services in a
'Web Based  Service Creation Environment' model allowing users to create interesting services building on top of 'primitives' that can be  represented on the Web.

This document describes the motivation for an RSS feed for Presence information, which the authors believe would be useful to create new services using a similar environment described above.

regds
arjun

--
Arjun Roychowdhury

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple
--------------------------------------------------------------------

CONFIDENTIALITY NOTICE

This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited. Please return it immediately to the sender and delete the message. Should you have any questions, please contact us by replying to [email-masked].

        Thank you

                                        www.telecomitalia.it

--------------------------------------------------------------------

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Arjun Roychowdhury" <[email-masked]>
Date: Mon, 9 Jul 2007 15:01:59 -0400

Hi Walter, thanks for your comments. I agree with your architectue
option - actually that is what I had intended to show in the example,
so that all UAs don't need to support feeds - I probably need to
reword it to make it clearer.

I will soon be posting an updated version - depending on the interest
in this list, it may make sense to work on a following requirements
draft. Alternately, if there is any other mailing list this work is
better suited for, please let me know.

regds
arjun

On 7/6/07, Goix Laurent Walter <[email-masked]> wrote:
> *****************************************************DISCLAIMER*****************************************************
>
> This message and/or attachment(s) contained here are confidential, proprietary to HUGHES SYSTIQUE and its customers.
> Contents may be privileged or otherwise protected by law. The information is solely intended for the entity it is
> addressed to. If you are not the intended recipient of this message, it is strictly prohibited to read, forward,
> print, retain, copy or disseminate this message or any part of it. If you have received this e-mail in error,
> please notify the sender immediately and delete the message.
>
> ********************************************************************************************************************
>
>

-- 
Arjun Roychowdhury