Subject: [Simple] Can we deprecate UDP for presence?

From: Avshalom Houri <[email-masked]>
Date: Wed, 28 Nov 2007 13:28:05 +0200

As we know it is not easy to scale presence.

Since presence RFCs and drafts were created after RFC 3261 that mandates 
both 
UDP and TCP support (opposed to 2543 that mandated only UDP), can we say 
that 
most if not all presence client will use TCP?

If we could deprecate UDP for presence then we can think about several 
traffic 
optimizations where the overhead is due to the UDP support of SIP?

Comments?

--Avshalom

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Wed, 28 Nov 2007 14:57:34 +0100

Are you suggesting that a sender has to look at the event header in a
SIP message before deciding which transport protocol to use, and decide
whether it is presence related.
 
This is an updates RFC 3261 issue, i.e. not for SIMPLE to write the RFC,
merely to determine if there are requirements in this area and pass them
to SIP.
 
regards
 
Keith

________________________________

	From: Avshalom Houri [mailto:[email-masked]] 
	Sent: Wednesday, November 28, 2007 11:28 AM
	To: simple mailing list
	Subject: [Simple] Can we deprecate UDP for presence?

	Since presence RFCs and drafts were created after RFC 3261 that
mandates both 
	UDP and TCP support (opposed to 2543 that mandated only UDP),
can we say that 
	most if not all presence client will use TCP? 
	
	If we could deprecate UDP for presence then we can think about
several traffic 
	optimizations where the overhead is due to the UDP support of
SIP? 
	
	Comments? 
	
	--Avshalom

---

From: Avshalom Houri <[email-masked]>
Date: Wed, 28 Nov 2007 17:11:42 +0200

Something in this direction and at the receiver side it will be possible 
to 
reject presence messages on UDP.

I agree that we will need to start with requirements in SIPPING and my 
intention 
was to gauge if it will be an issue or TCP is implemented by default for 
presence.

Thanks
--Avshalom

"DRAGE, Keith \(Keith\)" <[email-masked]> 
28/11/2007 15:57

To
Avshalom Houri/Haifa/IBM@IBMIL, "simple mailing list" <[email-masked]>
cc

Subject
RE: [Simple] Can we deprecate UDP for presence?

Are you suggesting that a sender has to look at the event header in a SIP 
message before deciding which transport protocol to use, and decide 
whether it is presence related.

regards
 
Keith

Comments? 

--Avshalom