Subject: [Simple] Multi-party Chat version 05 submitted

From: Geir Arne Sandbakken <[email-masked]>
Date: Mon, 05 Oct 2009 16:21:38 +0200

A new version of “Multi-party Chat Using the Message Session Relay 
Protocol (MSRP)” has been submitted.

The new version can be found here:
http://www.ietf.org/internet-drafts/draft-ietf-simple-chat-05.txt

Additions and changes from -04 based on the WGLC Summary:
1. Architectural diagrams or descriptions clarifying MSRP switch role 
towards MSRP relay, endpoints and focus
- Added diagram showing Focus UA, MSRP relays and MSRP switch. - Added 
reference to MSRP relays to make implementers compare mechanisms.
2. Clean up Section 6.2 on Private Messages
- Removed text regarding reports and responses.
- Made reference to regular messages - and removed duplicate text.
3. Various Nickname clarifications: terminology, privacy and security
- The review listed the Nickname as a missing identifier. Nicknames in 
simple-chat are not part of the identifiers of which one can populate in 
the To header field of the Message/CPIM wrapper. Nicknames are more like 
display names, but unique inside a chat room. - Rephrased section 7.1, 
and cleaned up the terminology.
- Added a Nickname paragraph under the security considerations.
- Did not add a time out - as a Nickname is not an identifier to be used 
for message relaying. Only used for display purposes, and it is the 
policy of the focus to apply any constraints.
4. Add normative reference to P-Asserted-Identity
- Done.
5. Example of a Conference Event Package notification with a nickname 
element
- Done
6. Lots of requirement clean ups. Scary.
- Removed REQ-2 talking about other media types
- Rephrased REQ-8
- Cleaned up REQ-9
- Cleaned up REQ-10
7. Clarification around conference "unaware" participants
- Added text under 5.2 "Joining a chat room". - Made clear that the rest 
of the document requires clients to be conference aware.
8. MSRP switch needs to be made Message-Id stateful. Add text.
- Added text under section 6 "Sending and receiving IM messages"
9. More reporting model update - and removal.
- Removed a lot of normative text. - Added separate section for report 
and response handling
10. Remove mixed media references
- Removed REQ-2 talking about other media types
- Removed all references to other media types.
11. Add text on side effect when removing chat rooms.
- Added text to section 5.x
12. Add Multi-chunk example
- Done
13. Remove GRUU example
- Done
14. Add error response on private message
- Done
15. Various editorial fixes and simplifications
- Done
16. Add Mary and Ben to Acknowledgements
- Done

Thanks,
Geir

---

From: Adrian Georgescu <[email-masked]>
Date: Tue, 20 Oct 2009 12:17:56 +0200

After reviewing this document, from an implementor perspective the  
draft addresses all my needs to build such a conference system based  
on MSRP protocol. I personally have no further suggestions for  
improving it and I would like to see this going through the process  
for becoming a proposed standard.

--
Adrian

On Oct 5, 2009, at 4:21 PM, Geir Arne Sandbakken wrote:

> 1. Architectural diagrams or descriptions clarifying MSRP switch  
> role towards MSRP relay, endpoints and focus
> - Added diagram showing Focus UA, MSRP relays and MSRP switch. -  
> Added reference to MSRP relays to make implementers compare  
> mechanisms.
> - The review listed the Nickname as a missing identifier. Nicknames  
> in simple-chat are not part of the identifiers of which one can  
> populate in the To header field of the Message/CPIM wrapper.  
> Nicknames are more like display names, but unique inside a chat  
> room. - Rephrased section 7.1, and cleaned up the terminology.
> - Did not add a time out - as a Nickname is not an identifier to be  
> used for message relaying. Only used for display purposes, and it is  
> the policy of the focus to apply any constraints.
> 5. Example of a Conference Event Package notification with a  
> nickname element
> - Done
> - Added text under 5.2 "Joining a chat room". - Made clear that the  
> rest of the document requires clients to be conference aware.
> - Removed a lot of normative text. - Added separate section for  
> report and response handling
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple