Subject: [Simple] ACM does not interoperate with any other MSRP entity

From: Adrian Georgescu <[email-masked]>
Date: Wed, 12 Jan 2011 16:13:02 +0100

Dear SIP SIMPLE WG, for those who care or are responsible for the conclusion of the works

In the last three years I have implemented the following:

1. MSRP chat-server based on the MSRP-chatserver draft. Source code will be soon available here http://sylkserver.com

2. MSRP client with support for all defined primitives related to MSRP standards. Source code and implementation available in Blink  http://icanblink.com

3. MSRP Relay based on its RFC. Source code is available http://msrprelay.org

Now the problem

ACM for MSRP is also implemented in Blink. But the ACM model no matter how much I tried, and I really tried (read $$$ and man months),  I could not make it interoperate with 1, 2 or 3. So whatever is ACM based will never talk to anything else despite that they share the protocol called MSRP.

My conclusion after all these years of coding MSRP based on the current RFCs, I could not spot relevant flaws in the MSRP related RFC I have implemented. They are good for the purpose, make  technical sense and for a developer are easy to understand and reasonable to implement complexity wise. All except for the Alternative Connection Model. The ACM stuff is completely out of place and breaks everything MSRP related RFCs to date.

I suggest that the ACM draft must explicitly mention the fact that it does not interoperate through design with ANY of the other MSRP entities. So that other developers do no get confused and waste time to discover this simple fact.

Regards,
Adrian

---

From: Ben Campbell <[email-masked]>
Date: Wed, 12 Jan 2011 21:28:22 -1000

Hi Adrian,

To clarify, are you really talking about ACM (i.e. Using COMEDIA) vs sessmatch (i.e.relaxing session matching rules to make life easier for SBC)

For the record, ACM was intended to allow fallback to the 4975 usage when the peer does not support COMEDIA. Can you elaborate on the failure cases?

Thanks,

Ben.

On Jan 12, 2011, at 5:13 AM, Adrian Georgescu <[email-masked]> wrote:

> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 18 Jan 2011 17:47:17 +0200

Hi,

as you all know, the ACM draft is already in the RFC Editor's queue. So,
any discussions on this issue should happen sooner rather than later.

Cheers,

Gonzalo

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Wed, 19 Jan 2011 18:30:39 +0100

> I suggest that the ACM draft must explicitly mention the fact that it does not interoperate through design with ANY of the other MSRP entities. So that other developers do no get confused and waste…

Hi Adrian, perhaps it would be useful if you point the exact issues of
ACM specification (I mean those points that break
compatibility/interoperability with non-ACM MSRP peers).

BTW, it is sad the fact that an expertised implementor working with
MSRP for 3 years complains in this way about a draft (next to become
and RFC) and nobody in this group cares or replies him. Just my
opinion.

Regards.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 19 Jan 2011 20:03:26 +0100

Hi,

>and RFC) and nobody in this group cares or replies him. Just my

I don't know what you mean by "nobody cares". At least Ben, Gonzalo and myself have asked Adrian to clarify the issue. I am not going to add statements that something doesn't work unless I know WHY it doesn't work. Because, the reason also needs to be documented.

It is very important to note that the draft has changed during the process. In the beginning the ACM draft also contained the stuff that is now in the SESSMATCH draft. And, in addition the SESSMATCH part is different today from what it was in the beginning. 

Regards,

Christer

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Thu, 20 Jan 2011 17:26:07 +0100

> I don't know what you mean by "nobody cares". At least Ben, Gonzalo and myself have asked Adrian to clarify the issue. I am not going to add statements that something doesn't work unless I know WHY…

I understand your point, and I agree that the reporter should include
exact description about the specification topics not working (those
breaking interoperability).

However I'd really would like somebody to argument here that MSRP
peers can interoperate with MSRP+ACM peers, by providing some example.
If not, it seems like a discussion betweeen papers (which always
compile) and a real attempt of implementation. This is, can somebody
ensure that MSRP peers can interoperate with no problem with MSRP+ACM
peers?

Regards.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 24 Jan 2011 12:28:22 +0100

We all have concern if there is a compatibility problem. 3GPP has a concern, because release 6 and release 7 are plain ordinary MSRP, and release 8 onwards allows ACM and these are meant to be still interoperable (with fallback to the lowest common denominator.

What we do need to see is a technical summary of what does not work - just stating it does not work hardly helps further technical work.

Keith

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 19 January 2011 19:03
To: Iñaki Baz Castillo; Adrian Georgescu
Cc: [email-masked] WG
Subject: Re: [Simple] ACM does not interoperate with any other MSRP entity

Hi,

Regards,

Christer