Subject: [Simple] draft-ietf-simple-msrp-acm-10.txt

From: Adrian Georgescu <[email-masked]>
Date: Wed, 12 Jan 2011 19:05:33 +0100

Dear Christer,

Can you please explicitly mention in your draft that by implementing the specifications described in it:

1. The SIP end-point that implements it will not be able to interoperate with any other MSRP end-point, that being MSRP end-point RFC 4975 compliant,  MSRP relay RFC 4976 compliant and MSRP chatserver draft-ietf-simple-chat-07 compliant.

2. The peer end-points must also implement the same specification and by doing it they will break the intrinsic security properties built into the MSRP protocol.

Thank you,
Adrian

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 12 Jan 2011 20:19:05 +0100

Hi Adrian,

(I noticed that I had previously sent my reply to you only, so I will re-send to the list.)

If there are limitations to the usage they can be documented.

However, in order to do that I would need to know exactly what goes wrong, and what doesn't work, so we can document it.

We can't just say that something doesn't work, and ask people to download a specific client in order to try to figure out why something doesn't work...

Regards,

Christer

________________________________________
From: Adrian Georgescu [[email-masked]]
Sent: Wednesday, January 12, 2011 8:05 PM
To: Christer Holmberg
Cc: [email-masked] WG
Subject: draft-ietf-simple-msrp-acm-10.txt

Dear Christer,

Thank you,
Adrian

---

From: Hisham Khartabil <[email-masked]>
Date: Thu, 13 Jan 2011 17:00:31 +1100

Christer,

You are saying that you thought about it and believe nothing can go wrong,
or that you haven't thought about it?

Thanks,
Hisham

On 13 January 2011 06:19, Christer Holmberg
<[email-masked]>wrote:

> However, in order to do that I would need to know exactly what goes wrong,
> and what doesn't work, so we can document it.
>
> We can't just say that something doesn't work, and ask people to download a
> specific client in order to try to figure out why something doesn't work...
>
> Regards,
>
> Christer
>
> 1. The SIP end-point that implements it will not be able to interoperate
> with any other MSRP end-point, that being MSRP end-point RFC 4975 compliant,
>  MSRP relay RFC 4976 compliant and MSRP chatserver draft-ietf-simple-chat-07
> compliant.
>
> 2. The peer end-points must also implement the same specification and by
> doing it they will break the intrinsic security properties built into the
> MSRP protocol.
>
> Thank you,
> Adrian
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple
>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 13 Jan 2011 07:39:29 +0100

Hi, 

>You are saying that you thought about it and believe nothing can go wrong, or that you haven't thought about it?

Thought about what? All I see is a comment that ACM doesn't work, but no description of what goes wrong...

Regards,

Christer

	
	On 13 January 2011 06:19, Christer Holmberg <[email-masked]> wrote:

		Hi Adrian,

		

		Regards,
		
		Christer

		Dear Christer,

		
		
		Thank you,
		Adrian

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 13 Jan 2011 07:43:12 +0100

Of course I have thought about interoperability with non-ACM entities, and in my opinion there is no issue.

But, again, since I don't know what the problem is I can't refer to any specific thoughts...

Regards,

Christer

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Christer Holmberg
> Sent: 13. tammikuuta 2011 8:39
> To: Hisham Khartabil
> Cc: Adrian Georgescu; [email-masked] WG
> Subject: Re: [Simple] draft-ietf-simple-msrp-acm-10.txt
> 
> 
> Hi, 
> 
> >You are saying that you thought about it and believe nothing 
> can go wrong, or that you haven't thought about it?
> 
> Thought about what? All I see is a comment that ACM doesn't 
> work, but no description of what goes wrong...
> 
> Regards,
> 
> Christer
> 
> 
> 	
> 	
> <[email-masked]> wrote:
> 	
> 
> 		Hi Adrian,
> 		
> 		(I noticed that I had previously sent my reply 
> to you only, so I will re-send to the list.)
> 		
> 		However, in order to do that I would need to 
> know exactly what goes wrong, and what doesn't work, so we 
> can document it.
> 		
> 		We can't just say that something doesn't work, 
> and ask people to download a specific client in order to try 
> to figure out why something doesn't work...
> 		
> 		Regards,
> 		
> 		Christer
> 		
> 		Can you please explicitly mention in your draft 
> that by implementing the specifications described in it:
> 		
> 		1. The SIP end-point that implements it will 
> not be able to interoperate with any other MSRP end-point, 
> that being MSRP end-point RFC 4975 compliant,  MSRP relay RFC 
> 4976 compliant and MSRP chatserver draft-ietf-simple-chat-07 
> compliant.
> 		
> 		2. The peer end-points must also implement the 
> same specification and by doing it they will break the 
> intrinsic security properties built into the MSRP protocol.
> 		
> 		Thank you,
> 		Adrian