Subject: [Simple] Empty Send Requests

From: "Achint Aggarwal" <[email-masked]>
Date: Wed, 2 Mar 2011 09:04:41 +0530

Sec 7.1.1 rfc 4975 states:

"There are some circumstances where an endpoint may choose to send an
empty SEND request".
I know that bodiless SEND requests are different from SEND requests with
empty bodies. But what could be the use case for the same??

Why can't we use SEND requests with empty bodies for keep-alive
mechanisms instead of bodiless SEND requests??

Regards

Achint Aggarwal

---

From: Ben Campbell <[email-masked]>
Date: Tue, 1 Mar 2011 21:45:56 -0600

On Mar 1, 2011, at 9:34 PM, Achint Aggarwal wrote:

> “There are some circumstances where an endpoint may choose to send an empty SEND request”.
> I know that bodiless SEND requests are different from SEND requests with empty bodies. But what could be the use case for the same??
>  
> Why can’t we use SEND requests with empty bodies for keep-alive mechanisms instead of bodiless SEND requests??

Why would you want to? A SEND request with an empty body is sometimes larger and never smaller than a bodiless send request.

I suspect there may be some confusion about what we mean by an empty body--an empty body is a well formed MIME payload that happens to carry no content. For something like text/plain, that is almost identical to a bodiless request--except that it must still have the content-type, etc.  OTOH, an empty XML body would need to have the proper XML preamble, closings, etc.

Also, the peer might choose to render an empty body. For example, maybe it inserts a blank message or line feed in a chat window, while it might choose to do nothing user-visible when it receives a bodiless SEND request.