Subject: [Simple] MSRP-sessmatch discussion

From: Ben Campbell <[email-masked]>
Date: Wed, 1 Jun 2011 16:24:29 -0500

(as chair)

Hi everyone,

We've had a lot of discussion about the msrp-sessmatch extension draft over the last couple of weeks. For those who have been involved in or are following the discussions, do you think that a face-to-face meeting at IETF81 would help?

We'd appreciate quick responses, since the deadline for requesting a meeting slot is coming up Monday.

Thanks!

Ben.

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 1 Jun 2011 23:38:46 +0200

Hi,

Personally, at this point, I see no need for a face-to-face meeting.

I don't want to wait for Quebec for making a decission on whether to move forward with the new sessmatch alternative. 

Based on the feedback so far, people seem to be ok (or, at least more ok than before :) with it, and we intend to submit a new version of the draft, describing the new alternative, by the end of next week. If anyone wants to go on with the old alternative, I would ask him/her to indicate so asap, and justfiy why.

Also, the new alternative solves some of the issues we've had in the past, so those don't need to be discussed at all anymore. And, AFAIK, it hasn't brough up any NEW issues.

Regards,

Christer

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Ben Campbell [[email-masked]]
Sent: Thursday, June 02, 2011 12:24 AM
To: Simple WG
Cc: [email-masked] Chairs
Subject: [Simple] MSRP-sessmatch discussion

(as chair)

Hi everyone,

Thanks!

Ben.

_______________________________________________
Simple mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/simple

---

From: Adam Roach <[email-masked]>
Date: Wed, 01 Jun 2011 16:57:31 -0500

I think it would be hard to gauge response this quickly. No one has had 
time to do the kind of serious analysis that would be necessary to 
determine whether the new proposal has any of the same kinds of flaws as 
the previous one.

Personally, I haven't had time, in the almost two work days since it was 
published, to study whether the new mechanism introduces any 
showstopping incompatibilities. I'd be surprised if anyone else thinks 
they've done a suitable level of diligence either.

If we go down the path of using a whole new mechanism, I can't imagine a 
world in which we don't need a face-to-face discussion in Quebec.

/a

---

From: Adrian Georgescu <[email-masked]>
Date: Thu, 2 Jun 2011 00:28:04 +0200

Gents,

Nobody can claim to understand the full consequences of this endless trial-and error approach to legitimate the insertion of an intermediate into an end-to-end Internet protocol. The consequences can only be seen later after the damage has been done and too late for anyone to fix as the working group has been closed.

There is nothing OK with this draft, it is fundamentally wrong starting with the very problem it tries to solve.

Even worse, it creates a dangerous precedent to do similar things with other Internet protocols in the future.

Regards,
Adrian

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 2 Jun 2011 10:11:59 +0200

Hi Adam,

I don't expect people to fully understand the new alternative just like that. The general idea, however, should be quite easy to understand, so I was more wondering whether people think we should even look into it. 

But, then we of course need to make sure we get the details correct etc.

BTW, regarding "a whole new mechanism", we would actually re-use more of the 4975 procedures than in the current mechanism :)

Regards,

Christer

________________________________________
From: Adam Roach [[email-masked]]
Sent: Thursday, June 02, 2011 12:57 AM
To: Christer Holmberg
Cc: Ben Campbell; Simple WG; [email-masked] Chairs
Subject: Re: [Simple] MSRP-sessmatch discussion

/a

---

From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 6 Jun 2011 17:15:44 +0200

Hi Christer,

I think, this new idea is worth further investigation.

Regards
Christian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of ext Christer Holmberg
Sent: Thursday, June 02, 2011 10:12 AM
To: Adam Roach
Cc: [email-masked] Chairs; Simple WG
Subject: Re: [Simple] MSRP-sessmatch discussion

Hi Adam,

I don't expect people to fully understand the new alternative just like
that. The general idea, however, should be quite easy to understand, so
I was more wondering whether people think we should even look into it. 

BTW, regarding "a whole new mechanism", we would actually re-use more of
the 4975 procedures than in the current mechanism :)

Regards,

Christer

/a

On 6/1/11 4:38 PM, Christer Holmberg wrote:
> I don't want to wait for Quebec for making a decission on whether to
move forward with the new sessmatch alternative.
>
> Based on the feedback so far, people seem to be ok (or, at least more
ok than before :) with it, and we intend to submit a new version of the
draft, describing the new alternative, by the end of next week. If
anyone wants to go on with the old alternative, I would ask him/her to
indicate so asap, and justfiy why.
>
> Also, the new alternative solves some of the issues we've had in the
past, so those don't need to be discussed at all anymore. And, AFAIK, it
hasn't brough up any NEW issues.
> We've had a lot of discussion about the msrp-sessmatch extension draft
over the last couple of weeks. For those who have been involved in or
are following the discussions, do you think that a face-to-face meeting
at IETF81 would help?