Subject: [Simple] Sessmatch: New name, abstract and applicability proposal

From: Christer Holmberg <[email-masked]>
Date: Tue, 14 Jun 2011 14:27:43 +0200

Hi,

Below is some suggested name/abstract/applicability text.

Note that I have kept the name of the ALG/SBC/B2BUA/whatever-terminology-we-will-use open for now. I have asked Hadriel to provide some definition text regarding that.

-----------

Name:

   "Connection Establishment for Media Anchoring (CAMA) for the Message Session Relay Protocol (MSRP)"

I think that name is short and descriptive. The applicability (see below) section will then talk about in what types of networks etc the extension is applicable.

-----------

For the Abstract section, I suggest the following modified text:

"Abstract

   This document defines an MSRP extension, Connection Establishment for Media
   Anchoring (CAMA). Support of the extension is optional. MSRP endpoints can
   implement the extension in order to allow MSRP communication in
   networks where <insert ALGs/SBCs/B2BUAs/whatever word we will use>
   anchor the MSRP connection, without the need for the <ALGs/SBCs/B2BUAs>
   to enable MSRP B2BUA functionality.  The document also defines a Session
   Description Protocol (SDP) [RFC4566] attribute, a=msrp-cama, that can
   be used by MSRP endpoints to indicate support of the CAMA extension."

-----------

For the Applicability section, I suggest the following modified text:

"3.  Applicability statement

   This document defines an MSRP extension, Connection Establishment for Media
   Anchoring (CAMA). Support of the extension is optional. MSRP endpoints can
   implement the extension in order to allow MSRP communication in
   networks where <insert ALGs/SBCs/B2BUAs/whatever word we will use>
   anchor the MSRP connection, without the need for the <ALGs/SBCs/B2BUAs>
   to enable MSRP B2BUA functionality.  The document also defines a Session
   Description Protocol (SDP) [RFC4566] attribute, a=msrp-cama, that can
   be used by MSRP endpoints to indicate support of the CAMA extension.

   The CAMA extension is primarily intended for MSRP endpoints
   that operate in networks in which <ALGs/SBCs/B2BUAs> that want to
   anchor media connections are deployed, without the need for those <ALGs/SBCs/B2BUAs>
   to enable MSRP B2BUA functionality. An example of such network is the IP
   Multimedia Subsystem (IMS) defined by the 3rd Generation Partnership
   Project (3GPP). The extension is also useful for other MSRP endpoints
   operating in other networks, but that communicate with MSRP endpoints in
   networks with such <ALGs/SBCs/B2BUAs>, unless there is a gateway between
   the networks that by default always enable MSRP B2BUA functionality."

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Tue, 14 Jun 2011 14:31:19 +0200

> Session Relay Protocol (MSRP)"

Hi, wouldn't be "CEMA"? I've seen however that you use CAMA various
times in your mail.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 14 Jun 2011 14:33:52 +0200

Correct. CEMA.

Regards,

Christer 

> -----Original Message-----
> From: Iñaki Baz Castillo [mailto:[email-masked]] 
> Sent: 14. kesäkuuta 2011 15:31
> To: Christer Holmberg
> Cc: [email-masked]
> Subject: Re: [Simple] Sessmatch: New name, abstract and 
> applicability proposal
> 
> Hi, wouldn't be "CEMA"? I've seen however that you use CAMA 
> various times in your mail.
> 
> --
> Iñaki Baz Castillo
> <[email-masked]>
>

---

From: Adrian Georgescu <[email-masked]>
Date: Tue, 14 Jun 2011 14:54:43 +0200

Hi Christer,

The name, abstract and applicability clearly indicates the purpose and context of this new MSRP extension.

It looks very good!

Best regards,
Adrian

P.S. This comment is not suppose to address any technical issues (if any at all present in the draft), but just the name, abstract and applicability.

On Jun 14, 2011, at 2:27 PM, Christer Holmberg wrote:

> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple

---

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Tue, 14 Jun 2011 15:53:05 +0200

Hi,

> Note that I have kept the name of the ALG/SBC/B2BUA/whatever-terminology-we-will-use open for now. I have asked Hadriel to provide some definition text regarding that.

In the sentence where it says "... without the need for the XXX to enable MSRP B2BUA ..." I'd add something like "on all scenarios" or "always" in the end.

I really like these new texts, they look really descriptive and nice :-)

Regards,

--
Saúl Ibarra Corretgé
AG Projects

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 14 Jun 2011 21:31:45 +0200

Hi,

>In the sentence where it says "... without the need for the XXX to enable MSRP B2BUA ..." I'd add something like "on all scenarios" or "always" in the end.

I guess I could say "in most cases", in order to have alligned wording with the change you earlier proposed in section 1/paragraph 4.

Regards,

Christer