Subject: [Simple] Please clarify this ambiguity with terminology.

From: prasun bheri <[email-masked]>
Date: Mon, 18 Jul 2011 19:45:50 +0530

Hello Group,
I have a little ambiguity with terminology in rfc4975

in this document, section 7.3.2 (page 27), fourth paragraph, it reads

"it is possible that an endpoint will receive a REPORT 'request' on a
session that is no longer valid"

in this context this REPORT (success/failure of a transaction) is being sent
to a session that has expired.
here REPORT is clearly sent as a 'response' where as in document it
is referred as report 'request'.

is there any specific reason to call it as report request rather than
calling it as response?

Thanks & Regards
Prasun

---

From: Ben Campbell <[email-masked]>
Date: Mon, 18 Jul 2011 10:07:50 -0500

On Jul 18, 2011, at 9:15 AM, prasun bheri wrote:

> "it is possible that an endpoint will receive a REPORT 'request' on a session that is no longer valid" 
> 
> in this context this REPORT (success/failure of a transaction) is being sent to a session that has expired. 
> here REPORT is clearly sent as a 'response' where as in document it is referred as report 'request'.
> 
> is there any specific reason to call it as report request rather than calling it as response?

Yes. A REPORT request is different than a response. A response is a transactional response to a specific request. a REPORT request is a way to send delivery information to an upstream device. It may cover data from more than one request. It has a different format, and is used in different situations, than a "response".

Hope this helps.

Ben.

> 
> Thanks & Regards
> Prasun
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple