Subject: [Simple] Comment on draft-ietf-msrp-sessmatch-13

From: Andrew Allen <[email-masked]>
Date: Fri, 29 Jul 2011 15:07:16 +0000

Christer

I have reviewed this draft and I am basically supportive of it.

One comment I have is that in 4.2 there is discussion of fallback behavior where the middlebox decides to act as B2BUA after it receives the first response based on a new offer within the same dialog. To act as a B2BUA the middlebox needs to determine to be a B2BUA when handling the dialog creating request so the fallback scenario requires the MSRP endpoint to cancel the existing dialog and send the revised offer in a new dialog creating request (not in a request on an existing dialog).

Andrew 
---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 29 Jul 2011 17:35:43 +0200

Hi Andrew,

The middlebox does not send a new offer - it is the task of the CEMA UA. The middlebox simply decides to either enable MSRP B2BUA. We did not want to start specifying procedures abuot middleboxes sending offers etc.

Having said that, one comment that you (and some others) have given is that the middlebox needed to determine whether to enable MSRP B2BUA when it receives the SDP offer, and I will address that.

Thanks!

Regards,

Christer

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Andrew Allen [[email-masked]]
Sent: Friday, July 29, 2011 6:07 PM
To: [email-masked]
Subject: [Simple] Comment on draft-ietf-msrp-sessmatch-13

Christer

Andrew
---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.
_______________________________________________
Simple mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/simple

---

From: Andrew Allen <[email-masked]>
Date: Fri, 29 Jul 2011 15:45:13 +0000

I don't think I said that the middlebox initiates the new offer. Its clear the UA does that.

----- Original Message -----
From: Christer Holmberg [mailto:[email-masked]]
Sent: Friday, July 29, 2011 10:35 AM
To: Andrew Allen; [email-masked] <[email-masked]>
Subject: Re: [Simple] Comment on draft-ietf-msrp-sessmatch-13

Hi Andrew,

Thanks!

Regards,

Christer

Christer

Andrew