Subject: Re: [Simple] Consensus Call on sessmatch-13

From: Christer Holmberg <[email-masked]>
Date: Sat, 2 Jul 2011 01:22:29 +0200

Hi,

>>I see no need for changing what RFC6135 says. What about something like: "MSRP endpoints supporting >>this specification MUST become active upon receiving an offer with 'actpass' " Would that be reasonable >>for you?
>
>This should be the way to go.

Sounds good.

Regards,

Christer

---

From: Ben Campbell <[email-masked]>
Date: Mon, 11 Jul 2011 14:58:21 -0500

Hi Atle,

By "constructive proposal", do you mean the consensus call itself, or did you mean to concur with my comment about wanting to understand the scenarios better?

Thanks!

Ben.

On Jun 28, 2011, at 6:00 AM, Atle Monrad wrote:

> +1 from me aswell
> 
> Thanks to Ben for a constructive proposal !
> 
> /atle
> 
> 
> ________________________________ 
> 
> 
> Atle Monrad
> 3GPP CT Chairman
> Standardization and Regulation,
> Group Function Technology and Portfolio Management 
> Ericsson
> 
> 
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of DOLLY, MARTIN C (ATTSI)
> Sent: 28. juni 2011 00:33
> To: Nancy Greene; [email-masked]
> Subject: Re: [Simple] Consensus Call on sessmatch-13
> 
> +1
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Nancy Greene
> Sent: Monday, June 27, 2011 12:32 PM
> To: [email-masked]
> Subject: Re: [Simple] Consensus Call on sessmatch-13
> 
> I also support sessmatch-13
> 
> Nancy 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Hadriel Kaplan
> Sent: June-27-11 12:27 PM
> To: <[email-masked]> <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Simple] Consensus Call on sessmatch-13
> 
> 
> +1
> 
> 
> On Jun 27, 2011, at 5:26 AM, <[email-masked]> <[email-masked]> wrote:
> 
>> Hi,
>> Yes I think that is the right direction to go.
>> 
>> Roland
>> 
>> 
>>> -----Ursprüngliche Nachricht-----
>>> Von: [email-masked] [mailto:[email-masked]] Im 
>>> Auftrag von Ben Campbell
>>> Gesendet: Freitag, 24. Juni 2011 20:45
>>> An: Simple WG
>>> Betreff: [Simple] Consensus Call on sessmatch-13
>>> 
>>> (as chair)
>>> 
>>> Hi,
>>> 
>>> The latest version of the sessmatch draft (
>>> draft-ietf-simple-msrp-sessmatch-13) is a significant change of 
>>> direction from older version. The essential difference is that the 
>>> new version involves compliant endpoints using the SDP m and c lines 
>>> to establish TCP connections, rather than the previous approach of 
>>> making clients more resilient to a middlebox changing an MSRP URI in 
>>> the a=path attribute. The draft refers to this new approach as CEMA.
>>> 
>>> Do people thinks this is the right direction to take this work? I'm 
>>> not asking if the draft is perfect and ready to go--we certainly 
>>> expect discussion and potential changes in the details. The point is 
>>> to decide if we should move forward with the CEMA approach instead of 
>>> the previous sessmatch approach.
>>> 
>>> (In a perfect world, we probably would put CEMA in a separate draft 
>>> so the two could be compared. But unless people strongly object, I 
>>> think we can still compare the approaches with the current draft
>>> structure.)
>>> 
>>> Please send opinions and comments to the SIMPLE list no later than 11 
>>> July 2011. Sooner is better. (This is probably longer than we need, 
>>> but I know we're into prime vacation time for a number of people, 
>>> including myself. I've allotted extra time in hopes of getting more
>>> comments)
>>> 
>>> Thanks!
>>> 
>>> Ben.
>>> _______________________________________________
>>> Simple mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/simple
>>> 
>> _______________________________________________
>> Simple mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/simple
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 11 Jul 2011 22:30:08 +0200

Hi,

In general, fallback is still needed in middlebox cases where a legacy entity establishes the MSRP TCP connection, or where the UA is behind a relay.

(If there are no middleboxes, procedures are according to 4975).

Regards,

Christer

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Ben Campbell [[email-masked]]
Sent: Monday, July 11, 2011 10:58 PM
To: Atle Monrad
Cc: [email-masked]
Subject: Re: [Simple] Consensus Call on sessmatch-13

Hi Atle,

Thanks!

Ben.

---

From: Ben Campbell <[email-masked]>
Date: Tue, 12 Jul 2011 15:20:28 -0500

(as chair)

I read the resulting thread as rough consensus to follow the general direction of the CEMA approach in sessmatch-13. We've seen some comments on details, and some requests for more analysis of scenarios. We've also seen comments questioning the general applicability of the work in a separate thread. Please continue with those conversations.

While we have agenda time for this in Quebec City, it would be even better to get as much work done as possible before the face to face meeting :-)

Thanks!

Ben.

On Jun 24, 2011, at 1:45 PM, Ben Campbell wrote:

> (as chair)
> 
> Hi,
> 
> The latest version of the sessmatch draft ( draft-ietf-simple-msrp-sessmatch-13) is a significant change of direction from older version. The essential difference is that the new version involves compliant endpoints using the SDP m and c lines to establish TCP connections, rather than the previous approach of making clients more resilient to a middlebox changing an MSRP URI in the a=path attribute. The draft refers to this new approach as CEMA.
> 
> Do people thinks this is the right direction to take this work? I'm not asking if the draft is perfect and ready to go--we certainly expect discussion and potential changes in the details. The point is to decide if we should move forward with the CEMA approach instead of the previous sessmatch approach.
> 
> (In a perfect world, we probably would put CEMA in a separate draft so the two could be compared. But unless people strongly object, I think we can still compare the approaches with the current draft structure.)
> 
> Please send opinions and comments to the SIMPLE list no later than 11 July 2011. Sooner is better. (This is probably longer than we need, but I know we're into prime vacation time for a number of people, including myself. I've allotted extra time in hopes of getting more comments)
> 
> Thanks!
> 
> Ben.