Subject: [Simple] XCAP clients in the real world

From: Adrian Georgescu <[email-masked]>
Date: Mon, 22 Aug 2011 21:37:19 +0200

Hello,

I know is too little too late but I am simple peasant born in Romania.

Now there is a SIP client with proper XCAP support available in the real world, you can find it in the Mac App Store if you search for Blink Lite or Blink Pro. 

It supports storage of contacts lists using resource-lists and rls-services documents based on OMA specifications and xcap-diff event package for synchronizing multiple clients in real time.

Regards,
Adrian

---

From: Emil Ivov <[email-masked]>
Date: Mon, 22 Aug 2011 21:55:29 +0200

Speaking of XCAP implementations, people here would probably be interested
in Jitsi too.

http://jitsi.org

XCAP support for Windows, Mac OS X, and Linux. Entirely open sourced and
free (as in beer and as in speech ;) )

Emil

-- sent from my mobile
On Aug 22, 2011 9:37 PM, "Adrian Georgescu" <[email-masked]> wrote:
> Now there is a SIP client with proper XCAP support available in the real
world, you can find it in the Mac App Store if you search for Blink Lite or
Blink Pro.
>
> It supports storage of contacts lists using resource-lists and
rls-services documents based on OMA specifications and xcap-diff event
package for synchronizing multiple clients in real time.
>
> Regards,
> Adrian
>
>
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Mon, 22 Aug 2011 22:03:12 +0200

2011/8/22 Emil Ivov <[email-masked]>:
> XCAP support for Windows, Mac OS X, and Linux.

How good is the XCAP support? when I tested it some time ago it was
really buggy. For example, I tryed to report the following bug (but
was impossible to use Jira web tracker):

When Jitsi uploads the resource-list (XCAP PUT) it set a wrong Content-Type:

-----------------------------------------
PUT /resource-lists/users/sip:[email-masked]/index HTTP/1.1'
Connection: close'
Content-Length: 231'
Content-Type: application/xcap-caps+xml'
Content-Encoding: UTF-8'
Host: example.org:800'
User-Agent: Apache-HttpClient/4.0.1 (java 1.5)'
Expect: 100-Continue'

<?xml version="1.0" encoding="UTF-8" standalone="no"?><resource-lists
xmlns="urn:ietf:params:xml:ns:resource-lists"><list
name="RootGroup"><entry
uri="sip:[email-masked]"/></list></resource-lists>
---------------------------------------

Why is it using "Content-Type: application/xcap-caps+xml"? Such mime
type is just for discovering XCAP Server Capabilities:
  http://tools.ietf.org/html/rfc4825#section-12

The mime type for a resource-lists document must be
application/resource-lists+xml:
  http://tools.ietf.org/html/rfc4826#section-3.4.2

Regards.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Adrian Georgescu <[email-masked]>
Date: Mon, 22 Aug 2011 22:06:15 +0200

Yes, it would be really nuts to be the only crazy person in town ;-)

Adrian

On Aug 22, 2011, at 9:55 PM, Emil Ivov wrote:

> Speaking of XCAP implementations, people here would probably be interested in Jitsi too.
> 
> http://jitsi.org
> 
> XCAP support for Windows, Mac OS X, and Linux. Entirely open sourced and free (as in beer and as in speech ;) )
> 
> Emil
> -- sent from my mobile
>

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Tue, 23 Aug 2011 13:06:45 +0200

2011/8/23 Emil Ivov <[email-masked]>:
>> How good is the XCAP support?
>
> Good enough I suppose. We are using it with OpenXCAP on a daily basis
> without any issues and we've had success reports for other impls too.

Good to know :)

>> when I tested it some time ago it was
>> really buggy. For example, I tryed to report the following bug
>> (but was impossible to use Jira web tracker):
>
> I couldn't find your report on our mailing lists (which is where we take
> them) so feel free to post there:
>
> http://jitsi.org/mailinglists

Well, the bug report is exactly what I've pasted in my previous mail
and it exists regardless I subscribe or not to that maillist (a really
hard task in my previous attempt, I didn't receive confirmation until
long days after requesting the subscription). So, if it's ok for you I
prefer not to subscribe (the bug report is exactly my previous mail).

Regards.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Emil Ivov <[email-masked]>
Date: Tue, 23 Aug 2011 12:57:09 +0200

Hey Iñaki,

Cheers,
Emil