Subject: Re: [Simple] Sessmatch products

From: Cullen Jennings <[email-masked]>
Date: Mon, 1 Aug 2011 12:48:06 -0700

old reply in my drafts folder ...

On May 26, 2011, at 3:46 AM, Christer Holmberg wrote:

> 
> In sessmatch mode the troughput for MSRP packets is line-interface wirespeed, while in MSRP B2BUA mode the maximum throughput for MSRP packets is much lower.

I'm pretty confused on how dealing with the SIP need to look at the path or just modify the SDP has an impact on the speed or sending MSRP packets once the session is set up. Of course I support the goal of rapid forwarding of MSRP packets once the session is set up. I can't see any  problem with archiving wireline speed forwarding of packets thorough an MSRP relay.

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 2 Aug 2011 00:19:04 +0200

Hi Cullen, 

>>In sessmatch mode the troughput for MSRP packets is 
>>line-interface wirespeed, while in MSRP B2BUA mode the 
>>maximum throughput for MSRP packets is much lower.
> 
>I'm pretty confused on how dealing with the SIP need to look 
>at the path or just modify the SDP has an impact on the speed 
>or sending MSRP packets once the session is set up. Of course 
>I support the goal of rapid forwarding of MSRP packets once 
>the session is set up. I can't see any  problem with 
>archiving wireline speed forwarding of packets thorough an 
>MSRP relay. 

I am not sure I understood you correctly, but yhe impact comes when a middlebox needs to modify the MSRP messages (MSRP B2BUA mode), rather than simply forwarding them.

Regards,

Christer

---

From: Ben Campbell <[email-masked]>
Date: Mon, 1 Aug 2011 20:58:29 -0400

I think the confusion was around the term "MSRP B2BUA". Christer has agreed to define this in the next revision of the draft.

Thanks!

Ben.

On Aug 1, 2011, at 6:19 PM, Christer Holmberg wrote:

> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 2 Aug 2011 13:27:08 -0700

> I am not sure I understood you correctly, but yhe impact comes when a middlebox needs to modify the MSRP messages (MSRP B2BUA mode), rather than simply forwarding them.

Well, what modifications are we talking about here and how much time do we think it will take? I'm not looking for exact measurements or anything but lets just work through how hard this is to do at wireline speeds.