Subject: [Simple] SDP comments to MSRP chat

From: "Miguel A. Garcia" <[email-masked]>
Date: Thu, 6 Oct 2011 21:59:16 +0200

Hi,

the MSRP chat was reviewed in MMUSIC, and we got two main comments:

1) extensibility of the 'chatroom' attribute in SDP. Do we need an IANA 
registry

2) Privacy concerns of this attribute.

The review is here:
http://www.ietf.org/mail-archive/web/mmusic/current/msg08940.html

For issue 1, I think that we don't need an IANA registry at this point, 
in particular because we are not expecting extensions to this attribute. 
My proposal is to simply indicate that organizations that want to extend 
this attribute and create new tokens should use their reversed names to 
avoid clashes among then.

For issue 2, I will think a bit what we need to say and I will post it in 
a separate mail once I have the text. I am willing to receive suggestions.

/Miguel

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain

---

From: Ben Campbell <[email-masked]>
Date: Thu, 6 Oct 2011 17:57:28 -0500

On Oct 6, 2011, at 2:59 PM, Miguel A. Garcia wrote:

> 1) extensibility of the 'chatroom' attribute in SDP. Do we need an IANA registry
> 
> For issue 1, I think that we don't need an IANA registry at this point, in particular because we are not expecting extensions to this attribute. My proposal is to simply indicate that organizations that want to extend this attribute and create new tokens should use their reversed names to avoid clashes among then.

Out of curiosity, if we don't expect extensions, do we need the extension point int he ABNF?

If an organization creates more than one extension token, is it up to that organization to coordinate them?

> 
> For issue 2, I will think a bit what we need to say and I will post it in a separate mail once I have the text. I am willing to receive suggestions.
> 
> /Miguel
> 
> -- 
> Miguel A. Garcia
> +34-91-339-3608
> Ericsson Spain
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 06 Oct 2011 19:25:34 -0400

> Out of curiosity, if we don't expect extensions, do we need the extension point int he ABNF?

We aren't always as good at predicting the future as we might wish, so I 
think it is still good to include an extension point. But we don't need 
to include a registry in that case - we can simply state that a revision 
to the draft is required to make an extension.

> If an organization creates more than one extension token, is it up to that organization to coordinate them?

If the intent is to allow private extensions without registration, then 
the ABNF needs to be modified to specify the syntax for the private 
names (distinct from any future standardized values), and the usage 
rules (e.g. reverse FQDN syntax) need to be spelled out.

	Thanks,
	Paul

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Fri, 7 Oct 2011 08:09:26 +0200

> Out of curiosity, if we don't expect extensions, do we need the extension point int he ABNF?

It is hard to determine what the future will bring. If we remove the 
extensibility now, and in the future we want to create an extension, then 
we will be forced to create a new SDP attribute. If we have the 
extensibility in place, but not the IANA registry, we can always create 
the IANA registry at a later point.

So, I am leaning towards being conservative, and allow the extensibility 
of the SDP 'chatroom' attribute, without having an IANA registry at this 
point.

/Miguel

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain

---

From: Saul Ibarra Corretge <[email-masked]>
Date: Fri, 7 Oct 2011 12:17:40 +0200

Hi,

On Oct 7, 2011, at 8:09 AM, Miguel A. Garcia wrote:

> It is hard to determine what the future will bring. If we remove the extensibility now, and in the future we want to create an extension, then we will be forced to create a new SDP attribute. If we have the extensibility in place, but not the IANA registry, we can always create the IANA registry at a later point.
> 
> So, I am leaning towards being conservative, and allow the extensibility of the SDP 'chatroom' attribute, without having an IANA registry at this point.
> 

At some point we did consider extending this attribute to specify that you may send some custom arbitrary data within a chat stream, for example, so if a server would add 'x-something' to the 'chatroom' attribute the client would know that it may send this kind of data. I'd like to see extensibility for 'chatroom' allowed.

Regards,

-- 
Saúl Ibarra Corretgé
AG Projects

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Fri, 7 Oct 2011 12:28:39 +0200

> At some point we did consider extending this attribute to specify that you may send some custom arbitrary data within a chat stream, for example, so if a server would add 'x-something' to the 'chat…

I agree with the extensibility of the attribute. I believe we can have a 
policy indicating that if someone wants to extend this attribute for 
their own purpose, they should prepend the value with the reversed DNS 
name of the organization, for example: com.example.foo-chat. For the time 
being, this seems to be enough.

/Miguel

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain

---

From: Saul Ibarra Corretge <[email-masked]>
Date: Fri, 7 Oct 2011 12:38:15 +0200

On Oct 7, 2011, at 12:28 PM, Miguel A. Garcia wrote:

> I agree with the extensibility of the attribute. I believe we can have a policy indicating that if someone wants to extend this attribute for their own purpose, they should prepend the value with the reversed DNS name of the organization, for example: com.example.foo-chat. For the time being, this seems to be enough.
> 

+1

The reversed DNS name of the organization seems good to me.

Regards,

-- 
Saúl Ibarra Corretgé
AG Projects

---

From: Ben Campbell <[email-masked]>
Date: Mon, 10 Oct 2011 13:27:13 -0500

> So, I am leaning towards being conservative, and allow the extensibility of the SDP 'chatroom' attribute, without having an IANA registry at this point.

Okay--I do not object to that approach.

---

From: Adrian Georgescu <[email-masked]>
Date: Mon, 10 Oct 2011 20:44:43 +0200

Yes, we have already extended the chatroom to advertise more features, it is useful and necessary.

Adrian