Subject: [Simple] [Technical Errata Reported] RFC5438 (3013)

From: RFC Errata System <[email-masked]>
Date: Fri, 4 Nov 2011 07:09:53 -0700 (PDT)

The following errata report has been submitted for RFC5438,
"Instant Message Disposition Notification (IMDN)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5438&eid=3013

--------------------------------------
Type: Technical
Reported by: Dan Price <[email-masked]>

Section: 7.2.1.1

Original Text
-------------
   From: Bob <im:[email-masked]>
   To: Alice <im:[email-masked]>
   NS: imdn <urn:ietf:params:imdn>
   imdn.Message-ID: d834jied93rf
   Content-type: message/imdn+xml
   Content-Disposition: notification
   Content-length: ...

Corrected Text
--------------
   From: Bob <im:[email-masked]>
   To: Alice <im:[email-masked]>
   NS: imdn <urn:ietf:params:imdn>
   imdn.Message-ID: d834jied93rf

   Content-type: message/imdn+xml
   Content-Disposition: notification
   Content-length: ...

Notes
-----
None of the examples in this RFC comply with the format of CPIM defined in RFC 3862, in which the message metadata headers are separated from the headers of the encapsulated MIME object by a blank line.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5438 (draft-ietf-simple-imdn-10)
--------------------------------------
Title               : Instant Message Disposition Notification (IMDN)
Publication Date    : February 2009
Author(s)           : E. Burger, H. Khartabil
Category            : PROPOSED STANDARD
Source              : SIP for Instant Messaging and Presence Leveraging Extensions
Area                : Real-time Applications and Infrastructure
Stream              : IETF
Verifying Party     : IESG

---

From: Nancy Greene <[email-masked]>
Date: Fri, 4 Nov 2011 10:48:12 -0400

This is the same issue I raised on the sip-implementor's list. Good to see this errata finally posted!
https://lists.cs.columbia.edu/pipermail/sip-implementors/2011-September/027736.html

Nancy 

www.ericsson.com  - This Communication is Confidential. We only send and receive email on the basis of the term set out at www.ericsson.com/email_disclaimer  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of RFC Errata System
Sent: November-04-11 10:10 AM
To: [email-masked]; [email-masked]; Gonzalo Camarillo; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Simple] [Technical Errata Reported] RFC5438 (3013)

The following errata report has been submitted for RFC5438, "Instant Message Disposition Notification (IMDN)".

Section: 7.2.1.1

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party (IESG) can log in to change the status and edit the report, if necessary. 

_______________________________________________
Simple mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/simple

---

From: Hisham Khartabil <[email-masked]>
Date: Mon, 7 Nov 2011 14:57:25 +1100

Hi,

I see separators in the examples in RFC3862, but I fail to find the text
that mandates that or describes it. Can you point it out to me?

Thanks,
Hisham

On 5 November 2011 01:48, Nancy Greene <[email-masked]> wrote:

> www.ericsson.com  - This Communication is Confidential. We only send and
> receive email on the basis of the term set out at
> www.ericsson.com/email_disclaimer
>
> To: [email-masked]; [email-masked]; Gonzalo
> Camarillo; [email-masked]; [email-masked];
> [email-masked]
> The following errata report has been submitted for RFC5438, "Instant
> Message Disposition Notification (IMDN)".
>
> None of the examples in this RFC comply with the format of CPIM defined in
> RFC 3862, in which the message metadata headers are separated from the
> headers of the encapsulated MIME object by a blank line.
>
> Instructions:
> -------------
> This errata is currently posted as "Reported". If necessary, please use
> "Reply All" to discuss whether it should be verified or rejected. When a
> decision is reached, the verifying party (IESG) can log in to change the
> status and edit the report, if necessary.
>

---

From: Robert Sparks <[email-masked]>
Date: Mon, 7 Nov 2011 09:32:08 -0600

I don't find 2119 language, but the requirement is described in the second paragraph of section 2.
I've marked this hold for document update.

RjS

On Nov 6, 2011, at 9:57 PM, Hisham Khartabil wrote:

> Hi,
> 
> I see separators in the examples in RFC3862, but I fail to find the text that mandates that or describes it. Can you point it out to me?
> 
> Thanks,
> Hisham
>