Subject: [Simple] Fwd: Re: [precis] I-D Action: draft-ietf-precis-nickname-02.txt

From: Peter Saint-Andre <[email-masked]>
Date: Sun, 23 Sep 2012 12:48:35 -0600

FYI. This also includes removal of the length restriction. I now
consider this I-D stable and would very much welcome reviews from
folks here. If no one volunteers to volunteer this little spec (only 7
pages!), I'll start poking people individually. ;-)

- -------- Original Message --------
Subject: Re: [precis] I-D Action: draft-ietf-precis-nickname-02.txt
Date: Sun, 23 Sep 2012 12:19:49 -0600
From: Peter Saint-Andre <[email-masked]>
To: [email-masked]

Minor changes to align with the IANA registration template in the
framework...

On 9/23/12 12:12 PM, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories. This draft is a work item of the Preparation and 
> Comparison of Internationalized Strings Working Group of the IETF.
> 
> Title           : Preparation and Comparison of Nicknames
> Author(s) : Peter Saint-Andre Filename        : 
> draft-ietf-precis-nickname-02.txt Pages           : 7 Date :
> 2012-09-23
> 
> Abstract: This document describes how to prepare and compare 
> Unicode strings representing nicknames, primarily as used within 
> textual chatrooms. This profile is intended to be used by chatroom 
> technologies based on both the Message Session Relay Protocol 
> (MSRP) and the Extensible Messaging and Presence Protocol (XMPP).
> 
> 
> The IETF datatracker status page for this draft is: 
> https://datatracker.ietf.org/doc/draft-ietf-precis-nickname
> 
> There's also a htmlized version available at: 
> http://tools.ietf.org/html/draft-ietf-precis-nickname-02
> 
> A diff from the previous version is available at: 
> http://www.ietf.org/rfcdiff?url2=draft-ietf-precis-nickname-02
> 
> 
> Internet-Drafts are also available by anonymous FTP at: 
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________ precis mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/precis
> 

_______________________________________________
precis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/precis

---

From: Mary Barnes <[email-masked]>
Date: Mon, 24 Sep 2012 16:25:12 -0500

I think the document looks good.  I do have one comment, however.  I have
updated
draft-boulton-xcon-session-chat to use this document for nickname
comparisons, as well.

So, I would suggest changing the abstract from:

   This profile is intended to be used by chatroom technologies

   based on
   both the Message Session Relay Protocol (MSRP) and the Extensible
   Messaging and Presence Protocol (XMPP).

to:

   This profile is intended to be used by chatroom technologies

   such as
   the Message Session Relay Protocol (MSRP) and the Extensible
   Messaging and Presence Protocol (XMPP).

Or, you could include the XCON Chat feature in that list, as well.

Thanks,
Mary.

On Sun, Sep 23, 2012 at 1:48 PM, Peter Saint-Andre <[email-masked]>wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG/MacGPG2 v2.0.18 (Darwin)
> Comment: Using GnuPG with Mozilla - http://www.enigmail.net/
>
> iEYEARECAAYFAlBfWYMACgkQNL8k5A2w/vxgnQCg5QmVajkV447tL8zh/+F4phWN
> xu0An33p0Fv7yK/uLOgtlfDtf/HfoewX
> =3YII
> -----END PGP SIGNATURE-----
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 24 Sep 2012 15:33:11 -0600

Hi Mary, thanks for the review!

On 9/24/12 3:25 PM, Mary Barnes wrote:
> I think the document looks good.  I do have one comment, however.
> I have updated draft-boulton-xcon-session-chat to use this document
> for nickname comparisons, as well.
> 
> based on both the Message Session Relay Protocol (MSRP) and the
> Extensible Messaging and Presence Protocol (XMPP).
> 
> to:
> 
> This profile is intended to be used by chatroom technologies such
> as the Message Session Relay Protocol (MSRP) and the Extensible 

Yes, that makes sense. It could even be used by non-chatroom
technologies, it's just that the chatroom uses are the driving force
now. Will fix.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/