Subject: [Simple] SIMPLE Interop Threads

From: Ben Campbell <[email-masked]>
Date: Thu, 1 Nov 2012 16:47:24 -0500

(as SIMPLE chair)

Hi Everyone,

We've recently had several very interesting thread about the interoperability issues in SIMPLE and what could be done to improve them. I'd like to see those discussions make progress. But please keep in mind that the work group is very close to completion on all it's milestones. (For the purpose of this thread, lets please ignore the question about whether that means "successful" completion). SIMPLE will almost certainly close in the near future.

That doesn't mean new work can't happen. It does mean that any such work will need to go through the normal RAI processes for substantially new work. Normally that means taking a proposal to DISPATCH. Success in DISPATCH will require the interested parties to (roughly) agree on the nature of the problem to be solved, and the scope of the work needed to do so. A problem statement in the form of an Internet-Draft  would be extremely helpful.

I suggest that the interested parties take the following concrete actions:

1) Work toward a rough consensus of the problem to be solved, and a rough idea of the scope of the work. What are the gaps in the standards that make interop hard? Where's the low hanging fruit? Please feel free to continue discussion on the SIMPLE list, with that goal in mind. (This also sounds like an interesting effort for the SIP Forum [nudge]  )

2) Bring a proposal to the DISPATCH list in time for the IETF-86 agenda deadlines. Continue discussion about the scope of work there.

3) Figure out next steps in DISPATCH, based on the scope, interest, and energy demonstrated there.

Again, I don't mean to stop the current discussion--please continue it, and feel free to use the SIMPLE list to help everyone get thoughts together to  make a concrete proposal to DISPATCH.

Thanks!

Ben.

---

From: "Olle E. Johansson" <[email-masked]>
Date: Fri, 2 Nov 2012 08:09:47 +0100

> Again, I don't mean to stop the current discussion--please continue it, and feel free to use the SIMPLE list to help everyone get thoughts together to  make a concrete proposal to DISPATCH.

Ben!
Thanks for your support of this issue and a very clear structure for us to follow.

There are members of the SIP Forum board on this list. 

I hope that they got the message that this is an issue that currently stops implementation and sales of SIP products that implement SIMPLE in favour of single-vendor solutions or alternatives like XMPP. For some members that's not a problem, but for general market growth I see it as a huge problem that should be a concern for the forum.

/O

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Fri, 2 Nov 2012 14:10:12 +0100

Ben, really thanks a lot for your feedback and proposal for continuing
the discussions. We will do our best efforts to provide the points you
ask for.

2012/11/1 Ben Campbell <[email-masked]>:
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple

-- 
Iñaki Baz Castillo
<[email-masked]>