Subject: [Simple] Fwd: [precis] spaces at end of nickname

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 01 Nov 2012 09:02:13 -0600

Feedback appreciated.

- -------- Original Message --------
Subject: [precis] spaces at end of nickname
Date: Thu, 01 Nov 2012 08:41:55 -0600
From: Peter Saint-Andre <[email-masked]>
To: [email-masked] <[email-masked]>

In the context of groupchat rooms, most applications show a room
roster of the participants. One way to spoof nicknames is to simply
add one or more space characters at the end, because the spaces don't
show up in the interface (thus "stpeter", "stpeter " with one space at
the end, and "stpeter  " with two spaces at the end would all appear
to be the same person). This seems like an obvious hole that we can
plug by disallowing trailing (and perhaps leading) spaces in
nicknames. I'll forward this message to the SIMPLE WG and XMPP WG for
their feedback, and also raise this issue during the PRECIS WG session
next week.

Peter

_______________________________________________
precis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/precis

---

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Thu, 1 Nov 2012 16:06:22 +0100

Hi Peter,

On Nov 1, 2012, at 4:02 PM, Peter Saint-Andre wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Feedback appreciated.
> 
> 

Trimming the nickname sounds reasonable to me, I don't see any case if which those spaces could bear any meaning.

Regards,

--
Saúl Ibarra Corretgé
AG Projects

---

From: Ben Campbell <[email-masked]>
Date: Thu, 1 Nov 2012 10:07:26 -0500

+1. Should we generalize this to leading and trailing white space?

On Nov 1, 2012, at 10:02 AM, Peter Saint-Andre <[email-masked]> wrote:

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG/MacGPG2 v2.0.18 (Darwin)
> Comment: Using GnuPG with Mozilla - http://www.enigmail.net/
> 
> iEYEARECAAYFAlCSjvUACgkQNL8k5A2w/vzbFQCeM1OGQDTI/bdS6oneRfF7+tH3
> RToAn2Ou9gA+mVKbnjKTv8YTyhKlcDUy
> =b45p
> -----END PGP SIGNATURE-----
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple
>

---

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Thu, 1 Nov 2012 16:10:19 +0100

> +1. Should we generalize this to leading and trailing white space?

I think so. Spaces are not perceived depending on where you align the text in a user interface.

--
Saúl Ibarra Corretgé
AG Projects

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 01 Nov 2012 12:22:13 -0400

> I think so. Spaces are not perceived depending on where you align the text in a user interface.

Agree with above.

In addition I think whitespace other than 'space' should be excluded 
(maybe it already is), and multiple sequential embedded spaces should be 
excluded.
(Will you notice the difference between "St Peter" and "St  Peter")?

	Thanks,
	Paul

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 01 Nov 2012 10:57:50 -0600

On 11/1/12 10:22 AM, Paul Kyzivat wrote:
> In addition I think whitespace other than 'space' should be
> excluded (maybe it already is),

Yes, all whitespace needs to be mapped to U+0020.

> and multiple sequential embedded spaces should be excluded. (Will
> you notice the difference between "St Peter" and "St  Peter")?

Probably not. This was suggested on the XMPP list, too. I think it's a
good idea.

Peter

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/