Subject: Re: [sip-overload] comments on draft-ietf-soc-overload-rate-control-01

From: "NOEL, ERIC C (ERIC C)" <[email-masked]>
Date: Thu, 5 Apr 2012 17:24:11 -0400

Volker,

Apologies for the delayed response.  Phil is away and could not provide input to below, and I am about to go away as well. So I am giving you partial responses which I will complete upon my return. Janet also provided some input in below.

- Section 3.4.:
   But when deriving this rate the server may need to
   take into account the effect of the client prioritization on the
   load it receives, e.g. CPU utilization will depend upon the
   characteristics of the requests.
How should the server take the client prioritization into account? Does the server need to know the prioritization made by the client?
[EN/JG] The server does not know the client(s) prioritization rules, but it could account for it implicitly  by relying on a resource measure such as the average CPU load per request due to the particular request stream mix resulting from the client's admission control.  Using this measure would allow the server to take into account the client prioritization.  

- Section 3.5.:
What is the adjusted-oc-value? Is this the value received in the oc parameter? How will it be adjusted?
[EN/JG] The parameter "adjusted-oc-value" is a typo, should be "oc-value". Will be changed in the next version.

How should the values TAU1 and TAU2 be set with respect to the overall TAU? Can you give guidance on how they should be chosen? What will they depend on?
[EN/JG] Putting together a small model to produce guidance on parameter selection. 

It would be very helpful to have a pseudo-code algorithm for rate based controls. This will make the description in this section easier to understand.
[EN/JG] Will be added in next version.

Eric Noel 
AT&T Labs, Inc. 
Rethink Possible

Network Design and Performance Analysis
200 South Laurel Avenue, D5-3D19
Middletown, NJ 07748
P: 732.420.4174
[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Volker Hilt
Sent: Tuesday, March 27, 2012 1:23 PM
To: [email-masked]
Subject: [sip-overload] comments on draft-ietf-soc-overload-rate-control-01

Eric, Phil,

here are a few comments on draft-ietf-soc-overload-rate-control-01:

- Section 3.4.:

    But when deriving this rate the server may need to
    take into account the effect of the client prioritization on the
    load it receives, e.g. CPU utilization will depend upon the
    characteristics of the requests.

How should the server take the client prioritization into account? Does the server need to know the prioritization made by the client?

- Section 3.5.:

What is the adjusted-oc-value? Is this the value received in the oc parameter? How will it be adjusted?

How should the values TAU1 and TAU2 be set with respect to the overall TAU? Can you give guidance on how they should be chosen? What will they depend on?

It would be very helpful to have a pseudo-code algorithm for rate based controls. This will make the description in this section easier to understand.

Thanks,

Volker

_______________________________________________
sip-overload mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sip-overload

---

From: Volker Hilt <[email-masked]>
Date: Fri, 6 Apr 2012 16:22:51 -0400

Eric,

thanks for your response. Looking forward to reading the next version.

More inline.
> [EN/JG] The server does not know the client(s) prioritization rules, but it could account for it implicitly  by relying on a resource measure such as the average CPU load per request due to the par…

Relying on local measurements and statistics in the servers seems 
reasonable. Would be good to clarify this in the draft.

Thanks,

Volker