Subject: A case related to "home Phone" type of functionality in SIP

From: "ANIRBAN ROY" <[email-masked]>
Date: Thu, 06 Jan 2000 09:25:43 +0530

hi,
I am trying to figure out how to get a home phone functionality in SIP.
The home phone has the following functionality
1    When a call comes all phones in the home ring
2    When one picks up, all other line must stop ringing
3    A user can picks up from any other telephone in the home and join
an existing call.

                                this a scenario where A calls a Home
Phone which has Three connection B, C, D in his home

+-------------|
                                                    A---------------|
Proxy        |---------------D

|                    |

+------------+

/     \

/       \

/         \

/           \

B           C

When a calls to a home phone which has 3 connection (B, C, D) lands on
proxy, then proxy forks the INVITE message to B, C, D. so every phone
starts ringing. This is the first character of Home Phone. Now Let's say
B picks up the phone then Proxy sends CANCEL message to C and D so that
the ringing can stop. This fulfills the Second point of Home Phone.

I am not able to get the call flow for the Third point in home Phone. If
lets say C picks up the phone then he should also be in session with A
and B. How can this be done because When a CANCEL message is received by
C and D then they both reached the state where they can only expect
INVITE.

Can any one please tell me how the call flow for the third point in the
home phone.

The above points of Home phone were taken from the -----Bell Labs
Journal (October-December 1998)

regards
Anirban

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 7 Jan 2000 13:11:43 -0500

I'll work on it.

Brian

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Friday, January 07, 2000 1:15 PM
> To: ANIRBAN ROY
> Cc: Dean Willis; Sean Olson; [email-masked]
> Subject: Re: A case related to "home Phone" type of 
> functionality in SIP
> 
> 
> I'd rather not delve too much farther into the technical 
> details of how
> until we have understood what we want to accomplish. There have been
> lots of ideas already in the last few days on how to do this, and they
> all are solutions to slightly different problems.
> 
> So, given there appears to be interest in working on this, let me ask
> the next question - who is willing to volunteer to work on a 
> design team
> to develop some documents for this? First step is 
> requirements. If there
> are sufficient people who are willing to actually do the work (phone
> conferences, mail discussions and possibly a face to face), I will
> discuss the possibility of adding this as a work item with my 
> co-chairs
> and the ADs.
> 
> -Jonathan R.
> 
> ANIRBAN ROY wrote:
> > 
> > hi ,
> > 
> > lets say in a house there are 3 phones B, C, D. now User 
> "A" calls to this house
> > 
> > Please tell me one question
> > 
> > When a call is going on between two user A and B and the 
> third person "C" picks
> > up the phone from the same house what happens then????.
> > 
> > #       does a 200 Response goes back to the caller. Or the 
> 200 Response just
> > append the Multicast Address with address "C".
> > 
> > #   RTP data goes directly from caller to callee. When 
> there are more than one
> > user is in conversation how Proxy makes it sure that the 
> RTP data will be send
> > to particular multicast address. As because Proxy only work 
> in the signalling
> > layer.
> > 
> > Please reply
> > 
> > Anirban
> > 
> > Dean Willis wrote:
> > 
> > > Are you saying that the first phone would multicast the 
> media streams to the
> > > others on the local LAN, or that the INVITES and media 
> would be sent
> > > multicast across the ISP network?
> > >
> > > If the former, it might work. COuld be pretty cool.
> > >
> > > If the latter, no, it's not going to happen that way.
> > >
> > > 1) No ISP that I know of will provide a multicast feed, 
> especially for a
> > > lowly dialup user.
> > >
> > > 2) Every SIP phone in the country is going to listen to a 
> universal
> > > multicast group, then make application discard decisions 
> on the INVITES that
> > > don't apply to it  . . . Or, we could statically allocate 
> a multicast
> > > address for each home network . . .not. The INVITE will 
> come in UNICAST.
> > >
> > > 3) Personally, I've never managed to get multicast 
> routing working right
> > > over the bizarre equipment that has accumulated at my house.
> > >
> > > 4) In our own internal network, we often saw join times 
> that took seven or
> > > eight minutes to propaget back to the source of a 
> multicast. That's some
> > > serious post-dial delay. I'm not sure we even try to 
> route multicast
> > > anymore.
> > >
> > > 5) The firewall issues that occur with cross-domain 
> multicast are mind
> > > boggling. Anything coming into my house is by-definition 
> cross-domain.
> > >
> > > Hey, I love multicast. I spent more than two years 
> building really cool
> > > businesses (Real Broadcast Netork, skyMCI, etc.) around 
> it, and I'm here to
> > > tell you it just isn't going to happen across an Internet 
> backbone for the
> > > average user any time soon.
> > >
> > > --
> > > Dean
> > >
> > > > -----Original Message-----
> > > > From: Sean Olson [mailto:[email-masked]]
> > > > Sent: Thursday, January 06, 2000 5:49 PM
> > > > To: [email-masked]
> > > > Cc: [email-masked]
> > > > Subject: RE: A case related to "home Phone" type of 
> functionality in SIP
> > > >
> > > >
> > > > >
> > > > > In a business environment, we call this a "single 
> line extension".
> > > > >
> > > > > SIP approaches tend to have the property that each 
> phone is uniquely
> > > > > addressed, whereas in the PSTN each circuit is 
> uniquely addressed.
> > > > >
> > > > > The obvious solution is to combine a parallel search 
> proxy and some UAS
> > > > > behavior.
> > > > >
> > > > > The sequence is:
> > > > > 1) Incoming call reaches parallel proxy.
> > > > > 2) Parallel proxy invites all UASes in extension group.
> > > > > 3) User answers one extension.
> > > > > 4) Parallel proxy cancels unanswered legs. Those 
> phones stop ringing.
> > > > > 5) Answering phone send INVITE to other phones in 
> group, with "NO RING"
> > > > > specified somehow, and long expire timer.
> > > > >
> > > > >
> > > >
> > > > In a business environment, this is a perfectly 
> acceptable and reasonable
> > > > solution. For a home environment, multicast/DHCP seems 
> more reasonable
> > > > because Joe consumer can go to Radio Shack, buy a 3com 
> SIP phone, and
> > > > plug it into his home IP network and it works with zero (or
> > > > almost-zero) configuration. Plus, it doesn't require 
> the home user
> > > > to buy/maintain a parallel proxy.
> > > >
> > > > (By multicast, I mean both signalling and media).
> > > >
> > > > 
> -----------------------------------------------------------------
> > > > Sean Olson           mailto:[email-masked]
> > > > Ericsson Inc.         tel:(972)583-5472
> > > >                       fax:(972)669-0154
> > > >
> 
> -- 
> Jonathan D. Rosenberg                       200 Executive Drive
> Chief Scientist                             Suite 120 
> dynamicsoft                                 West Orange, NJ 07052
> [email-masked]                     FAX:   (732) 741-4778
> http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
> http://www.dynamicsoft.com
>