Subject: Call flow for the Home Phone Application.

From: "ANIRBAN ROY" <[email-masked]>
Date: Tue, 11 Jan 2000 10:51:09 +0530

hi ,
I have tried to dipict the Call Flow for the Home Phone with some
diagram to make it easy to understand. I have some doubts in those Call
Flow. Please look into it and give some suggestion for this flow.

 I am attaching a windows word doc file with it which has the call flow
with diagramatic representation of each step.

I am sorry that i am attaching Windows word doc file as I don't have any
other tool for making the Diagram.

regards
Anirban

---

From: "Daniel G. Petrie" <[email-masked]>
Date: Tue, 11 Jan 2000 13:31:54 -0500

I would like to contribute some requirements:

I agree with Dean's points on multicast and would like to see
a solution which does not require multicast.

If a media "bridge" is used in the solution, it should be possible
for the answering party to be the bridge (as opposed to requiring
an additional entity).

The called parties which do not initially join the call, need some
minimal state information (i.e. to light a lamp to indicate that the
"line" is being used and/or the call is joinable).  This state information
should be provided in an event driven means (i.e. not polled).

Cheers,
Dan

ANIRBAN ROY wrote:

>   ------------------------------------------------------------
>                     Name: Call flow.doc
>    Call flow.doc    Type: WINWORD File (application/msword)
>                 Encoding: base64

---

From: "ANIRBAN ROY" <[email-masked]>
Date: Wed, 12 Jan 2000 11:40:21 +0530

hi,
Yes I will like to work on the feature of Home phone feature for the SIP Proxy.
Please include me in your list.

regards
Anirban Roy

Jonathan Rosenberg wrote:

> As I have mentioned, it is too premature to begin discussions on the
> implementation. We first must decide whether there:
>
> 1. is sufficient people to work on this,
> 2. the ADs approve adding it to the charter,
> 3. the requirements for the service are defined
>
> then we can figure out how to extend SIP. Regarding (1), I have received
> few offers of people willing to actually work on this (two, to be
> exact). Feel free to respond privately if you are willing to work.
>
> -Jonathan R.
>
> ANIRBAN ROY wrote:
> >
> > hi ,
> >   ------------------------------------------------------------------------
> >                     Name: Call flow.doc
> --
> Jonathan D. Rosenberg                       200 Executive Drive
> Chief Scientist                             Suite 120
> dynamicsoft                                 West Orange, NJ 07052
> [email-masked]                     FAX:   (732) 741-4778
> http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
> http://www.dynamicsoft.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 12 Jan 2000 00:43:52 -0500

-Jonathan R.