Subject: SIP AND CLID

From: "Buchanan, Paul" <[email-masked]>
Date: Mon, 31 Jan 2000 19:48:54 -0000

Can anyone help me ?  

How will SIP and CLI (Calling Line Identifier) work with each other?

Thanks

Paul Buchanan
Darkness Removal a Speciality 
IP Net Technology Planning
Waterside House, Longshot Lane, Bracknell Berks RG12 1XL
TEL:			01344 704064
FAX:			01344 726304
MOBILE (BEST BET)	0780 833 8143
PA247.com		[email-masked]
"Those who bring sunshine into the lives of others, cannot keep it from
themselves."
*Sir James M. Barrie{1860-1937 British Playwright and clever bloke}

---

From: Dean Willis <[email-masked]>
Date: Mon, 31 Jan 2000 18:40:28 -0600

There have been several approached put forward. The DCS approach put forward
in

http://www.softarmor.com/sipwg/drafts/draft-dcsgroup-sip-privacy-00.txt

is pretty thorough.

I believe the "IPTEL call flows" draft proposed a simpler approach. Roughly,
it translates to:

1) If there is no presented calling party number, set the From: field to
"UNKNOWN"
2) If the calling party privacy field indicates a private number, set the
From: field to "PRIVATE"
3) If there is a number presented, populate it into the From: field as the
username component. We might better use a Tel: url in this approach.

This simpler approach was taken due to the need to get things working
immediately.

--
Dean Willis

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Buchanan,
> Paul
> Sent: Monday, January 31, 2000 1:49 PM
> To: [email-masked]
> Subject: SIP AND CLID
>
>
> Can anyone help me ?
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 31 Jan 2000 23:57:42 -0500

Its also worth noting that rfc2543 does state that if the calling user
wishes to remain anonymous, they use the display name "Anonymous" in the
From field. 

-Jonathan R.

-- 
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120 
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com