Subject: Re:

From: "Siddharth Toshniwal" <[email-masked]>
Date: Thu, 13 Jan 2000 04:25:26 +0500

Hi,
    I'm new to this service and to SIP as a whole. Please tell me, is the ACK
message also sent for a fixed number of retransmissions in UDP? Or is it not?
If it isn't how does the callee know that the response it sent has reached?
(for eg. in the case that it sent a response 200 OK to an INVITE request)
    Also could you please tell me the difference between a stateful and stateless
proxy? Where is the former necessary?
   Thanks.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 13 Jan 2000 10:12:12 -0500

As a general rule, folks who are new to SIP are encouraged to browse
through the many tutorials and papers at
http://www.cs.columbia.edu/~hgs/sip

> message also sent for a fixed number of retransmissions in UDP? Or is it not?

No. ACK is sent when a response retransmission is received.

> If it isn't how does the callee know that the response it sent has reached?

Reliability is achieved because the response is retransmitted until an
ACK comes,
and the ACK is retransmitted on response retransmissions. Note this is
only for INVITE.

> proxy? Where is the former necessary?

Stateless proxies forget about the request once its forwarded. Stateful
proxies remember the request once its forwarded, so they can associate
the response with some internal state. Stateless proxies scale very
well, and can be very fast. They are good for network cores. Stateful
proxies can do more (they can fork, for example) and can provide
services stateless ones can't (call forward busy, for example). They
don't scale as big as stateless ones. An admininstrator gets to decide
which to use. These are also logical entities; a physical proxy is
likely to act as a stateless proxy for some calls, stateful for others,
and as a redirect server for even others.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120 
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: Sunitha Kumar <[email-masked]>
Date: Thu, 13 Jan 2000 15:41:40 -0600

The ACK msg, doesnt need to be retransmitted. The reason being that the callee
retransmits 200 OK. So, in the case the ACK gets lost, the 200 OK is retransmitted,
in which case the ACK is sent back again.

Hope that helps
sunitha

--
Sunitha Kumar
Software Engineer
Vovida Networks
(408) 957 - 6374