Subject: RE: SIP BCP-T Current Drafts (was RE: SIP BCP-T question)

From: [email-masked]
Date: Thu, 24 Feb 2000 13:57:19 -0700

The confusion probably stems from the fact there are around 5 drafts
pertaining to the ISUP MIME and SIP-T efforts at the IETF web-site. 
It would be great if the obsolete drafts could be taken out, although they
haven't expired yet.

Thanks,
Aparna

Aparna V.
Level (3) Communications.

-----Original Message-----
From: Dean Willis [mailto:[email-masked]]
Sent: Thursday, February 24, 2000 1:20 PM
To: sip
Subject: SIP BCP-T Current Drafts (was RE: SIP BCP-T question)

I've heard many implementors continuing to reference the old BCP draft and
claiming to "Support SIP-T".

I'd like to make two points:

1) As Gonzalo points out, the draft draft-zimmerer-mmusic-sip-bcp-t-00.txt
is quite obsolete. I believe draft-camarillo-mmusic-sip-isup-bcp-00.txt is
too, as is draft-ietf-mmusic-sip-isup-mime-00.txt

The current drafts are draft-zimmerer-sip-bcp-t-00.txt and
draft-ietf-sip-isup-mime-00.txt. I think these combine most of the previous
work in this area.

2) This is a "work in progress", NOT a standard. It's not even a proposed
standard. I bet its going to change a little more before it makes it to
proposed standard (don't they all?). Implementors should plan on making
changes as the work matures.

--
Dean Willis
SIP WG co-chair

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Gonzalo
> Camarillo
> Sent: Thursday, February 24, 2000 10:14 AM
> To: [email-masked]
> Cc: sip
> Subject: Re: SIP BCP-T question
>
>
> Hi,
>
> I am afraid you are talking about another draft.
>
> Your quote is from:
> http://www.ietf.org/internet-drafts/draft-camarillo-mmusic-sip-isu
> p-bcp-00.txt
>
> This thread deals with another draft:
> http://www.ietf.org/internet-drafts/draft-zimmerer-sip-bcp-t-00.txt
>
> If you have any comments on the first draft just let me know because a
> new version is about to be released.
>
> Best regards,
>
> Gonzalo
>
> [email-masked] wrote:
> >
> >  From BCP-T:
> >     "This document only takes into account the call control
> >     functionality of ISUP. Maintenance messages are outside
> >     the scope of this document."
> >
> > Suppose that messages such as Circuit Reset may also be received
> > during a
> > call setup
> > phase (to abort the setup), then should they also be mapped to such as
> > BYE
> > or CANCEL
> > (by PSTN GW)?
> >
> > Thanks,
> > -Taichi
> >
> > At 04:33 PM 2/23/00 -0600, Dean Willis wrote:
> > >It seems that these might really be "no-op" operations rather than
> > >"nonexistent" operations.
> > >
> > >There's a difference.
> > >
> > >--
> > >Dean
> > >
> > > > -----Original Message-----
> > > > From: [email-masked]
> > > > [mailto:[email-masked]]On Behalf Of Carr,
> > Steve
> > > > Sent: Monday, February 14, 2000 12:25 PM
> > > > To: 'Raja Badri'; sip ML
> > > > Subject: RE: SIP BCP-T question
> > > >
> > > >
> > > > The ISUP maintenance messages relate to the physical trunk
> > circuit, which
> > > > when not being used on a call, is still physically present and in
> > an IDLE
> > > > (or blocked) state. SIP BCT-T sets up calls over an RTP "logical"
> > > > connection, which is not a physical circuit. After the end of the
> > > > call, the
> > > > RTP connection ceases to exist. Therefore is does not make sense
> > to block
> > > > it, unblock it, reset it etc......
> > > >
> > > > Steve Carr
> > > > Unisphere Solutions Inc.
> > > > Boca Raton
> > > > [email-masked]
> > > > Office (561) 955-8288
> > > > Fax    (561) 955-6477
> > > >
> > > > www.unispheresolutions.com
> > > >
> > > > -----Original Message-----
> > > > From: Raja Badri [mailto:[email-masked]]
> > > > Sent: Monday, February 14, 2000 1:04 PM
> > > > To: sip ML
> > > > Subject: SIP BCP-T question
> > > >
> > > >
> > > > Hi,
> > > >
> > > > I have one question regarding the SIP BCP-T.
> > > > INFO message outlines the Mid-Call ISUP messages.
> > > > What is the reason behind not including the ISUP maintenance
> > > > messages like Block, Unblock and Reset ?
> > > >
> > > > Thanks,
> > > > Raja Badri
> > > > Santera Systems Inc.
> > > >
> > > >
> > > >
> > >
> > >
> >
> >     ---------------------------------------------------------------
> > From BCP-T:
> >    "This document only takes into account the call control
> >    functionality of ISUP. Maintenance messages are outside
> >    the scope of this document."
> >
> > Suppose that messages such as Circuit Reset may also be received
> > during a call setup
> > phase (to abort the setup), then should they also be mapped to such as
> > BYE or CANCEL
> > (by PSTN GW)?
> >
> > Thanks,
> > -Taichi
> >
> > At 04:33 PM 2/23/00 -0600, Dean Willis wrote:
> >
> > > It seems that these might really be "no-op" operations rather than
> > > "nonexistent" operations.
> > >
> > > There's a difference.
> > >
> > > --
> > > Dean
> > >
> > > > -----Original Message-----
> > > > From: [email-masked]
> > > > [mailto:[email-masked]]On Behalf Of Carr,
> > > Steve
> > > > Sent: Monday, February 14, 2000 12:25 PM
> > > > To: 'Raja Badri'; sip ML
> > > > Subject: RE: SIP BCP-T question
> > > >
> > > >
> > > > The ISUP maintenance messages relate to the physical trunk
> > > circuit, which
> > > > when not being used on a call, is still physically present and in
> > > an IDLE
> > > > (or blocked) state. SIP BCT-T sets up calls over an RTP "logical"
> > > > connection, which is not a physical circuit. After the end of the
> > > > call, the
> > > > RTP connection ceases to exist. Therefore is does not make sense
> > > to block
> > > > it, unblock it, reset it etc......
> > > >
> > > > Steve Carr
> > > > Unisphere Solutions Inc.
> > > > Boca Raton
> > > > [email-masked]
> > > > Office (561) 955-8288
> > > > Fax    (561) 955-6477
> > > >
> > > > www.unispheresolutions.com
> > > >
> > > > -----Original Message-----
> > > > From: Raja Badri [mailto:[email-masked]]
> > > > Sent: Monday, February 14, 2000 1:04 PM
> > > > To: sip ML
> > > > Subject: SIP BCP-T question
> > > >
> > > >
> > > > Hi,
> > > >
> > > > I have one question regarding the SIP BCP-T.
> > > > INFO message outlines the Mid-Call ISUP messages.
> > > > What is the reason behind not including the ISUP maintenance
> > > > messages like Block, Unblock and Reset ?
> > > >
> > > > Thanks,
> > > > Raja Badri
> > > > Santera Systems Inc.
> > > >
> > > >
> > > >
> > >
> > >
>
> --
> Gonzalo Camarillo         Phone :  +358  9 299 33 71
> Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
> Telecom R&D               Fax   :  +358  9 299 30 52
> FIN-02420 Jorvas          Email :  [email-masked]
> Finland
>

---

From: "David Israel" <[email-masked]>
Date: Thu, 24 Feb 2000 20:13:10 -0800

Hello,

   My job is to implement a subset  of SIP. I would like to obtain, as many
as possible, real SIP messages that  covers most(if not all) tags, keywords,
and etc. Could someone help me on this?

  Also, I would like to report the bugs I have encountered while I was
reading RFC2543. First the "toplabel" on page 21 is not correct, to make it
work, prepend * to alphanum. Another typo takes place on page 40, the first
vertical bar after Global-Failure should have been "=" instead.

thanks

-- Jimmy Zhang ([email-masked])

   Software Engineer

   IP Unity

---

From: "Stanislav S. Timinsky" <[email-masked]>
Date: Fri, 25 Feb 2000 10:55:21 +0300

Hello David,

Friday, February 25, 2000, 7:13:10 AM, you wrote:

David Israel> Hello,

David Israel>    My job is to implement a subset  of SIP. I would like to obtain, as many
David Israel> as possible, real SIP messages that  covers most(if not all) tags, keywords,
David Israel> and etc. Could someone help me on this?

David Israel>   Also, I would like to report the bugs I have encountered while I was
David Israel> reading RFC2543. First the "toplabel" on page 21 is not correct, to make it
David Israel> work, prepend * to alphanum. Another typo takes place on page 40, the first
David Israel> vertical bar after Global-Failure should have been "=" instead.

David Israel> thanks

David Israel> -- Jimmy Zhang ([email-masked])

David Israel>    Software Engineer

David Israel>    IP Unity

1.

Some test messages are at:
http://www.cs.columbia.edu/~hgs/sip/bakeoff2/testmsg.html
and
http://www.cs.columbia.edu/~hgs/sip/drafts/draft-sparks-sip-service-examples-00.txt

2.

As to inexactnesses in RFC-2543, they were also noted by me at realization of the SIP stack.
I want to notice, that RFC-2327 (SDP) also has some bugs in grammar description.

-- 
Best regards,
 Stanislav S. Timinsky                      mailto:[email-masked]
 Mera Labs.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 25 Feb 2000 09:29:19 -0500

David Israel wrote:
> work, prepend * to alphanum. 

Why? This grammar seems to work. The * appears outside the parens, so
there can be an arbitrary number of alphanums in the middle. Putting a *
in front of either of the alphanums is redundant. I'll also note that it
is identical to the grammar of rfc2396:

> toplabel      = alpha | alpha *( alphanum | "-" ) alphanum

Another typo takes place on page 40, the first
> vertical bar after Global-Failure should have been "=" instead.

Thanks, we'll fix that.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120 
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 25 Feb 2000 09:35:51 -0500

> I want to notice, that RFC-2327 (SDP) also has some bugs in grammar description.

Folks, if you find bugs or problems, please be sure to report them to
the list or to the authors privately. We will incorporate them into the
revised spec.

-Jonathan R.