Subject: Question on subsequent requests

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 03 Feb 2000 11:22:31 +0000

Hi all,

First, thank for all your responses to my previous answers.

I have a question about sending subsequent requests from the callee.

Section 11.4 in the SIP draft give the following rules:
- If the previous request contains a Record-Route, use the infos in this
header.
- Otherwise use the previous Contact received (if existing)
- Otherwise use the provisioned proxy server (if provisioned)
- Otherwise use the value in the From header field.

As the rules 1, 2 and 3 can fail, we must be sure that the rule 4 works. 
The problem is that the "transport=" parameter is forbidden in a From
header field, so there is no way to known which transport protocol to
use.
So do we must use :
- Any protocol?
- The same protocol that was use for the last received request?

Thank you for your answers.

Regards,

-- 
Marc Petit-Huguenin
Home: mailto:[email-masked]
Work: mailto:[email-masked]
"Everything I love is either immoral, illegal or makes you fat"

---

From: Igor Slepchin <[email-masked]>
Date: Thu, 03 Feb 2000 10:41:41 -0500

> - The same protocol that was use for the last received request?

You should use the same algorithm you used for the first request, see
1.4.2 and appendix D for details. If the other side wants to be
contacted differently (different transport, requestURI, port etc.), it
must specify so in the Contact field.

---
Igor Slepchin