Subject: Re: DHCP option tags for SIP

From: James Kempf <[email-masked]>
Date: Fri, 18 Feb 2000 09:50:48 -0800 (PST)

Well, at the risk of prolonging a controversy, SLP was designed to
fix exactly the problems you outline with DHCP.

		jak

>Delivered-To: [email-masked]
>Delivered-To: [email-masked]
>From: Michael Thomas <[email-masked]>
>MIME-Version: 1.0
>Content-Transfer-Encoding: 7bit
>Date: Fri, 18 Feb 2000 09:41:42 -0800 (PST)
>To: Jonathan Rosenberg <[email-masked]>
>Cc: [email-masked]
>Subject: DHCP option tags for SIP
>X-Face: &,heK/V66p?[2!i|tVn,9lN0TUvEv7:9FzXREj/AuzN4m<D]vnFJ>u!4x[/Z4t{V}~L]+Sk 
@RFNnJEg~WZ/(8<`5a),-7ukALWa^&?&D2R0CSG3kO5~#6JxLF\d,g">$%B!0w{W)qIhmwhye104zd 
bUcI'1!
>
>
>I'd like to throw out one wet blanket: getting the
>name of a first hop proxy is all well and good,
>but it hardly solves the larger provisioning
>problem, especially for "simple" phones and other
>devices which don't have an easy way to be
>configured by a user, or want/need to be centrally
>managed. Trying to cram bootstrap provisioning for
>N different kinds of protocols/devices into one
>MTU sized packet seems like a losing situation and
>symptomatic that DHCP is being used for way more
>than it can deliver in the long run.
>
>It seems to me that it would be far better to
>create some sort of indirection method within DHCP
>which says "here's the URL if you want to get SIP
>related parameters" (ad naseum). 
>
>But all that's being asked for is "just" the
>address of the first hop proxy... sigh.
>
>	   Mike
>
>
>Jonathan Rosenberg writes:
> > Folks,
> > 
> > Many of you may have seen the recent draft presenting DHCP option codes
> > for SIP:
> > 
> > http://search.ietf.org/internet-drafts/draft-nair-sip-dhcp-01.txt
> > 
> > The consensus among the authors and wg chairs is that this is a clearly
> > useful item, and we would like to move it forward. In the interests of
> > speed, we are proposing a "fast track" approach for this document.
> > Basically, this message will serve as announcement of our intention to
> > adopt this as a work item. If no one objects to this procedure, in one
> > weeks time, we will issue an extended working group last call on it, and
> > that call will last 3 weeks. Comments will be collected, and then we
> > will send the document to IESG for proposed.
> > 
> > I believe its critical that we do whatever we can to speed up the
> > process of delivering documents to the community. This is especially the
> > case for small, largely uncontroversial documents such as this. Rather
> > than languish for months, getting this from concept to submission to
> > IESG in a matter of a single month seems more desirable.
> > 
> > -Jonathan R.
> > -- 
> > Jonathan D. Rosenberg                       200 Executive Drive
> > Chief Scientist                             Suite 120 
> > dynamicsoft                                 West Orange, NJ 07052
> > [email-masked]                     FAX:   (732) 741-4778
> > http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
> > http://www.dynamicsoft.com
> > 
> > 
> > 
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 18 Feb 2000 14:43:01 -0500

There is definitely room for both. DHCP is appropriate where a simple
"gimme the closest proxy" will do. SLP is better when the selection
process is more complicated, and depends on attributes of the proxy.

-Jonathan R.