Subject: Re: Accept-Contact Header

From: [email-masked]
Date: Tue, 22 Feb 2000 10:15:47 +0530

Hi,
So if my interpretation is correct, what you are saying is put a "*" when
you dont want to specify a uri, else put a uri.
So in each Accept-Contact hdr, either a "*" or (name-addr |addr-spec) is
mandatory.

Is the example in Page 13 also correct then ?

 Accept-Contact: sip:[email-masked] ;q=0,
     ;media="!video" ;q=0.1,
     ;mobility="fixed"  ;q=0.6,
     ;mobility="!fixed" ;q=0.4

Im still confused with the use of commas - if they are indeed sep.
Acc-Contact hdrs, shouldnt the example be

 Accept-Contact: sip:[email-masked] ;q=0,
    * ;media="!video" ;q=0.1,
     *;mobility="fixed"  ;q=0.6,
     *;mobility="!fixed" ;q=0.4

And I guess the same holds for reject contact too ?

i.e.

 Reject-Contact  =  "Reject-Contact" ":"   1# ( ( name-addr | addr-spec |
"*" )  [ *( ";" new-params ) ] )

Regds
Arjun

Arjun Roychowdhyry @ Hughes Software Systems

Jonathan Rosenberg <[email-masked]> on 02/21/2000 09:30:52 PM

To:   Preethy Rangarajan/HSSBLR
cc:   [email-masked]

Subject:  Re: Accept-Contact Header

Thanks for pointing this out. The bnf appears to be wrong, as it
mandates a valid name-addr or addr-spec. The document clearly discusses
the capability of not specifying one. I will fix in the next version
(due out before the draft deadline). The BNF should be:

Accept-Contact = "Accept-Contact" ":" 1#rule
rule   =  (name-addr | addr-spec | "*")
....

So, we'll use the * for anything, aligning with current Contact usage.

-Jonathan R.

[email-masked] wrote:
>
> hi All,
>
> The document SIP Caller Preferences and Callee Capabilities -
> draft-ietf-sipcallerprefs-00.txt
> gives the grammer for Accept-Contact Header as
>
> Accept-Contact   =  "Accept-Contact" ":" 1# rule
>    rule             =  ( name-addr | addr-spec )
>                        [ *( ";" (cp-params | extension-param | q-param) )
]
>    q-param          =  "q" "=" qvalue
>    extension-param  =  extension-name "=" extension-value
>    extension-name   =  token
>    extension-value  =  token | quoted-string
>
> and the example given is
>
> Accept-Contact: sip:[email-masked] ;q=0,
>      ;media="!video" ;q=0.1,
>      ;mobility="fixed"  ;q=0.6,
>      ;mobility="!fixed" ;q=0.4
>
> According to my understanding, in this example each of the comma
separated
> values is a separate Accept Contact rule,
> And the parameters of a paticular accept contact rule are separated by
";"
> semicolon.
> Here each of the q-params are followed by a comma and then a semi-colon .
>
> I cannot understand whether to consider this as
> 1) a single accept contact rule with all the entries following
> sip:[email-masked] as parameters in which case I dont see a need for a
> comma and semi-colon as separaters between parameters.
>
> 2) 4 rules where-in the 2nd 3rd and 4th do not have a nameaddr|addrspec
> entry which is also an error, becos the rule mandates the presence of
> nameaddr|addr-spec.
>
> Can someone explain this to me.
>
> Regards,
> Preethy

--
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 22 Feb 2000 10:02:59 -0500

> Is the example in Page 13 also correct then ?

No; there must be a star there.

>      *;mobility="!fixed" ;q=0.4

Yes. This is correct.

> "*" )  [ *( ";" new-params ) ] )

Yes.

-Jonathan R.