Subject: RE: SIP BCP-T question

From: "Carr, Steve" <[email-masked]>
Date: Mon, 14 Feb 2000 13:25:21 -0500

The ISUP maintenance messages relate to the physical trunk circuit, which
when not being used on a call, is still physically present and in an IDLE
(or blocked) state. SIP BCT-T sets up calls over an RTP "logical"
connection, which is not a physical circuit. After the end of the call, the
RTP connection ceases to exist. Therefore is does not make sense to block
it, unblock it, reset it etc......
 
Steve Carr 
Unisphere Solutions Inc. 
Boca Raton 
[email-masked] 
Office (561) 955-8288 
Fax    (561) 955-6477 

www.unispheresolutions.com 

-----Original Message-----
From: Raja Badri [mailto:[email-masked]]
Sent: Monday, February 14, 2000 1:04 PM
To: sip ML
Subject: SIP BCP-T question

Hi,
 
I have one question regarding the SIP BCP-T.
INFO message outlines the Mid-Call ISUP messages.
What is the reason behind not including the ISUP maintenance 
messages like Block, Unblock and Reset ?
 
Thanks,
Raja Badri
Santera Systems Inc.

---

From: Dean Willis <[email-masked]>
Date: Wed, 23 Feb 2000 16:33:40 -0600

It seems that these might really be "no-op" operations rather than
"nonexistent" operations.

There's a difference.

--
Dean

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Carr, Steve
> Sent: Monday, February 14, 2000 12:25 PM
> To: 'Raja Badri'; sip ML
> Subject: RE: SIP BCP-T question
>
>

---

From: Taichi Fu <[email-masked]>
Date: Thu, 24 Feb 2000 00:58:03 -0800

From BCP-T:
    "This document only takes into account the call control
    functionality of ISUP. Maintenance messages are outside
    the scope of this document."

Suppose that messages such as Circuit Reset may also be received during a 
call setup
phase (to abort the setup), then should they also be mapped to such as BYE 
or CANCEL
(by PSTN GW)?

Thanks,
-Taichi

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 24 Feb 2000 18:14:01 +0200

Hi,

I am afraid you are talking about another draft.

Your quote is from:
http://www.ietf.org/internet-drafts/draft-camarillo-mmusic-sip-isup-bcp-00.txt

This thread deals with another draft:
http://www.ietf.org/internet-drafts/draft-zimmerer-sip-bcp-t-00.txt

If you have any comments on the first draft just let me know because a
new version is about to be released.

Best regards,

Gonzalo

[email-masked] wrote:
>     ---------------------------------------------------------------
> From BCP-T:
> Suppose that messages such as Circuit Reset may also be received
> during a call setup
> phase (to abort the setup), then should they also be mapped to such as
> BYE or CANCEL
> (by PSTN GW)?
> 
> Thanks,
> -Taichi
> 

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland

---

From: Taichi Fu <[email-masked]>
Date: Thu, 24 Feb 2000 08:56:14 -0800

Gonzalo,

Thanks for your clarification. My question is more on your draft.
I think those maintenance messages need also  to be covered.
Execuse me if you already have them in the coming version.

Best regards,
-Taichi

At 06:14 PM 2/24/00 +0200, Gonzalo Camarillo wrote:
> > during a
> > BYE

---

From: Dean Willis <[email-masked]>
Date: Thu, 24 Feb 2000 14:20:21 -0600

I've heard many implementors continuing to reference the old BCP draft and
claiming to "Support SIP-T".

I'd like to make two points:

1) As Gonzalo points out, the draft draft-zimmerer-mmusic-sip-bcp-t-00.txt
is quite obsolete. I believe draft-camarillo-mmusic-sip-isup-bcp-00.txt is
too, as is draft-ietf-mmusic-sip-isup-mime-00.txt

The current drafts are draft-zimmerer-sip-bcp-t-00.txt and
draft-ietf-sip-isup-mime-00.txt. I think these combine most of the previous
work in this area.

2) This is a "work in progress", NOT a standard. It's not even a proposed
standard. I bet its going to change a little more before it makes it to
proposed standard (don't they all?). Implementors should plan on making
changes as the work matures.

--
Dean Willis
SIP WG co-chair

> [mailto:[email-masked]]On Behalf Of Gonzalo
> Camarillo
> Sent: Thursday, February 24, 2000 10:14 AM
> To: [email-masked]
> Cc: sip
> Subject: Re: SIP BCP-T question
>
>
> Hi,
>

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 25 Feb 2000 15:17:30 +0200

Hi,

Yes, there is a section about it. The draft will be available pretty
soon.

Best regards,

Gonzalo