Subject: RE: Call legs and Cseq

From: Itamar Gilad <[email-masked]>
Date: Wed, 2 Feb 2000 18:19:30 +0200

> -----Original Message-----
> From: Anders Kristensen [mailto:[email-masked]]
> Sent: Wednesday, February 02, 2000 5:59 PM
> To: Itamar Gilad
> Cc: 'Anders Kristensen'; [email-masked]'
> Subject: Re: Call legs and Cseq
> 
> 
> 
> Itamar Gilad wrote:
> > 
> > Just to make sure:
> > 
> > reqMsg1 == reqMsg2 (duplicate requests) IFF the To, From, 
> Call-ID and CSeq
> > headers are identical (addresses and tags only in the To 
> and From headers).
> 
> Yes. Obviously, reqMsg1 and reqMsg2 may in fact differ in 
> other headers
> (although this should never happen), but for the purpose of 
> identifying
> and filtering out retransmissions they're the same.
> 
> > 
> > msg1 and msg2 belong to the same Call-leg if
> >     the Call-ID is the same and
> >     (msg1.To == msg2.To && msg1.From == msg2.From) ||
> >     (msg1.To == msg2.From && msg1.From == msg2.To)
> > 
> > ( ==  means the addresses and tags are the same)
> > 
> > Is that right?
> 
> Yes. 
> 
> > 
> > BTW, you cannot identify duplicate responses using the first rule.
> 
> No, not quite. If the request was sent without a To tag the 
> UAC needs to
> take into account the possibility that a UAS has added this to the
> response, and must also be prepared to handle multiple responses with
> different To tags (these belonging to different legs).
> 

Right, but what I meant is that even if two responses have the same To,
From, Call-ID and CSeq values (including tags where applicable) it still
doesn't mean these are identical messages.   The Status line may be
different (and usually is).

Cheers
  
  Itamar

---

From: Anders Kristensen <[email-masked]>
Date: Wed, 02 Feb 2000 17:28:11 +0000

> different (and usually is).

Right, of course. You don't want to filter out those final responses ;-)

-- 
Anders Kristensen <[email-masked]>,
http://www-uk.hpl.hp.com/people/ak/
Hewlett-Packard Labs, Bristol, UK