Subject: RE: Information request! (Billing Package?)

From: "Buchanan, Paul" <[email-masked]>
Date: Tue, 29 Feb 2000 10:35:43 -0000

CDR collection should be defacto and easily accessible right down to the SIP
client. 

I believe that SIP should interwork with the current VOIP suppliers like
XACCT, Mind CTI , Clarent, Sollect, Portal, Kenan and their contemporaries.
I can see a major problem with the FORKING capabilities of SIP as the
provider will be responsible for originating calls from the Gateway. In
effect we will have to make the receiver pay for calls which turns the
billing world on its head.

My concern is the security issues and, in addition, how service companies
can make an honest profit. As IP transmission costs plummet - so does the
cost of telephony generally and so does the service providers ability to
reinvest in the web infrastructure. I have several ideas on how this should
happen as SIP becomes a global product.

Paul Buchanan
Darkness Removal a Speciality 
VOIP/DSL/ATM Technical Architect IP Net Technology Planning
Waterside House, Longshot Lane, Bracknell Berks RG12 1XL
TEL:			01344 704064
FAX:			01344 726304
MOBILE (BEST BET)	0780 833 8143
PA247.com		[email-masked]
Home:			01227 450900
Home Fax:		01227 478929
Work Mail			[email-masked]
"Those who bring sunshine into the lives of others, cannot keep it from
themselves."

> -----Original Message-----
> From:	Jonathan Rosenberg [SMTP:[email-masked]]
> Sent:	Monday, February 28, 2000 9:50 PM
> To:	Mart Nurmet
> Cc:	[email-masked]
> Subject:	Re: Information request!  (Billing Package?)
> 
> There is no standardized "billing package" for SIP. There will be a MIB,
> and there are local log and transaction records generated by servers and
> gateways. This information can be collected to bill in any way you like.
> 
> -Jonathan R.
> 
> Mart Nurmet wrote:
> > 
> > I am looking for information if there has been any work done to generate
> a
> > billing package for SIP.  From my look at the available information
> there does
> > not seem to be any.  Is that the case or am I missing something?
> > 
> > Thank you,
> > -Mart
> 
> -- 
> Jonathan D. Rosenberg                       200 Executive Drive
> Chief Scientist                             Suite 120 
> dynamicsoft                                 West Orange, NJ 07052
> [email-masked]                     FAX:   (732) 741-4778
> http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
> http://www.dynamicsoft.com

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 29 Feb 2000 22:07:13 -0500

Interesting, I assumed everything EXCEPT a gateway throws CDRs.
Assuming a decomposed gateway, the GW feeds statistics to a Call Agent
(which would be a SIP UA among other things) that throws CDRs.

The billing system collates all the CDRs.

The spec required is, of course, the format of the CDR and the way they
are transported.  You could claim that a "transaction log" is a form of
CDR I suppose.

I'd certainly agree that SIP itself doesn't have any "billing package".
A UA and a server might, but that is independent of the protocol.  Billing
might very well impact some things in SIP.  

Brian

> From: Dean Willis [mailto:[email-masked]]
> Sent: Tuesday, February 29, 2000 2:41 PM
> To: Mart Nurmet; [email-masked]
> Subject: RE: Information request! (Billing Package?)
> 
> 
> What would a billing package look like? I've never really 
> understood the
> concept, and it might be useful to talk about it some more.
> 
> Here's how some implementors are doing it:
> 
> 1) Gateways throw CDRs using RADIUS or something similar. 
> This feeds into
> rating, reporting, and billing systems,
> 
> 2) SIP servers record transaction logs. These may feed into rating and
> billing systems, and probably feed into reporting systems.
> 
> 3) QoS PEP and PDPs log resource usages. These feed upstream as well.
> 
> 4) Other systems, like profile managers, report usage.
> 
> 5) Rating, reporting, and billing systems sift thru the vast 
> amounts of
> information coming at them and make useful things happen.
> 
> All of these things use other protocols and systems -- they aren't SIP
> specific. They do rely on SIP functions like authentication 
> -- that is, the
> goal of achieving billing functions has driven some 
> requirements into the
> design of SIP. However, other than driving some requirements 
> to SIP, such
> efforts are generally considered to be outside the scope of 
> the SIP WG.
> 
> Are you perhaps proposing to add functionality to SIP to 
> simplify or enhance
> reporting capabilities or to simplify the task of driving 
> downstream billing
> systems?
> 
> --
> Dena
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of 
> Mart Nurmet
> > Sent: Monday, February 28, 2000 2:24 PM
> > To: [email-masked]
> > Subject: Information request! (Billing Package?)
> >
> >
> > I am looking for information if there has been any work 
> done to generate a
> > billing package for SIP.  From my look at the available
> > information there does