Subject: Via-Header in a REGISTER-request

From: Michael Teroerde <[email-masked]>
Date: Tue, 8 Feb 2000 10:13:42 +0100 (MET)

Hello !!!

If I send an REGISTER and add an additional Via-header. Does the Server
remember the Via headers for sending an INVITE trough the same route ??

For example:

REGISTER sip:tu-berlin.de SIP/2.0
Via: SIP/2.0/UDP bell.de
Via: SIP/2.0/UDP nec.de
From: sip:[email-masked]
.....

Did the proxy forward an incomming INVITE for [email-masked] to bell.de or

did he tries to connect directly to nec.de ??

Thanks for your effort

Michael Teroerde
----------------------------------------------------------------
Michael Teroerde
Student at NEC- Heidelberg
[email-masked]

-- 
Sent through Global Message Exchange - http://www.gmx.net

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 08 Feb 2000 15:24:16 +0200

Michael,

> remember the Via headers for sending an INVITE trough the same route ??

Via headers are used just for routing responses. The INVITE is a
request.

> ......

The proxy will use the Contact header in the REGISTER.

Regards,

Gonzalo

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland