Subject: RE: [SIP] SIP and soft hand-off

From: "Roy, Radhika R, ALARC" <[email-masked]>
Date: Thu, 13 Apr 2000 09:51:15 -0400

Hi, Everyone:

I feel that it will be conflicting if we discuss this in another WG because
of the following:

1. To support mobility in the application layer for session layer, it will
require to extend the SIP.
2. SIP WG  has the sole authority to see whether the extension for mobility
in SIP is consistent with the overall architecture.
3. SIP is the control protocol for all networking environments.

The only thing that I can foresee is: To form a separate sub-group within
the SIP so that SIP WG can see the overall consistency in extensions.

Best regards,

Radhika R. Roy
AT&T

> -----Original Message-----
> From:	Glenn Morrow [SMTP:[email-masked]]
> Sent:	Thursday, April 13, 2000 9:16 AM
> To:	[email-masked]
> Subject:	RE: [SIP] SIP and soft hand-off
> 
> I honestly think this topic should be discussed in another WG, which WG is
> something for others (IAB, Area Directors) to decide.
> 
> 	-----Original Message----- 
> From:   Larry Cox [SMTP:[email-masked]] 
> Sent:   Wednesday, April 12, 2000 4:20 PM 
> To:     [email-masked] 
> Subject:        RE: [SIP] SIP and soft hand-off 
> 
> 	Brian Rosen wrote: 
> > ... 
> > 
> >It is entirely inappropriate for any session level protocol, let alone 
> >session establishment protocols, to have knowledge that the end 
> >device is mobile.  It's like having the protocol have to know 
> >whether they are on a LAN or a WAN.  Somewhere, someone cares, 
> >but it shouldn't be SIP! 
> > 
> >Brian 
> 
> 	I am glad that I am not alone. I had begun believing that we had
> lost sight 
> of the objective of having a layered protocol. If we cannot localize the 
> knowledge of delivery addresses, we have probably broken the protocol and 
> will have to go back and start over as soon as the next major evolutionary
> 
> change happens. It appears to me that if we have chosen to use UDP and
> TCP, 
> the necessity of having IP and the associated IP addresses underneath it 
> should be explicitly rejected. Some other protocol should be allowed at 
> that level if it works better. In the same sense that HDLC works best in 
> some spaces and Ethernet works better in others. If we are keeping the
> type 
> of network hardware separate form the application level, it is highly 
> illogical that we should expect the app to know about changes required for
> 
> mobility. Someone pointed out that simultaneous arrival of duplicate
> frames 
> is important for soft handoff. Should the SIP application be tasked with 
> tracking the transmission delay for multiple routes in order to make this 
> happen? If we get carried away and make the protocol monolithic there will
> 
> be very little chance for it to succeed. 
> 
> 	Larry 
> 
> 
> 	====================================== 
> 
> 	Larry Cox 
> Senior Software Engineer 
> 
> 	Cirilium Inc.            Phone: (480) 317-1115 
> 1615 S. 52 St.           Fax:   (480) ???-???? 
> Tempe, AZ 85281-6233     Web:    www.cirilium.com 
> USA 
> 
> 
> 	_______________________________________________ 
> SIP mailing list 
> [email-masked] 
> <http://lists.bell-labs.com/mailman/listinfo/sip> 
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Baba, S." <[email-masked]>
Date: Thu, 13 Apr 2000 15:54:08 -0500 (EST)

Hi,

I'm wondering the same thing as what Radhika raised.
Because I think some issues of the mobility management could
have to be discussed in the SIP WG.

Of course, we may be able to discuss whole issues separately first,
then come back to the WG with the related issues only later.
But I don't know if it works effectively or not.
So I would like to hear more suggestions.
That would help me to make my view clear either.

Regards,

baba//

From: "Roy, Radhika R, ALARC" <[email-masked]>
Subject: RE: [SIP] SIP and soft hand-off
Date: Thu, 13 Apr 2000 09:51:15 -0400