Subject: [SIP] SIP and soft hand-off

From: "Baba, S." <[email-masked]>
Date: Tue, 11 Apr 2000 10:00:30 -0500 (EST)

Folks,

Thank you for your attention to my presentation of
our mobility management requirement in Adelaide.

Let me add a brief explanation about a relation between
SIP and wireless soft hand-off, since I feel I didn't answer
raised questions well. Please read the related part (4.1)
of our revised draft <draft-itsumo-sip-mobility-req-01> also.

First, we believe that the requirement wireless
'technology-independent" is very important principle.
At the same time, the soft hand-off is one of the key
technology promising high efficiency for the CDMA-based
wireless system. So any protocol on top of the wireless
shall not break the soft hand-off capability in the
wireless part. These are our basic assumptions.

The soft hand-off has some aspects like giving smooth hand-off
taking several tens seconds or more for the radio path change
and giving more than one radio paths during the hand-off.
If the soft hand-off is handled in the L2 only or below
L3 and doesn't affect the upper layer process, it is no
problem with SIP.

But if we consider the future RAN using IP transport,
SIP User Agent and/or Proxy Server may need a process
to support the mobility management on top of the soft hand-off.
Because SIP controls smooth hand-off of its IP sessions.

Although the details are still open issues, this is the
basic consideration about the soft hand-off.
Any questions and comments are welcomed.

Thank you.

Baba//
-----
Shinichi Baba
Toshiba America Research, Inc. (TARI)
Mail-To: P.O.Box 136 Convent Station, NJ 07961-0136
Location: 445 South St. Suite 1B259B, Morristown, NJ 07960
Phone: (973) 829-4795/ Fax: (973) 829-5601
Email: [email-masked]

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Stephen Terrill <[email-masked]>
Date: Wed, 12 Apr 2000 11:13:20 +0200

Hi Baba,

I am not sure that I understand the requirements as discussed here.  I understand that the technology independance requirement, and quite like that, however I don´t understand the need of the SIP protocol level to be involved in the Soft hand-off.  I would have expected that the soft hand-off would be entirely within the "access network" (the mobile network technology), from the prespective of the SIP applications.  As such, the application shouldn´t even be aware of the hand-overs (won´t even change IP address).

Regards,

..//steve

---

From: Dean Willis <[email-masked]>
Date: Wed, 12 Apr 2000 14:49:26 -0500

One can envision a layer-2 hand off, a layer-3 (mobile-IP) hand off, or a
layer-4 handoff . . .

This mobility approach seems to me to be appropriate to a layer-4 handoff,
wherein the IP address actually changes. This has applicability outside
classic mobilephone. For example, when I undock my PC, I might want to
switch from my wired 100TX card to my wireless 802.11 card. Both can be
active during handoff -- then I shut down the wired card and undock.

--
Dean

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Stephen Terrill
> Sent: Wednesday, April 12, 2000 4:13 AM
> To: Baba, S.
> Cc: [email-masked]
> Subject: Re: [SIP] SIP and soft hand-off
>
>
> Hi Baba,
>
> I am not sure that I understand the requirements as discussed
> here.  I understand that the technology independance requirement,
> and quite like that, however I don´t understand the need of the
> SIP protocol level to be involved in the Soft hand-off.  I would
> have expected that the soft hand-off would be entirely within the
> "access network" (the mobile network technology), from the
> prespective of the SIP applications.  As such, the application
> shouldn´t even be aware of the hand-overs (won´t even change IP address).
>
> Regards,
>
> ..//steve
>
> "Baba, S." wrote:
>
> > Folks,
> >

---

From: "Michael A. Ramalho" <[email-masked]>
Date: Thu, 13 Apr 2000 16:20:17 -0400

I was going to jump in earlier ... but I agree with at least layer
3 ... and therefore SIP should be aware of soft handoff.

The issue here is that you get redundant streams (from the
voice payload point of view) from two different sources/sinks
during soft handoff.

If only one "end" was in the process of soft handoff ... I think
some combination of also/replace (with same call_id) would
work ... with a codec that knows what do to with two (payload)
redundant streams. The situation gets messy when both ends
are undergoing soft handoff or conferencing cases. I think
this is what Faramak was referring to as being difficult.

Michael Ramalho

>active during handoff -- then I shut down the wired card and undock.

Michael A. Ramalho, Ph.D.
Cisco Systems
1802 Rue de la Port
Wall Township, NJ 07719-3784
Office email: [email-masked]
Personal email: [email-masked]
Office: +1.732.449.5762
Cell: +1.732.809.0188
Pager: +1.800.365.4578