Subject: RE: [SIP] Question on ACKs for responses > 200

From: [email-masked]
Date: Fri, 7 Apr 2000 08:02:33 -0500

I apologize for the formatting problem in the previous message, but it seems
like the question was understood.

If UDP proxies do not send ACKs, then that clears it up for me.
I was reading section 4.2.2: 

2xx responses are acknowledged by client user agents, all other final
responses by the first proxy or client user agent to receive the response.

It sounds like that only applies to TCP proxies.

Although it's moot now, I was wondering about the reliability of the 4XX on
it's way back to A.  If it were ACKed by P2, and lost between P2 and P1, or
P1 and A, then I figured that the INVITE would be have to be retransmitted
by A, which didn't seem correct.

Thanks for clarifying.

Eric.

-----Original Message-----
From: EXT Donovan, Steven R. [mailto:[email-masked]]
Sent: Thursday, April 06, 2000 5:32 PM
To: [email-masked]'; [email-masked]
Subject: RE: [SIP] Question on ACKs for responses > 200

This flow does not apply to stateless proxies.  As stated in section 12.3 of
the RFC:

"...a stateless proxy forwards every request it
   receives downstream, and every response it receives upstream."

Thus the stateless proxy does not send the ACK.

I'm not sure I understand your question on reliability.

Steve

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, April 06, 2000 3:57 PM
> To: [email-masked]
> Subject: RE: [SIP] Question on ACKs for responses > 200
> 
> 
> Given the message flow shown below, and assuming that P1and 
> P2 are stateless
> UDP proxies, how would reliability be assured?
>  
> A                       P1                        P2 	 	B
> INVITE--------------->
>                            INVITE----------------->
>					INVITE--------------->
>  
>					 <--------------------4XX
> 					ACK------------------->
>                            <---------------------4XX
>                            ACK-------------------->
> <------------------- 4XX
> ACK-------------------->
>  
> ----
> Eric Cooper
> [email-masked] <mailto:[email-masked]> 
> (613) 271-6805
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Igor Slepchin <[email-masked]>
Date: Fri, 07 Apr 2000 12:45:55 -0400

> If UDP proxies do not send ACKs, then that clears it up for me.

_Stateless_ UDP proxies do not send ACKs, stateful do. Note that
stateless proxies cannot generate responses of their own as well, they
just proxy responses according to the Via header.
 
> by A, which didn't seem correct.

Assuming you refer to the picture from your previous message and P1 and
P2 are stateless, no ACKs will be generated by either P1 or P2.  In this
situation, UAC A and UAS B will provide reliability so the ACK
effectively becomes end to end. The correct diagram follows:

A                       P1                        P2                   
B
INVITE--------------->
                         INVITE----------------->
                                                  INVITE--------------->
                                                
<--------------------4XX
                                                 
ACK------------------->

---
Igor Slepchin