Subject: [SIP] Question on ACKs for responses > 200

From: Sunitha Kumar <[email-masked]>
Date: Tue, 04 Apr 2000 19:57:45 -0700

For ACKS, it is given that the ACK request Uri is based on the Route (if any), else the Contact(if any)

else the To field of the 200 response.

Does this hold good for all other responses, such as > 200 status codes.(because the

record route makes sense only for 200 )

The reason for this question is:

Consider a situation such as:

endpt A --INVITE----> proxy A ----INVITE--> proxy B----> endpt B.

endpt B ---4xx----> proxy B  and proxy B ---ACKs---> endpt B and this continues to endpt A.

Here, how does proxy B know endpt B's address to send it an ACK.

Thanks!

--
Sunitha Kumar
Software Engineer
Vovida Networks
(408) 383-1076

---

From: "Brett Tate" <[email-masked]>
Date: Thu, 6 Apr 2000 13:04:17 -0400

My understanding concerning Acks for responses >=3xx:

- Set Request-URI based on Record-Route and Contact 
  from the response if present.  They should only be 
  present in certain situations and it indicates they want you to use it. 
- Otherwise (based on section 10.5.1 in April 2000's 
  draft-ietf-sip-rfc2543bis-00) use the same Request-URI that 
  was used in the Invite.  
- Could try location server next if not forking and think its 
  worth the effort since it might not give the correct location.  
- Only as a last resort, use the To field to set the Request-URI 
  since it is most likely only ever correct for the original 
  originator of the Invite.
  ----- Original Message ----- 
  From: Sunitha Kumar 
  To: SIPbell-labs 
  Sent: Tuesday, April 04, 2000 10:57 PM
  Subject: [SIP] Question on ACKs for responses > 200

Thanks!
-- 
Sunitha Kumar
Software Engineer
Vovida Networks
(408) 383-1076