Subject: [SIP] end to end key transport

From: Michael Thomas <[email-masked]>
Date: Fri, 14 Apr 2000 08:29:48 -0700 (PDT)

While it's potentially OK to have a pre-shared
secret between a proxy and a UA, it clearly
doesn't scale well to have a mesh of pre-shared
secrets between all of the UA's for end to end
authentication of SIP traffic. As far as I can
remember, there's a way to send a key end to end
in the k: field of SDP, but that suffers from
two problems:

1) the key is intended for what the SDP
   announcement is describing, which is normally
   just a media descriptor. I don't think it
   is intended to be used for SIP session level
   keying. If there's a standard way to describe
   how to tell the UAS that that key ought to
   also be used for, say, http-authenticate's,
   that would probably be a fine solution.

2) the key is shipped in the clear. If there
   is no underlying transport crypto, then
   the key is really in the clear which makes
   the entire use of crypto rather dubious.

Toward the latter, assuming there is no transport
level security, maybe an acceptable alternative is
to use hop-by-hop keying between the UAC->Po Po->Pt
and Pt->UAS. In that case, we could use the
existing pre-shared secret for proxy-authenticate,
say, to encrypt the key itself in the SDP
announcement. 

Has anybody thought about this issue before? Is
this one of those areas where header encryption
might actually be useful, but for hop-by-hop
instead of end to end?

	   Mike

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Rohan Mahy <[email-masked]>
Date: Fri, 14 Apr 2000 20:23:53 -0700

Hi,

I wanted to point out that you can use k= is a few different ways:

k=base64:<key here in base64>   which suffers from the problem your mention
k=prompt:  i don't know how this is supposed to work
k=<mumble>:<url>

the URL could use the https: scheme to grab a key.  while clearly 
suboptimal, this could work in a relatively secure fashion.  sorry that i 
don't remember what <mumble> is off the top of my head.

thanks,
-rohan