Subject: RE: [SIP] SIP and soft hand-off

From: "Glenn Morrow" <[email-masked]>
Date: Thu, 13 Apr 2000 10:11:03 -0500

From my understanding the SIP terminal mobility solution does not require
changes to every application even without dynamic DNS updates. This is a
common misconception. 

Perhaps Hennning or someone could describe the interactions when someone
wants to FTP to another IP based terminal with a mobile user. Will FTP have
to change?

> -----Original Message-----
> From:	Rosen, Brian [SMTP:[email-masked]]
> Sent:	Wednesday, April 12, 2000 3:50 PM
> To:	'Dean Willis'; Stephen Terrill; Baba, S.
> Cc:	[email-masked]
> Subject:	RE: [SIP] SIP and soft hand-off
> 
> I understand what you want to do.  I like it.
> I don't like saying that because your IP address changed,
> ALL application level protocols have to know about it.
> 
> If that's what you want to do, let's purge the app level
> protocols of the part that changes, even if we have to add a layer
> somewhere.  It SHOULD NOT require changes in EVERY protocol
> to make real mobility work.  
> 
> That is the basic issue I see with the flurry of mobility efforts.
> These guys are EVERYWHERE telling us that we have to change what we
> are doing in order to accommodate mobility.  There isn't a protocol
> effort I'm involved in that doesn't have a cadre of people trying
> to get something in it to make mobility work.
> 
> That is just plain wrong.  If mobility is, or is about to be,
> ubiquitous, then we should change IP if we have to.  We should not
> change SIP, LDAP, COPS, ISUP, DNS, NTP, HTTP, FTP, RADIUS,
> and every other protocol we really use.  
> 
> It is entirely inappropriate for any session level protocol, let alone
> session establishment protocols, to have knowledge that the end
> device is mobile.  It's like having the protocol have to know
> whether they are on a LAN or a WAN.  Somewhere, someone cares,
> but it shouldn't be SIP!
> 
> Brian
> ------------
> Brian Rosen, Principal Engineer
> Marconi (Formerly FORE Systems)
> 1000 FORE Drive, Warrendale, PA 15086
> (724) 742-6826  mailto:[email-masked] 
> 
> 
> 
> > -----Original Message-----
> > From: Dean Willis [mailto:[email-masked]]
> > Sent: Wednesday, April 12, 2000 3:49 PM
> > To: Stephen Terrill; Baba, S.
> > Cc: [email-masked]
> > Subject: RE: [SIP] SIP and soft hand-off
> > 
> > 
> > 
> > One can envision a layer-2 hand off, a layer-3 (mobile-IP) 
> > hand off, or a
> > layer-4 handoff . . .
> > 
> > This mobility approach seems to me to be appropriate to a 
> > layer-4 handoff,
> > wherein the IP address actually changes. This has 
> > applicability outside
> > classic mobilephone. For example, when I undock my PC, I might want to
> > switch from my wired 100TX card to my wireless 802.11 card. 
> > Both can be
> > active during handoff -- then I shut down the wired card and undock.
> > 
> > --
> > Dean
> > 
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]]On Behalf Of Stephen Terrill
> > > Sent: Wednesday, April 12, 2000 4:13 AM
> > > To: Baba, S.
> > > Cc: [email-masked]
> > > Subject: Re: [SIP] SIP and soft hand-off
> > >
> > >
> > > Hi Baba,
> > >
> > > I am not sure that I understand the requirements as discussed
> > > here.  I understand that the technology independance requirement,
> > > and quite like that, however I don´t understand the need of the
> > > SIP protocol level to be involved in the Soft hand-off.  I would
> > > have expected that the soft hand-off would be entirely within the
> > > "access network" (the mobile network technology), from the
> > > prespective of the SIP applications.  As such, the application
> > > shouldn´t even be aware of the hand-overs (won´t even 
> > change IP address).
> > >
> > > Regards,
> > >
> > > ..//steve
> > >
> > > "Baba, S." wrote:
> > >
> > > > Folks,
> > > >
> > > > Thank you for your attention to my presentation of
> > > > our mobility management requirement in Adelaide.
> > > >
> > > > Let me add a brief explanation about a relation between
> > > > SIP and wireless soft hand-off, since I feel I didn't answer
> > > > raised questions well. Please read the related part (4.1)
> > > > of our revised draft <draft-itsumo-sip-mobility-req-01> also.
> > > >
> > > > First, we believe that the requirement wireless
> > > > 'technology-independent" is very important principle.
> > > > At the same time, the soft hand-off is one of the key
> > > > technology promising high efficiency for the CDMA-based
> > > > wireless system. So any protocol on top of the wireless
> > > > shall not break the soft hand-off capability in the
> > > > wireless part. These are our basic assumptions.
> > > >
> > > > The soft hand-off has some aspects like giving smooth hand-off
> > > > taking several tens seconds or more for the radio path change
> > > > and giving more than one radio paths during the hand-off.
> > > > If the soft hand-off is handled in the L2 only or below
> > > > L3 and doesn't affect the upper layer process, it is no
> > > > problem with SIP.
> > > >
> > > > But if we consider the future RAN using IP transport,
> > > > SIP User Agent and/or Proxy Server may need a process
> > > > to support the mobility management on top of the soft hand-off.
> > > > Because SIP controls smooth hand-off of its IP sessions.
> > > >
> > > > Although the details are still open issues, this is the
> > > > basic consideration about the soft hand-off.
> > > > Any questions and comments are welcomed.
> > > >
> > > > Thank you.
> > > >
> > > > Baba//
> > > > -----
> > > > Shinichi Baba
> > > > Toshiba America Research, Inc. (TARI)
> > > > Mail-To: P.O.Box 136 Convent Station, NJ 07961-0136
> > > > Location: 445 South St. Suite 1B259B, Morristown, NJ 07960
> > > > Phone: (973) 829-4795/ Fax: (973) 829-5601
> > > > Email: [email-masked]
> > > >
> > > > _______________________________________________
> > > > SIP mailing list
> > > > [email-masked]
> > > > http://lists.bell-labs.com/mailman/listinfo/sip
> > >
> > >
> > >
> > >
> > >
> > > _______________________________________________
> > > SIP mailing list
> > > [email-masked]
> > > http://lists.bell-labs.com/mailman/listinfo/sip
> > >
> > 
> > 
> > 
> > _______________________________________________
> > SIP mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/sip
> > 
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Faramak Vakil <[email-masked]>
Date: Thu, 13 Apr 2000 23:13:23 -0400

Glenn Morrow wrote:

>
>
> From my understanding the SIP terminal mobility solution does not
> require changes to every application even without dynamic DNS updates.
> This is a common misconception.
>

Correct!
Dynamic DNS is needed to provide location service to new
inbound connections.

>
> Perhaps Hennning or someone could describe the interactions when
> someone wants to FTP to another IP based terminal with a mobile user.
> Will FTP have to change?

HMMP supports TCP as is and requires no changes to FTP or any other
application
that runs on top of TCP.

Regards, Faramak