Subject: [SIP] Seven & Eleven

From: "Li, Renwei" <[email-masked]>
Date: Mon, 10 Apr 2000 09:54:59 -0700

In RFC 2543, there are two magic numbers: seven and eleven.

  Page 89:
          Retransmissions cease when the client has sent a total of ELEVEN
packets
 
  Page 91:
          or once it has sent a total of 7 request packets.

Is there any particular reasons for them? 

Thanks,

Renwei

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 10 Apr 2000 13:29:08 -0400

> Is there any particular reasons for them?

This is a secret, but a major U.S. convenience store chain is sponsoring
this work. They are into sips of slurpee and coffee, I gather. Other
numbers (e.g., for status codes) are still available for sponsorship.

The numbers were picked more-or-less arbitrarily, as a compromise
between the likely network failure rates, reasonable time-outs (i.e., if
you didn't get a response in that interval, somebody else will likely
lose patience anyway) and avoiding continuous flooding of the network.
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: Christian Huitema <[email-masked]>
Date: Mon, 10 Apr 2000 10:34:03 -0700

More seriously, there is a rationale way to determine when to stop
retransmitting. It has to do with the original value of the retransmission
timer, the exponential back-off and its 4 second cap, and the application
level timers in telephony gateways.

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Monday, April 10, 2000 10:29 AM
> To: [email-masked]
> Subject: Re: [SIP] Seven & Eleven
> 
> 
> "Li, Renwei" wrote:
> >