Subject: RE: [SIP] SIP and soft hand-off

From: "Roy, Radhika R, ALARC" <[email-masked]>
Date: Wed, 12 Apr 2000 09:33:21 -0400

Hi, Baba and Steve:

I guess that Steve is right.

Let us keep the activities of the lower layer (e.g., link/network) separate
from the application layer (e.g., SIP) as far as practicable.

For example, if the network layer address (e.g., IP address) is not changed
during the soft-handover why should we bring that abstraction to the
application layer (e.g., SIP)?

Best regards,
Radhika R. Roy
AT&T
+1 732 420 1580
[email-masked]

> -----Original Message-----
> From:	Stephen Terrill [SMTP:[email-masked]]
> Sent:	Wednesday, April 12, 2000 5:13 AM
> To:	Baba, S.
> Cc:	[email-masked]
> Subject:	Re: [SIP] SIP and soft hand-off
> 
> Hi Baba,
> 
> I am not sure that I understand the requirements as discussed here.  I
> understand that the technology independance requirement, and quite like
> that, however I don´t understand the need of the SIP protocol level to be
> involved in the Soft hand-off.  I would have expected that the soft
> hand-off would be entirely within the "access network" (the mobile network
> technology), from the prespective of the SIP applications.  As such, the
> application shouldn´t even be aware of the hand-overs (won´t even change
> IP address).
> 
> Regards,
> 
> ..//steve
> 
> "Baba, S." wrote:
> 
> > Folks,
> >
> > Thank you for your attention to my presentation of
> > our mobility management requirement in Adelaide.
> >
> > Let me add a brief explanation about a relation between
> > SIP and wireless soft hand-off, since I feel I didn't answer
> > raised questions well. Please read the related part (4.1)
> > of our revised draft <draft-itsumo-sip-mobility-req-01> also.
> >
> > First, we believe that the requirement wireless
> > 'technology-independent" is very important principle.
> > At the same time, the soft hand-off is one of the key
> > technology promising high efficiency for the CDMA-based
> > wireless system. So any protocol on top of the wireless
> > shall not break the soft hand-off capability in the
> > wireless part. These are our basic assumptions.
> >
> > The soft hand-off has some aspects like giving smooth hand-off
> > taking several tens seconds or more for the radio path change
> > and giving more than one radio paths during the hand-off.
> > If the soft hand-off is handled in the L2 only or below
> > L3 and doesn't affect the upper layer process, it is no
> > problem with SIP.
> >
> > But if we consider the future RAN using IP transport,
> > SIP User Agent and/or Proxy Server may need a process
> > to support the mobility management on top of the soft hand-off.
> > Because SIP controls smooth hand-off of its IP sessions.
> >
> > Although the details are still open issues, this is the
> > basic consideration about the soft hand-off.
> > Any questions and comments are welcomed.
> >
> > Thank you.
> >
> > Baba//
> > -----
> > Shinichi Baba
> > Toshiba America Research, Inc. (TARI)
> > Mail-To: P.O.Box 136 Convent Station, NJ 07961-0136
> > Location: 445 South St. Suite 1B259B, Morristown, NJ 07960
> > Phone: (973) 829-4795/ Fax: (973) 829-5601
> > Email: [email-masked]
> >
> > _______________________________________________
> > SIP mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/sip
> 
> 
> 
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Faramak Vakil <[email-masked]>
Date: Wed, 12 Apr 2000 11:07:04 -0400

In a nutshell, the soft hand-off  process

 i.   a mobile station (MS) commences communication
      with a new base station (BS) without interuppting
      communication with the old base station. In
      other word, the MS receives multiple copies of
      the "same" signal  from multiple BSs simultaneously.
 ii.  Then, the MS (DSP algorithms within the hand set) forwards
      a weighted combination of the received signal to the higher layers.

Thus, in order to maintain advantages of the soft hand-off process in
an IP environment, during the soft hand-off process of an MS (refered
to as the MS, hereafter)

   a.  the packets destined for the MS should be forwarded to
        multiple BSs (at least current and previous ones) during the
        soft hand-off process to ensure that signals received from
        different BSs carries actual user data, and
   b. multiple copies of the same packet forwarded by different
       BSs to the MS must arrive at the MS synchronously so that at the
       CDMA layer all signals contain identical user information, and
       accurate information is forwarded to higher layers of the MS.

Without much elaboration, we refer to (a) and (b) as "virtual"
soft hand-off in <draft- itsumo-sip-mobility-req-01.txt>. In
order to support it, we need to commence a synchronous multicast
of packets bound for the MS to multiple BSs during the soft hand-off
process and this is where SIP gets involved.  A simple and neat resoultion
of this problem is a challenge and we are currently working on it.

One last point, one way for ensuring wireless "technlogy independence"
axiom/requirement is that the MS may communicate its hand-off
preference (soft or hard) to its corresponding host via the SDP.

Regards, Faramak

---

From: "Baba, S." <[email-masked]>
Date: Wed, 12 Apr 2000 10:48:52 -0500 (EST)

Hi Steve and Radhika,

Thank you for your comments.

First of all, I agree with you that SIP needs to do nothing in
any case if IP address of Mobile Station (MS) is not changed.

And I also agree with both of you in the case of certain (and maybe
popular) architecture, e.g. the one on which 3GPP or 3GPP2 is
working right now. Because in this case the soft hand-off is
completely processed in or under the layer 2 and MS can not
distinguish if it is the hard hand-off or the soft hand-off from
upper layers.

As Faramak mentioned in his reply, we are looking at the future RAN
which will use the IP even for its transport method, i.e. IP
in the RAN or IP to the BTS, at the same time. Even in this case,
the mobility management by SIP shall not break the soft hand-off
process using IP communication. That is the point where we are
thinking as one of the important principles.

Regards,

baba//

---

From: Rohan Mahy <[email-masked]>
Date: Wed, 12 Apr 2000 13:55:39 -0700

Hi,

Is this a layer 2 multicast?  If so, it seems this problem could be solved 
by simply changing the ARP table during soft handoff.  Am I missing 
something here?

thanks,
-rohan

---

From: Faramak Vakil <[email-masked]>
Date: Wed, 12 Apr 2000 17:36:25 -0400

Hello,

If the MS IP address does not change during the soft hand-off
(i.e., cells belong to the same subnet) you are right in principle.
However, if the cells belong to different subnets and the MS IP
address changes, we need to multicast at the IP layer.

Regards, Faramak

---

From: Stephen Terrill <[email-masked]>
Date: Thu, 13 Apr 2000 09:37:31 +0200

Hi,

Perhaps out of all of the replies, this is the most appropriate to respond to.

It is interesting that it is pointed out here that for some of the popular archectures where this is being considered that the soft hand-over doesn´t come into the process as it happens at layer 2.  It is also interesting to not that a significant portion of those archectures do run on top of IP.  I think that it is required to remember where the IP network that the Application in the mobile terminal sees actually is - it is not necessary the IP network that is used to run the RAN.

Regards,

..//steve

---

From: Chris Wayman Purvis <[email-masked]>
Date: Thu, 13 Apr 2000 17:27:42 +0100

Radhika,

Would you like to take this view back to the ITU (SG16), where you disagreed
with the same point when I made it about H.323 to try to save people the vast
amounts of unnecessary work they're doing there on mobility?

Regards,
Chris

-- 
Dr Chris Purvis -- Development Manager
ISDN Communications Ltd, The Stable Block, Ronans, Chavey Down Road
Winkfield Row, Berkshire.  RG42 6LY  ENGLAND
Phone: +44 1344 899 007
Fax:   +44 1344 899 001