Subject: RE: [SIP] Basic questions

From: Kevin Summers <[email-masked]>
Date: Tue, 30 May 2000 08:25:28 -0500

I know my head is shaped like a bell, but a self-test on a given interface
is rather common.

-----Original Message-----
From: charles Agboh [mailto:[email-masked]]
Sent: Tuesday, May 30, 2000 8:06 AM
To: Dean Willis; [email-masked]
Cc: Jonathan Rosenberg
Subject: Re: [SIP] Basic questions

Can somebody please answer the following question? "

     How can you have a "session" of any kind with only one participant?

charles
Dean Willis wrote:

> Jonathan Rosenberg wrote:
> >
> > [email-masked] wrote:
> > >
> > > Hello, all. Just starting with SIP, but I already have a few basic
questions
> > > regarding the RFC. Since this is my first query, let me know if these
> > > questions should be posted elsewhere or I have otherwise violated some
other
> > > rule of etiquette.
> >
> > Many common questions are answered in the FAQ:
> > http://www.cs.columbia.edu/~hgs/sip/faq.html
> >
> > >
> > > - "...SIP...is...for...sessions with one or more participants." - How
can
> > > there be a session with only one participant? A session is defined
elsewhere
> > > as comprising one or more RTP sessions, which implies a sender and a
> > > receiver, or two participants. Should the sentence have been written
as
> > > "...with two or more participants?"
> >
> > Mulicast sessions can have a single participant. Not that interesting,
> > but possible.
> >
>
> Note that a "session" does not have to be RTP. It might have an RTP
> component, might have several RTP components, or none at all. I might
> also have an associated "Quake" game, SIGTRAN connection, or anything
> else that can be described  from a third-person perspective.
>
> > > - "Servers are either proxy, redirect or user agent servers or
> > > registrars." - I have also seen references to "location servers" and
"SIP
> > > servers." Is a location server the same thing as a redirect server? Is
"SIP
> > > server" just a general reference to servers in "SIPdom?"
> >
> > Location server is a non-SIP server, like an LDAP server or SQL
> > database. "SIP server" is any entity that receives requests (UAS, proxy,
> > redirect, registrar).
>
> This may be a slightly misleading statements. Many implemented Location
> Servers are in fact SIP Servers hat have access to additional routing
> data such as LDAP.
>
> --
> Dean
>
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip

--

Charles Agboh

Universite Libre de Bruxelles
Service Telematique et Communication
Bd du Triomphe, CP 230
B-1050 Brussels
Belgium

Tel. +32 2 6505717
Fax. +32 2 6505088, +32 2 6293816
RFC-822 : [email-masked]

----------------------------------
"Perilous to us all are the devices of an art deeper than we possess
ourselves."
--J.R.R Tolkien, The Two Towers

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: [email-masked]
Date: Wed, 31 May 2000 16:02:33 -0500

"Dave Oran" <[email-masked]> on 05/30/2000 01:30:31 PM

To:   "charles Agboh" <[email-masked]>, "Dean Willis"
      <[email-masked]>, [email-masked]
cc:   "Jonathan Rosenberg" <[email-masked]> (bcc: David K
      Brown/MAIN/MC1)

Subject:  RE: [SIP] Basic questions

> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of charles Agboh
> > Sent: Tuesday, May 30, 2000 9:06 AM
> What is the sound of one hand clapping?
>
> SIP can set up Zen sessions. It's completely general.

It may be general enough to allow these sessions but are they useful (some
multi-cast situations have been identified but those looked like transitional
situations).  I'm looking at this from the standpoint of possible services, not
strictly protocol rules.  Would single particiapant sessions possibly be of use
in the following types of service conditions: transition (adding, removing, or
locating participants), residue of failed or disrupted sessions (is this
possible for even a few moments?), pending sessions, meet-me or third party
controlled type conference sessions (which might even reasonably conceptually
have NO participants at some stage).  These possible single participant
situations are all transitions in a larger service, does anyone anticipate a
single participant only service?

Dave Brown
Marconi Comms