Subject: Re: [SIP] Another grammar query - Call-ID

From: Sean Olson <[email-masked]>
Date: Thu, 11 May 2000 10:05:01 -0500 (CDT)

> 
> Hi all,
> 
> I have another grammar query, this time regarding the call-id.  
> 
> Call-ID is defined as (bis 6.12):
> 
> callid = local-id  @  host
> local-id = 1*uric
> Call-ID = (  Call-ID  |  i  )  :  callid
> 

I may be wrong, but I seem to remember some agreement that Call-ID would become
a token and would not necessarily need to take the form "local-id@host".
But perhaps more importantly, I think its dangerous to start trying to parse the Call-ID
and possibly derive information from it, such as the host. 

--
Sean Olson <[email-masked]>

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Gethin Liddell <[email-masked]>
Date: Thu, 11 May 2000 16:04:52 +0100

> a token and would not necessarily need to take the form "local-id@host".

Great, that makes things easier :)

Can this be confirmed?

---

From: Anders Kristensen <[email-masked]>
Date: Thu, 11 May 2000 16:36:21 +0100

> > a token and would not necessarily need to take the form "local-id@host".

Yes, except token didn't work because it doesn't include the '@'
character. Basically, the field should be treated as an opaque,
uninterpreted identifier, e.g. TEXT-UTF8-TRIM in the grammar.

-- 
Anders Kristensen <[email-masked]>,
http://www-uk.hpl.hp.com/people/ak/
Hewlett-Packard Labs, Bristol, UK