Subject: Re: [SIP] Minutes of SIP Security task force in Adelaide

From: James Kempf <[email-masked]>
Date: Mon, 22 May 2000 13:41:21 -0700 (PDT)

>However, it is *very* clear to me that in the "new world"
>of web-based or web-like services (and services definition)
>that standardization of anything but the most rudimentary
>subscriber information or core services will not make it in
>"new world" deployments.
>
>Don't fence me in,
>

Don't see why this should be any more the case for a telephony
DTD than for any other standardized XML document. Naturally,
there needs to be some provision in the format for extensibility,
and I suspect that Old World Telephony GSM standardization didn't
see the need for that. 

		jak

>Michael Ramalho
>
>At 12:55 PM 5/22/00 -0700, Michael Thomas wrote:
>>James Kempf writes:
>> > >   I don't know what services the roaming network
>> > >   wants to provide -- other than trying to shoehorn
>> > >   themselves into the call. Even if, there is nothing
>> > >   to prevent me from obtaining those service even if
>> > >   it's routed through my home proxy first.
>> > >
>> > 
>> > 
>> > What about having a standardized XML-based user profile description?
>> > That way, the guy that wants to set up a telephony provider in
>> > his garage can have the same access to a description of his
>> > services as anybody else.
>>
>>   I think we have arrived at an impasse since I
>>   view this as a bug, not a feature. A standardized
>>   scheme always locks you to the least common
>>   denominator when you want to remote the
>>   features. That sounds like a shame to me; if I
>>   run it through my home proxy, I can have as
>>   many whacko features as I want to cook up
>>   without having to convince the world that
>>   they're a Good Idea. That way, the market
>>   decides rather than a bunch of standards
>>   weenies (present company excluded, yadda
>>   yadda).
>>
>>		Mike
>>
>>
>>_______________________________________________
>>SIP mailing list
>>[email-masked]
>>http://lists.bell-labs.com/mailman/listinfo/sip
>>
>
>
>Michael A. Ramalho, Ph.D.
>Cisco Systems
>1802 Rue de la Port
>Wall Township, NJ 07719-3784
>Office email: [email-masked]
>Personal email: [email-masked]
>Office: +1.732.449.5762
>Cell: +1.732.809.0188
>Pager: +1.800.365.4578

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Graham Klyne <[email-masked]>
Date: Tue, 23 May 2000 09:44:04 +0100

>there needs to be some provision in the format for extensibility,

[...]

There has been much talk over recent months of the Internet's end-to-end 
architecture, and the way that it allows innovation by any connected party 
rather than just those that control the core.  (I think SIP is just one 
fruit of this realization.)

I think there is a new front emerging over which the tensions between 
centralized and decentralized control will occur:  content formats.  How 
many organizations are stuck with a certain vendor's software because their 
documents are in the format of that software?  Through XML, XML namespaces, 
RDF and other initiatives, W3C are working on content formats that offer 
the potential for an end-to-end content architecture, much as IP has 
provided an end-to-end communication architecture.  The key is something 
that Tim Berners-Lee has called "language mixing".  (see 
http://www.w3.org/DesignIssues/Evolution.html)

These ideas are being developed in the context of WWW, but I belive are 
applicable to other Interbnet applications.

In summary:  using the right tools, a definition of core information should 
not be a fence, but a springboard.  (In this, I am broadly agreeing with 
James.)

#g

------------
Graham Klyne
([email-masked])