Subject: Re: [SIP] Minutes of SIP Security task force in Adelaide

From: James Kempf <[email-masked]>
Date: Mon, 22 May 2000 09:42:38 -0700 (PDT)

> >    * When the callee is roaming, either you use a standardized database 
transport protocol or you
> >      delegate the callee home domain proxy to perform the query, but you 
have a RTT towards the callee
> >      home domain. 
>
>   Which may effectively be zero.
>
>> Your solution of having synchronized copies of such database all over the 
world is
> >      another interesting enhancement, maybe expensive (pretty sure 
off-the-shelf solutions are already
> >      out there)
>
>   It doesn't sound much more interesting than a
>   localize LDAP cache on the client proxy. There
>   are other ways to do this as well. And it doesn't
>   imply synchronized; all that is necessary are caches
>   with TTL's.
>
> >         o the point I was making was that for all subsequent mid-call 
messages, just like the INVITEs
> >           you have to send for handovers, you should shortcut and avoid the 
round trip to the home
> >           net.
>
>   I disagree. Most traffic is between the two UA's.
>   And it absolutely does not follow that proxies 
>   need to have any part in handoffs. In fact, I
>   do not believe that proxies have any part in
>   handoffs when the UA is in the mobile unit. 
>
> >    * When the caller is roaming, under certain circumstances (related to the 
type of value added
> >      services required & the set of services supported by the visited 
network &  the possibility to
> >      transfer a user profile--see my previous messages)
>
>   I don't know what services the roaming network
>   wants to provide -- other than trying to shoehorn
>   themselves into the call. Even if, there is nothing
>   to prevent me from obtaining those service even if
>   it's routed through my home proxy first.
>

What about having a standardized XML-based user profile description?
That way, the guy that wants to set up a telephony provider in
his garage can have the same access to a description of his
services as anybody else.

Not that this has anything to do with SIP...

		jak

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Michael Thomas <[email-masked]>
Date: Mon, 22 May 2000 12:55:01 -0700 (PDT)

> services as anybody else.

   I think we have arrived at an impasse since I
   view this as a bug, not a feature. A standardized
   scheme always locks you to the least common
   denominator when you want to remote the
   features. That sounds like a shame to me; if I
   run it through my home proxy, I can have as
   many whacko features as I want to cook up
   without having to convince the world that
   they're a Good Idea. That way, the market
   decides rather than a bunch of standards
   weenies (present company excluded, yadda
   yadda).

		Mike

---

From: "Michael A. Ramalho" <[email-masked]>
Date: Mon, 22 May 2000 16:36:19 -0400

James/Mike,

I, for one, am grateful that you two have realized that
this is the crux of the debate between you. Can we go
on now?

What Mike Thomas says is correct .... the standardized
scheme will lock you into some core or least common
denominator services.

Because the relative scarcity of really neat features in
the wireless world ... some architects of tremendously
successful wireless deployments (e.g., GSM) believe
that their success was in the standardization of profiles.

I think they are/were correct from the perspective of
billing (and the corresponding roaming agreements) and
some traditional "old world" PSTN services. [When once
in a vacuum, any particulate matter looks interesting.]

However, it is *very* clear to me that in the "new world"
of web-based or web-like services (and services definition)
that standardization of anything but the most rudimentary
subscriber information or core services will not make it in
"new world" deployments.

Don't fence me in,

Michael Ramalho

>   weenies (present company excluded, yadda

Michael A. Ramalho, Ph.D.
Cisco Systems
1802 Rue de la Port
Wall Township, NJ 07719-3784
Office email: [email-masked]
Personal email: [email-masked]
Office: +1.732.449.5762
Cell: +1.732.809.0188
Pager: +1.800.365.4578

---

From: Romeo Zwart <[email-masked]>
Date: Fri, 26 May 2000 12:14:13 +0200

James/Mike/Mike, et al.

 > this is the crux of the debate between you. Can we go

The main disconnect in this discussion seems to be
the mixing of issues. On the one hand there's talk about
standardization of _services_ which is, as Mike mentioned
below, unlikely to be successful. In fact, I would argue that
even most "Old Word" operators realize that their strength
should be in service differentation, not in locking down
users into a handful of predefined features that everyone
offers.

On the other hand, there is the idea of having a mechanism
to exchange service _profiles_. This allows service portability
between service providers (whether Old or New World
operators), but brings with it a lot of issues around execution
control, relyability, etc. Defining a(nother) service definition
language, be that based on XML or anything else, would
have to take into account most if not all of the argumentation
that lead to CPL.

 > ... [stuff yanked] ...>

Fully agree with that.

 > Don't fence me in,
 >
 > Michael Ramalho
 > ... [more stuff yanked] ...
 >

Romeo