Subject: RE: [SIP] Domain or Zone concept

From: "Roy, Radhika R, ALARC" <[email-masked]>
Date: Tue, 30 May 2000 15:19:00 -0400

Hi, Anders:

Does it NOT mean that we should NOT use the term like "SIP Domain, SIP
Intra-domain, or SIP Inter-Domain?"

However, it appears that the terms like administrative domains, trust
domains, inter-domain QoS, etc. as well as domains based on DNS are being
used.

Is there any way that we can use the term "domain" in a consistent way
across all references?

Best regards,
Radhika R. Roy

> -----Original Message-----
> From:	Anders Kristensen [SMTP:[email-masked]]
> Sent:	Tuesday, May 30, 2000 2:32 PM
> To:	Tricia Wang
> Cc:	[email-masked]
> Subject:	Re: [SIP] Domain or Zone concept
> 
> 
> Tricia Wang wrote:
> > 
> > Hi,
> >    does SIP have Domain or Zone concept ?
> > I would assume it does, cause I saw a Draft describing SIP interdomain
> > architecture.
> > If it does, how does it define a Domain or Zone ? by Register on a SIP
> > Server ?
> 
> I would say that the only concept of domains in vanilla SIP is really
> those of DNS. At a different level people talk about a particular
> providers network consituting a domain of its own, especially when
> discussing trust issues. Trust domains will obviously not generally map
> onto DNS domains one-to-one.
> 
> > 
> > By the way, is there a API for SIP network?  I saw a Draft Java Servlet
> API
> > but that's about it.
> 
> Right. That would be
> 
> http://www.ietf.org/internet-drafts/draft-kristensen-sip-servlet-00.txt
> 
> There will hopefully be an update of that draft sometime in the future
> (then I haven't said too much ;-).  I did set up a mailing list for
> discussions related to the API (see http://com.hp.sip.listbot.com/) but
> it's been very quiet.
> 
> Anders
> 
> -- 
> Anders Kristensen <[email-masked]>,
> http://www-uk.hpl.hp.com/people/ak/
> Hewlett-Packard Labs, Bristol, UK
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Anders Kristensen <[email-masked]>
Date: Tue, 30 May 2000 20:40:54 +0100

> Intra-domain, or SIP Inter-Domain?"

Yes, FWIW I don't think those terms are well-defined and thus should be
qualified somehow.

> domains, inter-domain QoS, etc. as well as domains based on DNS are being

Right, but in these cases the qualifications of the term "domain" gives
some sort of idea of what's meant, so that's more reasonable.

> Is there any way that we can use the term "domain" in a consistent way

Just because RFC2543 doesn't talk about administrative domains doesn't
mean they are not important. I don't think there is any need for a
language police looking after how these terms are used (which is
probably not what you meant either), except to encourage people to be
clear about what they mean when they use them.

I feel a quote coming on...

  "Simplicity, clarity, singleness: These are the attributes that give
our lives power and vividness and joy as they are also the marks of
great art."
				-- Richard Holloway

just looked that up. Should be in the SIP spec, really ;-)

Anders