Subject: Re: [SIP] Problem with the syntax of URI extension parameters

From: Sean Olson <[email-masked]>
Date: Tue, 2 May 2000 19:10:05 -0500 (CDT)

> RFC 2543 (and the current bis draft) defines the BNF for SIP URLs' extension
> parameters as follows:
> 
>   other-param     = ( token | ( token "=" ( token | quoted-string )))
> 
> The problem with this is that RFC 2396 (URI Generic Syntax) specifically
> excludes quote marks from URIs, since they're a common URI delimeter in text
> documents and protocol fields.  What's more, both the "token" and
> "quoted-string" syntax elements come from a very different part of the SIP
> BNF; and no other URI syntax, as far as I know, uses anything like them.
> 
> I think it'd be much more in the spirit of the generic URI syntax to have 
> other-param be defined like this:
> 
>   other-param     = pname | pname "=" pvalue
>   pname           = 1*paramchar
>   pvalue          = 1*paramchar
>   paramchar       = param-reserved | unreserved | escaped
>   param-reserved  = "/" | "?" | ":" | "@" | "&" | "+" | "$" | ","
> 
> That is, special characters get %-escaped rather than quoted.
> "param-reserved" above is the same as the general "reserved" with ";" and
> "=", the parameter delimiters, omitted.
> 
> This would, however, be an incompatible change to the SIP spec.  What would
> people (especially the spec authors) think about this?
> 
> -- 
> Jonathan Lennox
> [email-masked]
> 

Sounds reasonable. I doubt that there are many implementations that actually accept a
quoted-string as part of a SIP URL parameter value. And as you mention, in general
the URI syntax doesn't allow quotes and in practice I've never seem them used.

--
Sean Olson <[email-masked]>

> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 02 May 2000 22:07:34 -0400

Sean Olson wrote:

> the URI syntax doesn't allow quotes and in practice I've never seem them used.

Same here. Escaping the " kind of works, but is very unclean, since you
are now escaping syntactically relevant delimiters.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs