Subject: RE: [SIP] Minutes of SIP Security task force in Adelaide

From: James Kempf <[email-masked]>
Date: Mon, 22 May 2000 13:37:11 -0700 (PDT)

>
>>That way, the market
>>   decides rather than a bunch of standards
>>   weenies
>
>Wow Michael! The Internet is defined entirely by its standard protocols,
>developed with great care by 'weenies', and not by 'market decides'
>managers. We know a lot of protocols developed by 'market decides' managers
>that are now history.
>
>>>   view this as a bug, not a feature.
>Actually, the portability of the service may seem very attractive to
>customers, and is one of the SIP potential applications. I could upload my
>preferences to the convenient service when on travel for example, to reduce
>some costs. Also, I could change these preferences when on travel, so as to
>adjust them to my changed needs. Enlightened service providers that allow
>such conveniences may be preferred by customers.
>

Right. The other thing a standardized user profile format would let me do is 
edit services on any  Web browser rather than have to call up the phone company 
and wait for them change my service profile. In New World Telephony,
this empowers the user so that they effectively control their services.
The phone company benefits in that their administrative costs are reduced.
And if the XML DTD for the user profile is made extensible, phone
service providers can add customized features, just like Web pages
have different features.

		jak

>My two cents, Henry
>
>>-----Original Message-----
>>From: Michael Thomas [mailto:[email-masked]]
>>Sent: Monday, May 22, 2000 2:55 PM
>>To: James Kempf
>>Cc: [email-masked]; [email-masked]; [email-masked]
>>Subject: Re: [SIP] Minutes of SIP Security task force in Adelaide
>>
>>
>>James Kempf writes:
>> > >   I don't know what services the roaming network
>> > >   wants to provide -- other than trying to shoehorn
>> > >   themselves into the call. Even if, there is nothing
>> > >   to prevent me from obtaining those service even if
>> > >   it's routed through my home proxy first.
>> > >
>> > 
>> > 
>> > What about having a standardized XML-based user profile description?
>> > That way, the guy that wants to set up a telephony provider in
>> > his garage can have the same access to a description of his
>> > services as anybody else.
>>
>>   I think we have arrived at an impasse since I
>>   view this as a bug, not a feature. A standardized
>>   scheme always locks you to the least common
>>   denominator when you want to remote the
>>   features. That sounds like a shame to me; if I
>>   run it through my home proxy, I can have as
>>   many whacko features as I want to cook up
>>   without having to convince the world that
>>   they're a Good Idea. That way, the market
>>   decides rather than a bunch of standards
>>   weenies (present company excluded, yadda
>>   yadda).
>>
>>		Mike
>>
>>
>>_______________________________________________
>>SIP mailing list
>>[email-masked]
>>http://lists.bell-labs.com/mailman/listinfo/sip
>>
>
>
>_______________________________________________
>SIP mailing list
>[email-masked]
>http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 22 May 2000 22:58:24 -0400

> service providers can add customized features, just like Web pages

There is certainly room for both.

CPL is aimed at exactly this kind of service mobility. Its a well
specified API, safe to execute in third party application servers, and
enables some nice services. However, its very limited. It cannot do many
of the exciting new services I think we will see down the road. These
services require more complex APIs and custom services that probably
won't be portable.

So, users can go to their home servers when they want these more
advanced services, and they can use anyone to provide these vanilla,
portable ones.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: Michael Thomas <[email-masked]>
Date: Tue, 23 May 2000 08:41:55 -0700 (PDT)

> service providers can add customized features, just like Web pages

   If you don't have an XML description of a
   subscriber's record you can't edit it in a web
   browser? Are you suggesting that Sun's and 
   Oracle have been selling web gear for the last
   few years no particular reason at all? :-)

   Seriously, XML descriptions of user data might
   be nice if they are used wisely (cf Jonathan's
   comments), but they don't take the place of 
   graphic design, UI's etc, etc. My point, if it's
   still unclear, is that forcing standardization 
   to be a  _prerequisite_ to deploying service is
   likely to hamstring innovation if multiple 
   service providers need to agree on anything.
   I have no such third party dependencies when
   it's just between me and my service provider.
   It might be nice if and when they got their
   act together, but I don't want to depend on
   that for my cool new features.

	     Mike