Subject: [SIP] Re: "headers" in SIP-URL

From: S_S_Dinesh/India/[email-masked]
Date: Mon, 8 May 2000 14:10:32 +0530

Henning Schulzrinne wrote:
>
> In a redirect, you can play tricks such as adding new headers to the
> next, redirected call. (For example, the redirect server could provide
> the password for another call.) While I doubt that it is used right now,
> it seems like a feature worth having around.

Are these headers copied to the next request - as long as one of the
following
is not specified :
Call-ID, From, To and CSeq, Via ??

Any security issues with this ??

Thanks,
Shail

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: S_S_Dinesh/India/[email-masked]
Date: Mon, 8 May 2000 14:10:24 +0530

Shail Bhatnagar wrote:
>
> A look at the syntax of SIP-URL shows that headers can be defined in a
SIP-URL
> itself. However, the spec also says they MUST NOT be present in From/To
and
> Request-URI. Does it mean they can be present in Contact header (the
addr-spec
> portion of Contact) ??
> I don't see any good reason for headers being allowed inside a SIP-URL
and I
> would be curious to know how many implementations actually introduce it
in
> SIP-URL ( probably the Contact header) and rely on it.

> --
> Best regards,

--
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: "Neville O'reilly" <[email-masked]>
Date: Mon, 8 May 2000 15:06:36 -0400

I believe that's true i.e. most of the extensions (maddr,headers, etc) are
not allowed in the To, From parameters, but can be used in the Contact
parameters 

-----Original Message-----
From: S_S_Dinesh/India/[email-masked]
[mailto:S_S_Dinesh/India/[email-masked]]
Sent: Monday, May 08, 2000 4:40 AM
To: Shail Bhatnagar
Cc: [email-masked]
Subject: [SIP] Re: "headers" in SIP-URL

SIP-URL
and
addr-spec
and I
in