Subject: [SIP] Re: Why must a stateless proxy insert a Via header for itself.

From: S_S_Dinesh/India/[email-masked]
Date: Mon, 8 May 2000 14:10:34 +0530

Anoop,

Just call your proxy a firewall, and then you don't have to.
Though, be advised that the next downstream UAS will add a 'received'
parameter to the topmost 'via' so you will see all subsequent responses
to this request.

regards,
david

>
> Currently, the RFC states that every server in the path of a request must
add
> itself as a Via header.
>
> As a stateless proxy, if this restriction is removed then I can process
more
> calls with faster call setup times.
>
> So , can we make inserting itself as a Via optional for a stateless
proxy.
> Thanks,
> Anoop

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: S_S_Dinesh/India/[email-masked]
Date: Mon, 8 May 2000 14:10:23 +0530

Max-Forwards could be used to detect infinite loops.

Alternatively, what if we implement another header called "ResponsePath" .
 If a proxy wants to be in the path of the response it will include itself
there
 ( On the same lines of Route header which are used for being in path of
future
transactions).
The Via header could be used for loop detection.

Thanks,

Anoop

Shail Bhatnagar <[email-masked]> on 03/17/2000 11:48:17 AM

Sent by:  Shail Bhatnagar <[email-masked]>

To:   Anoop Tripathi/MW/US/3Com
cc:   [email-masked]
Subject:  Re: Why must a stateless proxy insert a Via header for itself.

add
more
proxy.
> Anoop

Then how do you do loop detection ??

--
Best regards,
Shail

---

From: S_S_Dinesh/India/[email-masked]
Date: Mon, 8 May 2000 14:10:14 +0530

add
more
proxy.

--
Best regards,
Shail

---

From: S_S_Dinesh/India/[email-masked]
Date: Mon, 8 May 2000 14:10:14 +0530

add
more
proxy.

--
Best regards,
Shail