Subject: [SIP] Information

From: "raf" <[email-masked]>
Date: Mon, 5 Jun 2000 12:56:22 +0200

Hi, I need of a clarification about SIP. I don`t know if these addresses are the right places!!!
I am developing a NAT module properly for SIP. I have two scenarios: the first with a SIP Client
behind the NAT router (In a private realm), the second with a SIP Client and a SIP SERVER behind
a NAT router both. My NAT Module is listening on port 5060 UDP and it works when a UDP packet port 
5060 flows throgh the NAT router. This module works well when it is crossed by an Invite directly produced by
a SIP Client. Viceversa it doesn`t work when it is crossed by an Invite produced by a SIP Server. The two Invites are different
in the context: In SDP and in some fileds like VIA!!! 
Are there other differences ???? 
My module works only on the UDP header
and in the case of port 5060 processing SDP and change prvate addresses!!!
Thans a lot,
    Raffaele Pellicciotta

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 05 Jun 2000 12:34:43 -0400

> raf wrote:
> 5060 flows throgh the NAT router. This module works well when it is
> crossed by an Invite directly produced by
> a SIP Client. Viceversa it doesn`t work when it is crossed by an
> Invite produced by a SIP Server. The two Invites are different

The SDP should be the same unless the server has rewritten it for NAT
traversal. 

For info on how to do NAT with SIP, see:
http://search.ietf.org/internet-drafts/draft-rosenberg-sip-firewalls-00.txt
http://search.ietf.org/internet-drafts/draft-biggs-sip-nat-00.txt

-JOnathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip