Subject: Re: [SIP] Feature Processing Draft?

From: James Kempf <[email-masked]>
Date: Sun, 25 Jun 2000 19:47:52 -0700

For example, suppose the SIP proxy server gets an INVITE from a client that's a prepaid
cellular caller, and the company that sold the service is not the operator.
The operator's SIP proxy would like to pass authorization and accounting
(and potentially handling the call itself) to the third party server.

This *particular* example involves authorization and accounting, but one could imagine other
such features that do not involve them but are actually implemented by
a third party. 

I'm familiar with OPTIONS, which seems to be a way for the SIP server itself
to advertise that it supports particular features. Is SIP the proper way for
the SIP server to communicate with a server implementing the actual options
themselves or would that be some other protocol?

			jak

>Can you explain what you mean by "feature processing"? That's not really
>a SIP term...
>
>James Kempf wrote:
>> 
>> Can anybody point me at a draft that discusses call feature processing in
>SIP?
>> In particular, I'm interested in anything that separates feature
>> processing from initial connection management. Thanx.
>> 
>>                 jak
>> 
>> _______________________________________________
>> SIP mailing list
>> [email-masked]
>> http://lists.bell-labs.com/mailman/listinfo/sip
>
>

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Sun, 25 Jun 2000 22:57:29 -0400

Rather than repackaging SIP requests into another protocol (since
probably almost information in the request might be useful for some
service or another), it would seem easiest if the SIP proxy server
simply proxies the request to the server that has the necessary
information. Elsewhere, one might to need to worry about sending
signaling around, but this seems easiest in the SIP case. Clearly, for
some specialized applications, such as QoS and AAA, the mechanisms
described in draft-sinnreich-sip-qos-osp might be useful.