Subject: RE: [SIP] Distinctive ringing feature

From: "Maddux, Michel" <[email-masked]>
Date: Thu, 8 Jun 2000 16:20:34 -0500

Greetings:

It occurs to me that this is an exmple of the ability of the called party to
establish a personal filter based upon multiple characteristics; e.g. From:
list (preference to girlfriend/wife/mother) etc... Alarm tone for inbound
solicitors.  Isn't
this up to the endpoint to supply multiple ring capability?  Obvious fun
with .wav files include mooing from certain callers,
even up to a personalized voice announcment ("Hi honey, it's me.  Please
pick up.")  Sort of changes the whole distinctive ringing concept.  

Is there any problem with this sort of concept?  thanks. /m.

> -----Original Message-----
> From:	Henry Sinnreich [SMTP:[email-masked]]
> Sent:	Thursday, June 08, 2000 2:55 PM
> To:	[email-masked]; Sekhar Banerjee
> Cc:	[email-masked]
> Subject:	RE: [SIP] Distinctive ringing feature
> 
> Could distinctive ringing be a caller/called preference?
> 
> Thanks, Henry
> 
> >-----Original Message-----
> >From: [email-masked]
> >[mailto:[email-masked]]On Behalf Of 
> >[email-masked]
> >Sent: Wednesday, June 07, 2000 11:36 PM
> >To: Sekhar Banerjee
> >Cc: [email-masked]'
> >Subject: Re: [SIP] Distinctive ringing feature
> >
> >
> >
> >
> >Hi,
> >you can definetely implement distinctive ringing from 
> >a SIP endpoint.
> >The distinctive ring implementation is purely an 
> >endpoint side feature (see
> >SIP FAQ on Henning's site)
> >and does not need any special SIP signalling.
> >For example, if say your phone has two alloted phone 
> >numbers - and you want
> >a different ringing tone depending
> >on the number the caller dialed - your implementation 
> >would simply see the
> >phone number from the SIP headers
> >and generate the appropriate ring for that phone.
> >
> >
> >Regds
> >Arjun
> >--
> >Arjun Roychowdhury @ Hughes Software Systems
> >
> >
> >
> >
> >
> >
> >Sekhar Banerjee <[email-masked]> on 06/08/2000 
> >02:52:13 AM
> >
> >To:   "[email-masked]'" <[email-masked]>
> >cc:
> >
> >Subject:  [SIP] Distinctive ringing feature
> >
> >
> >
> >
> >Hi,
> >     I would like to know if it would be possible to 
> >use SIP to instruct
> >the endpoints/UA's to provide different ringing 
> >sequences. If someone has
> >implemented this feature I would love to know more 
> >about it. I am talking
> >about the distinctive ringing feature as it is present 
> >in the PSTN network
> >today.
> >
> >Thanks
> >
> >Sekhar
> >
> >
> >_______________________________________________
> >SIP mailing list
> >[email-masked]
> >http://lists.bell-labs.com/mailman/listinfo/sip
> >
> >
> >
> >
> >
> >
> >_______________________________________________
> >SIP mailing list
> >[email-masked]
> >http://lists.bell-labs.com/mailman/listinfo/sip
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 08 Jun 2000 17:28:41 -0400

> Is there any problem with this sort of concept?  thanks. /m.

No problem at all. Thats what people have been saying by "its a matter
of local implementation." What you describe is the approach supported in
the SIP model.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: Henry Sinnreich <[email-masked]>
Date: Thu, 08 Jun 2000 16:36:10 -0500

>>Is there any problem with this sort of concept?  thanks. /m.

Thought the same , but wanted some confirmation.

Thanks, Henry

>From: Maddux, Michel [mailto:[email-masked]]
>Sent: Thursday, June 08, 2000 4:21 PM
>To: 'Henry Sinnreich'; [email-masked]; Sekhar Banerjee

---

From: Henry Sinnreich <[email-masked]>
Date: Thu, 08 Jun 2000 16:41:37 -0500

http://www.infoworld.com/articles/hn/xml/00/06/06/000606hnworldc
om.xml

Enjoy!

Henry