Subject: Re: [SIP] Announcement of SIP Forum

From: Sean Olson <[email-masked]>
Date: Fri, 23 Jun 2000 11:12:10 -0500 (CDT)

Dave Walker wrote:
> Well, I don't know about the WAP Forum, but I would think that
> a certification program should certainly be open to non-members
> if it's run by a forum that charges for membership.  I'd be
> surprised if a certification program could be run without 
> costs that have to be covered somehow (volunteer organizations
> aren't too reliable in the long term).  

Oops. I think you have a typo in there. There a number of volunteer
organizations in the OpenSource community that have been very 
reliable, even in the long term. I do agree, however, that it is
reasonable for an organization to charge a reasonable fee for
certification (provided that don't make a business out of it)

> And remember, the reason
> people will want such a certification for their products is to
> make money.  And it takes money to make money.  (or it used to!)
>

Many of the best implementations of IETF protocols were not done
for profit and were done with little or no commercial support.
Is there a reason for discouraging research or non-profit implementations?
 
> I also note that SIP Forum indicates that it will be charging
> a fee to organizations (didn't see how much), and while it's
> free to individuals, it is typically organizations that have 
> more of a motivation for acquiring certification.
>
True.

my two cents
sean

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Neil Deason <[email-masked]>
Date: Fri, 23 Jun 2000 17:56:48 +0100

Sean Olson wrote:
> reliable, even in the long term. 

Indeed - the IETF is made up of volunteers.

> I do agree, however, that it is

Yes, this wasn't my major concern. That is that any 
closed organisation (a membership oriented 
group is by definition closed to non-members, be 
it because they can't afford the fees or even the 
governing body reserves the right to deny membership 
to them) might be able to decide what is certified 
as being the standard for an open protocol, such as SIP.

Cheers,
Neil.
-- 
Ubiquity Software Corporation, UK          
http://www.ubiquity.net

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 23 Jun 2000 19:50:50 -0400

While this is getting into hypotheticals (it is unlikely, say, that the
SIP Forum would deny membership to any semi-reasonable candidate, as the
likely "stink" generated is going to be far in excess of whatever damage
the membership could conceivably cause), one low-cost model might be to
provide a generally agreed upon set of call flows and sample messages,
similar to the torture tests and call flows in the existing I-D, that
makes the test open to community inspection and allows
self-certification. Since this is not a health-and-safety issue,
self-"certification" is less of a risk. I doubt that any company would
want to be caught claiming "we 'passed' the set of message flows" if
that was not the truth.