Subject: [SIP] Proxy-Supported header

From: [email-masked]
Date: Wed, 7 Jun 2000 14:07:12 +0300

Hi,

It seems that currently there is no mechanism to inform other parties (e.g.
other proxies) about the supported proxy capabilities.
This is needed especially in REGISTER messages but useful also in INVITEs as
well.

Currently there exists (proposed) Supported header in SIP, but I suppose it
is meant for terminal capabilities only. 
It is impossible to advertize both terminal and proxy capabilities at the
same time in one INVITE/REGISTER message.

Therefore, I'd like to propose "Proxy-Supported" header to be included into
RFC2543bis draft.
The syntax is identical to Supported header.

Comments?

--
Petri Koskelainen
Nokia Research Center

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Romeo Zwart <[email-masked]>
Date: Wed, 07 Jun 2000 17:32:30 +0200

Hi Petri,

At 02:07 PM 07-06-00 +0300, [email-masked] wrote:
 > This is needed especially in REGISTER messages but useful also in INVITEs
 > as well.

I agree with you that there is a need for a mechanism to exchange
capability info between proxies, in addition to capabilities exchange
between UA (C and S).

 > Currently there exists (proposed) Supported header in SIP, but I suppose
 > it is meant for terminal capabilities only.

According to 2543bis:
"The Supported general header field enumerates all the capabilities
of the client or server".

This text ("server") does not seem to exclude using Supported by
proxies, however, you are right that you run into problems with
expressing both UA and server capabilities in the same (forwarded)
message. Therefore Proxy-Supported seems to make sense.

 > Therefore, I'd like to propose "Proxy-Supported" header to be included
 > into RFC2543bis draft.

The same argumentation applies to a Proxy-Unsupported header
as well. If we need Proxy-Supported, do we also need
Proxy-Unsupported?

Romeo