Subject: RE: [SIP] Via discrepancy in latest 2543bis draft.

From: Sean Olson <[email-masked]>
Date: Mon, 5 Jun 2000 13:56:16 -0500 (CDT)

> 
> Wait up ... quick back pedal ... now I'm not so sure. As written in Section
> 6.45.4 it does suggest that you would use the source port over the Via port
> (as the "sent-by" includes the port part) but is this the best thing to do ?
> We know this Via scheme won't work for a NAPT (without a SIP proxy sitting
> on the firewall as well) so perhaps we should be using the port in the Via.
> This at least allows SIP user-agent spawning to function normally across a
> NAT.
> 
> Anyway, there is definitely a need for clarification here.
> Cheers,
> 
> Robert. 
>

Definitely confusing. Since 6.45.4 references 6.45.2 which describes the receiver-tagged
Via:, I would assume that you would use the source IP address, BUT, use the port
specified in the sent-by, since this is basically the behaviour specified for proxies
that receive a request from a different address than the top-most Via: specifies.

sean
--
Sean Olson <[email-masked]>
 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 05 Jun 2000 17:29:09 -0400

> that receive a request from a different address than the top-most Via: specifies.

Correct. The response is sent to the IP address the request came from,
and the port in the Via header. We will clean up to make this
consistent.

Thanks,
Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com