Subject: Re: [SIP] CPL

From: Sean Olson <[email-masked]>
Date: Thu, 1 Jun 2000 08:27:22 -0500 (CDT)

> 
> Hi,
> 
> I was wondering if the CPL allows dynamic creation of services, or is
> that capability not part of the CPL's functionality ?
> 
> Thanks.
> 
> -M
> 

CPL is best thought of as a wire representation of service logic. It is probable
that most servers will "compile" CPL into a more appropriate internal format for
executing and storing. So to answer your question, I expect that there will be
demand for service creation environments that you can use to build services 
(even dynamically) and one possible output format will be CPL. For example, it
would be trivial to use CGI/ASP to dynamically generate CPL in response to an
HTTP request to retrieve the service logic for a particular user. The utility of
doing so is another question altogether ;)

my two cents
sean

--
Sean Olson <[email-masked]>

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Michael Thomas <[email-masked]>
Date: Thu, 1 Jun 2000 06:40:24 -0700 (PDT)

> doing so is another question altogether ;)

   I'm going to show my complete ignorance here,
   but doesn't this beg the "sandbox" question?

   Related: how is authorization accomplished?

	    Mike