Subject: RE: [SIP] SIP URL telephone-subscriber syntax.

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Tue, 20 Jun 2000 03:34:15 -0700

Argh. Sorry everyone for filling up your Inbox's.

I also noticed it inserted a space into the URL. There weren't meant to be
any spaces.
 
sip:0w003585551234567;phone-context=[email-masked];user=phone
 
Cheers,
 
Robert.

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Gethin Liddell <[email-masked]>
Date: Tue, 20 Jun 2000 12:03:15 +0100

On Tue, 20 Jun 2000, Robert wrote:
> RFC2543bis now states that the user part may be a "telephone-subscriber" as
> defined in RFC2806 ( http://www.ietf.org/rfc/rfc2806.txt
> <http://www.ietf.org/rfc/rfc2806.txt> ). And that this is not discernable by
> BNF (hence the user=phone parameter).
>  
> So is the following a valid SIP URL:
>  

as i understand it this is not legal.  there is a semi-colon
in the user part.  i think that all characters that appear in the
userinfo section have to belong to the character set defined by user

therefore the ; character needs to be escaped as follows:

sip:0w003585551234567%3bphone-context=[email-masked];user=phone

when this is parsed, the %3b should be unescaped back to ; to obtain
the correct meaning.

the bis does not make this clear in section 2 in the bnf.  perhaps some
explanatory text of the semantics of the bis is required within the
explanation of telephone-subscriber to the effect of.

"Any characters of the telephone-subscriber that do not exist in the
character set of `user' MUST be escaped."

HTH

gethin

-- 
Gethin Liddell
Ubiquity Software Corporation

http://www.ubiquity.net
mailto:[email-masked]