Subject: Re: [SIP] Distinctive ringing feature

From: [email-masked]
Date: Thu, 8 Jun 2000 10:05:33 +0530

Hi,
you can definetely implement distinctive ringing from a SIP endpoint.
The distinctive ring implementation is purely an endpoint side feature (see
SIP FAQ on Henning's site)
and does not need any special SIP signalling.
For example, if say your phone has two alloted phone numbers - and you want
a different ringing tone depending
on the number the caller dialed - your implementation would simply see the
phone number from the SIP headers
and generate the appropriate ring for that phone.

Regds
Arjun
--
Arjun Roychowdhury @ Hughes Software Systems

Sekhar Banerjee <[email-masked]> on 06/08/2000 02:52:13 AM

To:   "[email-masked]'" <[email-masked]>
cc:

Subject:  [SIP] Distinctive ringing feature

Hi,
     I would like to know if it would be possible to use SIP to instruct
the endpoints/UA's to provide different ringing sequences. If someone has
implemented this feature I would love to know more about it. I am talking
about the distinctive ringing feature as it is present in the PSTN network
today.

Thanks

Sekhar

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henry Sinnreich <[email-masked]>
Date: Thu, 08 Jun 2000 15:55:28 -0500

Could distinctive ringing be a caller/called preference?

Thanks, Henry

>-----Original Message-----
>From: [email-masked]
>[mailto:[email-masked]]On Behalf Of 
>[email-masked]
>Sent: Wednesday, June 07, 2000 11:36 PM
>To: Sekhar Banerjee
>Cc: [email-masked]'
>Subject: Re: [SIP] Distinctive ringing feature
>
>
>
>
>Hi,