Subject: RE: AW: [SIP] SIP Application Server

From: "Farahmand, Fardad" <[email-masked]>
Date: Tue, 6 Jun 2000 14:57:14 -0400

Good question. The best example can be found in draft-rosenberg-sip-3pcc-00.
The draft proposes a scenario in which a "controller" initiates both legs of
a call in a third party call control model.  The controller can be an
Application Server initiating both legs of a call (either directly as in the
3pcc draft or through the SoftSwitch as in the ISC model). This brings up
another question.

Jonathan,

It seems that the 3pcc draft uses a mechanism which does not require any
extensions to rfc 2543. So is the "controller" in this draft a special case
of one (or more) of the existing clients and servers?  Or is the controller
a form of a server that needs to be specifically identified in the rfc?

Thanks,
Fardad Farahmand
[email-masked]

> -----Original Message-----
> From: Vijay K. Gurbani [mailto:[email-masked]]
> Sent: Tuesday, June 06, 2000 10:25 AM
> To: Jonathan Rosenberg
> Cc: Postmann Erwin; [email-masked]
> Subject: Re: AW: [SIP] SIP Application Server
> 
> 
> Jonathan Rosenberg wrote:
> > 
> > Postmann Erwin wrote:
> > >
> > > I have followed the discussion on the SIP application server with 
> > > big interest. My understanding of the application server 
> is that it 
> > > is a more complex SIP proxy, redirect server or user agent which 
> > > provides applications and services to the users.
> > > Is my understanding right?
> > 
> > Yes.
> 
> I have followed this thread with some interest as well.  
> However, IMHO,
> we need to delineate an application server from a proxy 
> server clearly.
> There are functions an application server can do that a proxy 
> MUST not.
> One case I can think of is that of third party call control 
> where some 
> network entity, based on some application logic, 
> asynchronously creates 
> both legs of a call.  Clearly, a proxy MUST not do this since a proxy
> MUST not create INVITE requests on its own. 
> 
> Regards,
> 
> - vijay
> -- 
> Vijay K. Gurbani  [email-masked] [email-masked] 
> [email-masked]
> IN Architecture and Internet Software Group
> Lucent Technologies/Bell Labs Innovations, 263 Shuman Blvd, Rm 1A-418
> Naperville, Illinois 60566  Voice: +1 630 224 0216 Fax: +1 
> 630 713 0184
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 06 Jun 2000 19:19:45 -0400

> a form of a server that needs to be specifically identified in the rfc?

The controller is a UAC, actually. It requires no extensions at all.

People seem to get caught up in whether a box is a proxy or a redirect
or a UA or whatever. These are logical roles. If a box does something
which defines it as a proxy, then its a proxy. If it does something
which is characteristic of a UA (like initiating its own requests), its
a UA.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 06 Jun 2000 18:57:46 -0700

> which is characteristic of a UA (like initiating its own requests), its

It seems that I am not the only one that have to explain that a SIP
proxy is not necessary a box to add on the network but some simple rules
that can be added to an implementation to gain this logical role.
Perhaps it will be a good thing to add some explanations about this in
the SIP draft?

Regards,

-- 
Marc Petit-Huguenin
Home: mailto:[email-masked]
Work: mailto:[email-masked]
"Everything I love is either immoral, illegal or makes you fat"

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 07 Jun 2000 08:26:31 -0400

> Perhaps it will be a good thing to add some explanations about this in

If you look at the June 5th edition of the 2543bis draft, you'll see
that the definition now includes wording about per-request behavior.
This is also explained in the SIP FAQ.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs