Subject: [SIP] PGP Authentication Scheme - REPOST

From: Phil Hoffer <[email-masked]>
Date: Fri, 23 Jun 2000 13:38:07 +0100

Hi,

Section 15.1.1 of the rfc2543bis draft is missing information, and a BNF entry with respect to pgp-pubalgolrithm.

Presumably, pgp-pubalgolrithm should be included in the BNF for pgp-params in section 15.1.1

Also some text about the parameter is required, e.g. what is the default value of pgp-pubalgolrithm if it is omitted from WWW-Authenticate header.
Is it assumed to be RSA?

Hope that helps
Regards
--
Phil Hoffer                         Ubiquity Software Corporation
Software Developer                  Ubiquity House
Tel: +44 (0) 1633-765600            Langstone Park
Fax: +44 (0) 1633-765601            Newport   NP18 2LH
URL: http://www.ubiquity.net
mailto:[email-masked]

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 26 Jun 2000 14:43:37 -0400

> Presumably, pgp-pubalgolrithm should be included in the BNF for pgp-params in section 15.1.1

Yes, I believe it should.

> Also some text about the parameter is required, e.g. what is the default value of pgp-pubalgolrithm if it is omitted from WWW-Authenticate header.

I presume... I guess it depends on what the default is for PGP in
general, if there is a default...?

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com