Subject: [SIP] H323 Fast Connect to SIP interworking

From: "Alexander Agranov" <[email-masked]>
Date: Fri, 23 Jun 2000 11:21:02 +0200

Session 5.2.1 in draft-singh-sip-h323-01, that describes interworking
of H323 Fast Connect with SIP says that there is "one-to-one mapping
between H.323 and SIP call establishment messages".

Nevertheless let's have a look at the scenario when H.323 Fast Start
message contains set of more than one alternative channels:

H.323 terminal                GW                         SIP UA
128.59.21.152                                         128.59.19.194
|                             |                            |
|            SETUP            |                            |
|---------------------------->|                            |
| destination:[email-masked]                          |
| fastStart={g711Ulaw,Tx},    |                            |
|  {{g711Ulaw,Rx,128.59.21.152:10000},                     |
|   {g711Alaw,Rx,128.59.21.152:10000}}                     |
|                             |                            |
|                             |          INVITE            |
|                             |===========================>|
|                             | To:[email-masked]     |
|                             | c=IN IP4 128.59.21.152     |
|                             | m=audio 10000 RTP/AVP 0 8  |
|                             |                            |
|                             |          200 OK            |
|                             |<===========================|
|                             | c=IN IP4 128.59.19.194     |
|                             | m=audio 8000 RTP/AVP 0 8   |
                           ????????

In this case (according to 8.1.1) IWF should generate INVITE
SIP request with SDP that contains multiple payloads.

Now it's my understanding of RFC2543 that SIP UA may respond
to such INVITE with "200 OK" that also contains SDP with
multiple payloads.

But we can't acknowledge both FastConnect alternative channels,
can we? 

So GW will need to acknowledge only one of the channels and 
issue reINVITE to SIP UA (like in H323v1), right?

This situation is applicable even when FastConnect contains
only one channel, since RFC2543 states that "200 OK" message's
"list of codecs may or may not be a subset of" INVITE message
codecs.

Please correct me if I'm wrong.

Best regards,
                Alex Agranov
---
ComGates Ltd.
Tel: +972 (9) 9500-404, Ext: 228
Mobile: +972 (54) 928435
Fax: +972 (9) 9500-385
E-mail: [email-masked]

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Kundan Singh <[email-masked]>
Date: Fri, 23 Jun 2000 10:25:33 -0400 (EDT)

One method is to send the updated SDP in ACK to SIP UA.

After receiving the 200 OK from SIP UA, the IWF
recalculates the capability sets and operating modes in
both directions and sends ACK to SIP UA.

IWF may send a reINVITE to SIP UA to inform about the 
updated modes, instead of changing the session description in ACK.

As far as call establishment is concerned, there can be
a one-to-one mapping between SIP and H.323 messages with fast
connect (in simple case).

Regards

Kundan

> ------------------------------------------------------------------------
> Act NOW before June 30 to win $5,000!
> Start grading businesses in your area to win.
> http://click.egroups.com/1/5524/7/_/302437/_/961748376/
> ------------------------------------------------------------------------
> 
> To Post a message, send it to:   [email-masked]
> 
> To Unsubscribe, send a blank message to: [email-masked]
> 
>