Subject: RE: [SIP] Distinctive ringing feature

From: [email-masked]
Date: Fri, 9 Jun 2000 09:53:57 +0530

why not ? :-)

lots of interesting things can be put in.

Since this is totally a client side implemenation that does not affect the
SIP signalling in any way,
we also did some cute(?!?) things like the ring volume being dynamically
modulated as duration of ring increases etc (you know,
like those alarms clocks that start with a whisper and keep screaming
louder and louder (till a point) till you hit on the button....

On the lighter side - here's some rings my limited imagination brings up:

Girl/BoyFriend Ring - sweet chimes (or doomsday bongs - depending on what
state you are with her/him)
Beer pal ring - hic..hic...ring.ring...hic..hic
Boss Ring - no ring :-p
Wife Ring - continuous monotonic ring :-))
etc......

Oh well :-) Back to work - I enjoyed keying in this mail :-p

Regds
Arjun

--
Arjun Roychowdhury @ Hughes Software Systems
Technical Leader, VOIP Solutions
Off: Prestige Opal,146 Infantry Road,Blore - 560001  Ph:+91-080-2286390/1/2
Res: 68/G 2nd Narayanappa Block, RT Nagar,Blore - 560032  Ph:3430565
http://arjun.cjb.net

Henry Sinnreich <[email-masked]> on 06/09/2000 02:25:28 AM

To:   archow, Sekhar Banerjee <[email-masked]>
cc:   [email-masked]

Subject:  RE: [SIP] Distinctive ringing feature

Could distinctive ringing be a caller/called preference?

Thanks, Henry

>-----Original Message-----
>From: [email-masked]
>[mailto:[email-masked]]On Behalf Of
>[email-masked]
>Sent: Wednesday, June 07, 2000 11:36 PM
>To: Sekhar Banerjee
>Cc: [email-masked]'
>Subject: Re: [SIP] Distinctive ringing feature
>
>
>
>
>Hi,
>you can definetely implement distinctive ringing from
>a SIP endpoint.
>The distinctive ring implementation is purely an
>endpoint side feature (see
>SIP FAQ on Henning's site)
>and does not need any special SIP signalling.
>For example, if say your phone has two alloted phone
>numbers - and you want
>a different ringing tone depending
>on the number the caller dialed - your implementation
>would simply see the
>phone number from the SIP headers
>and generate the appropriate ring for that phone.
>
>
>Regds
>Arjun
>--
>Arjun Roychowdhury @ Hughes Software Systems
>
>
>
>
>
>
>Sekhar Banerjee <[email-masked]> on 06/08/2000
>02:52:13 AM
>
>To:   "[email-masked]'" <[email-masked]>
>cc:
>
>Subject:  [SIP] Distinctive ringing feature
>
>
>
>
>Hi,
>     I would like to know if it would be possible to
>use SIP to instruct
>the endpoints/UA's to provide different ringing
>sequences. If someone has
>implemented this feature I would love to know more
>about it. I am talking
>about the distinctive ringing feature as it is present
>in the PSTN network
>today.
>
>Thanks
>
>Sekhar
>
>
>_______________________________________________
>SIP mailing list
>[email-masked]
>http://lists.bell-labs.com/mailman/listinfo/sip
>
>
>
>
>
>
>_______________________________________________
>SIP mailing list
>[email-masked]
>http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jay Batson <[email-masked]>
Date: Mon, 12 Jun 2000 18:23:37 -0400

<trying to avoid shameless self promotion>

For those who are titillated by such behaviors as this, there's a 
SIP/Ethernet/Java phone that'll be available in the marketplace "real soon" 
to which this behavior can be added via a Java applet created by you or 
your favorite Java developer and which runs directly on the phone.

We've created ring files with a bunch of old Hanna  Barbera cartoon sound 
effects, like the Jetson's telephone ring sound, Fred Flintstone's 
bongo-feet-runaway, etc.  They do catch your attention better than an old 
fashioned ring.

Do our venture capitalists think it'll be the killer app?  Nahh-- they're 
too boring.  Now do *we* think it'll be cool?   What do you think...?  ;-)

</trying to avoid shameless self promotion>

<shameless self promotion>

Go see http://www.pingtel.com for more info.

<shamless self promotion>

-jb

>Oh well :-) Back to work - I enjoyed keying in this mail :-p

PingMe!
Jay Batson
President, CEO
Pingtel Corp.
[email-masked]

781-938-5306 (office)
781-938-9650 (fax)