Subject: RE: [SIP] SIP->XML->SOAP

From: "Gardell, Steve" <[email-masked]>
Date: Mon, 3 Jul 2000 11:27:31 -0400

I apologize for the double posting. Read
"MGC" rather than "MG". What I get for 
going on vacation...

> -----Original Message-----
> From: Gardell, Steve 
> Sent: Monday, July 03, 2000 7:07 AM
> To: 'Matt Holdrege'; Henry Sinnreich
> Cc: [email-masked]
> Subject: RE: [SIP] SIP->XML->SOAP
> 
> 
> I have been on vacation, so appologies for the
> belated response. After struggling to explain
> "softswitches" to operations folks here, we 
> settled on a very general definition that could
> be taken to include MG's, SIP Proxy Servers,
> H.323 routed GK's as well as the more switch-like
> constructs being defined by the Multi-Media
> Switching Forum. However, as near as we can tell, 
> today "softswitch" is a marketing term most 
> closely associated with the IETF MG.
> 
> What definition is implicit in the "value" commentary
> here? 
> 
> Steven Gardell
> GTE Laboratories
> Voice: 781-466-2681, Fax: 781-466-3375
> 
> 
> > -----Original Message-----
> > From: Matt Holdrege [mailto:[email-masked]]
> > Sent: Wednesday, June 21, 2000 4:32 PM
> > To: Henry Sinnreich
> > Cc: [email-masked]
> > Subject: RE: [SIP] SIP->XML->SOAP
> > 
> > 
> > At 07:09 AM 6/18/00 -0500, Henry Sinnreich wrote:
> > > >> SIP->XML would converge the SIP methods and required
> > > >parameters to XML and
> > > >> allows the introduction of a DTD or schema to define
> > > >the syntax of a valid
> > > >> SIP message.
> > >
> > >Do not forget that endangering the deployment of SIP as is,
> > >would set IP telephony back for a generation and leave the field
> > >for "softswitches" and other such nonsense. Nobody on this
> > >mailing list would then live to see true/open Internet
> > >communications, but just the old circuit switch central control
> > >model with its terrible signaling. Just using IP as a cheap
> > >wire.
> > 
> > Henry,
> > 
> > This is the first time I recall seeing "softswitches" being 
> > denigrated on 
> > an IETF list. I would hope you realize that they are an 
> > enabler to get the 
> > circuit switched world to migrate to open communications? 
> Saying that 
> > Softswitches will preserve the circuit switched world with 
> > it's "terrible 
> > signalling" is a bit short-sighted.
> > 
> > You should also realize that SIP is doing quite well in the 
> > area of market 
> > acceptance. The more people buy into SIP the more evolution will be 
> > required. Change is inevitable even though we must try to 
> > manage it well. 
> > XML is one such change that seems (to me) to be inevitable. 
> > So it would be 
> > better to try and manage the interactions with SIP and XML 
> > here in the IETF 
> > rather than elsewhere. Besides, it's part of the openess that 
> > we all should 
> > encourage.
> > 
> > 
> > 
> > _______________________________________________
> > SIP mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/sip
> > 
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Neil Deason <[email-masked]>
Date: Mon, 03 Jul 2000 17:07:30 +0100

Check out:

http://www.computertelephony.com/article/CTM20000608S0021

As Henry explains in more detail here where a 'Softswitch' 
is used to preserve the signaling and control architecture 
of SS7 and the Intelligent Network the vendor who implements 
the Softswitch owns control over services. This reinvents 
the failings of the IN/PSTN whereas SIP seeks to build new 
services and empower service creation by end users.

Cheers,
Neil
-- 
Ubiquity Software Corporation, UK          
http://www.ubiquity.net

-- 
Ubiquity Software Corporation, UK          
http://www.ubiquity.net

---

From: Henry Sinnreich <[email-masked]>
Date: Wed, 05 Jul 2000 01:48:20 -0500

Neil writes:
> to build new

Yes, another angle is to empower service providers to use 3rd
party applications from the ASP world, reselling and
outsourcing. This is only possible in the open Internet
environment. A proprietary call agent will lock the service
provider to one single vendor. But maybe that's what is intended
in the first place :-)

Henry

>From: Neil Deason [mailto:[email-masked]]
>Sent: Monday, July 03, 2000 11:08 AM
>To: Gardell, Steve
>Cc: 'Henry Sinnreich'; [email-masked]'
>Subject: Softswitches (was Re: [SIP] SIP->XML->SOAP)
>
>
>Check out:
>