Subject: RE: [SIP] SIP URL telephone-subscriber syntax.

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Sun, 2 Jul 2000 08:57:12 -0700

Thankfully semicolons are not allowed in private prefixes. I believe the
only place a ';' is allowed in is the quoted string in the future-extension
parameter value. This should mean that the purpose of the two are
discernable, correct ?

[Henning, in your example you wrote %3bContext1%40Context2%22 and inferred
that this referred to ";Context1@Context2". Did you really mean that the
context is ";Context1@Context2\"" or is the escaped string incorrect?]

Cheers,

Robert.

> 
> I don't think you want recursive escaping if you can help it, as it
> becomes difficult to make sure the right number of 
> translations happen.
> Thus, the % should not be escaped, in my opinion. This is already
> implied in the BNF syntax for the 'user' part. However, the semicolon
> appears to be in the "needs to be escaped" category, which is 
> annoying,
> since it is a syntactically important character. Escaping 
> should only be
> used for characters that are opaque to the parsing of the URL, such as
> parameter values. Thus, in the slightly modified example from above,
> 
> sip:+12345;phone-context=[email-masked]
> ;user=phone
> 
> would really have to be written as 
> 
> sip:+12345%3bphone-context=[email-masked]
> om;user=phone
> 
> which is rather confusing since the two %3b's mean very 
> different things
> - the first is needed to understand the tel URL, the second is just a
> random character in a "context" parameter value 
> (";Context1@Context2").
> 
> There seem to be only two solutions:
> 
> - allow ; parameters in the user part. This probably works, 
> although it
> means that a parser won't know whether this is a user parameter or
> generic parameter in a @-less URL until the end. It's 
> probably too late
> to require a '@' in all URLs, even if the user part is empty.
> 
> - double-escaping rules; seems to me a recipe for perpetual confusion
> and unlikely to be implemented correctly. Basically, URLs should be
> split along delimiters and then un-escaped for each part. That's it.
> 
> -- 
> Henning Schulzrinne   http://www.cs.columbia.edu/~hgs
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Sun, 02 Jul 2000 12:01:02 -0400

> parameter value. This should mean that the purpose of the two are

; are used all over in the tel URL to delineate parameters, so I'm not
sure I understand your point here.

> context is ";Context1@Context2\"" or is the escaped string incorrect?]

Yes, this is a valid, if somewhat unlikely, context name.