Subject: [SIP] Tunneling with SIP

From: "Fox, Mike" <[email-masked]>
Date: Wed, 12 Jul 2000 11:22:09 -0700

'A la SIP static images, is a URL like:

Soap-Server: <http://www.yoursoapserver.net/soapservices>

enough for a SOAP enabled SIP element to find a SOAP server? What happens
next is another problem (one of product differentiation rather than SIP
specification). If you like, or need security, use HTTPS and/or other
security inside SOAP.

Best regards,
Mike Fox

> -----Original Message-----
> From: James Undery [mailto:[email-masked]]
> Sent: Wednesday, July 12, 2000 1:01 AM
> To: Jonathan Rosenberg
> Cc: Fox, Mike; [email-masked]
> Subject: Re: [SIP] Re: Tunneling with SIP
> 
> 
> 
> 
> Jonathan Rosenberg wrote:
> 
> > "Fox, Mike" wrote:
> > >
> > > Jonathan Rosenberg wrote:
> > > > I would not advocate tunneling DHCP over SIP, HTTP over SIP,
> > > > or SLP over
> > > > SIP, since those protocols
> > > > don't do the same thing SIP does. Same with megaco/mgcp.
> > > > Tunneling them
> > > > over SIP serves no purpose. SIP is not a good transfer
> > > > protocol (see the
> > > > Guidelines for Authors of SIP Extensions:
> > > > http://search.ietf.org/internet-drafts/draft-rosenberg-sip-gui
> > > >delines-00.txt).
> > > >Just use the native transport define by the protocol.
> > >
> > > Perhaps it would be too simple an extrapolation to 
> conclude that you are not
> > > in favor of ...
> > > http://www.ietf.org/internet-drafts/draft-deason-sip-soap-00.txt
> > >
> > > Could you share your opinion? (I would mine, but few care 
> about it! ;-)
> 
> I doubt many want mine, but, I'll give it anyway ;^)
> 
> >
> > I do not believe that SIP is a useful RPC mechanism. None 
> of its user
> > discovery and registration capabilities are needed for RPC, neither
> > are most of its proxy functions. As it is not an ideal transfer
> > protocol, it is not good at carrying serialized objects of any large
> > size.
> 
> There are times however when a RPC may need to be performed 
> in relation to a
> session and proxies may be interested in the result. I can't 
> believe anyone
> interested in ushering in the next generation of services 
> couldn't see this. That
> said as a generic RPC transport mechanism SIP is a very poor 
> choice, and from a
> security point SOAP is a nightmare (any RPC mechanism 
> designed to breech firewalls
> without a ALG is a nightmare.)
> 
> James Undery
> 
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: [email-masked]
Date: Mon, 17 Jul 2000 16:59:05 +0300

// "Fox, Mike" wrote:
// > 
// > Jonathan Rosenberg wrote:
// > > I would not advocate tunneling DHCP over SIP, HTTP over SIP,
// > > or SLP over
// > > SIP, since those protocols
// > > don't do the same thing SIP does. Same with megaco/mgcp.
// > > Tunneling them
// > > over SIP serves no purpose. SIP is not a good transfer
// > > protocol (see the
// > > Guidelines for Authors of SIP Extensions:
// > > http://search.ietf.org/internet-drafts/draft-rosenberg-sip-gui
// > >delines-00.txt).
// > >Just use the native transport define by the protocol.
// > 
// > Perhaps it would be too simple an extrapolation to 
// conclude that you are not
// > in favor of ...
// > http://www.ietf.org/internet-drafts/draft-deason-sip-soap-00.txt
// > 
// > Could you share your opinion? (I would mine, but few care 
// about it! ;-)
// 
// I do not believe that SIP is a useful RPC mechanism. None 
// of its user
// discovery and registration capabilities are needed for 
// RPC, neither
// are most of its proxy functions. As it is not an ideal transfer
// protocol, it is not good at carrying serialized objects 
// of any large
// size.
// 
// -Jonathan R.
// 

Well, correct me if I'm wrong, but when you talk of ORPC 
over SIP, then the ORPC mechanism would be handled by 
another protocol (like SOAP-XML) which would encapsulate 
information such as Object ID's, Interface id's, context 
information etc. So the user-discovery/registration 
capabilities of SIP would not be required since object 
requests would not directly utilize the capabilities of SIP, 
but of SOAP which is transferred as SIP payload (just as it 
is in HTTP - <<draft-box-http-soap-01.txt>>). And also, the 
payload would typically be used to relay ORPC 
request-responses and not large serialized objects.

-Sapan Bhatia

---

From: [email-masked]
Date: Mon, 17 Jul 2000 15:57:44 +0300

// "Fox, Mike" wrote:
// > 
// I do not believe that SIP is a useful RPC mechanism. None of its user
// discovery and registration capabilities are needed for RPC, neither
// protocol, it is not good at carrying serialized objects of any large
// size.
// 
// -Jonathan R.
// 

Well, correct me if I'm wrong, but when you talk of ORPC over SIP, then the
ORPC mechanism would be handled by another protocol (like SOAP-XML) which
would encapsulate information such as Object ID's, Interface id's, context
information etc. So the user-discovery/registration capabilities of SIP
would not be required since object requests would not directly utilize the
capabilities of SIP, but of SOAP which is transferred as SIP payload (just
as it is in HTTP - <<draft-box-http-soap-01.txt>>). And also, the payload
would typically be used to relay ORPC request-responses and not large
serialized objects.

-Sapan Bhatia