Subject: RE: [SIP] summary: DTMF and voice-over-packet

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 13 Jul 2000 18:03:49 -0400

I think that we have some confusion here on where the
DTMF decoders are.  Jonathan is assuming they are
in the UAS.  Some of the questions indicate that
others are imagining that they are in the media server.

The beauty of the "do it in RTP" approach that Jonathan
is advocating is that IT DOESN'T MATTER!

If the UAS has DTMF detection, send the RTP streams with
the DTMF codec.

If the UAS does not have DTMF detection, send the RTP
streams with an audio codec.

In the latter case, yes, you are tying up resources in
the media server.  That is EXACTLY how current systems
which allow long DTMF tones do it.  There is a system DTMF
receiver on line for the whole call.  It's usually in the
debit card processors' switch.  If you want to save
media server resources, you have to move the DTMF detection
into the UAS.  If it is there (and of course on-line for
the whole time), it can send RTP with DTMF codec to
the media server (or a proxy server if you prefer).

And, of course, if you are with Christian, you would do both;
send the audio streams to the media server for speech recognition
and send the DTMF streams for the DTMF.  Of course, some day,
we will probably have a phoneme codec, and things will be 
a little more interesting :)

The UAS could, if you wanted it to, actually disconnect
from the media server, and when it saw a tone, reconnect.
I wouldn't advocate doing it, but you could.

Brian

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Thursday, July 13, 2000 10:57 AM
> To: Culpepper, Bert
> Cc: Christian Huitema; [email-masked]
> Subject: Re: [SIP] summary: DTMF and voice-over-packet
> 
> 
> 
> 
> "Culpepper, Bert" wrote:
> > 
> > The technical issue with only carrying DTMF in RTP is that
> > my media server just grew 7 to 10-fold in terms of media port
> > (RTP port plus vocoder port) count.  That's the increase in
> > media port capacity my pre/post-paid calling card service
> > node needs to provide an equivalent feature set and maintain
> > the same overall call handling capacity it had in the PSTN.
> > 
> > Is there a flaw in this logic? 
> 
> Yes.
> 
> There are no ports here. All this comes in over IP, on an ethernet
> interface or what have you.
> 
> There are NO DSP RESOURCES OR VOCODERS. The DTMF is already been
> detected. Its encapsulated in RTP in completely decoded form, EXACTLY
> THE SAME as you would get it in INFO.
> 
> The difference as far as your platform is concerned, pretty much comes
> down to whether a DTMF digit arrives in a big packet on port 
> 5060, or a
> smaller packet on a dynamic port. 
> 
> -Jonathan R.
> 
> -- 
> Jonathan D. Rosenberg                       72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
> http://www.dynamicsoft.com
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 13 Jul 2000 18:41:59 -0400

Just a correction - I think Brian means UAC, not UAS. The
UAC is the one sending the RTP.

-Jonathan R.