Subject: [SIP] Display Name

From: Dvir Oren <[email-masked]>
Date: Fri, 21 Jul 2000 00:44:09 +0300 (IDT)

This may be a dumb questions, but I was wondering
when are you supposed to put quotes around
a display name?  Am I guaranteed to have 
quotes around a name with spaces?  Can I
discard spaces in a name without quotes?

How should I treat a Display Name like this:
From:  This      is
  My
     Name <...>

?
Can I treat it as "This is My Name" <...>?

-- 
Dvir Oren               <[email-masked]>
Lucid VON Ltd.     <http://www.lucidvon.com>
9 Saloniki St.,        Tel-Aviv       Israel
Tel:  +972 3 644 3038  Fax:  +972 3 644 3039

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 21 Jul 2000 01:37:56 -0400

I believe it has to be a quoted string if it contains non-token
characters:

Contact: "< this is a test" <sip:user@host>

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: "Jo Hornsby" <[email-masked]>
Date: Fri, 21 Jul 2000 10:46:06 +0100

> Contact: "< this is a test" <sip:user@host>

Is this definitely right?

6.15 says:
    Contact = ( "Contact" | "m" ) ":" 
                 ("*" | (1# (( name-addr | addr-spec )
                 *( ";" contact-params ) )))

       name-addr      = [ display-name ] "<" addr-spec ">"
       addr-spec      = SIP-URL | URI
       display-name   = *token | quoted-string

And given the "implied *LWS" rule in appendix C, doesn't that
make
Contact: Monsieur Muppet <sip:[email-masked]>
legal?

 - Jo.

---

From: Henning Schulzrinne <[email-masked]>
Date: Sun, 23 Jul 2000 13:03:40 -0400

> Contact: "< this is a test" <sip:user@host>

To amplify: The spec definition is 

which, I believe, addresses this unambiguously.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs