Subject: [SIP] Content-Length header and End-to-End Encryption

From: dENIS Vandersteene <[email-masked]>
Date: Fri, 07 Jul 2000 17:53:07 +0200

Hi there,

In RFC 2543bis (July) Section 13.1.1 (End-to-End Encryption) and Table 4
& 5 (on pages 35-36) mention what headers MUST NOT be encrypted and what
headers MAY be. Referring to Table 4, the Content-Length header MAY be
encrypted, but in section 13.1.1, § 2 on page 88, it is said :
    " Upon receipt by the called UA possessing the correct decryption
key, the message body as indicated by the Content-Length field is
decrypted, [...]"

So, shouldn't that be a "MUST NOT be encrypted" header, as it's needed
to decrypt the message?

Thanks,

dENIS

--
Denis Vandersteene
Software Engineer
Indigo Software
50 Rue Wiertz
Brussels, 1050 – Belgium
Tel. +32 2 401 68 23
[email-masked]
http://www.indigosw.com
--------------------------------------------

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 07 Jul 2000 11:54:55 -0400

> So, shouldn't that be a "MUST NOT be encrypted" header, as it's needed

I don't see Content-Length as sensitive, so it probably should not be
encrypted. I changed the table entry.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs