Subject: RE: [SIP] OK with no ACK

From: "Agboh, Charles" <[email-masked]>
Date: Thu, 6 Jul 2000 17:21:45 +0200

Callers don't receive ACKs unless they received an invite from the callee. 

-----Original Message-----
From: Vijay K. Gurbani [mailto:[email-masked]]
Sent: Thursday, July 06, 2000 5:06 PM
To: Vakil, Mohammad
Cc: Dvir Oren; SIP
Subject: Re: [SIP] OK with no ACK

"Vakil, Mohammad" wrote:
> 
> Vijay -
> 
> How can a User Agent Server issue a Cancel? What Dvir is describing 
> here is a UAS is trying to send 200 OK and never receives an ACK. It 
> should just kill the call without having to send anything after 
> retransmission time out.

Mohammad:

You are correct; I mistook Dvir's scenario for another context that I
have been thinking about recently (when you have a hammer, everything
looks like a nail...).  Clearly, in case of an INVITE if the caller does 
not receive an ACK to the 200 OK, it will keep on re-transmitting the 
200 OK until it has exhausted its retry limit.

Sorry for the confusion

- vijay
-- 
Vijay K. Gurbani  [email-masked] [email-masked] [email-masked]
IN Architecture and Internet Software Group
Lucent Technologies/Bell Labs Innovations, 263 Shuman Blvd, Rm 1A-418
Naperville, Illinois 60566  Voice: +1 630 224 0216 Fax: +1 630 713 0184

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 06 Jul 2000 14:08:19 -0500

Boy, am I off today.  I meant if the "callee" does not receive an ACK
to the 200 OK it send out in response to the INVITE it got.  There, I
hope I said that correctly.  Need to get some more coffee or a better
brand of it...