Subject: [SIP] Port in Request-URI

From: Dvir Oren <[email-masked]>
Date: Thu, 6 Jul 2000 17:20:15 +0300 (IDT)

I'm not clear whether a Request-URI can or cannot have a port number.
Although I saw somewhere in the RFC that a Request-URI can have a
port, I see no examples of such use.

-- 
Dvir Oren               <[email-masked]>
Lucid VON Ltd.     <http://www.lucidvon.com>
9 Saloniki St.,        Tel-Aviv       Israel
Tel:  +972 3 644 3038  Fax:  +972 3 644 3039

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 06 Jul 2000 09:38:54 -0500

> port, I see no examples of such use.

A Request-URI is a SIP URL as described in Section 2 of the bis draft.
SIP URLs include hostport as a mandatory element where

   hostport = host [":" port]

Thus a Request-URI MAY contain a port number.  A Request-URI of the form

   sip:[email-masked]:5065

is perfectly valid and my SIP UAC can put this in my From: or Contact: 
headers when sending a request.

Regards,

- vijay
-- 
Vijay K. Gurbani  [email-masked] [email-masked] [email-masked]
IN Architecture and Internet Software Group
Lucent Technologies/Bell Labs Innovations, 263 Shuman Blvd, Rm 1A-418
Naperville, Illinois 60566  Voice: +1 630 224 0216 Fax: +1 630 713 0184