Subject: [SIP] QoS and Mid-Session SDP changes

From: Sudipto Mukherjee <[email-masked]>
Date: Fri, 07 Jul 2000 12:12:15 -0400

Hi,

RE-INVITEs can change media characteristics such as port, 
IP address and codecs, for QoS-Assured Sessions. In this case, 
resource reservation needs to be done again with the new media 
parameters for the ongoing session. 

The following flow illustrates the above scenario -

	 A                                B

	 <-- Active Session with Qos ---->

  A decides to change media characteristics and sends a
  Re-INVITE.

         INV (New SDP A w precondition) 
	 --------------------------------->

           183 (SDP B w precondition)
	 <--------------------------------
           PRACK
	 -------------------------------->
           200 OK (PRACK)
	 <-------------------------------

   Reservations successful at A & B

          COMET
	 --------------------------------->
           200 OK (COMET)
	 <--------------------------------
           COMET
	 <--------------------------------
           200 OK (COMET)
	 --------------------------------->

           200 OK (SDP B)
	 <--------------------------------
           ACK
	 --------------------------------->

   Session resumes with updated media parameters

The above flow generates lots of signaling traffic for a 
mid-call SDP change.

Please comment on the correctness of the flow. Any 
suggestions to improve upon, is appreciated.

Thanks
-- Sudipto

---------------------------------------------------------------------------
Sudipto Mukherjee
Cisco Systems, Inc             [email-masked] 
7025 Kit Creek Rd              919-392-5780
PO Box 14987
Research Triangle Park, NC 27709          
--------------------------------------------------------------------------

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 10 Jul 2000 02:51:59 -0400

>          INV (New SDP A w precondition)

Well, thats the penalty for assured traffic. It is TBD about whether
COMET is bidirectional in this and other cases.

> suggestions to improve upon, is appreciated.

It seems correct, excepting right now there is only a COMET from A to B.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com