Subject: [SIP] how is the proxy talks to the other proxy ?

From: Andi Janti <[email-masked]>
Date: Wed, 26 Jul 2000 13:29:32 -0700 (PDT)

Hi, all

I'm pretty new on this SIP issue and I was wondering
how exactly the proxy server talks to other proxy
server ?
I am quite familiar with the H.323 gatekeeper talk
which is usually done with LRQ message when one gk is
communicating with another gk.

Is there some kind of mechanism how the SIP proxy
server communicates with each other ?
Or maybe do SIP has a similar spec called
administration zone/domain just like on H.323 ?

A few related questions, if the proxy server that is
serving the UAC doesn't know the destination address,
how is the proxy server resolve the called address ?
Do they need to talk to location server (such as DNS)
all the way to the top until it finds the address or
the proxy needs to communicate with another available
proxy server on the SIP network ?

Thank you.
--
Andi

__________________________________________________
Do You Yahoo!?
Get Yahoo! Mail - Free email you can access from anywhere!
http://mail.yahoo.com/

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 26 Jul 2000 18:08:25 -0400

> how exactly the proxy server talks to other proxy

With SIP. The UA to proxy and proxy to proxy protocols are
exactly the same and indistinguishable. Thats a feature.

> proxy server on the SIP network ?

SIP routing is next-hop routing. It uses some external location
service (whcih can be registrations or anything else you want),
or DNS. 

I recommend you check out the numerous tutorials and papers on sip
available at:
http://www.cs.columbia.edu/~hgs/sip

which explain these basics.

-Jonathan R.
-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com