Subject: [SIP] SIP-T Draft Feedback

From: Adam Roach <[email-masked]>
Date: Mon, 31 Jul 2000 11:38:19 -0700 (PDT)

Comments about draft-vemuri-sip-t-context-00.txt:

- On page 5, the point about "PSTN origination"
  should make mention that some ISUP modifications
  may occur to sync up with changes made by SIP
  proxies in the SIP network.

- In the call flows, you tend to map ACM messages
  to "183 Session Progress." In practice, ACMs
  typically have indication of "Subscriber
  free," which *should* map to "180 Ringing."
  Admittely, you don't have any ISUP parameters
  detailed in the call flows, but I think you
  shouldn't be using the exceptional cases to
  illustrate call flows.

- On page 10, there's a minor cut and paste error
  where the final BYE response is listed as BYE.

- Also in the call flow in page 10, note that
  the 200 response for BYE is used only for
  reliability; in ISUP, the RLC is used to
  indicate that a circuit is available for re-use.
  In most circumstances, it doesn't make sense
  to hold off the 200 response to the BYE
  until the RLC arrives.

- On page 14: I just want to bring your attention
  to the fact that much of the header mapping
  is already present in Gonzalo's and my draft.

- Also on page 14: it should be mentioned that
  encryption should be used for ISUP bodies.

- Section 6.2: It seems a bit odd to have a special
  purpose application server "fixing" the ISUP
  before it goes to the egress gateway. Since this
  gateway is already having to unpack the ISUP and
  (to some degree) understand it, it makes the
  most sense to perform that function in the MGC.

- On note 9: in Gonzalo's and My draft, we specify
  that any informationthat shouldn't be presented
  also shouldn't be mapped into SIP headers.
  I beleive this is a non-issue, as long as the
  ISUP bodies are encrypted.

Thanks for the good work!

- Adam Roach

(Mailing from Yahoo! from the IETF; prefered
address is typically [email-masked])

__________________________________________________
Do You Yahoo!?
Kick off your party with Yahoo! Invites.
http://invites.yahoo.com/

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: [email-masked]
Date: Mon, 31 Jul 2000 12:43:30 -0600

Are you here in Pittsburgh today, Adam? If so, let's get together and talk.

- Jon

-----Original Message-----
From: Adam Roach [mailto:[email-masked]]
Sent: Monday, July 31, 2000 2:38 PM
To: Vemuri, Aparna; Peterson, Jon
Cc: [email-masked]; [email-masked]
Subject: [SIP] SIP-T Draft Feedback

- Adam Roach