Subject: [SIP] Comparing URLs

From: Dvir Oren <[email-masked]>
Date: Mon, 24 Jul 2000 12:05:23 +0300 (IDT)

Are the following two URLs the same?

<sip:[email-masked];maddr=192.168.1.1>
<sip:[email-masked];maddr=192.168.1.1>

Although the RFC says that the IP address from a DNS lookup does not
equal the hostname of that lookup, it doesn't really say anything
about maddr.

-- 
Dvir Oren               <[email-masked]>
Lucid VON Ltd.     <http://www.lucidvon.com>
9 Saloniki St.,        Tel-Aviv       Israel
Tel:  +972 3 644 3038  Fax:  +972 3 644 3039

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Gethin Liddell <[email-masked]>
Date: Mon, 24 Jul 2000 10:13:14 +0100

> <sip:[email-masked];maddr=192.168.1.1>

No, these two are definitely not the same.

Section 2 describes URL equality and is pretty black and white on this
subject:

"user, password, host, port and any url-parameter parameters of the
URI must match."

here the hosts do not match, irrespective of what parameters are
present.

-- 
Gethin Liddell
Ubiquity Software Corporation

http://www.ubiquity.net
mailto:[email-masked]