Subject: RE: [SIP] DTMF digit handling

From: "Culpepper, Bert" <[email-masked]>
Date: Mon, 10 Jul 2000 16:24:41 -0500

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Monday, July 10, 2000 4:36 PM
> To: Girzon, Gary
> Cc: Culpepper, Bert; Michael Thomas; Jonathan Rosenberg; Igor 
> Slepchin;
> Shankar, Krishnakumar; [email-masked]'
> Subject: Re: [SIP] DTMF digit handling
> 
> 
> "Girzon, Gary" wrote:
> > 
> > An example of where "DTMF over RTP" and "DTMF over SIP INFO" methods
> > can be both used is a pre-paid application. Pre-paid falls into a
general
> > category
> > of 3rd party call-control apps in which a controlling party typically
does
> > not care
> > about audio between the other 2 parties but wishes to be notified about
> > certain
> > in-band audio events such as DTMF.  Initially, the controlling party
> > receives
> > DTMF over RTP. After the transfering a call, there is no need for
> > the controlling party to remain in the RTP or media "loop" and waste
> > connection resources.
> 
> That party should then disconnect the DTMF RTP stream, using existing
> SIP "drop media" mechanisms. (I actually doubt this works in practice,
> since most such prepaid applications allow the user to "hang up" and
> redial by holding down the # key for two seconds, compensating for the
> lack of cookies in payphones.)
> 

Exactly, I can't provide all of the features of pre-paid (or post-paid)
calling
cards on a SIP server without someway to get that 2-second # key after
I've re-directed the media.

> 
> > 
> > Again, I don't think anyone is proposing tunneling MGCP or Megaco over
SIP,
> > just recycling some of the already defined packages for syntax defining
DTMF
> > events.
> >
> The person(s) doing the proposing can speak for themselves :-)
>

I'm not sure what I've proposed :) but "recycling" is a nice term (since
tunneling
is so reprehensible).

Existing methods (183 Session Progress, G.711) work at session
establishment.  And it seems RFC2833 encoded DTMF in a mid-session
INFO message is best for that point in a session.  Well, I hope to find
out what is acceptable in the near future.

I understand what I proposed in a Draft probably violates SIP's purpose but
I
would like a way to provide a digit mask and have the digits collected
at the gateway and reported in a single result message.  And a network
that has MGCP/Megaco in places and SIP in other places is likely to be
reality.  I guess we can't always have what we want though :)

> -- 
> Henning Schulzrinne   http://www.cs.columbia.edu/~hgs
> 

Bert

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henry Sinnreich <[email-masked]>
Date: Mon, 10 Jul 2000 20:36:28 -0500

Please help me understand
>And a network
>that has MGCP/Megaco in places and SIP in other places

why cannot the IP telephony gateway behave like a SIP endpoint?

Thanks, Henry

>From: [email-masked]
>[mailto:[email-masked]]On Behalf Of
>Culpepper, Bert
>Sent: Monday, July 10, 2000 4:25 PM
>To: Henning Schulzrinne; Girzon, Gary
>Cc: Michael Thomas; Jonathan Rosenberg; Igor Slepchin; Shankar,
>Krishnakumar; [email-masked]'
>Subject: RE: [SIP] DTMF digit handling
>
>
>