Subject: RE: [SIP] OK with no ACK

From: "Vakil, Mohammad" <[email-masked]>
Date: Thu, 6 Jul 2000 11:21:02 -0400

Charles -

You cannot issue BYE whenever you want. 

Section 4.2.3 in the bis draft says:

"A BYE request from either called or calling party terminates any pending
INVITE, but the INVITE request transaction MUST be completed with a final
response."

Mohammad Vakil
OutReach Technologies
 
-----Original Message-----
From: Agboh, Charles [mailto:[email-masked]]
Sent: Thursday, July 06, 2000 11:10 AM
To: 'Vakil, Mohammad'
Subject: RE: [SIP] OK with no ACK

The CANCEL doesn't apply to the calle since it never issued a request for
that session.  Right?  AS a callee, I can issue a BYE when ever I want right
(after receiving an invite af course)? 

-----Original Message-----
From: Vakil, Mohammad [mailto:[email-masked]]
Sent: Thursday, July 06, 2000 4:58 PM
To: [email-masked]'; Dvir Oren
Cc: SIP
Subject: RE: [SIP] OK with no ACK

Vijay - 

How can a User Agent Server issue a Cancel? What Dvir is describing here is
a UAS is trying to send 200 OK and never receives an ACK. It should just
kill the call without having to send anything after retransmission time out.

Mohammad Vakil
OutReach Technologies

-----Original Message-----
From: Vijay K. Gurbani [mailto:[email-masked]]
Sent: Thursday, July 06, 2000 10:33 AM
To: Dvir Oren
Cc: SIP
Subject: Re: [SIP] OK with no ACK

Dvir Oren wrote:
> 
> I think that a situation where the calle sent OK, but doesn't receive
> ACK for an extended period of time should be handled.  I'm
> implementing a timeout on OK replies, that will kill the call if no
> ACK was received after a defined period of time.
> 
> My question is, should I send a CANCEL or a BYE?

I would send a CANCEL since the call has not been established until the
ACK from the caller gets to the callee.  That is the behavior of my
proxy.  A BYE (to me at least) conveys that a session was successfully
established and is now being torn down.

Regards,

- vijay
-- 
Vijay K. Gurbani  [email-masked] [email-masked] [email-masked]
IN Architecture and Internet Software Group
Lucent Technologies/Bell Labs Innovations, 263 Shuman Blvd, Rm 1A-418
Naperville, Illinois 60566  Voice: +1 630 224 0216 Fax: +1 630 713 0184

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Agboh, Charles" <[email-masked]>
Date: Thu, 6 Jul 2000 17:23:53 +0200

I thought the callee already issues the final response and is waiting for
the ACK!

-----Original Message-----
From: Vakil, Mohammad [mailto:[email-masked]]
Sent: Thursday, July 06, 2000 5:21 PM
To: Agboh, Charles; Vakil, Mohammad
Cc: 'sip'
Subject: RE: [SIP] OK with no ACK

Charles -

Mohammad Vakil
OutReach Technologies

-----Original Message-----
From: Vakil, Mohammad [mailto:[email-masked]]
Sent: Thursday, July 06, 2000 4:58 PM
To: [email-masked]'; Dvir Oren
Cc: SIP
Subject: RE: [SIP] OK with no ACK

Vijay - 

Mohammad Vakil
OutReach Technologies

-----Original Message-----
From: Vijay K. Gurbani [mailto:[email-masked]]
Sent: Thursday, July 06, 2000 10:33 AM
To: Dvir Oren
Cc: SIP
Subject: Re: [SIP] OK with no ACK

Regards,

- vijay

---

From: "Vakil, Mohammad" <[email-masked]>
Date: Thu, 6 Jul 2000 12:36:02 -0400

Dvir -

Ringing is a provisonal response. I'd stop retransmission of INVITE on
receiving Ringing but I'd not stop my Timer. And I'd send a CANCEL after
timer runs out.

The way I would implement is, I would remain in Inviting state until I
receive a Final response. I wouldn't go to a provisional state.

Mohammad Vakil
OutReach Technologies

-----Original Message-----
From: Dvir Oren [mailto:[email-masked]]
Sent: Thursday, July 06, 2000 11:57 AM
To: Vakil, Mohammad
Cc: SIP
Subject: RE: [SIP] OK with no ACK

Vakil, Mohammad writes ("RE: [SIP] OK with no ACK"):

> You don't send a CANCEL or BYE if don't receive any ACK to your 200 OK.
You
> can just kill the call after retransmission timer runs out. But you MUST
> keep retransmitting 200 OK until timer runs out.

This would leave the other end dangling.  Maybe I'll draw a scenario:

A  --- INVITE --->  B
   <-- RINGING ---  
                     --- OK --->
                     --- OK --->
                     --- OK --->
                     (timeout)
                     (quietly dies)

If 'B' will quietly die at this point, 'A' will never be able to leave 
its 'Ringing' state.  

I imagine that if there is a user at 'A', he/she will at some point
tire of hearing the 'ring', and simply hang up.  However, if there is
no user at 'A' (the most immediate scenario is in debugging!), then 
'A' will never leave this state.

-- 
Dvir Oren               <[email-masked]>
Lucid VON Ltd.     <http://www.lucidvon.com>
9 Saloniki St.,        Tel-Aviv       Israel
Tel:  +972 3 644 3038  Fax:  +972 3 644 3039