Subject: RE: Softswitches (was Re: [SIP] SIP->XML->SOAP)

From: "Neville O'reilly" <[email-masked]>
Date: Mon, 3 Jul 2000 17:02:00 -0400

1) I did not know "Verizon" was a company - yet (although the Genuity IPO
seems to remove the last major obstacle.)

2) the term "softswitch" does not denote a switch - is it not most often
used for a call control and processing agent (Call Agent , MGC are pretty
syonomous terms? - a term that came about in the context of the adoption of
a 3 layer "architecture" which separates services, call control and
infrastructure/gateways from each other. It has nothing to do intrinsically
with end user controlled vs. network controlled services. 

SOftswitch implementations could range from consumer software distributed on
a CD to network centric call processors which manage large mediation
switches and MGs with high port densities through MGCP signalling and talk
to each other via SIP - for example. 

-----Original Message-----
From: Gardell, Steve [mailto:[email-masked]]
Sent: Monday, July 03, 2000 12:31 PM
To: 'Neil Deason'
Cc: 'Henry Sinnreich'; [email-masked]'
Subject: RE: Softswitches (was Re: [SIP] SIP->XML->SOAP)

Thanks for the pointer Neil. 

Given current market-driven definitions, Henry's 
description (definition) of softswitches is 
reasonable, but I would note that a number
of vendors talk of using "softswitches" in
contexts where there is no (direct) SS7
signaling. For example one leading telcom
vendor used a "softswitch" as a foundation
for a new IP-PBX. Also, "softswitches" are promoted as 
"interior" service platforms (e.g. not controlling
any MG's) by several large telcom vendors.

SIP is a wonderful tool for service creation in 
it's own right, but I don't think that Henry's article 
really does justice to "API approaches" to service 
creation and standardization such as JAIN/JTAPI.
At the least a reasoned discounting might be in
order.

Lastly, in a heterogeneous world order (where it
just ain't all IP), it seems to me that softswitches
are a step in the right direction, especially if
we allow that it is a "poor softswitch that is
not also a SIP Proxy." As a representative of the
company (Verizon) with the largest number of POTS 
lines in the US, I am not sure what choice I have...

Steven Gardell
GTE Laboratories
Voice: 781-466-2681, Fax: 781-466-3375

> -----Original Message-----
> From: Neil Deason [mailto:[email-masked]]
> Sent: Monday, July 03, 2000 12:08 PM
> To: Gardell, Steve
> Cc: 'Henry Sinnreich'; [email-masked]'
> Subject: Softswitches (was Re: [SIP] SIP->XML->SOAP)
> 
> 
> Check out:
> 
> http://www.computertelephony.com/article/CTM20000608S0021
> 
> As Henry explains in more detail here where a 'Softswitch' 
> is used to preserve the signaling and control architecture 
> of SS7 and the Intelligent Network the vendor who implements 
> the Softswitch owns control over services. This reinvents 
> the failings of the IN/PSTN whereas SIP seeks to build new 
> services and empower service creation by end users.
> 
> Cheers,
> Neil
> -- 
> Ubiquity Software Corporation, UK          
> http://www.ubiquity.net
> 
> "Gardell, Steve" wrote:
> > 
> > I apologize for the double posting. Read
> > "MGC" rather than "MG". What I get for
> > going on vacation...
> > 
> > > -----Original Message-----
> > > From: Gardell, Steve
> > > Sent: Monday, July 03, 2000 7:07 AM
> > > To: 'Matt Holdrege'; Henry Sinnreich
> > > Cc: [email-masked]
> > > Subject: RE: [SIP] SIP->XML->SOAP
> > >
> > >
> > > I have been on vacation, so appologies for the
> > > belated response. After struggling to explain
> > > "softswitches" to operations folks here, we
> > > settled on a very general definition that could
> > > be taken to include MG's, SIP Proxy Servers,
> > > H.323 routed GK's as well as the more switch-like
> > > constructs being defined by the Multi-Media
> > > Switching Forum. However, as near as we can tell,
> > > today "softswitch" is a marketing term most
> > > closely associated with the IETF MG.
> > >
> > > What definition is implicit in the "value" commentary
> > > here?
> > >
> > > Steven Gardell
> > > GTE Laboratories
> > > Voice: 781-466-2681, Fax: 781-466-3375
> > >
> > >
> > > > -----Original Message-----
> > > > From: Matt Holdrege [mailto:[email-masked]]
> > > > Sent: Wednesday, June 21, 2000 4:32 PM
> > > > To: Henry Sinnreich
> > > > Cc: [email-masked]
> > > > Subject: RE: [SIP] SIP->XML->SOAP
> > > >
> > > >
> > > > At 07:09 AM 6/18/00 -0500, Henry Sinnreich wrote:
> > > > > >> SIP->XML would converge the SIP methods and required
> > > > > >parameters to XML and
> > > > > >> allows the introduction of a DTD or schema to define
> > > > > >the syntax of a valid
> > > > > >> SIP message.
> > > > >
> > > > >Do not forget that endangering the deployment of SIP as is,
> > > > >would set IP telephony back for a generation and leave 
> the field
> > > > >for "softswitches" and other such nonsense. Nobody on this
> > > > >mailing list would then live to see true/open Internet
> > > > >communications, but just the old circuit switch central control
> > > > >model with its terrible signaling. Just using IP as a cheap
> > > > >wire.
> > > >
> > > > Henry,
> > > >
> > > > This is the first time I recall seeing "softswitches" being
> > > > denigrated on
> > > > an IETF list. I would hope you realize that they are an
> > > > enabler to get the
> > > > circuit switched world to migrate to open communications?
> > > Saying that
> > > > Softswitches will preserve the circuit switched world with
> > > > it's "terrible
> > > > signalling" is a bit short-sighted.
> > > >
> > > > You should also realize that SIP is doing quite well in the
> > > > area of market
> > > > acceptance. The more people buy into SIP the more 
> evolution will be
> > > > required. Change is inevitable even though we must try to
> > > > manage it well.
> > > > XML is one such change that seems (to me) to be inevitable.
> > > > So it would be
> > > > better to try and manage the interactions with SIP and XML
> > > > here in the IETF
> > > > rather than elsewhere. Besides, it's part of the openess that
> > > > we all should
> > > > encourage.
> > > >
> > > >
> > > >
> > > > _______________________________________________
> > > > SIP mailing list
> > > > [email-masked]
> > > > http://lists.bell-labs.com/mailman/listinfo/sip
> > > >
> > >
> > 
> > _______________________________________________
> > SIP mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/sip
> 
> -- 
> Ubiquity Software Corporation, UK          
> http://www.ubiquity.net
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Matt Holdrege <[email-masked]>
Date: Mon, 03 Jul 2000 14:15:34 -0700

>seems to remove the last major obstacle.)

According to the Ultimate Authority (Wall St.) VZ was born today.

>with end user controlled vs. network controlled services.

Yep!

>to each other via SIP - for example.

Precisely! And they can talk to ASP's via SIP.

---

From: "Gardell, Steve" <[email-masked]>
Date: Wed, 5 Jul 2000 07:24:14 -0400

> Sent: Tuesday, July 04, 2000 11:35 AM
> To: Henry Sinnreich
> At 11:12 AM 7/4/00 -0500, Henry Sinnreich wrote:
> >Matt, thanks for the reasoned note. One item:
> > >A SIP phone may not need a
> > >softswitch to do this,
> > >but the umpteen billion non-SIP phones need a little help.
> >
> >SIP RJ-11 to RJ-45 adapters are now available and could be
> >available as consumer devices with consumer price points. Such
> >adapters are actually one-channel IP telephony gateways and are
> >fully qualified SIP UAs under user control. Compliant with
> >Internet transparency. Personally, I would always prefer a SIP
> >Ethernet to black phone adapter that gives me free choice of
> >service provider to  xGCP phones controlled by the Telco as in
> >old times. Would you really have your analog phones controlled
> >by the Telco, rather then being able to point them to any SIP
> >server of your choice?
> 
> Sure, but I think it may be a few years before everyone in 
> the world has 
> such a phone which is why we need to help them into a more open 
> architecture. Even with XGCP controlled phones, things are 
> way more open 
> than with the circuit-switched world.
> 

Exactly to my point. There are undoubtedly exciting "green field"
opportunities for SIP services; however the many millions of "copper
loops" in place are not going away anytime soon. Architectures are
required that support a **migration** towards the pure packet 
world aptly addressed by SIP. We should also bear in mind the lessons
of IN - An industry standard protocol (in that case TCAP) is a 
necessary, but **insufficient** condition for open competitive service
creation. The comparison is not perfect, but neither is it irrelevant.
Enough, I guess, of the "evil telco" perspective...