Subject: RE: [SIP] Multiple sessions in SDP payload

From: Christian Huitema <[email-masked]>
Date: Tue, 18 Jul 2000 11:53:39 -0700

Jonathan,

Suppose a station wants to encode its desire to support both RTP over IPv6
and RTP over IPv4. Due to various constraints, it cannot use the same
listening UDP port for IPv4 and IPv6. In the current definition of SDP, the
port number is encoded as the token immediately following the media type in
the "m=" line, and the address type is encoded on a "c=" line. How can I
possibly encode the SDP without having two media lines?

Christian Huitema

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Tuesday, July 18, 2000 7:17 AM
> To: Christian Huitema
> Cc: 'William Lee'; 'Philip Levis'; [email-masked]
> Subject: Re: [SIP] Multiple sessions in SDP payload
> 
> 
> 
> Christian Huitema wrote:
> > The problem is, there is a fundamental contradiction 
> between two requirements. If I include 3 "m=audio" lines, do 
> they describe
> > 3 ways to pass audio, such as IPv4, IPv6 and POTS, or do I 
> describe 3 audio channels that should be deployed in parallel? My
> > take so far would be to use multiple instance of the same 
> media within a single SDP payload to describe alternative encodings,
> > and to use multiple SDP payloads, using MIME multipart, to 
> encode several parallel sessions.
> 
> I think three lines of the same type means the same thing it does in
> SAPs usage - parallel media streams, not alternatives. This, 
> in fact, is
> necessary as per the other thread on sending DTMF using 
> rfc2833 to third
> party application servers.
> 
> 
> As for multiple sessions per SDP, I don't know what the value of this
> would be. rfc2543 is silent on this, and I would suggest it be
> disallowed within SIP.
> 
> -Jonathan R.
> 
> >        -----Original Message-----
> >        From: William Lee [mailto:[email-masked]]
> >        Sent: Monday, July 17, 2000 10:15 PM
> >        To: 'Philip Levis'
> >        Cc: [email-masked]
> >        Subject: RE: [SIP] Multiple sessions in SDP payload
> > 
> >        Yes, according to the spec, multiple SDP sessions 
> may be specified.  
> >        At the 2nd SIP bake-off, we tested a trial 
> implementation of our 
> >        SDP parser/statemachine that sent and received 
> multiple SDP sessions. 
> >        No one supported this, and as far as I know no one 
> else does today. 
> 
> 
> 
> -- 
> Jonathan D. Rosenberg                       72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
> http://www.dynamicsoft.com
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 19 Jul 2000 17:59:20 -0400

There is no way to do this kind of thing with SDP. But, there are lots
of other things you also can't do. I believe SDP covers some 95% of the
most common application cases. So, there are a few options for the
remaining 5%. Either hack the daylights out of SDP, else use SDPng,
which mmusic is looking at. I guess its a matter of preference about
which you do.

-Jonathan R.