Subject: RE: [SIP] OK with no ACK

From: "Vakil, Mohammad" <[email-masked]>
Date: Thu, 6 Jul 2000 10:27:12 -0400

You don't send a CANCEL or BYE if don't receive any ACK to your 200 OK. You
can just kill the call after retransmission timer runs out. But you MUST
keep retransmitting 200 OK until timer runs out.

Mohammad Vakil
OutReach Technologies

-----Original Message-----
From: Dvir Oren [mailto:[email-masked]]
Sent: Thursday, July 06, 2000 10:15 AM
To: SIP
Subject: [SIP] OK with no ACK

I think that a situation where the calle sent OK, but doesn't receive
ACK for an extended period of time should be handled.  I'm
implementing a timeout on OK replies, that will kill the call if no
ACK was received after a defined period of time.

My question is, should I send a CANCEL or a BYE?

-- 
Dvir Oren               <[email-masked]>
Lucid VON Ltd.     <http://www.lucidvon.com>
9 Saloniki St.,        Tel-Aviv       Israel
Tel:  +972 3 644 3038  Fax:  +972 3 644 3039

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Dvir Oren <[email-masked]>
Date: Thu, 6 Jul 2000 18:56:53 +0300 (IDT)

> keep retransmitting 200 OK until timer runs out.

This would leave the other end dangling.  Maybe I'll draw a scenario:

A  --- INVITE --->  B
   <-- RINGING ---  
                     --- OK --->
                     --- OK --->
                     --- OK --->
                     (timeout)
                     (quietly dies)

If 'B' will quietly die at this point, 'A' will never be able to leave 
its 'Ringing' state.  

I imagine that if there is a user at 'A', he/she will at some point
tire of hearing the 'ring', and simply hang up.  However, if there is
no user at 'A' (the most immediate scenario is in debugging!), then 
'A' will never leave this state.