Subject: [SIP] DTMF digit handling

From: "Shankar, Krishnakumar" <[email-masked]>
Date: Sun, 9 Jul 2000 17:17:55 -0400

Hi,
	Is there any information available on how DTMF tones/digits are
handled in SIP ?  More specifically how are DTMF tones/digits sent as part
of the RTP media stream over UDP handled reliably. I would like to know is
there any other way to receive the DTMF tones at the UAS (user agent server)
using SIP.

Thanks
--Krishna

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Igor Slepchin <[email-masked]>
Date: Mon, 10 Jul 2000 00:51:49 -0400

"Shankar, Krishnakumar" wrote:
> 
> More specifically how are DTMF tones/digits sent as part
> of the RTP media stream over UDP handled reliably. 

They are sent as a special payload format described in RFC2833.

> I would like to know is
 
In-band RTP is likely to be the preferred way of sending DTMF to a UA.
If some of the systems along signaling path are interested in the DTMF,
the INFO method may also be used. There are a few ways to encode DTMF in
the body of INFO: by using the payload format described in RFC2833, by
using MGCP/Megaco packages, etc.

---
Igor Slepchin

---

From: "Krishna G" <[email-masked]>
Date: Mon, 10 Jul 2000 10:23:48 +0530

Hi Krishna,

    There is lot of information available on the handling of DTMF in SIP. U
may want to refer the following internet drafts/RFCs for the information:
1). RTP Payload for DTMF Digits, Telephony Tones and Telephony Signals - RFC
2833
2). Sample Uses of SIP INFO with Varying Reliability Needs - James Kuthan,
3). SIP Info method for DTMF digit transport and collection - Tahsin
Chouduri and few other authors from Nortel Networks.
4). SIP Info method for Event Reporting - Bert Culpepper etc.

Cheers,

Krishna G.
Silicon Automation Systems
India

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 10 Jul 2000 02:28:50 -0400

> using MGCP/Megaco packages, etc.

I should note that this is still an issue of some controversy, both on
whether its needed (a UAS will still get the DTMF through RTP), and on
how to do it. So, you should not take any of the extensions proposed so
far as authoritative or normative. I hope to resolve this at the next
meeting.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: "Doug Weisenberg" <[email-masked]>
Date: Mon, 10 Jul 2000 09:39:57 -0400

> far as authoritative or normative. I hope to resolve this at the next

Given the number of viable mechanisms assuming "its needed", I would
guess that Client/Server agreement thru negotiation would be one way to
determine "how to do it".  Agree?

   -- Doug

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 10 Jul 2000 10:38:40 -0400

> determine "how to do it".  Agree?

No. If we do it, we will pick a single protocol extension for it, thats
it. 

-Jonathan R.

---

From: Michael Thomas <[email-masked]>
Date: Mon, 10 Jul 2000 08:41:24 -0700 (PDT)

Igor Slepchin wrote:
 > > the body of INFO: by using the payload format described in RFC2833,

   Yuck.

 > >  by

   Double Yuck. 

   Why is it so difficult to just receive RFC2833 payloads
   over RFC 1889 transport?

 > far as authoritative or normative. I hope to resolve this at the next

   In the last go-round of this perennial merry-go-round,
   the main complaint I heard is that interior IVR's might
   not have the MIPS/whatever to do DTMF detection and that
   they'd like to have the originator -- who has to have 
   a DTMF detector anyway -- do the DSP kruft. Fine. We now
   have RFC 2833. Trying to thread this back through SIP,
   however, seems like a really bad idea though: why not
   just use SIP to transport RTP itself? And putting 
   MGCP/MEGACO into SIP body headers is a gruesome
   layer violation... it's sort of like the
   protocol equivalent of an inter-subroutine goto 
   with none of the careful rationalizations of 
   setjmp/longjmp.

		Mike

---

From: Henry Sinnreich <[email-masked]>
Date: Mon, 10 Jul 2000 13:52:37 -0500

Yes, the attached are good pointers, but it seems a DTMF-SIP
framework document is required to tie all this info together.
Any volunteers?

Henry

>-----Original Message-----
>From: [email-masked]
>[mailto:[email-masked]]On Behalf Of Krishna G
>Sent: Sunday, July 09, 2000 11:54 PM
>To: Shankar, Krishnakumar
>Cc: [email-masked]
>Subject: Re: [SIP] DTMF digit handling
>
>
>Hi Krishna,
>

From:	[email-masked] on behalf of Jonathan
Rosenberg [[email-masked]]
Sent:	Monday, July 10, 2000 1:29 AM
To:	Igor Slepchin
Cc:	Shankar, Krishnakumar; [email-masked]'
Subject:	Re: [SIP] DTMF digit handling

> using MGCP/Megaco packages, etc.

I should note that this is still an issue of some controversy,
both on
whether its needed (a UAS will still get the DTMF through RTP),
and on
how to do it. So, you should not take any of the extensions
proposed so
far as authoritative or normative. I hope to resolve this at the
next
meeting.

-Jonathan R.

--
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ
07936
[email-masked]                     FAX:   (973)
952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732)
741-7244
http://www.dynamicsoft.com

>> there any other way to receive the DTMF tones at the
>UAS (user agent
>server)
>> using SIP.
>>
>> Thanks
>> --Krishna
>>
>>
>>