Subject: [SIP] RE: Tunneling with SIP

From: "Fox, Mike" <[email-masked]>
Date: Tue, 11 Jul 2000 17:40:32 -0700

Jonathan Rosenberg wrote:
> I would not advocate tunneling DHCP over SIP, HTTP over SIP, 
> or SLP over
> SIP, since those protocols 
> don't do the same thing SIP does. Same with megaco/mgcp. 
> Tunneling them
> over SIP serves no purpose. SIP is not a good transfer 
> protocol (see the
> Guidelines for Authors of SIP Extensions:
> http://search.ietf.org/internet-drafts/draft-rosenberg-sip-gui
>delines-00.txt).
>Just use the native transport define by the protocol. 

Perhaps it would be too simple an extrapolation to conclude that you are not
in favor of ...
http://www.ietf.org/internet-drafts/draft-deason-sip-soap-00.txt

Could you share your opinion? (I would mine, but few care about it! ;-)

Best regards,
Mike Fox

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 11 Jul 2000 23:49:40 -0400

> Could you share your opinion? (I would mine, but few care about it! ;-)

I do not believe that SIP is a useful RPC mechanism. None of its user
discovery and registration capabilities are needed for RPC, neither
are most of its proxy functions. As it is not an ideal transfer
protocol, it is not good at carrying serialized objects of any large
size.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: James Undery <[email-masked]>
Date: Wed, 12 Jul 2000 09:00:50 +0100

> > Could you share your opinion? (I would mine, but few care about it! ;-)

I doubt many want mine, but, I'll give it anyway ;^)

> protocol, it is not good at carrying serialized objects of any large

There are times however when a RPC may need to be performed in relation to a
session and proxies may be interested in the result. I can't believe anyone
interested in ushering in the next generation of services couldn't see this. That
said as a generic RPC transport mechanism SIP is a very poor choice, and from a
security point SOAP is a nightmare (any RPC mechanism designed to breech firewalls
without a ALG is a nightmare.)

James Undery

---

From: Neil Deason <[email-masked]>
Date: Thu, 13 Jul 2000 11:57:22 +0100

> > Could you share your opinion? (I would mine, but few care about it! ;-)

Well I would. The reason I submitted this draft was to encourage
thought about the relationship of SIP and XML for services. Not
because I think SIP and SOAP necessarily provides the absolute
ultimate answer. 

> protocol, it is not good at carrying serialized objects of any large

In the draft you can see I explicitly said that SIP does not
provide the basis for a high efficiency or general computing RPC
mechanism. I note that you have now copied this sentiment into
your extensions guidelines draft ;) I also wouldn't expect that
size limits on datagram packets would be much of an issue for
SOAP messages. What SIP/SOAP might do is provide a clean
interface for sophisticated service requests between the many
different forms of SIP enabled nodes we all expect to see in the
near future. 

Cheers,
Neil.
-- 
Ubiquity Software Corporation, UK          
http://www.ubiquity.net