Subject: [SIP] Behaviour of the expires header

From: [email-masked] (Deepak Pant)
Date: Sat, 29 Jul 2000 14:47:34 -0500 (CDT)

Does every proxy that receives an INVITE request
needs to process the expires header? If every proxy
processes an INVITE request with the expires header,
then at the expiry of the INVITE, every proxy will
issue a 408 status.

-Deepak

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "rafi" <[email-masked]>
Date: Mon, 31 Jul 2000 11:15:18 +0530

----- O> Does every proxy that receives an INVITE request
> needs to process the expires header?

   RFC does not mandate the processing of Expire
   Header field received in INVITE message. What it
   says is  time duration mentioned in Expire Header filed
   can be used  as upper limit for the user to respond when 
   processed at the called party. When processed at proxy 
   it can be used to limit  the search operation. 

>If every proxy

  Assuming all proxies have  decided to use Expire  Headre 
field  then it is more likely that the first proxy times out first 
resulting in sending 408 response. Other proxies  which 
eventualy times out and send 408 response are simply 
collected by other proxies  and may be ignored in this perticular
case.  

  Now consider two prxoies  say proxy1 and proxy2 involved 
in the transaction. If proxy1 decided  to use Expiry  field and proxy 2 
decided not use Expire ( Whether such combination are allowed
are not is not clear but should be possible because action of one
 proxy should be independent of others)  field,  in this case if prxoy 1
times out then  response received from proxy 2 will be of no use.
Thus it looks if Expire header field  is  to be processed then 
every proxy should process or else no one should process it.
It looks mixture of above two leads to inefficient usage of
this field.

Any comments ?

Rafi Assadi H.M.
 riginal Message ----- 
From: Deepak Pant <[email-masked]>
To: <[email-masked]>
Sent: Sunday, July 30, 2000 1:17 AM
Subject: [SIP] Behaviour of the expires header