Subject: RE: Softswitches (was Re: [SIP] SIP->XML->SOAP)

From: "Gardell, Steve" <[email-masked]>
Date: Mon, 3 Jul 2000 12:30:33 -0400

Thanks for the pointer Neil. 

Given current market-driven definitions, Henry's 
description (definition) of softswitches is 
reasonable, but I would note that a number
of vendors talk of using "softswitches" in
contexts where there is no (direct) SS7
signaling. For example one leading telcom
vendor used a "softswitch" as a foundation
for a new IP-PBX. Also, "softswitches" are promoted as 
"interior" service platforms (e.g. not controlling
any MG's) by several large telcom vendors.

SIP is a wonderful tool for service creation in 
it's own right, but I don't think that Henry's article 
really does justice to "API approaches" to service 
creation and standardization such as JAIN/JTAPI.
At the least a reasoned discounting might be in
order.

Lastly, in a heterogeneous world order (where it
just ain't all IP), it seems to me that softswitches
are a step in the right direction, especially if
we allow that it is a "poor softswitch that is
not also a SIP Proxy." As a representative of the
company (Verizon) with the largest number of POTS 
lines in the US, I am not sure what choice I have...

Steven Gardell
GTE Laboratories
Voice: 781-466-2681, Fax: 781-466-3375

> -----Original Message-----
> From: Neil Deason [mailto:[email-masked]]
> Sent: Monday, July 03, 2000 12:08 PM
> To: Gardell, Steve
> Cc: 'Henry Sinnreich'; [email-masked]'
> Subject: Softswitches (was Re: [SIP] SIP->XML->SOAP)
> 
> 
> Check out:
> 
> http://www.computertelephony.com/article/CTM20000608S0021
> 
> As Henry explains in more detail here where a 'Softswitch' 
> is used to preserve the signaling and control architecture 
> of SS7 and the Intelligent Network the vendor who implements 
> the Softswitch owns control over services. This reinvents 
> the failings of the IN/PSTN whereas SIP seeks to build new 
> services and empower service creation by end users.
> 
> Cheers,
> Neil
> -- 
> Ubiquity Software Corporation, UK          
> http://www.ubiquity.net
> 
> "Gardell, Steve" wrote:
> > 
> > I apologize for the double posting. Read
> > "MGC" rather than "MG". What I get for
> > going on vacation...
> > 
> > > -----Original Message-----
> > > From: Gardell, Steve
> > > Sent: Monday, July 03, 2000 7:07 AM
> > > To: 'Matt Holdrege'; Henry Sinnreich
> > > Cc: [email-masked]
> > > Subject: RE: [SIP] SIP->XML->SOAP
> > >
> > >
> > > I have been on vacation, so appologies for the
> > > belated response. After struggling to explain
> > > "softswitches" to operations folks here, we
> > > settled on a very general definition that could
> > > be taken to include MG's, SIP Proxy Servers,
> > > H.323 routed GK's as well as the more switch-like
> > > constructs being defined by the Multi-Media
> > > Switching Forum. However, as near as we can tell,
> > > today "softswitch" is a marketing term most
> > > closely associated with the IETF MG.
> > >
> > > What definition is implicit in the "value" commentary
> > > here?
> > >
> > > Steven Gardell
> > > GTE Laboratories
> > > Voice: 781-466-2681, Fax: 781-466-3375
> > >
> > >
> > > > -----Original Message-----
> > > > From: Matt Holdrege [mailto:[email-masked]]
> > > > Sent: Wednesday, June 21, 2000 4:32 PM
> > > > To: Henry Sinnreich
> > > > Cc: [email-masked]
> > > > Subject: RE: [SIP] SIP->XML->SOAP
> > > >
> > > >
> > > > At 07:09 AM 6/18/00 -0500, Henry Sinnreich wrote:
> > > > > >> SIP->XML would converge the SIP methods and required
> > > > > >parameters to XML and
> > > > > >> allows the introduction of a DTD or schema to define
> > > > > >the syntax of a valid
> > > > > >> SIP message.
> > > > >
> > > > >Do not forget that endangering the deployment of SIP as is,
> > > > >would set IP telephony back for a generation and leave 
> the field
> > > > >for "softswitches" and other such nonsense. Nobody on this
> > > > >mailing list would then live to see true/open Internet
> > > > >communications, but just the old circuit switch central control
> > > > >model with its terrible signaling. Just using IP as a cheap
> > > > >wire.
> > > >
> > > > Henry,
> > > >
> > > > This is the first time I recall seeing "softswitches" being
> > > > denigrated on
> > > > an IETF list. I would hope you realize that they are an
> > > > enabler to get the
> > > > circuit switched world to migrate to open communications?
> > > Saying that
> > > > Softswitches will preserve the circuit switched world with
> > > > it's "terrible
> > > > signalling" is a bit short-sighted.
> > > >
> > > > You should also realize that SIP is doing quite well in the
> > > > area of market
> > > > acceptance. The more people buy into SIP the more 
> evolution will be
> > > > required. Change is inevitable even though we must try to
> > > > manage it well.
> > > > XML is one such change that seems (to me) to be inevitable.
> > > > So it would be
> > > > better to try and manage the interactions with SIP and XML
> > > > here in the IETF
> > > > rather than elsewhere. Besides, it's part of the openess that
> > > > we all should
> > > > encourage.
> > > >
> > > >
> > > >
> > > > _______________________________________________
> > > > SIP mailing list
> > > > [email-masked]
> > > > http://lists.bell-labs.com/mailman/listinfo/sip
> > > >
> > >
> > 
> > _______________________________________________
> > SIP mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/sip
> 
> -- 
> Ubiquity Software Corporation, UK          
> http://www.ubiquity.net
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henry Sinnreich <[email-masked]>
Date: Mon, 03 Jul 2000 14:47:12 -0500

In the Internet context, which is the only one of interest for
this IETF list, a softswitch seems to be a marketing term for an
IP telephony gateway that acts as a SIP UA on the IP side. This
has been mentioned below by Steve Gardell. There is nothing
wrong with it. (There seem also to be trademark applications
from several vendors that include the name "softswitch").

Also no problem with
>"softswitches" are promoted as
>any MG's) by several large telecom vendors.

Problems seem to arise when circuit switch vendors promote the
softswitch as an "exterior" service platform, across the net.
Even without going into the technical issues, it seems we would
then end up with a "Softswitchnet" instead of the Internet. This
seemed far fetched to me until I actually heard a circuit switch
vendor promoting the "Next Generation Public Network" that
actually went so far as to discard the Internet completely!

More problems arise when a GC is promoted to control IP phones.
In this case, a competitor to the operator for that GC could not
extend features to the GC controlled phones. This is a prime
example of fogging up the Internet, actually of reinventing
unequal access at the control level. Besides, how do you
integrate the services of xGCP phones with other services on the
Internet?

The above may be mistaken opinions, but there are also questions
such as, how does a softswitch environment handle:
Presence?
Instant Messaging?
Unified Messaging?
Caller and called preferences?
Mobility?

I suspect softswitch designers can find a way to solve all the
above, but how will such an approach compare to SIP? Is it
targeted to be an IETF standard?
Would appreciate any insight from the list.

Some time ago, SIP and H.323 comparisons were made in a number
of places. Is it now time to make SIP-softswitch comparisons?

Thanks, Henry

>From: [email-masked]
>[mailto:[email-masked]]On Behalf Of
>Gardell, Steve
>Sent: Monday, July 03, 2000 11:31 AM
>To: 'Neil Deason'
>Subject: RE: Softswitches (was Re: [SIP] SIP->XML->SOAP)
>
>

---

From: Matt Holdrege <[email-masked]>
Date: Mon, 03 Jul 2000 14:06:23 -0700

>actually went so far as to discard the Internet completely!

There is nothing we can do about vendor marketing approaches here.

>integrate the services of xGCP phones with other services on the

There is nothing we can do about competitive control of phones or services 
here. All we can do is build protocols. How they are used in the above 
context is way outside our scope.

>Caller and called preferences?

The Softswitch could incorporate each of those features. But the more 
likely scenario is that they would use SIP to communicate to ASP's that 
provide those features. A SIP phone may not need a softswitch to do this, 
but the umpteen billion non-SIP phones need a little help.

This style of open service delivery is one of the great things about our 
next-gen architecture.

>of places. Is it now time to make SIP-softswitch comparisons?

SIP and Softswitches are not mutually exclusive. Pretty much all 
Softswitches speak SIP now or will in the near future.

---

From: Neil Deason <[email-masked]>
Date: Tue, 04 Jul 2000 09:45:35 +0100

> At the least a reasoned discounting might be in

A problem with these APIs tends to be the 
lack of support for them. JTAPI must be about 
4 years old now and how many implementations of 
it are there? It is nice for Sun to define the 
Java interfaces for just about everything, but 
everybody else has to be convinced to go and 
actually implement them. 

As JAIN appears to want to be the mother of all 
telecom interfaces we will have to wait to see 
what happens there. But I can't recall seeing 
much progress over the last year from JAIN. 
Maybe someone from Dynamicsoft has a better
perspective on the situation as they are leading
the JAIN-SIP initiative?

Cheers,
Neil.

> > -----Original Message-----

[snip]

---

From: Henry Sinnreich <[email-masked]>
Date: Tue, 04 Jul 2000 11:12:25 -0500

Matt, thanks for the reasoned note. One item:
>A SIP phone may not need a
>softswitch to do this,

SIP RJ-11 to RJ-45 adapters are now available and could be
available as consumer devices with consumer price points. Such
adapters are actually one-channel IP telephony gateways and are
fully qualified SIP UAs under user control. Compliant with
Internet transparency. Personally, I would always prefer a SIP
Ethernet to black phone adapter that gives me free choice of
service provider to  xGCP phones controlled by the Telco as in
old times. Would you really have your analog phones controlled
by the Telco, rather then being able to point them to any SIP
server of your choice?

Henry

>Sent: Monday, July 03, 2000 4:06 PM
>To: Henry Sinnreich
>Cc: 'Neil Deason'; Gardell, Steve; [email-masked]

---

From: Matt Holdrege <[email-masked]>
Date: Tue, 04 Jul 2000 08:35:13 -0700

>by the Telco, rather then being able to point them to any SIP

Sure, but I think it may be a few years before everyone in the world has 
such a phone which is why we need to help them into a more open 
architecture. Even with XGCP controlled phones, things are way more open 
than with the circuit-switched world.

---

From: "Rajeev Gupta" <[email-masked]>
Date: Thu, 6 Jul 2000 21:38:25 -0700

> Henry Sinnreich wrote:
> Would you really have your analog phones controlled by the
> Telco, rather then being able to point them to any SIP server
> of your choice?

1) As far as I know, your analog phones *are* controlled by the telco. It is
a dumb device, acting upon the stimulus of the network (controller). To a
degree, a GCP phone (or an IAD that connects to an analog phone) would
simulate similar functionality.

2) You have the choice today to run your SIP UA on your desktop connected to
your ISP, and thus talk to any SIP server of your choice. Similarly, you
could connect your GCP phone or IAD to any MGC that will talk to you.  The
protocol model (SIP vs GCP) does not imply a business model (open/free vs
controlled/fee).

3) This is not a technical issue, rather a business issue of whether MGCs
provide their service for free, like today's SIP servers. It is not hard to
imagine that SIP servers will evolve to provide value-add services for a
fee, just as some folks may deploy experimental MGCs that, like SIP proxies,
provide free services (clearly net-to-net calls, that do not gateway to the
PSTN, can be provided free of cost, and there are many examples of that
today).

4) Given that you can use the "free" Internet for voice using the protocol
of your choice (SIP, GCP, H.323, etc.), why then would you want a fee-based
service? Clearly, this will be driven by additional values the service
provider can deliver such as SLAs, QoS, enhanced services, etc.

It seems you are mixing the SIP vs GCP argument with the business model of
delivering services to users.

Rajeev Gupta
empowerTel Networks
475 Sycamore Drive, Milpitas, CA 95035
Phone: +1 408 519 7136
Fax: +1 408 519 7399
mailto:[email-masked]
http://www.empowertel.com

Personally, I would always prefer a SIP

Henry

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 07 Jul 2000 10:07:26 -0400

Rajeev Gupta wrote:

> protocol model (SIP vs GCP) does not imply a business model (open/free vs

Not quite. While you can have as many SIP identifiers you want (implying
that you can get services and calls from as many companies as you like),
your phone can only be controlled by one MGC at a time. (You can
obviously switch to another one, but then you can't receive calls
through the former one any more.)

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: Henry Sinnreich <[email-masked]>
Date: Fri, 07 Jul 2000 16:19:19 -0500

The issue of "softswitches" - the good, the bad and the ugly in
the context of the Internet architecture should IMHO be the
topic of an IETF plenary, similar to the WAP discussion at the
47th IETF.

On another venue, there will be a "SIP and Softswitch" session
at the VON Fall 2000 with four speakers from the industry. See
Session 1 at
http://pulver.com/von/schedule.html

Henry

>[mailto:[email-masked]]On Behalf Of Rajeev Gupta
>Sent: Thursday, July 06, 2000 11:38 PM
>To: 'Henry Sinnreich'