Subject: RE: [SIP] summary: DTMF and voice-over-packet

From: "Culpepper, Bert" <[email-masked]>
Date: Thu, 13 Jul 2000 09:34:12 -0500

The technical issue with only carrying DTMF in RTP is that
my media server just grew 7 to 10-fold in terms of media port
(RTP port plus vocoder port) count.  That's the increase in
media port capacity my pre/post-paid calling card service
node needs to provide an equivalent feature set and maintain
the same overall call handling capacity it had in the PSTN.

Is there a flaw in this logic?  A call signaling message seems
a lot more desirable to me.

Regards,
Bert Culpepper

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Tuesday, July 11, 2000 11:45 PM
To: Christian Huitema
Cc: 'Kevin Davis'; [email-masked]
Subject: Re: [SIP] summary: DTMF and voice-over-packet

Christian Huitema wrote:
> 
> > From: Kevin Davis [mailto:[email-masked]]
> > ...
> > 4) Today, the telephone keypad interface is linked to DTMF.
> >   If or when this relationship should change is another
> >   matter.  If it should change, it is still important to
> >   maintain compatibility with a huge installed base of DTMF.
> 
> Nobody is proposing to cut support for DTMF. The argument is that,
out of
> two ways to support DTMF, the out of band solutions that include
DTMF
> translations in the signalling channel don't carry over to voice
> recognition, while the in band solutions that establish a specific
RTP leg
> to the DTMF handler also work for voice recognition. Ergo, we should
> consider that the "DTMF in RTP" solution is adequate and stop
worrying about
> the addition of DTMF verbs, or parameters, in SIP itself.

Exactly. Well said.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 13 Jul 2000 10:57:22 -0400

"Culpepper, Bert" wrote:
> Is there a flaw in this logic? 

Yes.

There are no ports here. All this comes in over IP, on an ethernet
interface or what have you.

There are NO DSP RESOURCES OR VOCODERS. The DTMF is already been
detected. Its encapsulated in RTP in completely decoded form, EXACTLY
THE SAME as you would get it in INFO.

The difference as far as your platform is concerned, pretty much comes
down to whether a DTMF digit arrives in a big packet on port 5060, or a
smaller packet on a dynamic port. 

-Jonathan R.