Subject: [SIP] send only media streams

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 18 Aug 2000 10:49:01 -0400

I believe rahul's question is aimed at a slight inconsistency in
appendix B.2, which says:

> For receive-only and send-or-receive streams, the port number and
>    address in the session description indicate where the media stream
>    should be sent to by the recipient of the session description, either
>    caller or callee. For send-only streams, the address and port number
>    have no significance and SHOULD be set to zero.

So, the caller sends a stream recvonly. So, the callee wishes to accept
it. Clearly its sendonly from their perspective. According to the above,
the port is set to zero. But, later on:

> If caller and callee have no media formats in common for a particular
>    stream, the callee MUST return a session description containing the
>    particular "m=" line, but with the port number set to zero, and no
>    payload types listed.

which says its set to zero as well, but with no payload types. That
would be fine, and there would be no inconsistency here. However, we
have observed this to be inconsistent with rfc2327, which mandates at
least one codec there:

> media-field =         "m=" media space port ["/" integer]
>                          space proto 1*(space fmt) CRLF

Sooo, what is the significance of port zero in the response to INVITE
for an offered recvonly stream responded with sendonly?

I believe the solution is that we modify the latter text in SIP to read:

> For receive-only and send-or-receive streams, the port number and
>    address in the session description indicate where the media stream
>    should be sent to by the recipient of the session description, either
>    caller or callee. For send-only streams, the address and port number
>    have no significance and MAY be set to any value, but MUST NOT be set to zero.

i.e., we have port zero mean ONE THING only - refusal of a media stream.

-Jonathan R.

rahul pande wrote:
> 
> hello all,
>   I had a query regarding a call flow in SIP. The caller sends me a recvonly
> request for a unicast session which i want to reject, how do i reply to his
> request :
> The request which i have received is as follows :
> 
>    CALLER :
>           INVITE....
>           ..........
> 
>           v=0
>           ..........
>           m=audio 3241 rtp/avp 0
>           a=recvonly
>           m=vedio 3245 rtp/avp 1
> 
> I want to reject his first media stream, can someone please tell me what
> will be the response.
> 
>          Thanking you all,
>            rahul
> ________________________________________________________________________
> Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 22 Aug 2000 17:38:01 -0400

B.2, August 6th (-01) edition says:

  For receive-only and send-or-receive streams, the port number and
   address in the session description indicate where the media stream   
   should be sent to by the recipient of the session description, either
   caller or callee.  For send-only RTP streams, the address and port   
   number indicate where RTCP reports are to be sent. (RTCP reports are 
   sent to the port number one higher than the number indicated.)

You seem to be citing something else. What am I missing?
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs