Subject: Re: [SIP] A query on SIP call flow

From: "rahul pande" <[email-masked]>
Date: Fri, 18 Aug 2000 09:14:12 GMT

>rahul pande wrote:
>
> > hello all,
> >   I had a query regarding a call flow in SIP. The caller sends me a 
>recvonly
> > request for a unicast session which i want to reject, how do i reply to 
>his
> > request :
> > The request which i have received is as follows :
> >
> >    CALLER :
> >           INVITE....
> >           ..........
> >
> >           v=0
> >           ..........
> >           m=audio 3241 rtp/avp 0
> >           a=recvonly
> >           m=vedio 3245 rtp/avp 1
> >
> > I want to reject his first media stream, can someone please tell me what
> > will be the response.
> >
> >          Thanking you all,
> >            rahul
> > _

Hishab wrote:
>
>I would suggest 403 Forbidden response (server understands the request but
>refuses to fulfill it), or 415 Unsupported Media type.  I would go for 403.
>
>Regards,
>Hisham

Hi, I don't want to reject the whole message but only the first media 
stream, I'm still accepting the second media stream.
    regards,
     rahul
_______________________________________________________________________
> > Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com
> >
> > _______________________________________________
> > SIP mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/sip
>
>
>
>_______________________________________________
>SIP mailing list
>[email-masked]
>http://lists.bell-labs.com/mailman/listinfo/sip

________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Hisham Khartabil <[email-masked]>
Date: Fri, 18 Aug 2000 12:27:13 +0300

You would send a 200 OK, the body of that response would contain your
capabilities.

Hisham