Subject: [SIP] Operating a SIP Client behind a Firewall

From: Harleen Gill <[email-masked]>
Date: Wed, 16 Aug 2000 10:10:06 -0700

Is there any recommendation on how to keep a timed connection "alive" 
between a SIP client that is behind a firewall and a SIP server that is 
outside the firewall?  

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jiri Kuthan <[email-masked]>
Date: Wed, 16 Aug 2000 19:35:04 +0200

> between a SIP client that is behind a firewall and a SIP server that is

What do you mean by a timed connection between SIP clients and servers?

I see two separate packet flow classes:

a) Signaling

  Typically, there is a static permission in firewall that 
allows UDP traffic from/to a SIP proxy at port 5060 to pass
through. 
  Keeping a session alive is a SIP issue, which works the same
way regardless if firewalls are deployed or not.

b) Media

Either the firewall implements an embedded SIP ALG and 
opens media pinholes dynamically or a SIP proxy instructs
the firewall to do so.

There is a document on firewall traversal:
draft-rosenberg-sip-firewalls-00.txt

Jiri