Subject: Re: [SIP] A query on SIP call flow

From: "rahul pande" <[email-masked]>
Date: Fri, 18 Aug 2000 10:26:38 GMT

>rahul pande wrote:
>
> > >rahul pande wrote:
> > >
> > > > hello all,
> > > >   I had a query regarding a call flow in SIP. The caller sends me a
> > >recvonly
> > > > request for a unicast session which i want to reject, how do i reply 
>to
> > >his
> > > > request :
> > > > The request which i have received is as follows :
> > > >
> > > >    CALLER :
> > > >           INVITE....
> > > >           ..........
> > > >
> > > >           v=0
> > > >           ..........
> > > >           m=audio 3241 rtp/avp 0
> > > >           a=recvonly
> > > >           m=vedio 3245 rtp/avp 1
> > > >
> > > > I want to reject his first media stream, can someone please tell me 
>what
> > > > will be the response.
> > > >
> > > >          Thanking you all,
> > > >            rahul
> > > > _
> >
> > Hishab wrote:
> > >
> > >I would suggest 403 Forbidden response (server understands the request 
>but
> > >refuses to fulfill it), or 415 Unsupported Media type.  I would go for 
>403.
> > >
> > >Regards,
> > >Hisham

> >rahul wrote :

> > Hi, I don't want to reject the whole message but only the first media
> > stream, I'm still accepting the second media stream.
> >     regards,
> >      rahul
> >

>Hisham wrote :

>You would send a 200 OK, the body of that response would contain your
>capabilities.
>
>Hisham
>

hi,
It might sound silly but can u tell me exactly how should i respond to the 
request, it will be a 200OK response and i should have one to one mapping 
"m=" lines in that case what will be the contents of my first "m=" line in 
the example specified above.
    Thanking you,
       rahul

________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Scott Orton" <[email-masked]>
Date: Fri, 18 Aug 2000 08:23:30 -0500

If you just want to reject the first media stream the 200 response should 0 
the port for the meadia streams you want to reject. This is explained in
detail in appendix B of the latest draft and the RFC. You have to respond
one to one for each m line sent to you.

CALLED:
    SIP/2.0 200 .........
    .............
    
    v=0
    ............
    m=audio 0 RTP/AVP 0
    m=video 6546 RTP/AVP 1

Scott 

-----Original Message-----
From: rahul pande [mailto:[email-masked]]
Sent: Thursday, August 17, 2000 11:22 PM
To: [email-masked]
Subject: [SIP] A query on SIP call flow

hello all,
  I had a query regarding a call flow in SIP. The caller sends me a recvonly

request for a unicast session which i want to reject, how do i reply to his 
request :
The request which i have received is as follows :

   CALLER :
          INVITE....
          ..........

          v=0
          ..........
          m=audio 3241 rtp/avp 0
          a=recvonly
          m=vedio 3245 rtp/avp 1

I want to reject his first media stream, can someone please tell me what 
will be the response.

         Thanking you all,
           rahul

---

From: "rahul pande" <[email-masked]>
Date: Fri, 18 Aug 2000 14:22:34 GMT

rahul wrote :
>_______________________________________________________________________

Scott wrote :

>CALLEE:
hi,
   A callee responding to the first media stream will basically be sending a 
"a=sendonly" response for that "m=" media stream. So when you reply back to 
the requester in the above manner, the caller receiving this response would 
interprert the following for the first "m=" media stream :

       1) Since its a one to one mapping for his "a=recvonly" request, he 
would logically assume that the reply is "a=sendonly", even if the callee is 
accepting a media stream there is no hard and fast rule that he should 
respond with a "a=" line, its logically understood.

       2) The SIP rfc states that :

    " For send-only streams, the address and port number
   have no significance and SHOULD be set to zero. "

         Through the above statement a callee who wants to accept the media 
stream might also put a port no. as 0 in his reply.

       So, i hope u understand what i am trying to say i.e. even if the 
responder is wanting to accept the requested first media stream, the SIP rfc 
recommends him to put the port to 0. Now how will he reject the offer. Its a 
race condition.
       Please let me know if i have not been clear in explaining my doubt or 
if its just a silly one.

      Thanking you,
          rahul