Subject: RE: [SIP] Change in SIP URL syntax

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Thu, 10 Aug 2000 19:14:51 -0700

Sorry, I meant to reply to this a while back.

This is with regards to the telephone-subscriber ambiguity (again) 
(eg sip:ABCD;telparam=[email-masked];user=phone).

Was the conclusion that
a) an unescaped '@ is allowed in a parameter as long is it is not ambiguous.
(ie, sip:ABCD;telparam=[email-masked];toad=dog@cat;user=phone is ok)
or
b) '@' must always be escaped in parameter names and values.

I personally feel the latter is safer and I'm not sure if your reply is
supporting this viewpoint.

If that is the case then won't '@' also have to be removed from
param-reserved ?

Robert.

-- My opinions are my own. I tried selling them once but everybody
	seems to already have one. -- 
> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Wednesday, August 02, 2000 9:53 AM
> To: Fairlie-Cuninghame, Robert
> Cc: 'Ajay Chitturi'; Gethin Liddell; [email-masked]
> Subject: Re: [SIP] Change in SIP URL syntax
> 
> 
> The current version reads:
> 
>   hname           = 1*( hnv-unreserved | unreserved | escaped )
>   hvalue          = *( hnv-unreserved | unreserved | escaped )
>   hnv-unreserved  = "[" | "]" | "/" | "?" | ":" | "+" | "$"
> 
> Thus, @ MUST be escaped (if it doesn't have syntax 
> significance). It is
> also listed as a separator.
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 10 Aug 2000 22:25:05 -0400

> If that is the case then won't '@' also have to be removed from

@ is a reserved character (being a separator with syntactic
significance).
Reserved characters must be escaped. I'm not sure from what it must be
removed since it doesn't appear in any explicit listing of unreserved
characters. 

unreserved    = alphanum | mark
      mark    = "-" | "_" | "." | "!" | "~" | "*" | "'" |
                      "(" | ")"

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs