Subject: Re: [SIP] CPL, WML, VoiceXML and SIP Features

From: Tom Gray <[email-masked]>
Date: Sun, 13 Aug 2000 15:53:54 -0700 (PDT)

It would be nice if the inter-relationships between
these protocols (CPL, WML, VoiceXML and SIP features)
and the call processing problem could be captured in
an informational RFC to eliminate duplicated effort
and to identify areas in which no protocol has been
set up. An expecially important set of topics would be
areas in which it would be undesirable for a protocol
to be created.

There was a suggestion here previously that CPL be
extended to encompass switches on authorization. This
is coming perilously near the use of CPL to handle
classes of service. This would be one step on an
infinite journey of defining a call processing
architecture which could not be finished. it would be
like painting the Golden Gate Bridge. When it is done,
it is time to start over.

Tom Gray

__________________________________________________
Do You Yahoo!?
Yahoo! Mail – Free email you can access from anywhere!
http://mail.yahoo.com/

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jiri Kuthan <[email-masked]>
Date: Tue, 15 Aug 2000 01:48:06 +0200

Tom Gray wrote:
> An expecially important set of topics would be

The motivation for the CPL authentication extension is call 
processing logic may depend on authentication status. 
Consider, for example, a SIP-2-PSTN gateway. Operator of 
the gateway may want to provide 800 and local calls for free 
to anyone whereas LD calls only to authenticated users.
Using CPL scripts to specify which calls will be accepted
and which not seems the most natural way to me. 

Note that the CPL extension does not require creating 
a new protocol.

If you still see some complexity of "painting the Golden
Bridge" grade, please be more specific. (And please use the
iptel mailing list rather than sip.)

Jiri