Subject: RE: [SIP] Simplify SIP

From: "Bratakos, Maroula" <[email-masked]>
Date: Fri, 18 Aug 2000 11:13:56 -0700

I'd like to re-interate what Jonathan said in a previous email on this
thread (see below) that there is already a fair amount of SIP out there
already so this discussion might be coming too late.  The last thing we need
are interoperability issues with SIP implementations that are coming out at
different times.

Maroula Bratakos

-----Original Message-----
From: Pete Cordell [mailto:[email-masked]]
Sent: Friday, August 18, 2000 10:48 AM
To: Jonathan Rosenberg; Gethin Liddell
Cc: Bertil Engelholm; [email-masked]
Subject: Re: [SIP] Simplify SIP

Just to add my two pence...

I found line folding and the comma separation a bit of a pain when doing our
SIP implementation.

I feel that if someone does a quick and dirty implementation of SIP, then
this is something they may either forget or just leave out.

As one of the attractions of SIP is its simplicity (at least the appearance
of such!), then I feel such quick and dirty jobs may appear in a number of
places.  This would lead to interoperability problems.

Therefore I think it would be reasonable for the spec to strongly suggest
that messages generated by a UA should not use line folding and comma
separation.  I think such advice would remove a whole bunch of potential
interoperability problems between industrial strength implementations and
quick jobs you might knock up in Perl or something to give you some neat
feature.

However, I agree that if you want to be industrial strength then you have no
choice but to cope with line-folding and comma separation for ever more.

Pete.

=============================================
Pete Cordell
Tech-Know-Ware
[email-masked]
+44 1473 635863
=============================================

----- Original Message -----
From: Jonathan Rosenberg <[email-masked]>
To: Gethin Liddell <[email-masked]>
Cc: Bertil Engelholm <[email-masked]>;
<[email-masked]>
Sent: 18 August 2000 15:53
Subject: Re: [SIP] Simplify SIP

> If I had it over again, I would eliminate line folding, case
> insensitivity, and a host of other things. But, when the spec was begun,
> it was decided that rather than inventing new syntax, we would borrow
> from a clearly successful, highly interoperable, well understood
> protocol for which a whole lot of code was available. That meant we
> inherited the good along with the bad.
>
> Because we must be backwards compatible with rfc2543, there is no choice
> but to insist implementations handle line folding and other things (in
> reality its not so bad once you construct a tokenizer than knows about
> line folding. In this way, it is handled once. My old C code for this
> was on the order of 50 lines). We could have rfc2543bis insist on
> sending in some canonical form, but it won't help parsers which must
> anyway handle the various forms. I suppose eventually those could be
> phased out, but there is a fair amount of SIP out there already, so I
> don't know that non-canonical form would be gone that soon.
>
> -Jonathan R.
>
> Gethin Liddell wrote:
> >
> > i agree.
> >
> > the sip specification is not easy to implement, for the main reason
> > that you have to be able to accept the same information in many
> > different ways.
> >
> > conforming to the canonicial form should not be a hardship for anyone
> > and will make everyone's implementations faster thanx to a, probably
> > quite noticable, efficiency gain.
> >
> > On Fri, 18 Aug 2000, Bertil Engelholm wrote:
> > > Hello,
> > >
> > > we would like to start a discussion about the possibility of making
> > > SIP more simple than today. We realize that it's a little late to
> > > make big changes in the protocol at this stage but the change we

... snip...

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Pete Cordell" <[email-masked]>
Date: Fri, 18 Aug 2000 23:31:20 +0100

Nothing I said contradicted this point that Jonathan made....

Pete.

----- Original Message -----
From: Bratakos, Maroula <[email-masked]>
To: 'Pete Cordell' <[email-masked]>; Jonathan Rosenberg
<[email-masked]>; Gethin Liddell <[email-masked]>
Cc: Bertil Engelholm <[email-masked]>;
<[email-masked]>
Sent: 18 August 2000 19:13
Subject: RE: [SIP] Simplify SIP