Subject: Re: [SIP] Media & Signaling inter-dependencies, issue with 183 ?

From: "Ashutosh Dutta" <[email-masked]>
Date: Sun, 20 Aug 2000 18:02:13 -0400

Hi,
            IP mobility solution would probably work fine for intra-domain case
with fast hand-off mechanism, some of which have been  proposed recently. But
for Interdomain case we still need a better solution than just plain  IP
mobility approach for reducing the loss (if we care about it) when the IP
address changes on the wireless handset. We may have a need to adopt a hybrid
approach in that case.

Thanks
Ashutosh

Michael Thomas <[email-masked]> on 08/19/2000 01:14:20 PM

To:   Jean-Hugues ROBERT <[email-masked]>
cc:   Michael Thomas <[email-masked]>, Jonathan Rosenberg
      <[email-masked]>, "Arnoud van Wijk (ETM)"
      <[email-masked]>, "'SIP'" <[email-masked]> (bcc:
      Ashutosh Dutta/Telcordia)
Subject:  Re: [SIP] Media & Signaling inter-dependencies, issue with 183  ?

Jean-Hugues ROBERT writes:
 > At 09:02 AM 8/19/00 -0700, Michael Thomas wrote:
 > >   If you want decomposed, use MGCP/MEGACO.
 >
 > When wireless IP phone IP address is changed, early
 > media need to be delivered to the new IP address, not the old one. That is
 > were a RTP Switcher is needed.

   This is if you make the assumption that you can't
   use IP mobility instead which solves the general
   problem. I've seen some pretty promising work on
   that front which looks like it converges very, very
   fast. Application layer routing should be the last
   option, not the first in my opinion.

 > >   There are some clear disadvantages of trying to
 > >    use some UA-like proxy though: namely garden
 > >    walls, end to end transparency, and far worse,
 > >    privacy/security. In order to justify this sort
 > >    of architecture, the cost savings would need to
 > >    be at least an order of magnitude down on a
 > >    cost item that actually impacts the COG's
 > >    significantly. This ain't one of them, IMO.
 >
 > Good points. Fact is, there is no such thing as a cheap IP phone, wireless
 > or not... yet.

 > What is "COG" ?

   Sorry, cost of goods.

            Mike

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Michael Thomas <[email-masked]>
Date: Mon, 21 Aug 2000 10:28:21 -0700 (PDT)

> address changes on the wireless handset. We may have a need to adopt a hybrid

   Why would you ever want to change the home IP
   address at all? If you believe in mobility,
   then you obtain new COA's and the problem
   reduces to a (solvable) AAA problem.

	      Mike

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 21 Aug 2000 13:33:46 -0400

>    reduces to a (solvable) AAA problem.

This assumes, of course, that you can get a generally accessible IP
address where you can install a HA. If you're behind a firewall at
"home" and don't have the support of the local sysadmin, this is
non-trivial. The lack of deployment of mobile IPv4 seems to attest to
this difficulty.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: Michael Thomas <[email-masked]>
Date: Mon, 21 Aug 2000 10:57:12 -0700 (PDT)

> non-trivial. The lack of deployment of mobile IPv4 seems to attest to

   This assumes that the HA is always at "home".

   Also: I'm not sure how you're naming your UA
   behind the NAT/firewall without the help of
   some sysadmin type person.

		Mike

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 21 Aug 2000 14:06:43 -0400

Michael Thomas wrote:

>    This assumes that the HA is always at "home".

No, but it has to be somewhere where the network is willing to give me a
permanent IP address. I'm not aware of such a service, although it would
be quite useful.

>    some sysadmin type person.

Not really. I can imagine using a permanent address of the
hotmail/yahoo/etc. variety without any sysadmin help and without fees.
There is no shortage of user or domain names. I could run such a service
on my DSL line at home, with one IP address.

---

From: Michael Thomas <[email-masked]>
Date: Mon, 21 Aug 2000 11:38:39 -0700 (PDT)

> permanent IP address. I'm not aware of such a service, although it would

For every problem there is an equal and opposite
opportunity. :-)

I personally think there is a good deal of
motivation for wireless things to not have their
HA on the same subnet as their real home
subnet. The main reason is that a dog-leg through
a comparatively slow access (cable, DSL, etc) that
almost certainly wants you to pay for QoS bits
doesn't sound like a very ideal situation to
me. It would be a lot cleaner to put the HA in the
middle of a diffserv cloud and be done with it.

 > on my DSL line at home, with one IP address.

What bound the A record to your domain name?

	       Mike

---

From: Michael Thomas <[email-masked]>
Date: Mon, 21 Aug 2000 11:57:21 -0700 (PDT)

Henning Schulzrinne writes:
 > Network Solutions, register.com or any of its competitors that offer DNS
 > 'hosting' for a few bucks a year.

   It's hard to determine who is being more obtuse
   here, but it appears to me that we've come full
   circle to there not being any reason to change
   your home IP addresses when roaming.

	     Mike

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 21 Aug 2000 15:05:25 -0400

>    your home IP addresses when roaming.

We're talking about completely different things:

- I can, with existing tools and services, build a service today that
allows application-layer mobility, even running it out of my attic on my
DSL line with a single static IP address. (Since this fictional service
would never see a single voice packet, regardless of whether the caller
or callee supports binding updates, this would work as long as the
signaling traffic is less than about 60 kb/s in my case.) Obviously, so
could hotmail, yahoo, or a dedicated SIP "roaming" provider, without
requiring a unique IP address per customer. This would offer mobility
for customers with any type of access, as long as they have a (changing
set) of IP addresses they can be reached at. The ISPs serving the
customer are obviously not at all involved.

- I could also install a HA at home for me, but that would only work for
me (and wouldn't work if I had only dial-up access). Apparently, that's
what you're referring to.

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 21 Aug 2000 14:43:14 -0400