Subject: [SIP] SDP: `s' & `t' lines

From: [email-masked]
Date: Thu, 17 Aug 2000 09:09:19 +0530 (IST)

This is with regard to the torture tests in 
"draft-ietf-sip-call-flows-00.txt"

The SDP announcements in most of those tests (section 8.1 onwards) do 
NOT have `s' & `t' lines. The attached text says that the total SIP
message is `correctly formatting'.

According to the SDP grammar, however, both are mandatory lines.
So, is that an error or not?

[Yes, I know that there was a thread on making the `s' line
optional, but it doesn't seem to have been resolved. Or has it?]

Thanks.

Example attached below:
----------------------------------------------------------------------------
8.1 INVITE Parser Torture Test Message

   This message is a correctly formatting SIP message. It contains:

         line folding all over
         escaped characters within quotes
         LWS between colons, semicolons, headers, and other fields
         both comma separated and separate listing of headers
         mix or short and long form for the same header
         unknown header field
         unusual header ordering
         nested comments
         unknown parameters of a known header

   Proxies should forward message and clients should respond as to a
   normal INVITE message.

   Message Details

   INVITE sip:[email-masked] SIP/2.0
   TO :
    sip:[email-masked] ;   tag    = 1918181833n
   From   : "J Rosenberg \\\"" <sip:[email-masked]>
     ;
     tag = 98asjd8
   Call-ID
    : [email-masked]
   cseq: 8
     INVITE
   Via  : SIP  /   2.0
    /UDP
       135.180.130.133
   Subject :
   NewFangledHeader:   newfangled value
    more newfangled value
   Content-Type: application/sdp
   v:  SIP  / 2.0  / TCP     12.3.4.5   ;
     branch  =   9ikj8  ,
    SIP  /    2.0   / UDP  1.2.3.4   ; hidden
   m:"Quoted string \"\"" <sip:[email-masked]> ; newparam =
   newvalue ;
     secondparam = secondvalue  ; q = 0.33
     (((nested comments) and (more)))   ,
    tel:4443322

   v=0
   o=mhandley 29739 7272939 IN IP4 126.5.4.3
   c=IN IP4 135.180.130.88
   m=audio 492170 RTP/AVP 0 12
   m=video 3227 RTP/AVP 31
   a=rtpmap:31 LPC
----------------------------------------------------------------------------

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 17 Aug 2000 01:05:09 -0400

SIPs usage of SDP must be compliant to rfc2327. As s is mandatory in
SDP, its mandatory to be used when SDP is used within SIP. We should fix
these errors in the call flows document.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com