Subject: RE: [SIP] The NOTIFY method

From: Tom Gray <[email-masked]>
Date: Mon, 7 Aug 2000 15:48:35 -0700 (PDT)

--- Henry Sinnreich <[email-masked]> wrote:
> >May I ask why SIP is being extended to include PBX
> >feature handling?
> 
> SIP phones can provide the PBX features without the
> (IP)PBX.
> 
> Henry
> 

What levels of features do you then see being created
with SIP?  There a a whole host of PBX features. It
seems that you are asking for a subset.

Tom Gray

> >-----Original Message-----
> >From: [email-masked]
> >[mailto:[email-masked]]On Behalf Of
> Tom Gray
> >Sent: Monday, August 07, 2000 10:37 AM
> >To: Robert Sparks; [email-masked]
> >Subject: Re: [SIP] The NOTIFY method
> >
> >
> >May I ask why SIP is being extended to include PBX
> >feature handling? Isn't this an example of creeping
> >featurism which could kill a protocol?
> >
> >--- Robert Sparks <[email-masked]> wrote:
> >> If you have not already done so, please look over
> >> draft-ietf-sip-cc-transfer-00.txt (attached for
> >> convenience) and comment.
> >> 
> >> We missed the original target for completing this
> >> work. If there are any issues with the draft,
> lets
> >> work through them as soon as possible.
> >> 
> >> Thanks!
> >> RjS
> >> 
> >> 
> >
> >
> >__________________________________________________
> >Do You Yahoo!?
> >Kick off your party with Yahoo! Invites.
> >http://invites.yahoo.com/
> >
> >
> >_______________________________________________
> >SIP mailing list
> >[email-masked]
> >http://lists.bell-labs.com/mailman/listinfo/sip
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip

__________________________________________________
Do You Yahoo!?
Kick off your party with Yahoo! Invites.
http://invites.yahoo.com/

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Rohan Mahy <[email-masked]>
Date: Tue, 08 Aug 2000 09:28:46 -0700

Hi,

The philosophy of SIP call control is to create a small number of 
*primitives* that can be used to deliver a much larger number of features.

REFER  is a primitive which asks another UA to send a SIP request on the 
Referrer's behalf.  It can be used for "Transfers", but you can also use it 
for 3rd party desktop call control, and we will probably take advantage of 
the primitive to build collaborative applications (conferencing).

I estimate that we can get all the PBX features (past, present, and future) 
using three to five well-defined primitives.

Hope this helps.

thanks,
-rohan