Subject: [SIP] isomorphic clarification

From: "Garret Wilson" <[email-masked]>
Date: Thu, 10 Aug 2000 12:23:15 -0700

The SIP specification states that, "Two requests or responses are defined to
be isomorphic for the purposes
of this document if they have the same values for the Call-ID, To, From and
CSeq header fields."

The phrase, "same values" seems to be undefined, which means that what it
means for two header fields to be equal is unspecified. For example, if two
"From" strings are identical except that the second one specifies a port of
":5060", do these two value have the "same value?"

sip:[email-masked]
sip:[email-masked]:5060

(After all, since 5060 is the default SIP port, the first SIP-URI really has
the same port as the second.)

Cheers,

Garret

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 11 Aug 2000 08:52:07 +0300

Hi,

>The SIP specification states that, "Two requests or responses are defined >to be isomorphic for the purposes of this document if they have the same >values for the Call-ID, To, From and CSeq header fields."
> 
>means for two header fields to be equal is unspecified. For example, if >two "From" strings are identical except that the second one specifies a >port of ":5060", do these two value have the "same value?"

Yes.
 
>sip:[email-masked]
>sip:[email-masked]:5060
> 
>(After all, since 5060 is the default SIP port, the first SIP-URI really >has the same port as the second.)

That is correct.

Regards,

Christer Holmberg
Ericsson Finland

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 11 Aug 2000 13:22:56 -0400

> of this document if they have the same values for the Call-ID, To, From and

The -01 draft also mentions that the Request URIs must be identical, to
support spirals.

As an additional thing, the *top* Vias must be the same, in order to
detect merged requests. We should add this here and elsewhere in the
document as needed.

You later write:
> I just realized that the latest spec explains how to compare URIs. The
> question remains that, if two URI's are equal yet not identical in string
> format, are two From headers (for example) which contain these two URIs
> considered to have the "same value" as per the definition of isomorphic?

Yes. Two FRoms are equal if (1) their URIs match under URI comparison,
(2) their From parameters match, based on standard matching rules for
header parameters (case sensitive equality of both name and value). 

It might be a good idea to formally define "identical" in this section.
Its a constant source of confusion and problems at the bakeoffs.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 11 Aug 2000 17:52:49 -0400

> detect merged requests. We should add this here and elsewhere in the

Might be good to have an example for this.

> header parameters (case sensitive equality of both name and value).

Presumably parameters missing in one of the From/To are ignored in the
comparison. This seems to work for 'tag'.

Note that according to RFC 2616 and the BNF definition, 

"literal"
      Quotation marks surround literal text. Unless stated otherwise,
      the text is case-*in*sensitive.

Added to URI section (not sure what you mean by "this section").

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs