Subject: RE: [SIP] send only media streams

From: Meir Fuchs <[email-masked]>
Date: Mon, 21 Aug 2000 18:17:11 +0300

Hi,

  What about a RTCP ? Shouldn't the terminals sending the media on
send-only/recv-only streams pass a non-zero port on which they can receive
RTCP traffic ?

Meir.

> -----Original Message-----
> From:	Jonathan Rosenberg [SMTP:[email-masked]]
> Sent:	Friday, August 18, 2000 5:49 PM
> To:	sip
> Subject:	[SIP] send only media streams
> 
> I believe rahul's question is aimed at a slight inconsistency in
> appendix B.2, which says:
> 
> > For receive-only and send-or-receive streams, the port number and
> >    address in the session description indicate where the media stream
> >    should be sent to by the recipient of the session description, either
> >    caller or callee. For send-only streams, the address and port number
> >    have no significance and SHOULD be set to zero.
> 
> So, the caller sends a stream recvonly. So, the callee wishes to accept
> it. Clearly its sendonly from their perspective. According to the above,
> the port is set to zero. But, later on:
> 
> > If caller and callee have no media formats in common for a particular
> >    stream, the callee MUST return a session description containing the
> >    particular "m=" line, but with the port number set to zero, and no
> >    payload types listed.
> 
> which says its set to zero as well, but with no payload types. That
> would be fine, and there would be no inconsistency here. However, we
> have observed this to be inconsistent with rfc2327, which mandates at
> least one codec there:
> 
> > media-field =         "m=" media space port ["/" integer]
> >                          space proto 1*(space fmt) CRLF
> 
> 
> Sooo, what is the significance of port zero in the response to INVITE
> for an offered recvonly stream responded with sendonly?
> 
> I believe the solution is that we modify the latter text in SIP to read:
> 
> > For receive-only and send-or-receive streams, the port number and
> >    address in the session description indicate where the media stream
> >    should be sent to by the recipient of the session description, either
> >    caller or callee. For send-only streams, the address and port number
> >    have no significance and MAY be set to any value, but MUST NOT be set
> to zero.
> 
> i.e., we have port zero mean ONE THING only - refusal of a media stream.
> 
> -Jonathan R.
> 
> rahul pande wrote:
> > 
> > hello all,
> >   I had a query regarding a call flow in SIP. The caller sends me a
> recvonly
> > request for a unicast session which i want to reject, how do i reply to
> his
> > request :
> > The request which i have received is as follows :
> > 
> >    CALLER :
> >           INVITE....
> >           ..........
> > 
> >           v=0
> >           ..........
> >           m=audio 3241 rtp/avp 0
> >           a=recvonly
> >           m=vedio 3245 rtp/avp 1
> > 
> > I want to reject his first media stream, can someone please tell me what
> > will be the response.
> > 
> >          Thanking you all,
> >            rahul
> > ________________________________________________________________________
> > Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com
> > 
> > _______________________________________________
> > SIP mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/sip
> 
> -- 
> Jonathan D. Rosenberg                       72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
> http://www.dynamicsoft.com
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 21 Aug 2000 10:26:57 -0500

Meir,

Last I checked the RTCP had to be one greater than the RTP port to which it
corresponded.

--Brian

Meir Fuchs wrote:                             (Mon, 21 Aug 2000 18:17:11)

---

From: "Chris Fulmer" <[email-masked]>
Date: Mon, 21 Aug 2000 15:11:45 -0400

I think that's the point -- if you're sending '0' as your port number, does that
mean that your RTCP port is port 1 ??  I suppose you could do that once, but man
is that going to screw around with RFC 1078.  In send-only mode, you still
expect RTCP Receiver-Reports from the receiver, and in receive-only mode, you
still send them back.

--
C