Subject: [SIP] some inconsistencies in SIP rfc

From: "rahul pande" <[email-masked]>
Date: Tue, 08 Aug 2000 14:10:20 GMT

The foll. example is given in SIP rfc :
   v=0
   o=alice 2890844526 2890844526 IN IP4 host.anywhere.com
   c=IN IP4 host.anywhere.com
   m=audio 49170 RTP/AVP 0
   a=rtpmap:0 PCMU/8000
   m=video 51372 RTP/AVP 31
   a=rtpmap:31 H261/90000
   m=video 53000 RTP/AVP 32
   a=rtpmap:32 MPV/90000

The callee, Bob, does not want to receive or send the first video
stream, so it returns the media description below:

   v=0
   o=bob 2890844730 2890844730 IN IP4 host.example.com
   c=IN IP4 host.example.com
   m=audio 47920 RTP/AVP 0 1
   a=rtpmap:0 PCMU/8000
   a=rtpmap:1 1016/8000
** m=video 0 RTP/AVP 31 ****** some payload value is specified
   m=video 53000 RTP/AVP 32
   a=rtpmap:32 MPV/90000

The above is the example specified in the SIP rfc, but its contradicting 
with the following statement in SIP rfc under Appendix B:

   If caller and callee have no media formats in common for a
   particular stream, the callee MUST return a session description
   containing the particular "m=" line, but with the port number
   set to zero, and no payload types listed.

Again the above statement "no payloads type listed" contradicts with the SDP 
rfc since its grammar does not allow the format list to be empty or blank. 
Its :
     media-field = "m=" media space port ["/" integer]
                    space proto 1*(space fmt) CRLF

________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 08 Aug 2000 10:44:10 -0400

>    set to zero, and no payload types listed.

This statement is incorrect. It will be fixed in the next revision of
the draft. A payload value must be specified, as per rfc2327. It doesn't
matter what its value is.

-Jonathan R.
-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com