Subject: [SIP] via headers required?

From: "Garret Wilson" <[email-masked]>
Date: Thu, 3 Aug 2000 16:01:29 -0700

draft-ietf-sip-2542bis-00 claims, in section 6.45.1, that all requests must
contain at least one "Via:" header. Yet there are examples in the same
document that don't. Are via headers required?

Garret Wilson

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 03 Aug 2000 23:46:00 -0400

Yes, they are always required since the UAC MUST insert them.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: "Garret Wilson" <[email-masked]>
Date: Fri, 4 Aug 2000 07:37:18 -0700

In response to the several questions about the location of the missing
"Via:" headers, the missing via's start (or, more correctly, don't start) on
page 106 of the PDF version (section 16.6), with Alice's server replying to
Charles'. Missing via's continue with section 16.7, "Negotiation", and 16.8,
"OPTIONS Request," etc.

Garret

----- Original Message -----
From: "Hisham Khartabil" <[email-masked]>
To: "Garret Wilson" <[email-masked]>
Sent: Friday, August 04, 2000 2:50 AM
Subject: Re: [SIP] via headers required?

> Can you point them out so they can be fixed, I couldn't find any.
>
> Regards,
> Hisham
>
> Garret Wilson wrote:
>