Subject: [SIP] INVITE a=sendrecv, 200ok a=sendonly a=recvonly..?

From: "rahul pande" <[email-masked]>
Date: Mon, 07 Aug 2000 07:41:05 GMT

hi all,
Pl. answer the queries or refer a url
i have few queries to ask :

1) if caller requests the foll.
    m=<some description> 0 1
    a=sendrecv
if the callee supports only sendonly with 0
and recvonly with 1 then how can he specify this
in his response
would it be:
    m=<some description> 0
    a=sendonly
    m=<some description> 1
    a=recvonly
but the above will voilate the sip rfc where it specifies that
there should be one to one mapping b/w the requests and the response.

2) The netmeeting tool of Microsoft implements the H323 stack and there
we have a provision for file transfer too, can we do the same using SIP
stack,
but how will we convey the request in the SDP.

3) another query on SDP responses:
if caller sends a request:
    m=<some description> <fmt>
    a=recvonly
and the callee supports it, does it have to change the a= value to
sendonly in the response i.e.
    m=<some description> <fmt>
    a=sendonly
or the above will be assumed by the caller on receipt of the positive
response
________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 09 Aug 2000 11:13:34 -0400

> there should be one to one mapping b/w the requests and the response.

Correct. This is not something that is expressable in SDP, at least in
a single pass. The caller should probably accept the call with one of
sendonly or recvonly, and then do re-INVITE to add the stream in the
other direction.

> but how will we convey the request in the SDP.

I don't know of a specific definition of an ftp session within SDP;
seems easy to do.

> or the above will be assumed by the caller on receipt of the positive

The spec doesn't say. I think either will work, with a=sendonly being
the most correct thing.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com