Subject: RE: [SIP] The NOTIFY method

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 8 Aug 2000 08:27:14 -0400

My opinion is that where it is essential that two sip components
agree on how a feature is to be handled, then there should be
some kind of document that describes how that works, so that
interoperability can be achieved.  If the feature is solely implemented
in a single element, then it is not something we need to 
worry about.

Just because there needs to be a document does not imply a standards
track RFC.  Only things which are not achievable with existing SIP
methods might need extensions.  Other features might be covered in
other kinds of documents, Informational RFCs for example, or even
documents not in the IETF.  

> -----Original Message-----
> From: Tom Gray [mailto:[email-masked]]
> Sent: Monday, August 07, 2000 6:49 PM
> To: Henry Sinnreich; Robert Sparks; [email-masked]
> Subject: RE: [SIP] The NOTIFY method
> 
> 
> 
> --- Henry Sinnreich <[email-masked]> wrote:
> > >May I ask why SIP is being extended to include PBX
> > >feature handling?
> > 
> > SIP phones can provide the PBX features without the
> > (IP)PBX.
> > 
> > Henry
> > 
> 
> What levels of features do you then see being created
> with SIP?  There a a whole host of PBX features. It
> seems that you are asking for a subset.
> 
> Tom Gray
> 
> 
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Alan Johnston <[email-masked]>
Date: Wed, 09 Aug 2000 15:19:29 -0500

Brian,

The next call flows document, SIP Service Examples (based on what was
section 7 from draft-ietf-sip-call-flows-00.txt which uses Bye-Also) will
cover many of these issues, and will hopefully become an Informational
RFC.   The basic goal of the document will be to give examples of common
PSTN Class and PBX features using SIP.  The draft will use REFER and other
new methods and extensions.

Alan.