Subject: [SIP] Last Call: Reliability of Provisional Responses in SIP to Proposed Standard

From: The IESG <[email-masked]>
Date: Fri, 25 Aug 2000 17:25:53 -0400

The IESG has received a request from the Session Initiation Protocol
Working Group to consider Reliability of Provisional Responses in SIP
<draft-ietf-sip-100rel-02.txt> as a Proposed Standard.

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action.  Please send any comments to the
[email-masked] or [email-masked] mailing lists by September 8, 2000.

Files can be obtained via
http://www.ietf.org/internet-drafts/draft-ietf-sip-100rel-02.txt

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 30 Aug 2000 11:07:53 -0400

This is the SIP list, not the SCTP list.  If you have questions on
SCTP, you might want to take them over to the SCTP list
([email-masked]).

SCTP runs over IP, and does not use UDP or TCP.  Originally, it
was going to be layered on UDP (not TCP), but that was changed.
It now runs directly on IP, as a layer 4 equivalent to UDP or TCP.

Brian

> -----Original Message-----
> From: Vijay K. Gurbani [mailto:[email-masked]]
> Sent: Tuesday, August 29, 2000 6:36 PM
> To: jimmy Zhang
> Cc: [email-masked]
> Subject: Re: [SIP] Last Call: Reliability of Provisional Responses in
> SIP to Proposed Standard
> 
> 
> jimmy Zhang wrote:
>  
> > I thought SCTP is an application level protocol that is 
> designed to be
> > transported over TCP/IP. 
> 
> It is -- for now.  I belive the intent is for it to be 
> another transport
> in addition to UDP and TCP and reside at the transport layer, or if it
> does not reside at the transport layer, to directly use the 
> services of
> the IP layer (a la ICMP or OSPF).  BTW, IP had another 
> "faster than TCP" 
> but "more reliable than UDP" protocol called RDP (Reliable Datagram
> Protocol) -- don't know why it never caught on (if you look in your 
> /etc/protocols file, you may still find an entry for it).  W. Richard 
> Stevens in one of his seminal books proposes T/TCP 
> (Transaction Oriented 
> TCP) to be in much the same vein.  Don't know why it never caught on, 
> either.
> 
> > My question is why it would be faster than TCP/IP. 
> 
> Take a look at 
> http://search.ietf.org/internet-drafts/draft-ietf-sigtran-sctp-13.txt
> for many reasons.
> 
> > Also what is the point of build an application level 
> protocol on top 
> > of another?
> 
> Quick acceptance.  Until (and unless?) vendors modify their 
> IP kernels 
> to support another transport protocol, the easiest and most portable
> way is to run it as an application level protocol.
> 
> I believe vendor support is coming soon.  Sun folks are talking about 
> using SCTP for AAA.  Storage Area Network folks are talking about it
> as well.
> 
> Regards,
> 
> - vijay
> -- 
> Vijay K. Gurbani  [email-masked] [email-masked] 
> [email-masked]
> Internet Software Group/Intelligent Network and Instant Messaging
> Lucent Technologies/Bell Labs Innovations, 263 Shuman Blvd, Rm 1A-413
> Naperville, Illinois 60566  Voice: +1 630 224 0216 Fax: +1 
> 630 713 0184
> 
> 
>