Subject: [SIP] separate SIP and stream addresses

From: Chris Durand <[email-masked]>
Date: Tue, 29 Aug 2000 14:39:57 -0600

I'm new to SIP and want to make sure I understand how addressing of the
streams is done. In particular, I want to check that it is not required that
the audio be routed to the same IP address as the SIP messages.
For example if I want all SIP messages to be sent to 192.168.200.1, but I
want the audio for a particular call to be sent to 192.168.200.5, port 3456
, is it legal to do the following:

C->S:	INVITE sip:[email-masked] SIP/2.0
	Via: SIP/2.0/UDP some.server.com
	From: 192.168.200.1
	To: Test <sip:[email-masked]>
	Call-ID: [email-masked]        
	CSeq: 1 INVITE
	Contact: 192.168.200.1
	Subject: Send audio there, no here.
	Content-Type: application/sdp
	Content-Length: ...

	v=0
	o=- 53655765 2353687637 IN IP4 192.168.200.1
	s=Please send audio here.
	t=3149328600 0
	c=IN IP4 192.168.200.5			<---- address to send RTP
packets to
	m=audio 3456 RTP/AVP 0 3
	a=rtpmap:0 PCMU/8000
	a=rtpmap:3 GSM/8000

Note that the address in "From"/"Contact" is different from the address in
"c=". Is this the proper way to do it?
Thanks

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 29 Aug 2000 23:05:42 -0400

> the audio be routed to the same IP address as the SIP messages.

Correct - it is not required.

>         c=IN IP4 192.168.200.5                  <---- address to send RTP

Your syntax is a bit wrong; the Contact header is a URL, as is the From:

From: sip:[email-masked]
Contact: sip:[email-masked]

Otherwise OK.

-Jonathan R.
-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com