Subject: RE: [SIP] The NOTIFY method

From: Tom Gray <[email-masked]>
Date: Tue, 8 Aug 2000 11:37:28 -0700 (PDT)

--- Rohan Mahy <[email-masked]> wrote:
> Hi,
> 
> The philosophy of SIP call control is to create a
> small number of 
> *primitives* that can be used to deliver a much
> larger number of features.
> 

Thanks for the reply. How would SIP, in itself, be
used to deliver such features as Group Pick Up,  Line
Appearance , Call Back and so on? Extensions to do
these would seem to be getting into the functioning of
the user agent and the definition of other agent
types.

Tom Gray

__________________________________________________
Do You Yahoo!?
Kick off your party with Yahoo! Invites.
http://invites.yahoo.com/

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henry Sinnreich <[email-masked]>
Date: Tue, 08 Aug 2000 15:30:05 -0500

How would SIP, in itself, be
>Appearance , Call Back and so on?

Call flows posted for the SIP WG and some available at
http://www.softarmor.com/sipwg/drafts/ cover such PBX functions.

The central call agent makes you have the PBX network all over
again, only this time over IP. With all the properties of
proprietary PBX's.

It would be of interest to make an inventory of advanced
features published for SIP and map them to existing PBX features
and finally to make a list of what PBX features make really
sense for SIP.

Henry

>-----Original Message-----
>From: Tom Gray [mailto:[email-masked]]
>Sent: Tuesday, August 08, 2000 1:37 PM
>To: Rohan Mahy
>Cc: Henry Sinnreich; Robert Sparks; [email-masked]
>Subject: RE: [SIP] The NOTIFY method
>
>
>

---

From: Rohan Mahy <[email-masked]>
Date: Tue, 08 Aug 2000 18:01:24 -0700

Hi,

You are right that most "features" will be implemented in the UAs.  They 
will only need to support the appropriate primitives, and have some way to 
invoke them in the propoer combination (probably a URI or URI-list), and 
code to render meaningful messages/status.

Specifically, several folks on the list have commented at various times on 
how to do Call Park and Pickup, Conferencing, Transfer, 3rd party call 
control, message waiting, etc.  Call queuing and forwarding are already 
built into the protocol.

thanks,
-rohan