Subject: [SIP] Bakeoff #5 Advanced Scenarios: Media Changes summary for one group

From: "Brett Tate" <[email-masked]>
Date: Wed, 16 Aug 2000 21:18:09 -0400

Here is my attempt at summarizing the results of 
SIP Bakeoff #5 advanced testing of media switching
for one of the two participating groups.

Please forgive any errors or omissions.

Brett Tate
BroadSoft

------------------------------------------------------
SIP Bakeoff #5: Advanced Media Testing
unofficial summary for one of the two groups. 

It was decided that session hold and retrieval did 
not need to be tested.  However the importance of an
INVITE without SDP to pull a held party off of hold 
was reiterated for its use by third party call controllers. 

Scenario 1) 

Allow a re-INVITE to occur which changes 
the SDP's connection address and port for an 
active call.

It was soon decided that the scenario could not
be initiated by the players involved.  If I remember 
correctly, it was decided that putting the call 
on hold before the switch invalidated the scenario.

The players in the scenario were Cisco, Nuera, 
VegaStream and BroadSoft.

Scenario 2) 

Allow the media codec to change during call setup.

A--B--C
    |
    D

A invites C with B acting as a proxy/controller.  
A passes two encoder possibilities within the SDP.
C returns 180 with SDP choice 1.
B cancels the invite to C and invites D.
D returns 180 with SDP choice 2 and answers using 
choice 2.

The test was not completed because of lack of time
before players started leaving for the airport.

Player A was performed by Cisco and Nuera. 
Player B was BroadSoft.
Players C and D were performed by VegaStream, 
Pingtel, Vovida, and BroadSoft.

Additional scenario idea for next bakeoff:

Same as scenario 2 but D passes back 180 
without SDP.  

Expected result: ringing switches from remote to local.

---

From: "IPTelephonyJobs.com" <[email-masked]>
Date: Sun, 20 Aug 2000 21:58:23 -0700

Hello,

   We have launched IPTelephonyJobs.com. The site is
dedicated to IP Telephony professionals. The following
areas are specifically targeted among others:

     VoIP (h.323, mgcp, sip, megaco, call agents...)
     PSTN(ss7, isdn, ain/in,..)
     Wireless(gprs, cdma, gsm,...)
     IP Routing/Switching
     + others

Services offered to Job Seekers:

 - Profile only entries lets you keep your personal information private.

 - Profile + Resume entries lets the employer have a better understanding of
your background.

 - Control access to your resume on demand.

So just drop by our site and fill in your profile.

http://www.iptelephonyjobs.com

[email-masked]

---

From: "IPTelephonyJobs.com" <[email-masked]>
Date: Wed, 30 Aug 2000 00:28:18 -0700

Hello,

   - Profile + Resume entries lets the employer have a better understanding
of your background.

  [email-masked]