Subject: [SIP] Nit in 2543bis

From: David Shrader <[email-masked]>
Date: Thu, 10 Aug 2000 10:54:45 -0400

Henning,

I found a small discrepancy in 2543bis regarding the Contact header in the
INVITE message. 

Section 6.5 Contact states "INVITE requests MUST ... contain Contact
headers..."

Section 11.1 Caller Issues Initial INVITE Request states "A UAC MAY
optionally add a Contact header ..."

Which is the correct requirement here?

David

----------------------------
David Shrader
Master Consultant, Inc.
[email-masked]
http://www.EyeForTheFuture.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 10 Aug 2000 11:27:35 -0400

> Which is the correct requirement here?

The latter, contained in the bis-01 version to appear tomorrow. (The I-D
announcement today is for the old, July 13th, version and should be
ignored.)
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 10 Aug 2000 11:28:18 -0400

> optionally add a Contact header ..."

Oops, wrong reference in my previous email. MUST is the right choice.
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs