Subject: [SIP] Sending ACKs using Request-URI ??

From: Bertil Engelholm <[email-masked]>
Date: Tue, 24 Oct 2000 18:03:58 +0200

Hi again,

I now have another question. It says in the specification 
that ACKs should be sent according to the REQUEST-URI.

Why shouldn't it be sent according to ROUTE ?

Isn't there a risc that the message will take another path
through the network if you use the REQUEST-URI ? 

-- 
Bertil Engelholm
AXE Research and Development        voice : +46 8 727 3499
SIP Security                        Fax   : +46 8 647 8276
S-126 25 Stockholm Sweden           E-mail:
[email-masked]

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 24 Oct 2000 13:28:48 -0400

ACKs for non-200 are hop by hop, and thus need to be sent the same place the
request was sent. ACKs for 200 do indeed follow the Route headers.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Bertil Engelholm [mailto:[email-masked]]
> Sent: Tuesday, October 24, 2000 12:04 PM
> To: [email-masked]
> Subject: [SIP] Sending ACKs using Request-URI ??
> 
> 
> Hi again,
>