Subject: RE: [SIP] Re: draft-ietf-sip-session-timer-02.txt

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 31 Oct 2000 12:22:05 -0500

> -----Original Message-----
> From: Adam B. Roach [mailto:[email-masked]]
> Sent: Monday, October 30, 2000 11:23 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [SIP] Re: draft-ietf-sip-session-timer-02.txt
> 
> 
> > I know this email is ancient, but I am finally
> > getting around to updating
> > this. So, here are some comments:
> ...
> > > 
> > > In section 4, you specify that the lack of
> > > require and session-timer headers in an
> > > INVITE response imply that the UAC has no
> > > further actions to take. This is somewhat
> > > misleading. If, for example, the UAC sends
> > > a "Supported: timer" header and a
> > "Session-Expires"
> > > header, but receives no timer indication in the
> > > response, he still should be responsible for
> > > initiating the periodic re-INVITEs for his
> > > own use.
> > 
> > I disagree. In this case, neither proxies nor the
> > UAS are interested in the
> > timer. Why send periodic re-INVITES if no one cares?
> 
> Because the *UAC* is interested in knowing if
> the far side goes down. Perhaps a subtle point
> that isn't even necessarily related to the draft.

Good point. It does need to be addressed, actually. I've added text for
handling this case. It'll be in the -04 version.

> > > How, for
> > > example, does the calling UA handle the
> > > 420 response? Yes, this is fairly straightforward,
> > > but I really think it should be outlined in
> > > the text of the draft.
> > 
> > Good point. This scenario is likely to be confusing
> > for the
> > UAC. Thats because it doesn't know session timer,
> > didn't put
> > a Require in the request, yet gets back a 420 Bad
> > Extension.
> > I recall we discussed this on the list and several
> > people felt
> > strongly about having the ability of proxies to put
> > in Require
> > despite this problem. 
> 
> Yes. If you dig back in the archives to find the
> thread that started the whole session-refresh
> bit, you'll find that the entire initial motivation
> was to allow call-stateful proxies to have a sure-fire
> way to tell whether a call is up. Remember the
> proposal for the "PING" method? This is what came of
> those discussions. If the final result is that
> proxies cannot insist on some mechnanism to
> determine liveness of a call (not just a UA -- a
> *call* in particular), then this has been an
> academic exercise, as far as I'm concerned.
> 
> The point I was attempting to make by this
> comment is that you should probably explicitly
> point out that the UAC will treat this 420 as
> any other 4xx class failure, and the call will
> not be set up.

I've added a note explicitly discussing this situation.

> 
> > > - Section 8.4, the first message from the SPS
> > >   to the called UA should have a "Require" header
> > >   in it (I think).
> > 
> > No. Proxy insertion of Require is not recommended.
> 
> "Since the proxy requires session timer..." would
> seem to imply that the proxy requires (not desires)
> a session timer. If the called party doesn't support
> the session timer, we need to have appropriate 
> handling.

THis text has changed in -03 to say "want" instead of "require".

> 
> I guess that this could be done by having the proxy
> note whether the response from the UAS contains
> the "Session-Expires" header, and adding it back
> in if not present. This situation (UAS doesn't
> support timer, UAC does, and proxy requires it)
> probably warrants its own call flow.

"Session Timer without Called UA Support" handles this case,
excepting the proxy *desires*, not *requires* it.

> 
> In any case, shouldn't the called UA to SPS
> message contain a "Required" header to indicate
> that the timer is being used for this session?
> I thought this was the way that feature negotiation
> worked.

No; the presence of Require would tell the UAC that some
feature has been applied to the response. But, in this case,
the calling UA doesn't understand the feature. So, the REquire
header is not appropriate.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Adam B. Roach" <[email-masked]>
Date: Tue, 31 Oct 2000 19:44:33 -0600 (CST)

>header is not appropriate.

Aha. Yes, that makes sense. I think the text in the draft clarifying 
this point is new (or I missed it the first time around).

A quick glance through the current draft looks good. I'll get out
my fine-toothed comb in a bit and see if I find any other minor
glitches.

-- 
Adam Roach, Ericsson Inc. |  Ph: +1 972 583 7594 | 1010 E. Arapaho, MS L-04
[email-masked]   | Fax: +1 972 669 0154 | Richardson, TX 75081 USA