Subject: RE: [SIP] Registrar - Require or Proxy-Require

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 23 Oct 2000 10:09:13 -0400

Its Require.

Remember, registrar, proxy, UA are *logical* roles. If it answers a
REGISTER, its a registrar for that transaction. Require applies to entities
that actually answer a request, and thus, is appropriate for a registrar.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Neil Deason [mailto:[email-masked]]
> Sent: Monday, October 23, 2000 9:04 AM
> To: [email-masked]
> Subject: [SIP] Registrar - Require or Proxy-Require
> 
> 
> Is there a general consensus whether the Require or 
> Proxy-Require header should be used by clients to request
> features of a Registrar? Require seems more correct as the
> Registrar is the terminating server. However, a Registar
> is typically co-located with a proxy. Maybe a clear 
> statement in the spec would remove any scope for confusion.
> 
> Cheers,
> Neil.
> -- 
> Ubiquity Software Corporation, UK        http://www.ubiquity.net
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Neil Deason <[email-masked]>
Date: Mon, 23 Oct 2000 15:31:25 +0100

I agree that Require is the right choice. Section 6.35 
Require only refers to User Agent Servers using the header 
though not Registrars. 

Cheers,
Neil.

---

From: "Christopher A. Martin" <[email-masked]>
Date: Mon, 23 Oct 2000 09:39:48 -0500

I have a question regarding IPSec as a hop-by-hop authentication soultion.

In SIP bis 02 (section 13.2), an example is stated: "If required, hop-by-hop
authentication can be provided, for example, by the IPSEC Authentication
Header". Since the application of hop-by-hop authentication in one of my
scenarios will be IPSec protection between WAN routers only, would it really
matter if it were AH or ESP, besides the cost of CPU cycles?

Example:

UA/UAS---Gateway---WAN ROUTER---(IPSec Authenticated and perhaps encrypted
Link)---WAN ROUTER---Gateway---UA/UAS

As long as the Gateways recieve the original data from the WAN Routers, the
original data should be untouched, correct?

This line of thought is aimed at the KISS way of thinking.

Thanks in advance,
Chris Martin

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Jonathan Rosenberg
Sent: Monday, October 23, 2000 9:09 AM
To: 'Neil Deason'; [email-masked]
Subject: RE: [SIP] Registrar - Require or Proxy-Require

Its Require.

-Jonathan R.

---

---

From: Michael Thomas <[email-masked]>
Date: Mon, 23 Oct 2000 09:29:46 -0700 (PDT)

> matter if it were AH or ESP, besides the cost of CPU cycles?

   No. ESP with message integrity would be just fine.
 > original data should be untouched, correct?

   So long as none of the hosts behind the two security
   gateways are bad guys, of course :-)

		Mike