Subject: RE: [SIP] Registrars and Date

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 10 Oct 2000 04:13:47 -0400

Good catch.

Wouldn't life be easier if every device had a GPS receiver with completely
syncrhonized time.... oh well.

ANyway, there are a few possible solutions here:

1. always send a response with a delta-time if the request had an expires
with a delta-time
2. always use relative times in register responses
3. always send Date in the 200 OK response to INVITE

The third solution is what is proposed by Eric. 2 and 3 assume that
registrars have access to the date. I thinks its a reasonable assumption.

The easiest solution for all is probably 2, as it eliminates another option.
But, I suspect that there are already implementations that always send
absolute times. 

Comments?

-Jonathan R.

> -----Original Message-----
> From: Eric Tremblay [mailto:[email-masked]]
> Sent: Wednesday, September 27, 2000 11:14 AM
> To: [email-masked]
> Subject: [SIP] Registrars and Date
> 
> 
> 
> I have a very simple question/request:
> 
> Would it be possible to make the Date header mandatory in Registrar
> responses?  This would be required if the registrar sends its 
> expires time
> in SIP-date format.
> 
> The reason for this are the following:
> 
> 1- Some embedded devices don't keep track of the time at all.
> 2- Other that do might be connecting to a NTP/SNTP server to 
> acquire the
> notion of time (probably at bootup).  What if the server is down?  The
> device has no knowledge of the time.  This sould not prevent 
> the device from
> registering.  If the date header is not included, the device 
> cannot know for
> how long the registration is valid, until the time server 
> comes back up.
> 
> Regards,
> 
> EricT
> 
> ___________________________________________
> Eric Tremblay      | Mediatrix Telecom Inc.
> Technical Leader   | www.mediatrix.com
> 
> [email-masked]
> tel: +1-819-829-8749 x238
> fax: +1-819-829-5100
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 10 Oct 2000 09:19:54 -0400

> But, I suspect that there are already implementations that always send

I would suggest that servers send Date headers. Everyone does anyways
(as far as I can tell), it allows really simple end systems that use the
registrar for a rough notion of time, without reliance on another
service, and the incremental pain for registrars is zero. We really
don't want to add to the two big blunders in electrical engineering,
blinking 12:00 on VCRs and ISDN phones that have to have their time set
manually...

Restricting Expires headers just adds yet another error condition. 

If the end system truly has no notion of time and gets an absolute
expiration time, it just keeps to the one hour default. If the registrar
doesn't like this, it just gets what it deserves by saving five lines of
program code.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs