Subject: RE: [SIP] Repost: Use of Record-Route and Contact Headers

From: "Emami-Nouri, Mohsen" <[email-masked]>
Date: Thu, 19 Oct 2000 16:03:57 -0700

the following text from bis 6.33 might help better understanding:

"the UAS copies the record-route request header field unchanged into the
response. (record-route is only relevant  for 2xx responses and responses
where  the server can expect the client to retry the same call -id as in 401
or 484" 

-----Original Message-----
From: Phil Hoffer [mailto:[email-masked]]
Sent: Wednesday, October 18, 2000 5:02 AM
To: [email-masked]
Subject: [SIP] Repost: Use of Record-Route and Contact Headers

> Hi,
>
> Table 4 of bis02 states that a Contact header can occur in the following
> response types:
>
> 1xx
> 2xx
> 3xx
> 485 (Ambiguous)
>
> However, Table 5 states that Record-Route can occur in the following
> response types:
>
> 2xx
> 401 (Unauthorized)
> 484 (Address Incomplete)
>
> I don't see how  a response can include a Record-Route, if it can't
contain
> a Contact.
> I believe that 401 and 484 should be added to the list of response types
for
> a Contact header.
>
> What do you think?
>
> Cheers
> Phil (Just appreciating how overloaded Contact header is! :)

Hi again,

No replies so far!
Probably got lost in the deluge.

Thanks In Advance
Phil

http://www.ubiquity.net

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Phil Hoffer" <[email-masked]>
Date: Fri, 20 Oct 2000 10:49:14 +0100

> > contain a Contact.
> > I believe that 401 and 484 should be added to the list of response type
for
> where  the server can expect the client to retry the same call -id as in
401

Hi Moshen,

Yes I'm aware of the paragraph.
My perception is that Record-Route is used to override short cuts in the
routing
provided by the Contact header.

Therefore, if you can expect to receive a Record-Route header in a 401 and a
484
as defined by Table 5 and the stated paragraph, then I'd expect to be able
to receive
a Contact in a 401 and 484. That is why I'm asking if table 4 needs to be
updated.

Regards
Phil

http://www.ubiquity.net