Subject: Re:[SIP] Error in draft-ietf-sip-call-flows-01.txt

From: "Phil Hoffer" <[email-masked]>
Date: Thu, 19 Oct 2000 17:16:15 +0100

Hi,

Just to clarify.
The quoting of some of the authentication parameters in Neal's :) corrected
call flows are
unfortunately incorrect. Specifically, the use of quotation marks on the
algorithm parameter and
stale parameter.

There has been discussion on this list before about the quoting of the
authentication parameters.
I have supplied the authors of the call flows document with updates.

The corrected call flows are listed below.

Cheers,
Phil

http://www.ubiquity.net

--
2.1.1 SIP Client New Registration
F1 REGISTER B -> SIP Server
   REGISTER sip:ss2.wcom.com SIP/2.0
   Via: SIP/2.0/UDP there.com:5060
   From: LittleGuy <sip:[email-masked]>
   To: LittleGuy <sip:[email-masked]>
   Call-ID: [email-masked]
   CSeq: 1 REGISTER
   Contact: LittleGuy <sip:[email-masked]>
   Contact: sip:[email-masked];user=phone
   Contact: tel:+1-972-555-2222
   Content-Length: 0
   F2 401 Unauthorized SIP Server -> User B
   SIP/2.0 401 Unauthorized
   Via: SIP/2.0/UDP there.com:5060
   From: LittleGuy <sip:[email-masked]>
   To: LittleGuy <sip:[email-masked]>
   Call-ID: [email-masked]
   CSeq: 1 REGISTER
   WWW-Authenticate: Digest realm="MCI WorldCom SIP",
domain="wcom.com",
    nonce="ea9c8e88df84f1cec4341ae6cbe5a359", opaque="",
stale=FALSE,
    algorithm=MD5
   Content-Length: 0
   F3 REGISTER B -> SIP Server
   REGISTER sip:ss2.wcom.com SIP/2.0
   Via: SIP/2.0/UDP there.com:5060
   From: LittleGuy <sip:[email-masked]>
   To: LittleGuy <sip:[email-masked]>
   Call-ID: [email-masked]
   CSeq: 2 REGISTER
   Contact: LittleGuy <sip:[email-masked]>
   Contact: sip:[email-masked];user=phone
   Contact: tel:+1-972-555-2222
   Authorization:Digest username="UserB", realm="MCI WorldCom
SIP",
    nonce="ea9c8e88df84f1cec4341ae6cbe5a359", opaque="",
    uri="sip:ss2.wcom.com",
response="dfe56131d1958046689cd83306477ecc"
   Content-Length: 0
   F4 200 OK SIP Server -> B
   SIP/2.0 200 OK
   Via: SIP/2.0/UDP there.com:5060
   From: LittleGuy <sip:[email-masked]>
   To: LittleGuy <sip:[email-masked]>
   Call-ID: [email-masked]
   CSeq: 2 REGISTER
   Contact: LittleGuy <sip:[email-masked]>
   Contact: sip:[email-masked];user=phone
   Contact: tel:+1-972-555-2222
   Content-Length: 0
2.2.1 Unsuccessful SIP registration
F1 REGISTER B -> SIP Server
   REGISTER sip:ss2.wcom.com SIP/2.0
   Via: SIP/2.0/UDP there.com:5060
   From: LittleGuy <sip:[email-masked]>
   To: LittleGuy <sip:[email-masked]>
   Call-ID: [email-masked]
   CSeq: 1 REGISTER
   Contact: LittleGuy <sip:[email-masked]>
   Contact: sip:[email-masked];user=phone
   Contact: tel:+1-972-555-2222
   Content-Length: 0
   F2 Unauthorized SIP Server -> User B

   SIP/2.0 401 Unauthorized
   Via: SIP/2.0/UDP there.com:5060
   From: LittleGuy <sip:[email-masked]>
   To: LittleGuy <sip:[email-masked]>
   Call-ID: [email-masked]
   CSeq: 1 REGISTER
   WWW-Authenticate: Digest realm="MCI WorldCom SIP",
domain="wcom.com",
    nonce="f1cec4341ae6ca9c8e88df84be55a359", opaque="",
stale=FALSE,
    algorithm=MD5
   Content-Length: 0
   F3 REGISTER B -> SIP Server
   REGISTER sip:ss2.wcom.com SIP/2.0
   Via: SIP/2.0/UDP there.com:5060
   From: LittleGuy <sip:[email-masked]>
   To: LittleGuy <sip:[email-masked]>
   Call-ID: [email-masked]
   CSeq: 2 REGISTER
   Contact: LittleGuy <sip:[email-masked]>
   Contact: sip:[email-masked];user=phone
   Contact: tel:+1-972-555-2222
   Authorization:Digest username="UserB", realm="MCI WorldCom
SIP",
    nonce="f1cec4341ae6ca9c8e88df84be55a359", opaque="",
    uri="sip:ss2.wcom.com",
response="61f8470ceb87d7ebf508220214ed438b"
   Content-Length: 0
   /*  The response above encodes the incorrect password
_IForgotIt_ */
   F4 401 Unauthorized SIP Server -> User B
   SIP/2.0 401 Unauthorized
   Via: SIP/2.0/UDP there.com:5060
   From: LittleGuy <sip:[email-masked]>
   To: LittleGuy <sip:[email-masked]>
   Call-ID: [email-masked]
   CSeq: 2 REGISTER
   WWW-Authenticate: Digest realm="MCI WorldCom SIP",
domain="wcom.com",
    nonce="84f1c1ae6cbe5ua9c8e88dfa3ecm3459", opaque="",
stale=FALSE,
    algorithm=MD5
   Content-Length: 0

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Alan Johnston <[email-masked]>
Date: Thu, 19 Oct 2000 12:52:17 -0500

Both of these errors have been previously discussed on the list and have been
corrected in the next draft, due out soon...

Thanks,
Alan Johnston