Subject: Re: [SIP] Conferencing

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 11 Oct 2000 08:24:42 +0300

Hi Aparna,

Check section 3 of:
http://search.ietf.org/internet-drafts/draft-camarillo-3pcc-qos-00.txt

The request-URI is used in order to know which conference you want to
join.
The example includes also a controller.

Regards,

Gonzalo

[email-masked] wrote:
> 
> Hello.
> I have a question about SIP-based conferencing. Let us assume the existence
> of a SIP UA that performs conferencing. SIP UAs that want to join a
> conference send SIP INVITEs to the conference server to conference them in,
> i.e. for an n-party conference, the CS will receive n INVITEs. I believe
> there has to be  a need for corrolation and disambiguation of the different
> call-legs at the conference server. For a dial-in conference such as this, I
> think the easiest (and the most intuitive) way to corrolate all these n
> INVITEs (that have different Call-IDs) is via the dialed number/
> conference-ID  (i.e. the "To" field).
> 
> However, if all these different call-legs were initiated by a third-party
> entity (called the controller) that sent these INVITEs on behalf of the
> actual participants, how should the corrolation and disambiguation of
> call-legs be performed at the conference server?
> 
> I think there are two options:
> a) Same as before. Have each one of the INVITEs have different Call-IDs and
> have the conferencing SIP UA corrolate them based on the "To" field.
> This requires the controller to have a mechanism to corrolate all these
> call-legs at its end.
> 
> b) Mandate that all the call-legs share the same Call-ID. The 'From' field
> in each INVITE  sent to the CS (from the controller) must then be tagged.
> The CS could use the Call-ID to corrolate all these call-legs and the tag in
> the From to help distinguish one from the other.
> 
> Is there a reason to prefer one over the other? Is there a third option that
> I have missed? Is there a preferred/ accepted mechanism to accomplish this
> and is this documented somewhere?
> 
> Thanks,
> Aparna
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Junyoung Heo" <[email-masked]>
Date: Wed, 11 Oct 2000 15:54:22 +0900

Hi, all.

> http://search.ietf.org/internet-drafts/draft-camarillo-3pcc-qos-00.txt

I cannot understand that draft camarillo-3pcc-qos-00.
What is PRACK, COMET ?
I have never seen these methods. Where can I find its definition?

> The request-URI is used in order to know which conference you want to

I know request-URI may be changed by proxies.
So, How changable field can be used as ID?
And, I think, SIP is not necessary to support multi-unicast call itself.
It overburden SIP. I like SIP for its simplicity.
I use origin of SDP for conference ID.

Thanks so much if you point out my misunderstanding about SIP and related doc.

> > and is this documented somewhere?
ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÒ ùšŠX§‚X¬µ"þX¬¶ÏÛzYÿ•¦ìýÊ&†ÛiÿÿåŠËlý·¥—ùZnÏÜ¢oæj)fjåŠËbú?

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 11 Oct 2000 10:44:01 +0300

Hi,

> I cannot understand that draft camarillo-3pcc-qos-00.

Check these references out:

http://search.ietf.org/internet-drafts/draft-ietf-sip-100rel-02.txt
http://search.ietf.org/internet-drafts/draft-manyfolks-sip-resource-01.txt
http://search.ietf.org/internet-drafts/draft-camarillo-manyfolks-confirm-00.txt

Gonzalo

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 11 Oct 2000 08:45:32 -0400

> I have never seen these methods. Where can I find its definition?

You could, for example, consult the SIP web site at
http://www.cs.columbia.edu/sip, under "drafts".

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: Rohan Mahy <[email-masked]>
Date: Mon, 16 Oct 2000 09:39:26 -0700

>So, How changable field can be used as ID?

The requestURI can be changed by proxies... to change it into something
meaningful to the receiving proxies and UAs.

so I can change:  	sip:[email-masked]
into:			sip:[email-masked]

the o= line in the SDP is unlikely to be useful.  hope this helps...

thanks,
-rohan

>/s/s/sip
>.com
>> http://lists.bell-labs.com/mailman/Hƒæj)bž	
>b²Ôˆ>X¬¶ÆÞ­YZnÇ(šm§ÿåŠËlmée•¦ìr‰¿™¨¥™©ÿ+-ŠwèþÈ©