Subject: RE: [SIP] New I-D on SDP and IPv6

From: Christian Huitema <[email-masked]>
Date: Fri, 27 Oct 2000 15:28:09 -0700

Why are you trying to syntactically prevent the use of IPv4 class E
addresses, or IPv4 addresses that terminate in ".0" ? These may not be
terribly useful, but a syntax description is the wrong place to do this kind
of controls. Besides, I can see why I would want in some cases to use a null
address, or an experimental anycast address.

Besides, the whole thing does not seem consistent. You don't spend the same
amount of effort to qualify the fact that there shall be at most 8 hexparts
in the IPv6 address, or that the IPv6 multicast addresses start with a well
known prefix. I believe it would be much simpler to simply use the
definitions:

   IP6-address =         hexpart [ ":" IP4-address ] 
   IP4-address =         decimal-uchar 3*( "." decimal-uchar )
   IP4-unicast = IP4-address
   IP6-unicast = IP6-address
   IP4-multicast = IP4-address
   IP6-multicast = IP6-address

And do the test "is this a multicast address" later, not during parsing.

> -----Original Message-----
> From: Sean Olson [mailto:[email-masked]]
> Sent: Friday, October 27, 2000 12:47 AM
> To: [email-masked]; [email-masked]
> Subject: [SIP] New I-D on SDP and IPv6
> 
> 
> Hello,
> 
> There is a new Internet-Draft available on the use of IPv6
> addresses in SDP. The I-D simply clarifies the syntax to use
> for representing an IPv6 address in an SDP description.
> Any comments are welcome.
> 
> http://www.ietf.org/internet-drafts/draft-olson-sdp-ipv6-00.txt
> 
> Regards,
> Sean Olson <[email-masked]>
> 
> 
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Sean Olson <[email-masked]>
Date: Sun, 29 Oct 2000 20:36:52 +0100

> Christian Huitema wrote:

> address, or an experimental anycast address.

This is based on current text in RFC2327. I wasn't trying to be more
restrictive or more liberal in what was allowed in an IPv4 address in SDP.

The original ABNF was:
   IP4-address =         b1 "." decimal-uchar "." decimal-uchar "." b4
   b1 =                  decimal-uchar
                         ;less than "224"; not "0" or "127"
   b4 =                  decimal-uchar
                         ;not "0"

I'm perfectly happy to remove these restrictions, but this is not the
aim of this Internet-Draft.

> known prefix.

This was a compromise. It is easier to specify this for IPv4 than it is for IPv6
:)
This is not the focus of the I-D either. I would be happy to simplify the v4
ABNF
to its original form.

> I believe it would be much simpler to simply use the
> definitions:
>

I believe the distinction between the unicast and multicast syntax
should be made clearer. I would be happy to revert to a simpler
syntax as long as this distinction is highlighted.

> And do the test "is this a multicast address" later, not during parsing.

This is an implementation issue. The presence of the more restrictive ABNF
is not an attempt to dictate the implementation of the parser. (In fact, as you
note, it would be a poor implementation choice to strictly use the ABNF
as posed for a parser.) But, the more precise ABNF is intended to clarify
the distinction between the multicast and unicast syntax.

Thanks for the comments.
/sean