Subject: RE: [SIP] Session Information

From: [email-masked]
Date: Tue, 10 Oct 2000 14:22:52 +0530

Yes,
Im not keen on having to mandate a protocol just for some size message.
Then, we would be saying that 'for this type of
message, SIP is transport dependant' . And if we must make it transport
independant, lot of dirty application level breakup
and co-relation of UDP would be needed - does not seem to be worth it.

Also, isnt 64K size enough to put SIP into a 'bulk transporter' something
which its not supposed to be ?

imho,  the 64k limit is really enough (hoping that this does not go down as
the infamous '640K memory is all that a computer
needs' quote way) .

Regds
Arjun

--
Arjun Roychowdhury @ Hughes Software Systems

Jonathan Rosenberg <[email-masked]> on 10/10/2000 01:51:53 PM

To:   "'Jo Hornsby'" <[email-masked]>, Jonathan Rosenberg
      <[email-masked]>, archow, "'Sunitha Kumar'"
      <[email-masked]>
cc:   "'Burger Christian'" <[email-masked]>,
      "[email-masked]'" <[email-masked]>

Subject:  RE: [SIP] Session Information

Hmm.

TCP itself would be able to handle SIP messages above 64k, yes. It would
just send them in multiple IP packets.

The problem is, if we have a scenario of TCP->UDP->TCP through proxies,
that
UDP hop is not going to work.

We could mandate the usage of TCP for sending messages over a certain size.
I'm not that fond of this approach, though.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Jo Hornsby [mailto:[email-masked]]
> Sent: Tuesday, October 10, 2000 4:09 AM
> To: Jonathan Rosenberg; [email-masked]; 'Sunitha Kumar'
> Cc: 'Burger Christian'; [email-masked]
> Subject: RE: [SIP] Session Information
>
>
> > > Afaik, there is no MUST limit (maybe except the max size
> > > allocated to a n/w read kernel buffer - usually 64k ? )
> >
> > Maximum IP packed size is 64K, so this represents the absolute upper
> > bound on a SIP message.
>
> How about if I have TCP connection between two UAs, for example?
> I agree in the general case one cannot know whether UDP (or other
> unreliable transport) will be used anywhere along the signalling
> path, but should this rule out messages > 64K?
>
> Cheers,
>
>
>  - Jo.
>
>

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: hammer michael <[email-masked]>
Date: Tue, 10 Oct 2000 11:18:53 -0700

If the "signaling" message becomes that obese, then perhaps it is time to 
split the functionality supported by that message into smaller parts 
supported by multiple smaller messages (not the same as blindly segmenting).

Also, if it is routing information that is causing this, then it is time to 
find a shorter path, that does not waste as much network bandwidth.  Surely 
the added delay is not good.

Mike