Subject: RE: [SIP] Re-direct of Media During Ringing

From: "Mark Watson" <[email-masked]>
Date: Wed, 4 Oct 2000 13:46:37 +0100

Added to this we have the concept of a preliminary one way media stream
(from called party to calling party) which is not charged for - i.e.
alerting or queueing phase.

I guess this has been modelled as 'early media' which occurs before
confirmation of the session, whereas arguably this should be something which
is considered to take place after establishment of the session, but before
charging begins.

Is the problem the fact that session establishment has been equated with
called party answer ?

Regards,

Mark Watson
Nortel Networks

-----Original Message-----
From: Drage, Keith (Keith) [mailto:[email-masked]]
Sent: 04 October 2000 10:42
To: Simon Barber; 'Henning Schulzrinne'
Cc: Jonathan Rosenberg; 'hammer michael'; Doug Harbert; Taylor, Tom-PT ;
'sip'
Subject: RE: [SIP] Re-direct of Media During Ringing

This all appears to be focussing back to the old ISDN/B-ISDN discussions of
what does answer really mean. Essentially there are several concepts that
need to be designated, and a clear statement needs to be made about which
protocol mechanism indicates which. They are:

i)	indication to the remote user of the session request
ii)	remote user acceptance of the session
iii)	start of charging for the session
iv	indication to the remote user of a media stream request
v	remote user acceptance of the media stream
vi)	start of charging for the media stream

In the PSTN these boil down to two events, although with IN based queuing
mechanisms, this is not totally satisfactory. In SIP they definitely do not
all occur at the same time, and can need separate protocol mechanism for
each. 

Some of these appearing at separate times will occur in more scenarios than
others. The kludge is happening because the concepts have not been clearly
separated.

Keith Drage

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Henning Schulzrinne[SMTP:[email-masked]]
> Sent: 	04 October 2000 0:18
> To: 	Simon Barber
> Cc: 	Jonathan Rosenberg; 'hammer michael'; Doug Harbert; 'Tom-PT Taylor';
> 'sip'
> Subject: 	Re: [SIP] Re-direct of Media During Ringing
> 
> The problem is treating waiting in queue as early media - it's a session
> and should be treated as such. It's a call when you call the airline,
> say, even with steamphones. As I said earlier, the whole early media
> stuff is a kludge. The less we use it, the better. Trying to fix the
> kludge just adds layers upon layers of double complexity, once for
> "real" sessions and once for "pseudo" sessions, for no good reason. With
> a real VoIP system (as opposed to one that tries to imitate the analog
> phone system), you wouldn't get a voice stream for queueing, it would
> just be a 18x message, with no bandwidth difficulties. 
> -- 
> Henning Schulzrinne   http://www.cs.columbia.edu/~hgs
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 04 Oct 2000 08:49:28 -0400

Can we please remove the word "charging" from the discussion? SIP has
nothing directly to do with charging or billing, as discussed numerous
times on this mailing list. Tying SIP requests to charging in a
PSTN-like way is only going to lead to convoluted, inflexible and
bell-headed architectures.
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs