Subject: RE: [SIP] draft-ietf-sip-cc-transfer-01

From: Subramania Sivaram <[email-masked]>
Date: Tue, 17 Oct 2000 19:41:30 +0530

I happened to read this draft today. I have a fundamental question on why
the REFER is needed to
achieve transfer. To mimic today's behaviour in the PSTN, won't the
following be sufficient

Transferor puts transferee on hold via a RE-INVITE.
Transferor does an INVITE to transfer target.
Transferor does a re-INVITE to both transferee & transfer target to give
each other's IP address (much like
3rd party call control scenario). 

Regards,
Sivaram.

> -----Original Message-----
> From:	Robert Sparks [SMTP:[email-masked]]
> Sent:	Tuesday, September 19, 2000 12:08 AM
> To:	[email-masked]
> Subject:	[SIP] draft-ietf-sip-cc-transfer-01
> 
> 
> The attached revision to sip-cc-transfer has been submitted to the
> internet-drafts repository.
> 
> This revision addresses the following:
> 
> . Separated definition of the REFER method and headers from the definition
> of its use to achieve transfer.
> . Replaced the syntax of the Referred-By header to align with
> sip-ietf-sip-guidelines.
> . Added short forms of Refer-To and Referred-By as recommended by
> sip-ietf-sip-guidelines.
> . Allows REFERs outside the scope of an existing call-leg.
> 
> I've tried to reflect most of the feedback received since the Pittsburg
> meeting. Please
> review - if I've missed something, let me know.
> 
> RjS << File: draft-ietf-sip-cc-transfer-01.txt >> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Robert Sparks" <[email-masked]>
Date: Tue, 17 Oct 2000 09:47:43 -0500

What you describe gives the other two parties each other's
addresses for media exchange, not signalling. The transferor
would have to continue to play as a signalling "middle-man"
for the duration of the call. 

RjS

p.s. - note that one of the other parties has to support
a delayed-sdp invite, i.e. negotiating the session in the
200 OK and ACK, for the setup you describe to do what you want.

> From: Subramania Sivaram [mailto:[email-masked]]
> Sent: Tuesday, October 17, 2000 9:12 AM
> To: Robert Sparks; [email-masked]
> Subject: RE: [SIP] draft-ietf-sip-cc-transfer-01
> 
>