Subject: RE: [SIP] distributed sip

From: "Jonathan Rosenberg" <[email-masked]>
Date: Mon, 2 Oct 2000 01:37:06 -0400

> -----Original Message-----
> From: farhan [mailto:[email-masked]]
> Sent: Thursday, September 28, 2000 2:34 PM
> To: sip
> Subject: [SIP] distributed sip
>
>
> is there anything that prevents a sip deployment such that
> all the ua's
> behind a sip proxy are not sip compliant ?
> let me build this up slowly.
> 1. consider a multi-user host that can run individual sip UAs
> for each user
> logged in.
> 2. we can replace the multiple instances of UA with a single
> user agent that
> is able to handle more than one simultaneous user. This may not seem
> efficient, but there is nothing which prevents such a deployment.
> 3. now consider that the physical endpoints are in turn
> remotely located.
>
> We will at this stage have a distributed SIP wherein, the
> actual endpoints
> of a sip call are slave units of a central control unit and
> the control unit
> in turn is sip compliant (the slave units are not).

I hate to break it to you, but this is not a new idea. Its exactly what is
done in the mgcp/megaco gateway decomposition model. Its even been done in
models where the protocol between "slave" and "controller" is not a
master-slave protocol, but a call control protocol. I believe dialpad works
this way for H.323.

So, of course you can do it. As far as the SIP network is concerned, your
controller is the SIP UA.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Dvir Oren <[email-masked]>
Date: Sat, 30 Sep 2000 16:32:41 +0300 (IDT)

farhan writes ("[SIP] distributed sip"):

> We will at this stage have a distributed SIP wherein, the actual endpoints
> of a sip call are slave units of a central control unit and the control unit

What you are suggesting is in fact some SIP-X gateway, where 'X' is
some proprietery protocol that is supposed to be smaller than SIP.
The network between the SIP gateway and the end point units is not a
SIP network, but an 'X network'.  You might even want to hink of using 
MGCP, which is client-server based, where the end points are just dumb 
terminals.  I'm suggesting this since it might help to use something
that already has been done.

On the other hand, since between the SIP gateway and the remote units
there is a network, you'll have to handle all the possible errors in
the network.  Basically, this will mean re-inventing a protocol.  So,
why not use an existing one?

I don't even see why you can't use SIP.  

> client is just a 48kb slave totally controlled by hotfoon.com. As a

I don't think you need one of those giant C++/Java implementations
that are megabytes in size.  You can do with a small implementation of 
SIP.

-- 
Dvir Oren               <[email-masked]>
Lucid VON Ltd.     <http://www.lucidvon.com>
9 Saloniki St.,        Tel-Aviv       Israel
Tel:  +972 3 644 3038  Fax:  +972 3 644 3039