Subject: RE: [SIP] Phone number in SIP

From: James Yu <[email-masked]>
Date: Wed, 11 Oct 2000 12:35:37 -0500

Michel,

It is an issue on how the PSTN will route the call to a GW.  It may be the
number itself that causes the PSTN to route the call to a GW or may be that
the originating PSTN always routes the calls to a GW or a set of GWs.  

Since your question is about what happens when the GW receives the call,
I'll mention one possibility - use ENUM (Telephone Number Mapping: phone
number in ... URL out).   The GW can initiate the ENUM process to retrieve
all the NAPTR RRs associated with that phone number and selects the SIP
URL(s) to route the call, or the GW can route the call to a SIP proxy
server, which then initiates the ENUM process.  An I-D on how to use ENUM to
support SIP services will be out soon.

James

> -----Original Message-----
> From: Frederic Huve [mailto:[email-masked]]
> Sent: Wednesday, October 11, 2000 11:45 AM
> To: Michel Eilat
> Cc: SIPbell-labs
> Subject: Re: [SIP] Phone number in SIP
> 
> 
> Michel,
> 
> I think that you're missing a point, a SIP proxy have to take 
> place between
> the PSTN-SIP GW and the SIP end point, this SIP proxy via 
> some location logic
> translates the E164 to the SIP URL.
> see draft-johnston-sip-call-flows-00.txt (especially section 5).
> 
> Fred.
> 
> Michel Eilat wrote:
> 
> > Hello all,
> >
> > Let's imagine that a call need to be made from a POTS 
> telephone to a SIP
> > endpoint through a PSTN-SIP GW. From the POTS,  one will 
> dial for example
> > 1234. How is the GW suppose to complete the SIP address 
> form the phone
> > number. What procedure must the GW undergo ?
> >
> > Sorry if it is off interset - new  to SIP
> >
> > Michel Eilat
> >
> > Audiocodes LTD
> > 4 Hahoresh St,
> > P.O.Box 14 Yehud 56470
> > Israel
> >
> > Direct:      +972-3-5394160
> > Fax:         +972-3-5394040
> > Email:      [email-masked]
> > Web Site: http://www.audiocodes.com
> >
> > _______________________________________________
> > SIP mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/sip
> 
> --
> Frederic HUVE                         5,Avenue Raymond Chanas - Eybens
> R&D Engineer                          38053 Grenoble Cedex 9 - FRANCE
> Telecom Infrastructure Division       Tel +33 (0)4 76 14 47 43
> Hewlett-Packard                       Fax +33 (0)4 76 14 14 88
> 
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Christian Huitema <[email-masked]>
Date: Wed, 11 Oct 2000 11:07:05 -0700

Assume that the gateway receiving the call learns the dialed number, e.g.
through caller-id, through ISDN signalling, or through SS7. There are at
least two ways to perform the translation between this phone nuber and a
destination address: you can either use ENUM, and look for a mapping from
the dialed number to the sip service, or you can use a local database,
somehow managed by the gateway (or by the call agent that controls the
gateway.) The local database makes a lot of sense, since there must be some
relation between the called number and the gateway service, otherwise the
call would not be routed to the gateway in the first place. The local
database could indeed use the ENUM technology.

If the gateway is reached through a generic number, or through a service
selection procedure such as the "10xxx" prefixes in the US, then using ENUM
makes a lot of sense.

-- Christian Huitema

> Sent: Wednesday, October 11, 2000 8:45 AM
> To: Michel Eilat
> Cc: SIPbell-labs

---

From: "Emami-Nouri, Mohsen" <[email-masked]>
Date: Wed, 11 Oct 2000 13:53:36 -0700

I think TRIP is the other possibility. It is not as elegant as ENUM, but it
addresses the routing information update well.

-----Original Message-----
From: Christian Huitema [mailto:[email-masked]]
Sent: Wednesday, October 11, 2000 11:07 AM
To: 'Frederic Huve'; Michel Eilat
Cc: SIPbell-labs
Subject: RE: [SIP] Phone number in SIP

-- Christian Huitema

---

From: Christian Huitema <[email-masked]>
Date: Wed, 11 Oct 2000 14:23:12 -0700

Actually, TRIP solves a different problem, that of finding the adequate
gateway to reach a phone number from the Internet. In the example, we would
first use ENUM or a local DB to try to find a sip URL that corresponds to
the phone number; if there is none, we would use TRIP to find an adequate
gateway.

> From: Emami-Nouri, Mohsen [mailto:[email-masked]]
> Sent: Wednesday, October 11, 2000 1:54 PM
> To: Christian Huitema; 'Frederic Huve'; Michel Eilat
> Cc: SIPbell-labs

---

From: "Emami-Nouri, Mohsen" <[email-masked]>
Date: Wed, 11 Oct 2000 18:46:57 -0700

-----Original Message-----
From: Christian Huitema [mailto:[email-masked]]
Sent: Wednesday, October 11, 2000 2:23 PM
To: 'Emami-Nouri, Mohsen'; 'Frederic Huve'; Michel Eilat
Cc: SIPbell-labs
Subject: RE: [SIP] Phone number in SIP

the phone number;
 
when we find an URL by using ENUM, the found URL could be a gateway's one.
why TRIP is to find gateways and ENUM to find UA (?)

 if there is none, we would use TRIP to find an adequate
gateway.

---

From: James Yu <[email-masked]>
Date: Wed, 11 Oct 2000 21:27:49 -0500

ENUM offers a generic process that maps an E.164 number to a list of NAPTR
RRs (URLs).  The use of ENUM for each application must be defined for each
application (e.g., SIP and voice messaging).

James
> From: Bobby Sardana [mailto:[email-masked]]
> Sent: Wednesday, October 11, 2000 4:11 PM
> To: Jean-Francois Mule
> Cc: James Yu; Michel Eilat; SIPbell-labs; 'Frederic Huve'
> Greetings:
> An I-D:
> http://www.ietf.org/internet-drafts/draft-lind-enum-callflows-00.txt
> 
> does describe the use of ENUM and SIP. I was wondering what 
> the new I-D, as
> mentioned by James Yu, will reflect?
> 
> Regards,
> 
> [email-masked]
> 
> Jean-Francois Mule wrote:
> 
> > The second method combining James & Christian' suggestions 
> is more elegant:
> > pstn-sip gw --> PROXY: use of ENUM or any other location 
> services like LDAP
> > directory, look-up in local DB to translate abbreviated 
> number into a
> > "routable" one.
> >
> > Jean-Francois.
> >
> > James Yu wrote:
> > > From: James Yu [mailto:[email-masked]]
> > ... snip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 11 Oct 2000 22:38:10 -0400

> Sent: Wednesday, October 11, 2000 9:47 PM
> To: 'Christian Huitema'; Emami-Nouri, Mohsen; 'Frederic Huve'; Michel
> Eilat
> Cc: SIPbell-labs

Sigh. If only I had a dime for every time this issue has come up. 

The TRIP framework discusses this issue in some detail:
http://www.ietf.org/rfc/rfc2871.txt

Anyway, to summarize, enum is a worldwide global database. When you look up
a number, you always get the same answer back. Routing to gateways is much
more an issue of policy, with local inputs and rules that are different for
each provider. Enum solves a NAME TO ADDRESS mapping problem, and TRIP
solves an ADDRESS TO ROUTE problem.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com