Subject: [SIP] [SIP]When the proxy server send a CANCEL message?(Help)

From: 이희석 <[email-masked]>
Date: Fri, 20 Oct 2000 12:12:24 +0900

I have a question about proxy server. help me please!

A proxy B
| INVITE | |
|--------------->| |
| Trying | |
|<---------------| INVITE |
| |------------->|
| | RINGING |
| |<-------------|
| | |
| | |
| | |
| | CANCEL | When the proxy server send a CANCEL message?
| |------------->|
| | |

User B send a RINGING message but B is moved away temporarily.
so User B can't send a 200 OK message to the proxy server. Accordingly User B's phone is ringing so long.

When the proxy server send a CANCEL messge? How long the proxy server wait for 200 OK message from User B?

In the draft-ietf-sip-rfc2543bis_00.ps Figure 13: State transition diagram of server for INVITE method,

After the server received 1XX message for INVITE(current state Call proceeding), when it send a CANCEL messge and goes to Initial state?

Would anybody give me correct answell ? please

-----------------------------------

못말리는 인터넷채널,

채널아이 http://www.channeli.net

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 20 Oct 2000 01:05:53 -0400

-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]
>Sent: Thursday, October 19, 2000 11:12 PM
>To: [email-masked]
>Subject: [SIP] [SIP]When the proxy server send a CANCEL message?(Help)
>
>
>
>|                            |    CANCEL        |       When the proxy
server send a CANCEL >message? 
>so User B can't send a 200 OK message to the proxy server. Accordingly User
B's phone is 
>ringing so long.
>
>When the proxy server send a CANCEL messge? How long the proxy server wait
for 200 OK 
>message from User B?

Generally, a proxy will send a CANCEL when:

1. It has forked, and receives a 200 or 600 response on one of the branches,
in which case it CANCELs unanswered branches.
2. The time described in the Expires header of the request has elapsed
3. No response at all, even provisional, was ever received
4. Internal logic determines its time to end the call (a CPL, for example).

>
>In the draft-ietf-sip-rfc2543bis_00.ps Figure 13: State transition diagram
of server for 
>INVITE method,
>
>After the server received 1XX message for INVITE(current state Call
proceeding), when it 
>send a CANCEL messge and goes to Initial state? 

You should check out the most recent bis draft.

-Jonathan R.

Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com