Subject: RE: [SIP] Re-direct of Media During Ringing

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 4 Oct 2000 10:42:07 +0100

This all appears to be focussing back to the old ISDN/B-ISDN discussions of
what does answer really mean. Essentially there are several concepts that
need to be designated, and a clear statement needs to be made about which
protocol mechanism indicates which. They are:

i)	indication to the remote user of the session request
ii)	remote user acceptance of the session
iii)	start of charging for the session
iv	indication to the remote user of a media stream request
v	remote user acceptance of the media stream
vi)	start of charging for the media stream

In the PSTN these boil down to two events, although with IN based queuing
mechanisms, this is not totally satisfactory. In SIP they definitely do not
all occur at the same time, and can need separate protocol mechanism for
each. 

Some of these appearing at separate times will occur in more scenarios than
others. The kludge is happening because the concepts have not been clearly
separated.

Keith Drage

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Henning Schulzrinne[SMTP:[email-masked]]
> Sent: 	04 October 2000 0:18
> To: 	Simon Barber
> Cc: 	Jonathan Rosenberg; 'hammer michael'; Doug Harbert; 'Tom-PT Taylor';
> 'sip'
> Subject: 	Re: [SIP] Re-direct of Media During Ringing
> 
> The problem is treating waiting in queue as early media - it's a session
> and should be treated as such. It's a call when you call the airline,
> say, even with steamphones. As I said earlier, the whole early media
> stuff is a kludge. The less we use it, the better. Trying to fix the
> kludge just adds layers upon layers of double complexity, once for
> "real" sessions and once for "pseudo" sessions, for no good reason. With
> a real VoIP system (as opposed to one that tries to imitate the analog
> phone system), you wouldn't get a voice stream for queueing, it would
> just be a 18x message, with no bandwidth difficulties. 
> -- 
> Henning Schulzrinne   http://www.cs.columbia.edu/~hgs
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Simon Barber" <[email-masked]>
Date: Wed, 4 Oct 2000 09:58:53 -0700

You put it far better than I could have!

The big question is how to change SIP to better separate these concepts.

Simon Barber

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Drage, Keith (Keith)
> Sent: Wednesday, October 04, 2000 2:42 AM
> To: Simon Barber; 'Henning Schulzrinne'
> Subject: RE: [SIP] Re-direct of Media During Ringing
>
>

---

From: Doug Harbert <[email-masked]>
Date: Wed, 04 Oct 2000 14:02:49 -0600

> others. The kludge is happening because the concepts have not been clearly

Keith:
    In my opinion, the early media kludge is due to the desire to equate
establishment of a session with the called party answering the phone. I think
that if we establish the session early on, then setting up media streams for
delivery of call progress tones, and setting up media streams for voice
conversation within that session can be accomplished with protocol elements
already defined for SIP (specifically re-invite). An agent which is recording
charging data could be made to trigger on those elements to determine the start
of each phase of the call.

Doug Harbert.