Subject: RE: [SIP] sip mobility with REGISTER

From: Michael Thomas <[email-masked]>
Date: Mon, 2 Oct 2000 15:20:12 -0700 (PDT)

Roy, Radhika R, ALCOO writes:
 > Hi, Billy:
 > 
 > The bottom line of your argument is "performance (e.g., frequency of use,
 > latency, etc.)" problems, if you use anything in the SIP layer to address
 > mobility.
 > 
 > Let assume for sake of argument that there is no performance problem: Will
 > the procedure work using REGISTER and re-INVITE?
 > 
 > The second aspect of your assumption is that mobile IP mobile will solve all
 > problems. No, mobile IP has also problems from performance point of view
 > especially for real-time communications like voice in addition to fast
 > hand-offs and frequency of location updates.

   These are common problem regardless of whether you
   do it at L3 or L7. The thing that seriously pushes
   me toward the L3 solution is that in order to do fast
   handoff, it must be performed in a geographically/
   topologically localized fashion or you're going
   to need to make c faster. 

   The reason that this pushes me toward L3 is just
   from the standpoint of end to end transparency:
   I'd much rather tell the local provider that I
   want to move my attachment point for IP packets
   from here to there, rather than having to tell
   a localized SIP proxy to do the SIP equivalent
   (and http, and smtp, ad nauseum). This nicely
   avoids the e-2-e security problems of proxy
   routed traffic as well which makes me happy 
   too :-)

	      Mike

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Roy, Radhika R, ALCOO" <[email-masked]>
Date: Tue, 3 Oct 2000 10:28:43 -0400

Hi, Mike:

It is being examined how much L1, L2, L3, and/or upper layer (e.g., L7) need
to be involved for the hand-off.

So, it not so much pushing the L1 solution to L2/L3/L7. It is rather: What
needs to be in each layer, if any, so far the hand-off is concerned as the
point of attachment is changed during the session.

Best regards,
Radhika R. Roy
AT&T

-----Original Message-----
From: Michael Thomas [mailto:[email-masked]]
Sent: Monday, October 02, 2000 6:20 PM
To: Roy, Radhika R, ALCOO
Cc: Billy Biggs; farhan; sip
Subject: RE: [SIP] sip mobility with REGISTER

	      Mike