Subject: [SIP] Gateway Question

From: zeeshan razzaque <[email-masked]>
Date: Tue, 10 Oct 2000 05:29:26 -0700 (PDT)

Hi,
Well I continue from where I left. I asked how the
Gateways register themselves and I was told to use
TRIP instead of REGISTER. What is the current status
of TRIP. Who sponsors it and is it widely enough used?
What is the method 'in vogue' for SIP Gateway
Registration?

Secondly, if my Gateway has a concurrent capacity of
say a 100 connections, does it register 100 different
UAs for that? Or is there any other SIP support for
it?

Now the default port for SIP listener is 5060. If the
gateway spawns a 100 or more(or less for that matter)
UAs, when INVITES arrive at the Gateway, is the
gateway supposed to send 200 OK and put the UA SIP URL
in the CONTACT header or does it send a 300 REDIRECT
response. In other words should it act as a big
brother or the Redirect Server. Is it mandated by SIP
in nay way or is it an implementation detail not
handled by SIP?

Cheers,
Zeeshan.

__________________________________________________
Do You Yahoo!?
Get Yahoo! Mail - Free email you can access from anywhere!
http://mail.yahoo.com/

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 11 Oct 2000 22:39:57 -0400

> -----Original Message-----
> From: zeeshan razzaque [mailto:[email-masked]]
> Sent: Tuesday, October 10, 2000 8:29 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [SIP] Gateway Question
> 
> 
> Hi,

TRIP itself is nearly complete. There are a few implementations. However,
the subject here is TRIP-GW. This is just a proposal at this point.

> What is the method 'in vogue' for SIP Gateway

Right now it is being done through static configuration of routes in
proxies.

> UAs for that? Or is there any other SIP support for

There is no register. Thats the point. TRIP-GW does this differently.

> in nay way or is it an implementation detail not

You seem to have some model that there is a separate UA process for each
port on a gateway. This is not how it generally works.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com