Subject: RE: [SIP] RE: REFER -> Referred-By syntax

From: "Robert Sparks" <[email-masked]>
Date: Mon, 2 Oct 2000 20:13:32 -0500

I agree with Jonathan's suggestion.

One small thing to note:

A side effect of allowing the arguments to be completely unordered is
removing "href" and "scheme" from the set of parameter names that
can appear in sig-scheme-params. In the extremely unlikely event that
someone developed a scheme in other circles that used those parameter
names, and we wanted to use it for SIP, we would have to map them into 
something that didn't collide.

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Thursday, September 28, 2000 11:54 AM
> To: 'Eric Tremblay'; 'Robert Sparks'; [email-masked]'
> Subject: RE: [SIP] RE: REFER -> Referred-By syntax
> 
> 
> Referrer URL should definited be name-addr or addr-spec.
> 
> Also, the BNF actually imposes an order on the parameters, which is
> different from other headers. I would argue the BNF should be:
> 
> Referred-By = "Referred-By" ":" (name-addr | addr-spec) *(";"
> referred-by-params)
> referred-by-params =  referenced-url | ref-signature
> 
> and then you would add wording that says referencd-url is mandatory.
> 
> -Jonathan R.
> 
> ---
> Jonathan D. Rosenberg                       72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> > -----Original Message-----
> > From: Eric Tremblay [mailto:[email-masked]]
> > Sent: Wednesday, September 27, 2000 8:58 PM
> > To: 'Robert Sparks'; Eric Tremblay; [email-masked]
> > Subject: [SIP] RE: REFER -> Referred-By syntax
> > 
> > 
> > 
> > I agree but for one thing (and this is probably what you meant):
> > 
> > As per the Contact description, if "referrer-url" or "referenced-url"
> > contains a comma, semicolon or question mark, then the URL with such a
> > character MUST be enclosed within the "<" and ">" brackets.  
> > Otherwise, the
> > URL does not need to be enclosed in the brackets (but it can 
> > be all the
> > same).
> > 
> > I think we should make this clear in the spec.
> > 
> > As for the having a name-addr instead of a single SIP-URL for
> > "referrer-url", I fully agree.
> > 
> > Best regards,
> > 
> > EricT
> > 
> > -----Original Message-----
> > From: Robert Sparks [mailto:[email-masked]]
> > Sent: Wednesday, September 27, 2000 6:00 PM
> > To: Eric Tremblay; [email-masked]
> > Subject: RE: REFER -> Referred-By syntax 
> > 
> > 
> > The -01 syntax follows Contact very closely. ref=, scheme= and
> > the sig-scheme-params are all header parameters (they come after
> > the first semicolon after the referred-by URL). You will have
> > to go through the same level of effort to parse them that you
> > go through for expires= on a Contact header.
> > 
> > Things creating a Referred-By header SHOULD wrap URIs in <>
> > wherever they occur, per the below recommendation.
> > 
> > The primary deviation from the spirit of Contact's syntax is
> > allowing only a SIP-URL for the referrer-url instead of allowing
> > (name-addr|addr-spec). On reflection, the display-name in name-addr
> > would probably be useful to parties receiving the header. Are there
> > objections to allowing that?
> > 
> > RjS
> > > -----Original Message-----
> > > From: Eric Tremblay [mailto:[email-masked]]
> > > Sent: Wednesday, September 27, 2000 4:15 PM
> > > To: 'Robert Sparks'; [email-masked]
> > > Subject: REFER -> Referred-By syntax
> > >
> > >
> > >
> > > I think the syntax of Referred-By should be reviewed:
> > >
> > > 1- The parser has to check for "ref" to find the beginning of the
> > > "referenced-url", which (I think) goes against the suggestion in
> > > draft-ietf-sip-guidelines-00.txt (and it badly breaks my 
> > parser ;) ):
> > >
> > >    Headers that contain a list of URIs SHOULD follow the 
> > same syntax as
> > >    the Contact header in SIP. Implementors are also 
> > encouraged to always
> > >    wrap these URI in angle brackets "<" and ">". We have 
> > found this to
> > >    be a frequently misimplemented feature.
> > >
> > > 2- The same thing to find the beginning of "ref-signature", 
> > the parser has
> > > to look out for "scheme" in the previous URL.
> > >
> > >
> > > Shouldn't the syntax be something like the following (making the
> > > "<" and ">"
> > > brackets mandatory):
> > >
> > >      Referred-By      = ("Referred-By" | "b") ":"     referrer-url
> > >                                                   ";" referenced-url
> > >                                                  [";" ref-signature]
> > >      referrer-url     = "<" SIP-URL ">"
> > >      referenced-url   = "<" URL ">"
> > >      ref-signature    = signature-scheme *( ";" sig-scheme-params )
> > >      signature-scheme = "scheme" "=" token
> > >      sig-scheme-parms = token "=" ( token | quoted-string )
> > >
> > >
> > > Best regards,
> > >
> > > EricT
> > >
> > >
> > >
> > > -----Original Message-----
> > > From: Robert Sparks [mailto:[email-masked]]
> > > Sent: Tuesday, September 26, 2000 10:06 AM
> > > To: Tom-PT Taylor; [email-masked]
> > > Subject: [SIP] RE: Referred-By: ...referenced-url
> > >
> > >
> > > Yes.
> > >
> > > The referenced party needs to be able to know, with proof, 
> > which of the
> > > headers in
> > > the request it receives came from the referrer, and that those
> > > headers have
> > > not been
> > > modified.
> > >
> > > RjS
> > > -----Original Message-----
> > > From: Tom-PT Taylor [mailto:[email-masked]]
> > > Sent: Monday, September 25, 2000 7:03 PM
> > > To: [email-masked]
> > > Cc: [email-masked]'
> > > Subject: Referred-By: ...referenced-url
> > >
> > >
> > > According to draft-ietf-sip-cc-transfer-01.txt, the
> > > referenced-url component
> > > of the Referred-By: header contains a copy of the URL 
> > transmitted in the
> > > Refer-To: header.  What if the Refer-To: URL contains headers (e.g.
> > > Accept-Contact:).  Are these also reproduced in 
> > Referred-By:, particularly
> > > as it appears in the REFER request?
> > > Tom Taylor
> > >
> > 
> > _______________________________________________
> > SIP mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/sip
> > 
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 3 Oct 2000 01:22:08 -0400

> Sent: Monday, October 02, 2000 9:14 PM
> To: Jonathan Rosenberg; [email-masked]
> can appear in sig-scheme-params. 

Well, you're not removing them from the header, right? They would just also
be normal header params along with referenced URL, right?

> In the extremely unlikely event that

This doesn't seem like a real problem.

THanks,
Jonathan R.

---