Subject: RE: [SIP] received param

From: "Jonathan Rosenberg" <[email-masked]>
Date: Mon, 2 Oct 2000 01:32:55 -0400

> -----Original Message-----
> From: Gethin Liddell [mailto:[email-masked]]
> Sent: Friday, September 29, 2000 12:27 PM
> To: Jonathan Rosenberg; 'Dvir Oren'; 'SIP'
> Subject: RE: [SIP] received param
> 
> 
> On Fri, 29 Sep 2000, Jonathan Rosenberg wrote:
> > I agree that the proxy should not be checking the received 
> parameter, since
> > it didn't insert it in the first place. In fact, I thought 
> that the spec
> > said that the downstream proxy should actually remove the 
> received parameter
> > before forwarding upstream. But, I couldn't find text 
> stating that in
> > rfc2543 or the bis draft which said that.
> > 
> > I think its a good idea to strip out the received tag. 
> Basically if a UA or
> > proxy sends a request with a via parameter X, what comes back in the
> > response should be exactly the same.
> > 
> > Anyone object to adding this to the spec (along with text 
> clarifying not to
> > look at the received parameter if it is there).
> 
> no objection, but is this just gonna turn into another one of 
> those "be
> strict on what you send and liberal on what you receive" scenario's, 
> 
> i.e. should it not be a MUST to send back vias without 
> modification but
> a SHOULD in that clients are able to a handle modified vias as
> described b4?

Seems so.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Dvir Oren <[email-masked]>
Date: Sat, 30 Sep 2000 16:41:59 +0300 (IDT)

Jo Hornsby writes ("RE: [SIP] received param"):

> Isn't your DNS potentially flawed, then?  I don't see why the proxy
> can't know all the IP addresses that it's using (in the simplest
> case, just make them configurable).

I wouldn't say 'flawed', but it certainly is incomplete.  The point is 
that DNS is an external function to the SIP implementation, and I
can't force any DNS maintainer to enter all the IP addresses
correctly.

-- 
Dvir Oren               <[email-masked]>
Lucid VON Ltd.     <http://www.lucidvon.com>
9 Saloniki St.,        Tel-Aviv       Israel
Tel:  +972 3 644 3038  Fax:  +972 3 644 3039