Subject: [SIP] Stateful proxy

From: Baniel Uri-CUB001 <[email-masked]>
Date: Wed, 18 Oct 2000 10:14:08 -0500

Hello 

Why does a proxy that uses TCP must be stateful ? Can someone show me a scenario which went wrong because of a proxy have used a TCP and
was stateless?

Thanks

Uri

=====================
Uri Baniel
Motorola
Network solution Sector
1155 W. Dundee Rd
Arlington Heights
Tel: 847 632 4616
=====================

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Emami-Nouri, Mohsen" <[email-masked]>
Date: Thu, 19 Oct 2000 16:20:02 -0700

if it is agreed that statelessness means not caring about the reliability of
delivery, then a TCP based server is statefull by nature.

-----Original Message-----
From: Baniel Uri-CUB001 [mailto:[email-masked]]
Sent: Wednesday, October 18, 2000 8:14 AM
To: [email-masked]
Subject: [SIP] Stateful proxy

Hello 

Why does a proxy that uses TCP must be stateful ? Can someone show me a
scenario which went wrong because of a proxy have used a TCP and
was stateless?

Thanks

Uri

=====================
Uri Baniel
Motorola
Network solution Sector
1155 W. Dundee Rd
Arlington Heights
Tel: 847 632 4616
=====================

---

From: Baniel Uri-CUB001 <[email-masked]>
Date: Thu, 19 Oct 2000 19:17:53 -0500

Nouri

Frankly, I think any SIP entity can achieve SIP reliability, even when using UDP as a transport, by application means (RFC2543bis section 10.4.1 - exponential backoff)
On the other hand... I have totally missed RFC2543bis section 10.3 which explicitly address my question.
Looks like I need to do some more reading...
Sorry for taking your time and thanks anyway!

Uri

-----Original Message-----
From: Baniel Uri-CUB001 [mailto:[email-masked]]
Sent: Wednesday, October 18, 2000 8:14 AM
To: [email-masked]
Subject: [SIP] Stateful proxy

Hello 

Thanks

Uri

=====================
Uri Baniel
Motorola
Network solution Sector
1155 W. Dundee Rd
Arlington Heights
Tel: 847 632 4616
=====================

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 26 Oct 2000 04:40:52 -0400

The situation comes up in a proxy which is TCP on the downstream side and
UDP in the upstream side:

      UDP            TCP
UA1 -------- Proxy --------- UA2

Lets assume that this proxy is stateless, meaning that it holds the TCP
connection state but otherwise does not store transaction state. According
to the specification, INVITE responses are not retransmitted over TCP. So,
UA2 sends its non-200 response, say a 400, just once over that TCP
connection. The proxy receives this, and forwards it to UA1. Its lost. UA2
will not retransmit (since its TCP), and neither will the proxy, since its
stateless, thus, the message is lost.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> Sent: Wednesday, October 18, 2000 11:14 AM
> Why does a proxy that uses TCP must be stateful ? Can someone 
> show me a scenario which went wrong because of a proxy have 
> used a TCP and
> was stateless?
> 
> Thanks
> 
> Uri
> 
> =====================
> Uri Baniel
> Motorola
> Network solution Sector
> 1155 W. Dundee Rd
> Arlington Heights
> Tel: 847 632 4616
> =====================
> 
>

---

From: Igor Slepchin <[email-masked]>
Date: Thu, 26 Oct 2000 18:03:39 -0400

Actually, proxies are required to retransmit final INVITE responses over TCP
(see 10.5.2 in 2543bis).

The problem happens in a slightly different scenario:

       TCP            UDP

Here, a stateless proxy has TCP on the upstream and UDP on the downstream.
Since requests are not retransmitted over TCP, the stateless Proxy will
never retransmit the requests over UDP link (Proxy->UA2).

---
Igor Slepchin

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Thursday, October 26, 2000 4:41 AM

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 29 Oct 2000 15:04:15 -0500

You are correct. Thanks.

-Jonathan R.

---

> From: Igor Slepchin 
> Sent: Thursday, October 26, 2000 6:04 PM
> To: Jonathan Rosenberg; 'Baniel Uri-CUB001'; [email-masked]
> Actually, proxies are required to retransmit final INVITE 
> responses over TCP (see 10.5.2 in 2543bis).
> 
> Here, a stateless proxy has TCP on the upstream and UDP on 
> the downstream. Since requests are not retransmitted over 
> TCP, the stateless Proxy will never retransmit the requests 
> over UDP link (Proxy->UA2).
> 
> ---
> Igor Slepchin
> 
>