Subject: RE: [SIP] Session Information

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 10 Oct 2000 00:24:50 -0400

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, October 09, 2000 11:32 PM
> To: Sunitha Kumar
> Cc: Burger Christian; [email-masked]'
> Subject: Re: [SIP] Session Information
> 
> 
> 
> 
> 
> 
> sk> The maximum size of the SIP message , including the 
> content data MUST
> be within
> sk> the bounds of 1500 bytes, inorder to prevent 
> fragmentation of packets.
> Please
> sk> refer Section 3, of the August 6, SIP draft.
> 
> 
> No, that is not true, The draft mentions that it as a SHOULD 
> and I think
> that is hardly
> true now. Even 'typical' SIP messages cross well over 2000 bytes,
> especially with all these
> new extensions chipping into the message.

Correct. In fact, I think this 1500 limit needs to be qualified or changed.

> 
> Afaik, there is no MUST limit (maybe except the max size 
> allocated to a n/w
> read kernel buffer - usually 64k ? )

Maximum IP packed size is 64K, so this represents the absolute upper bound
on a
SIP message.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Jo Hornsby" <[email-masked]>
Date: Tue, 10 Oct 2000 09:09:09 +0100

> > allocated to a n/w read kernel buffer - usually 64k ? )
> 
> Maximum IP packed size is 64K, so this represents the absolute upper
> bound on a SIP message.

How about if I have TCP connection between two UAs, for example?
I agree in the general case one cannot know whether UDP (or other
unreliable transport) will be used anywhere along the signalling
path, but should this rule out messages > 64K?

Cheers,

 - Jo.

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 10 Oct 2000 07:41:41 -0400

Added sentence:

than the path maximum transmission unit (MTU) if the MTU is known, or
1500 bytes if the MTU is unknown.
\begin{changebar}
However, implementations {\MUST} be able to handle messages up to the
maximum UDP packet size.
\end{changebar}

Other wording fix suggestions appreciated.
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs