Subject: RE: [SIP] Option-tag value for rfc2976 ?

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 16 Oct 2000 10:40:37 -0400

New methods don't require option tags. They are covered by the Allow/405
mechanism. Two answer your second question - yes, it is a good idea, in
fact, to include Allow in INVITE to indicate supported methods. Same with
the 200 OK. This is really useful for REFER, for example. It allows a caller
to "grey out" the transfer button if the called party doesn't support it.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Brett Tate [mailto:[email-masked]]
> Sent: Monday, October 16, 2000 1:31 AM
> To: SIPbell-labs
> Subject: [SIP] Option-tag value for rfc2976 ?
> 
> 
> What is rfc2976's option-tag value?
> 
> Are new SIP extension methods such as INFO 
> valid in the Supported header?  If not, can the 
> Allow header be included in INVITE request
> to indicate what methods the caller supports?
> 
> 
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Brett Tate" <[email-masked]>
Date: Mon, 16 Oct 2000 13:11:27 -0400

rfc2543bis-02 section 6.4 table 4 comment:

Please add a row to show that Allow is
optional in an INVITE request.

Section 6.10 should also be updated to
reflect that the Allow header can be used
in a request to show what methods are
supported by the sender of the INVITE.

----- Original Message -----
From: Jonathan Rosenberg <[email-masked]>
To: 'Brett Tate' <[email-masked]>; 'SIPbell-labs'
<[email-masked]>
Sent: Monday, October 16, 2000 10:40 AM
Subject: RE: [SIP] Option-tag value for rfc2976 ?

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 16 Oct 2000 13:24:36 -0400

> supported by the sender of the INVITE.

Tentatively added as being possible for all requests (no reason to
single out INVITE, I believe) and applying to the same call leg.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs