Subject: [SIP] re-INVITE with SDP modifications of media description

From: Jean-Francois Mule <[email-masked]>
Date: Tue, 10 Oct 2000 18:37:29 -0700

Context:
We consider the case of UDP transport only. A SIP session is active between
UA1 and UA2.  
A re-INVITE is sent with an updated SDP body from UA1 to UA2, in particular,
a new media description is given (only 1 m= line appears in SDP body, for
e.g., with a new RTP port).  If the receiving UA, UA2, can honor the new
request, it sends a 200 OK back to UA1.  

In that case, UA1 sends ACK and starts listening for media on the new UDP
port.  It also releases *any* previously allocated port for that call /
connection (same cseq, call-id, to:, from:).  Upon receipt of ACK from UA1,
UA2 starts sending media to the new RTP port.  
=> Agreed?  Comments?

If the intent of UA1 is to add one additional media connection, it MUST
repeat the previous m= lines.
=> Agreed?  Comments?

Thank you in advance,
Jean-Francois Mule.
Clarent

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 11 Oct 2000 00:21:56 -0400

Sounds right to me.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Jean-Francois Mule [mailto:[email-masked]]
> Sent: Tuesday, October 10, 2000 9:37 PM
> To: SIP ietf wg
> Subject: [SIP] re-INVITE with SDP modifications of media description
> 
> 
> Context: