Subject: RE: [SIP] SIP through firewalls without SIP proxy

From: "Jonathan Rosenberg" <[email-masked]>
Date: Sun, 1 Oct 2000 23:17:55 -0400

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Saturday, September 30, 2000 3:34 PM
> To: [email-masked]; [email-masked]
> Subject: RE: [SIP] SIP through firewalls without SIP proxy
>
>
>
> In fact, there has been talk (out of the foglamps mailing list) of
> chartering a new group to pursue this protocol in particular.
> This group is
> developing a framework document to describe the
> characteristics of such a
> firewall control protocol, see:
>
> http://search.ietf.org/internet-drafts/draft-kuthan-fcp-01.txt
>
> From a casual glance at your sketch below, it seems that your
> work is in
> line with the efforts in that community of interest. I'm sure
> that group
> would be happy to see more support of the exploration of
> these sorts of
> protocols.

In fact, your proposal seems more or less to be the same as proposed in the
above document. Whether the protocol is used between a proxy and the
firewall/NAT and whether its used between the proxy and the firewall/NAT
doesn't change the protocol.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Simon Barber" <[email-masked]>
Date: Mon, 2 Oct 2000 11:00:49 -0700

I am proposing a protocol that runs on any character stream between the
client (behind the firewall) and a server (outside the firewall), and that
does not need any special arrangements made on the firewall. The best
example would be using HTTP to communicate between the client and the
server - this channel is the most commonly available channel on the internet
(except e-mail), and may pass through proxys and firewalls between the
client and server.

The key difference between this and foglamps or SOCKS is that this does not
require the firewall administrator's permission, or even knowledge. For this
to work UDP and TCP data and control must all pass over the same connection.

Simon Barber

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Sunday, October 01, 2000 8:18 PM
> To: [email-masked]; [email-masked]; [email-masked]