Subject: RE: [SIP] Destination addresses in Via/Contact

From: "Emami-Nouri, Mohsen" <[email-masked]>
Date: Tue, 17 Oct 2000 17:23:09 -0700

-----Original Message-----
From: Piotr S. Kossowski [mailto:[email-masked]]
Sent: Tuesday, October 17, 2000 3:15 PM
To: [email-masked]
Subject: [SIP] Destination addresses in Via/Contact

Hello,

After studying of Via and Contact description in RFC-2543, My thinking
about these headers is not fully clear (My apologies, if it is basic
question). So, please someone to explain if something below is wrong:

Let's imagine an INVITE sent from UAC directly to UAS that contain 
(amongst others):

Via: SIP/2.0/UDP wonderland.com:6000 
Contact: [email-masked]:5080

After getting that INVITE by UAS, UAS should send a response
to UDP socket 6000 on wonderland.com host. 
This "wonderland.com:6000" destination is valid only for this
single request from UAC. In next requests (e.g. re-INVITE or BYE)
UAC can put in Via not the same data, for example "new" 6001 port.

As I figured out, Contact has no influence on destination of response.
Port 5080 on wonderland.com host will be used only if UAS (callee) would
like to send some request (e.g. BYE) to UAC (caller) during this call.

Is that true ?

>>>that would be my interpretation too. 

Regards, Piotr

PS

BTW (For Henning, I suppose): There is incorrect year of expiration 
on the first side of rfc2354bis-02...

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 18 Oct 2000 03:17:40 -0400

Yes, your interpretation is correct.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> Sent: Tuesday, October 17, 2000 6:15 PM