Subject: RE: [SIP] Redirect server returning new From header

From: Igor Slepchin <[email-masked]>
Date: Tue, 24 Oct 2000 19:03:31 -0400

You can use URL headers to specify SIP message headers, e.g., the Contact in
the 302 may look like

Contact: sip:chirster@ericsson?from=tel:12345

It's then up to the UAC to trust your redirect server and overwrite its
default From header. See section 2 of 2543bis for details.

---
Igor Slepchin

> -----Original Message-----
> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Tuesday, October 24, 2000 5:39 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [SIP] Redirect server returning new From header
> 
> 
> 
> Hi,
> 
> >Do you actually mean the From: or do you mean the To:?
> 
> From.
> 
> >It seems a bit odd for a redirect server to tell the UAC what
> >From: to use. Perhaps you could give an example of its usage.
> 
> Well, this is - once again - related to the PSTN/SIP GW 
> issue, if the GW
> needs a telephone number for some kind of A number analysis. 
> When I make
> a phone call from my SIP phone I may not know that the call may end up
> on the PSTN side, so I can for example put my email address 
> in the From
> header. However, since the network architecture includes a GW to the
> PSTN network, somewhere there could be a server which is able 
> to do the
> mapping between the email address user part and a telephone 
> number user
> part (if SIP URL is used).
> 
> Regards,
> 
> Christer Holmberg
> Ericsson Finland
> 
> 
> > 
> > Regards,
> > Sean
> > 
> > --
> > Sean Olson <[email-masked]>
> > 
> > Christer Holmberg wrote:
> > 
> > > Another proposal on the issue, with another use of the "Also-From"
> > > header.
> > >
> > > Currently, a redirect server add a new Request-URI (in 
> the 3xx response
> > > Contact header) to the UAC. An idea would be that it 
> could also return a
> > > new From header, for example with a telephone number. In 
> this case, the
> > > UAC, and intermediate proxies, would not need to insert any extra
> > > headers or URI parameters in the request. This would be a 
> new, optional,
> > > feature in a redirect server.
> > >
> > > Comments?
> > >
> > > Christer Holmberg
> > > Ericsson Finland
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Tajindrapal Singh <[email-masked]>
Date: Tue, 24 Oct 2000 21:15:35 -0400 (EDT)

Hi,

   I am trying to build Instant messenger on top of SIP, but having some problems. First, is there a SIP server available where I can register myself and see if the Instant messenger is working or not ?

   Second, By reading the documentation I understand that there is a SIP server and SIP client. Just to make it clear, does the SIP server involve in authentication (registar)? OR is it simply a daemon running on a machine and waiting for conections from other sIP servers ?

   Third, to build an Instant messenger.. Would I build it on top of a SIP client? OR can I build it independently of the sip client.?

The questions might me trivial for some people...But please understand I am a beginner in terms of knowing SIP...

Any suggestions and comments will be greatly appreciated.

Thanks
T.Singh