Subject: [SIP] TCP connection

From: Baniel Uri-CUB001 <[email-masked]>
Date: Thu, 19 Oct 2000 09:05:40 -0500

Hello 

Apologize for the basic question below...

RFC2543bis section 12.3 says:

"Proxies that accept TCP connections MUST be stateful when handling the TCP connection.
Otherwise, if the proxy were to lose a request, the TCP client would never retransmit it."

Any simple sequence that demonstrates the problem which occurs if the proxy were not statefull during the TCP session?

Thanks
Uri

=====================
Uri Baniel 
Motorola
Network solution Sector
1155 W. Dundee Rd
Arlington Heights
Tel: 847 632 4616
=====================

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Jo Hornsby" <[email-masked]>
Date: Thu, 19 Oct 2000 15:22:45 +0100

> Any simple sequence that demonstrates the problem which occurs if 
> the proxy were not statefull during the TCP session?

If a stateless proxy initiates a TCP connection, when does it
close it?  Since a connection being closed before a final response
is sent is supposed to be interpreted as a CANCEL (section 10.3),
this is a problem.

If a stateless proxy accepts a TCP connection, it will only
ever proxy one request per transaction since requests are not
retransmitted over reliable transports (section 10.4.2). 
Since the next hop must be over an unreliable transport (see
previous paragraph), this request might be lost, in which
case it's game over.

HTH,

 - Jo.