Subject: RE: [SIP] SIP through firewalls without SIP proxy

From: "Arnoud van Wijk (ELN)" <[email-masked]>
Date: Tue, 3 Oct 2000 10:15:40 +0200

Hmm, what about a fixed port number for RTP traffic?
(odd and even port)
Maybe even a second and a third RTP port pair (in case of high traffic)?

You will indeed leave the firewall open in this way, but it still would be a guarded entrance (only allow RTP/RTCP packets)

Just my 2 cents.

Arnoud van Wijk

> -----Original Message-----
> From: Simon Barber [mailto:[email-masked]]
> Sent: Monday, October 02, 2000 2:01 PM
> To: Jonathan Rosenberg; [email-masked]; 
> [email-masked]
> Subject: RE: [SIP] SIP through firewalls without SIP proxy
> 
> 
> I am proposing a protocol that runs on any character stream 
> between the
> client (behind the firewall) and a server (outside the 
> firewall), and that
> does not need any special arrangements made on the firewall. The best
> example would be using HTTP to communicate between the client and the
> server - this channel is the most commonly available channel 
> on the internet
> (except e-mail), and may pass through proxys and firewalls between the
> client and server.
> 
> The key difference between this and foglamps or SOCKS is that 
> this does not
> require the firewall administrator's permission, or even 
> knowledge. For this
> to work UDP and TCP data and control must all pass over the 
> same connection.

But they don't; the RTP is carried on a separate port from the signaling,
which is one of the main problems. How would you handle this case?

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: [email-masked]
Date: Tue, 3 Oct 2000 09:56:45 +0100

Arnoud,

Whilst I think this may be a practical solution for very small installations
(at home perhaps) it will definitely not scale to large deployments - the
number of physical boxes would become impractical from a physical management
point of view and very expensive. There would also need to be some method of
letting the end applications know which fixed port pairs they could use.
Even then how would you do admission control between competing applications
to avoid QoS problems for the media streams?

regards

Richard

-----Original Message-----
From: Arnoud van Wijk (ELN) [mailto:[email-masked]]
Sent: Tuesday, October 03, 2000 9:16 AM
To: 'Jonathan Rosenberg'; 'Simon Barber'; [email-masked]';
[email-masked]'
Subject: RE: [SIP] SIP through firewalls without SIP proxy

You will indeed leave the firewall open in this way, but it still would be a
guarded entrance (only allow RTP/RTCP packets)

Just my 2 cents.

Arnoud van Wijk

-Jonathan R.
---