Subject: RE: [SIP] Session Information

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 10 Oct 2000 04:21:53 -0400

Hmm.

TCP itself would be able to handle SIP messages above 64k, yes. It would
just send them in multiple IP packets.

The problem is, if we have a scenario of TCP->UDP->TCP through proxies, that
UDP hop is not going to work. 

We could mandate the usage of TCP for sending messages over a certain size.
I'm not that fond of this approach, though. 

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Jo Hornsby [mailto:[email-masked]]
> Sent: Tuesday, October 10, 2000 4:09 AM
> To: Jonathan Rosenberg; [email-masked]; 'Sunitha Kumar'
> Cc: 'Burger Christian'; [email-masked]
> Subject: RE: [SIP] Session Information
> 
> 
> > > Afaik, there is no MUST limit (maybe except the max size 
> > > allocated to a n/w read kernel buffer - usually 64k ? )
> > 
> > Maximum IP packed size is 64K, so this represents the absolute upper
> > bound on a SIP message.
> 
> How about if I have TCP connection between two UAs, for example?
> I agree in the general case one cannot know whether UDP (or other
> unreliable transport) will be used anywhere along the signalling
> path, but should this rule out messages > 64K?
> 
> Cheers,
> 
> 
>  - Jo.
> 
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 10 Oct 2000 07:55:53 -0400

> I'm not that fond of this approach, though.

That is the approach used by DNS, for example. However, redirects only
work if the end system supports TCP. Most of the end systems that only
support UDP are unlikely to ever send such large messages, so in
practice this is not likely to be a problem.  The basic issue is how to
find out whether the recipient can handle large messages and, if
necessary, can switch to TCP. If web pages are included, the "nice"
thing to do would be to do an OPTIONS and then decide whether the other
side can accept text/html. 
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs