Subject: Re: [SIP] Session Information

From: [email-masked]
Date: Tue, 10 Oct 2000 09:01:53 +0530

sk> The maximum size of the SIP message , including the content data MUST
be within
sk> the bounds of 1500 bytes, inorder to prevent fragmentation of packets.
Please
sk> refer Section 3, of the August 6, SIP draft.

No, that is not true, The draft mentions that it as a SHOULD and I think
that is hardly
true now. Even 'typical' SIP messages cross well over 2000 bytes,
especially with all these
new extensions chipping into the message.

Afaik, there is no MUST limit (maybe except the max size allocated to a n/w
read kernel buffer - usually 64k ? )
as such for the length of payload- just that try and keep it as
short as possible, and if its getting really big, look at the new message
and see if you
really should be doing it wrapped in SIP or not.

Regds
Arjun

--
Arjun Roychowdhury @ Hughes Software Systems

Sunitha Kumar <[email-masked]> on 10/10/2000 04:24:52 AM

To:   "Burger Christian" <[email-masked]>
cc:   "[email-masked]'" <[email-masked]>

Subject:  Re: [SIP] Session Information

Christian:

The maximum size of the SIP message , including the content data MUST be
within
the bounds of 1500 bytes, inorder to prevent fragmentation of packets.
Please
refer Section 3, of the August 6, SIP draft.

sunitha

"Burger, Christian" wrote:

> Hi,
>
> I had a question concerning Session Information that can be sent via SIP
(or
> in fact SDP).
> I did not find a size limit as to how much text could this way be
conveyed.
> Is there such a limit of how much can be sent with a SIP message?
> Greetings,
>
> Christian Burger
> E-mail: [email-masked]
>
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip

--
Sunitha Kumar
http://www.vovida.com

---

From: [email-masked]
Date: Tue, 10 Oct 2000 14:38:35 +0530

Some protocols do infact provide for a segmentation feature which allows
segmented messages to
be sent, received and assembled. For example, some versions of SS7  provide this
at an ISUP
level (which is similar to the level at which SIP is). So I guess, if there is a
real need to support
messages above 64 K (now or in future) then the segmentation facility should be
provided in the
protocol - independent of the transport (TCP/UDP). Ofcourse this also requires
the protocol to
specify how to handle lost/duplicated segments and so on....

Rohit

[email-masked] on 10/10/2000 03:22:52 PM

To:   Jonathan Rosenberg <[email-masked]>
cc:   "'Jo Hornsby'" <[email-masked]>, Jonathan Rosenberg
      <[email-masked]>, Arjun Roychowdhury/HSSBLR@HSSBLR, "'Sunitha
      Kumar'" <[email-masked]>, "'Burger Christian'"
      <[email-masked]>, "[email-masked]'"
      <[email-masked]> (bcc: Rohit Gupta/HSS)

Subject:  RE: [SIP] Session Information

Yes,
Im not keen on having to mandate a protocol just for some size message.
Then, we would be saying that 'for this type of
message, SIP is transport dependant' . And if we must make it transport
independant, lot of dirty application level breakup
and co-relation of UDP would be needed - does not seem to be worth it.

Also, isnt 64K size enough to put SIP into a 'bulk transporter' something
which its not supposed to be ?

imho,  the 64k limit is really enough (hoping that this does not go down as
the infamous '640K memory is all that a computer
needs' quote way) .

Regds
Arjun

Jonathan Rosenberg <[email-masked]> on 10/10/2000 01:51:53 PM

To:   "'Jo Hornsby'" <[email-masked]>, Jonathan Rosenberg
      <[email-masked]>, archow, "'Sunitha Kumar'"
      <[email-masked]>
cc:   "'Burger Christian'" <[email-masked]>,
      "[email-masked]'" <[email-masked]>

Subject:  RE: [SIP] Session Information

Hmm.

TCP itself would be able to handle SIP messages above 64k, yes. It would
just send them in multiple IP packets.

The problem is, if we have a scenario of TCP->UDP->TCP through proxies,
that
UDP hop is not going to work.

We could mandate the usage of TCP for sending messages over a certain size.
I'm not that fond of this approach, though.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Jo Hornsby [mailto:[email-masked]]
> Sent: Tuesday, October 10, 2000 4:09 AM
> To: Jonathan Rosenberg; [email-masked]; 'Sunitha Kumar'
> Cc: 'Burger Christian'; [email-masked]
> Subject: RE: [SIP] Session Information
>
>
> > > Afaik, there is no MUST limit (maybe except the max size
> > > allocated to a n/w read kernel buffer - usually 64k ? )
> >
> > Maximum IP packed size is 64K, so this represents the absolute upper
> > bound on a SIP message.
>
> How about if I have TCP connection between two UAs, for example?
> I agree in the general case one cannot know whether UDP (or other
> unreliable transport) will be used anywhere along the signalling
> path, but should this rule out messages > 64K?
>
> Cheers,
>
>
>  - Jo.
>
>