Subject: [SIP] Error in Via received BNF?

From: [email-masked] (Vijay K Gurbani)
Date: Tue, 3 Oct 2000 14:44:19 -0500

Hi:

The Sept 4th 2000 BNF, Section 6.46.2, says that, "...If and only if the
source address and port differ from the sent-by address, the proxy also
includes the source port in the received parameter."

The BNF of the received parameter in Section 6.46.6 is:

   via-received = "received" = host

Given the statement in 6.46.2, shouldn't it be:

   via-received = "received" = host[":"port]

Comments?

- vijay
--
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
IN Architecture and Internet Software Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 03 Oct 2000 17:42:27 -0400

> includes the source port in the received parameter."

This was an over-enthusiastic addition to the text, which will disappear
again (since it didn't help and isn't backward compatible). Thus, no
need to change the text.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs