Subject: RE: [SIP] SIP ISUP MIME draft

From: [email-masked]
Date: Wed, 4 Oct 2000 13:37:47 -0600

1. Content-Encoding is not used in any of the examples in the draft; the
form in which ISUP is transmitted should be its native binary encoding. So
it shouldn't be expected, no. Whether or not it could be used (if you for
some reason wanted to encode ISUP differently) is a matter that would
require some discussion. I wouldn't rule it out.

2. It is optional, but it has a default value as outlined in rfc2543 which
we are not overloading - namely that the content should be considered a
mandatory content (handling=required), and that in requests and 2xx
responses 'session' is the assumed disposition for backwards-compatibility.

However, rfc2543bis-02 also specifies that if the MIME type doesn't have a
default disposition, then the disposition should be assumed to be 'render'.
This seems to conflict with the backwards compatibility mechanism described
above, and someone should probably fix that. I'd vote for mainaining the
latter statute.

Now, that much said, the ISUP MIME draft today doesn't specify a default
content disposition for the ISUP MIME type. As the bis asks MIME types to
have a default, I think we probably should define one, and I think it should
be 'session' for ISUP. I suppose it would be the same for QSIG... Lyndon,
have any feelings about that?

3. In the examples in the draft, a MIME multipart/mixed type is used; this
allows multiple MIME bodies to appear in the same message. So, yes, it is
possible, with multipart/mixed, although the format is different than the
one you suggest below.

Jon Peterson
Aparna Vemuri
Level(3) Communications

-----Original Message-----
From: Amit Choksi [mailto:[email-masked]]
Sent: Wednesday, October 04, 2000 12:44 PM
To: Lyndon Ong
Cc: sip
Subject: Re: [SIP] SIP ISUP MIME draft

Hi,
I had a few questions about the draft

1. Can a Content-Transfer-Encoding  header be expected
2. Is Content-Disposition a mandatory field
3. Is it possible that we have multiple Content-Type: headers followed by
the corresponding payload

Content-Type:application/ISUP
Content-Type:application/SDP
CRLF
          .....data......
CRLF
        ........data.....
CRLF

I appologize if I have missed the information already clarified in the
draft.
Thanks in advance

Amit Choksi

Lyndon Ong wrote:

> Folks,
>
> I have not seen any comments on the list regarding the reissued SIP ISUP
> MIME draft
> (http://www.ietf.org/internet-drafts/draft-ietf-sip-isup-mime-04.txt),
> although I've gotten some minor ones offline.  Are there any comments or
> questions on the draft?
>
> Thanks,
>
> L. Ong
>
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Lyndon Ong" <[email-masked]>
Date: Wed, 04 Oct 2000 15:13:34 -0700

>require some discussion. I wouldn't rule it out.

Absolutely, in fact content-encoding was in an earlier draft and was taken 
out on the advice of MIME experts since the assumption was binary.

>have any feelings about that?

That sounds reasonable to me, "render" certainly does not make much 
sense.  This can be added pretty easily.

>possible, with multipart/mixed, although the format is different than the

Yes, Amit, please have a look at the examples in the draft.

>From: Amit Choksi [<mailto:[email-masked]>mailto:[email-masked]]
> (<http://www.ietf.org/internet-drafts/draft-ietf-sip-isup-mime-04.txt>http 
> ://www.ietf.org/internet-drafts/draft-ietf-sip-isup-mime-04.txt),
> <http://lists.bell-labs.com/mailman/listinfo/sip>http://lists.bell-labs.co 
> m/mailman/listinfo/sip
>
><http://lists.bell-labs.com/mailman/listinfo/sip>http://lists.bell-labs.com 
>/mailman/listinfo/sip
>
><http://lists.bell-labs.com/mailman/listinfo/sip>http://lists.bell-labs.com 
>/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 4 Oct 2000 19:02:27 -0400

> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, October 04, 2000 3:38 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: [SIP] SIP ISUP MIME draft
> 
> 
>

You are right, this seems to be contradictory. I think the former
one is sort of trying to say that the default content disposition
value for SDP is "session". I agree that the latter statute is better.

> have any feelings about that?

No, I don't think session is write. This is not a session description. It is
describing
extra information used to support signaling interworking. I think a new
content-disposition
makes sense here. 
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: [email-masked]
Date: Wed, 4 Oct 2000 17:57:36 -0600

Well, 'session' seemed better than any of the other options listed in the
bis, anyway. I suppose 'session' would then refer exclusively to SDP?

It was be nice if the disposition-type used for ISUP and QSIG could be the
same, and could cover any other encapsulated signals from other protocols
that are used by interworking UAs, at the very least. Perhaps 'signal' as a
disposition-type?

Jon Peterson
Level(3) Communications

---

From: "Joshua Moloney" <[email-masked]>
Date: Thu, 5 Oct 2000 11:25:18 +0100

Sorry to barge in, guys. I like the idea of having this new disposition
type, and although 'signal' is better than session, I reckon 'signalling'
would be better still. Sorry to be picky, but I just can't help it!

Josh Moloney
Nortel Networks

> From:	[email-masked] [SMTP:[email-masked]]
> Sent:	05 October 2000 00:58
> To:	[email-masked]; [email-masked]; Ong, Lyndon

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 5 Oct 2000 16:21:17 -0400

A rose by any other name....
 
It shouldn't be session. signal, signaling, sig, whatever. I propose that
the author of the draft pick something and let us know.
 
-Jonathan R.

Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen <http://www.cs.columbia.edu/~jdrosen>
PHONE: (732) 741-7244
http://www.dynamicsoft.com <http://www.dynamicsoft.com/>  

-----Original Message-----
From: Joshua Moloney [mailto:[email-masked]]
Sent: Thursday, October 05, 2000 6:25 AM
To: [email-masked]'
Cc: [email-masked]
Subject: RE: [SIP] SIP ISUP MIME draft

Josh Moloney 
Nortel Networks 

	-----Original Message----- 
From:   [email-masked] [SMTP:[email-masked]] 
Sent:   05 October 2000 00:58 
To:     [email-masked]; [email-masked]; Ong, Lyndon 
Cc:     [email-masked] 
Subject:        RE: [SIP] SIP ISUP MIME draft 

	Well, 'session' seemed better than any of the other options listed
in the 
bis, anyway. I suppose 'session' would then refer exclusively to SDP? 

	It was be nice if the disposition-type used for ISUP and QSIG could
be the 
same, and could cover any other encapsulated signals from other protocols 
that are used by interworking UAs, at the very least. Perhaps 'signal' as a 
disposition-type? 

	Jon Peterson 
Level(3) Communications 

	-----Original Message----- 
From: Jonathan Rosenberg [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Wednesday, October 04, 2000 5:02 PM 
To: Peterson, Jon; [email-masked]'; [email-masked]' 
Cc: [email-masked]' 
Subject: RE: [SIP] SIP ISUP MIME draft 

> From: [email-masked] [ mailto:[email-masked]
<mailto:[email-masked]> ] 

> have any feelings about that? 

	No, I don't think session is write. This is not a session
description. It is 
describing 
extra information used to support signaling interworking. I think a new 
content-disposition 
makes sense here. 
--- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave. 
Chief Scientist                             First Floor 
dynamicsoft                                 East Hanover, NJ 07936 
[email-masked]                     FAX:   (973) 952-5050 
http://www.cs.columbia.edu/~jdrosen <http://www.cs.columbia.edu/~jdrosen>
PHONE: (973) 952-5000 
http://www.dynamicsoft.com <http://www.dynamicsoft.com>  

	_______________________________________________ 
SIP mailing list 
[email-masked] 
http://lists.bell-labs.com/mailman/listinfo/sip
<http://lists.bell-labs.com/mailman/listinfo/sip>  

	_______________________________________________ 
SIP mailing list 
[email-masked] 
http://lists.bell-labs.com/mailman/listinfo/sip
<http://lists.bell-labs.com/mailman/listinfo/sip>