Subject: RE: [SIP] Use of notes within the RFC bis draft

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 26 Oct 2000 06:50:13 -0400

> -----Original Message-----
> From: Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: Wednesday, October 25, 2000 9:52 AM
> To: 'SIP discussion list'
> Subject: [SIP] Use of notes within the RFC bis draft
> 
> 
> This comment is about the documentation, rather than one of any direct
> technical import.
> 
> I note throughout the bis draft various areas of indented 
> text, which I
> assume to be the equivalent of notes in documents produced by other
> standards bodies. Is this true?

They are commentaries that provide explanations or implementation hints.

> 
> Some of these paragraphs begin with the word "Note:" and some 
> do not. Does
> this imply any difference in status of that text.

No.

> 
> There are additionally a large number of sentences throughout 
> the text that
> commence: "Note that...". Are these also notes.
> 
> As there is a need for other standards organisations to reference the
> resultant RFCs with a clear understanding of the difference between
> normative (i.e. requirements and definitions) and informative 
> material (i.e.
> notes), I would like to propose that this distinction is made 
> absolutely
> clear. In particular, I propose:
> 
> -	add the word "Note:" at the start of all indented text.
> -	make all sentences starting with the words "Note that" 
> into indented
> text comencing with the word "Note:".

I don't think this is really needed. The IETF has a clearly defined syntax
for describing normative behaviors (rfc2119), and this has sufficed for RFCs
up till now. 

-Jonatan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Eric Burger" <[email-masked]>
Date: Thu, 26 Oct 2000 17:48:10 -0700

We're talking about an issue of clarity here.  Even though the text
"conforms" with RFC 2119, it's by no means clear.  For a good example of the
use of NOTEs, see the MIME series (RFC 1521-1524).  It's very clear what's
normative and what's not.  Moreover, the NOTEs are truly helpful.

By obfuscating what's normative and what's not, one invites various
implementations that "conform" with the RFC, yet don't interoperate.  I'd
much rather get clear, concise, straight-forward RFCs, WITH that added NOTE
or three that makes everything make sense.  I prefer this to a "well, you
can figure it out by carefully parsing the MUSTS and SHOULDS, and if you get
it wrong, too bad for you" posture.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Jonathan Rosenberg
Sent: Thursday, October 26, 2000 3:50 AM
To: 'Drage, Keith (Keith)'; 'SIP discussion list'
Subject: RE: [SIP] Use of notes within the RFC bis draft

> Subject: [SIP] Use of notes within the RFC bis draft

[snip]

-Jonatan R.
---