Subject: Re: [SIP] Redirect server returning new From header

From: Christer Holmberg <[email-masked]>
Date: Wed, 25 Oct 2000 08:47:28 +0300

Hi,

>You can use URL headers to specify SIP message headers, e.g., the Contact >in the 302 may look like
> 
>Contact: sip:chirster@ericsson?from=tel:12345
> 
>It's then up to the UAC to trust your redirect server and overwrite its
>default From header. See section 2 of 2543bis for details.

True, but in this case the redirect server (what I mean by that is
actually any SIP node, server or UA, with redirect functionality...)
will not know if the UAC is going to use the new header or not. For some
reason, the redirect server may behave in different ways (maybe, in some
case, it won't even allow the UAC to contact a certain host if the
feature is not supported...) depending on if it can give the UAC a new
From header or not.

But, if we have a new header for this, the UAC can indicate in the
Supported header that it supports this feature. Then, the redirect
server can add the new "Also-From" header in the response, and indicate
in the Require header that the UAC must use it. Maybe this is possible
also in the case where you just add it to the Contact header, but in any
case I think you would have to define a new Supported/Require tag value
(?)

Regards,

Christer Holmberg
Ericsson Finland

> 
> ---
> Igor Slepchin
> 
> > -----Original Message-----
> > From: Christer Holmberg [mailto:[email-masked]]
> > Sent: Tuesday, October 24, 2000 5:39 AM
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: Re: [SIP] Redirect server returning new From header
> >
> >
> >
> > Hi,
> >
> > >Do you actually mean the From: or do you mean the To:?
> >
> > From.
> >
> > >It seems a bit odd for a redirect server to tell the UAC what
> > >From: to use. Perhaps you could give an example of its usage.
> >
> > Well, this is - once again - related to the PSTN/SIP GW
> > issue, if the GW
> > needs a telephone number for some kind of A number analysis.
> > When I make
> > a phone call from my SIP phone I may not know that the call may end up
> > on the PSTN side, so I can for example put my email address
> > in the From
> > header. However, since the network architecture includes a GW to the
> > PSTN network, somewhere there could be a server which is able
> > to do the
> > mapping between the email address user part and a telephone
> > number user
> > part (if SIP URL is used).
> >
> > Regards,
> >
> > Christer Holmberg
> > Ericsson Finland
> >
> >
> > >
> > > Regards,
> > > Sean
> > >
> > > --
> > > Sean Olson <[email-masked]>
> > >
> > > Christer Holmberg wrote:
> > >
> > > > Another proposal on the issue, with another use of the "Also-From"
> > > > header.
> > > >
> > > > Currently, a redirect server add a new Request-URI (in
> > the 3xx response
> > > > Contact header) to the UAC. An idea would be that it
> > could also return a
> > > > new From header, for example with a telephone number. In
> > this case, the
> > > > UAC, and intermediate proxies, would not need to insert any extra
> > > > headers or URI parameters in the request. This would be a
> > new, optional,
> > > > feature in a redirect server.
> > > >
> > > > Comments?
> > > >
> > > > Christer Holmberg
> > > > Ericsson Finland
> >

---

From: "Hisham Khartabil" <[email-masked]>
Date: Wed, 25 Oct 2000 09:53:47 +0300

Christer,

Normally, you contact a redirect server to get contact information about a
Callee. That callee has to registered with a registrar that co-exists with
the redirect server.  Now you are asking that registrar to return info about
you (the caller).  Is that right?

Regards,
Hisham

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Christer Holmberg
> Sent: 25. lokakuuta 2000 8:47
> Cc: Igor Slepchin; [email-masked]

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip