Subject: RE: [SIP] SIP through firewalls without SIP proxy

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 3 Oct 2000 01:00:41 -0400

> -----Original Message-----
> From: Simon Barber [mailto:[email-masked]]
> Sent: Monday, October 02, 2000 2:01 PM
> To: Jonathan Rosenberg; [email-masked]; 
> [email-masked]
> Subject: RE: [SIP] SIP through firewalls without SIP proxy
> 
> 
> I am proposing a protocol that runs on any character stream 
> between the
> client (behind the firewall) and a server (outside the 
> firewall), and that
> does not need any special arrangements made on the firewall. The best
> example would be using HTTP to communicate between the client and the
> server - this channel is the most commonly available channel 
> on the internet
> (except e-mail), and may pass through proxys and firewalls between the
> client and server.
> 
> The key difference between this and foglamps or SOCKS is that 
> this does not
> require the firewall administrator's permission, or even 
> knowledge. For this
> to work UDP and TCP data and control must all pass over the 
> same connection.

But they don't; the RTP is carried on a separate port from the signaling,
which is one of the main problems. How would you handle this case?

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Simon Barber" <[email-masked]>
Date: Tue, 3 Oct 2000 15:37:46 -0700

I'm proposing a generic method to transport socket API calls (these may
apply to many sockets) through a single connection. RTP media would be
transported by sending messages corresponding to send and recv API calls.
All these messages would go through the same single connection. This
connection might be a TCP stream or an HTTP stream.

Simon

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Monday, October 02, 2000 10:01 PM
> To: 'Simon Barber'; Jonathan Rosenberg; [email-masked]';
> [email-masked]'

---

From: "Lyndon Ong" <[email-masked]>
Date: Tue, 03 Oct 2000 16:05:38 -0700

Folks,

I have not seen any comments on the list regarding the reissued SIP ISUP 
MIME draft 
(http://www.ietf.org/internet-drafts/draft-ietf-sip-isup-mime-04.txt), 
although I've gotten some minor ones offline.  Are there any comments or 
questions on the draft?

Thanks,

L. Ong

---

From: Jiri Kuthan <[email-masked]>
Date: Wed, 04 Oct 2000 17:15:00 +0200

If you use an RTP/UDP/IP/Simon's_remote_sockets/HTTP/TCP/IP protocol 
stack you'll lose UDP's real-time property, introduce considerable
bandwidth and processing overhead, and require presence of 
a cooperating Simon's_remote_sockets/HTTP/TCP/IP server.

SOCKs is more or less doing what you're proposing.

> connection might be a TCP stream or an HTTP stream.

If your design requirement is the ability to subvert firewall policy you
should check mailing lists dedicated to firewall hacking.

> The key difference between this and foglamps or SOCKS is that this does not
> require the firewall administrator's permission, or even knowledge. For this
> to work UDP and TCP data and control must all pass over the same connection.

---

From: Amit Choksi <[email-masked]>
Date: Wed, 04 Oct 2000 11:44:23 -0700

Hi,
I had a few questions about the draft

1. Can a Content-Transfer-Encoding  header be expected
2. Is Content-Disposition a mandatory field
3. Is it possible that we have multiple Content-Type: headers followed by
the corresponding payload

Content-Type:application/ISUP
Content-Type:application/SDP
CRLF
          .....data......
CRLF
        ........data.....
CRLF

I appologize if I have missed the information already clarified in the
draft.
Thanks in advance

Amit Choksi

---

From: Bobby Sardana <[email-masked]>
Date: Wed, 04 Oct 2000 13:16:57 -0700

Hello Amit:

The (3) would require a "unique boundary" (RFC 2046 MIME Part 2, Section
5.1.1) for separation of each embedded Content-Type.

Regards,

[email-masked]