Subject: [SIP] From header to ISUP CgPN mapping

From: [email-masked]
Date: Wed, 11 Oct 2000 17:16:33 +0100

In the call flows document draft-ietf-sip-call-flows-01.txt, scenario 4.1.1,
the message detail and text show User A using a SIP telephone number rather
than a SIP address in the From header. The text at the beginning of section
4 also says "that User A still uses his/her SIP URL in the Contact header,
since the call could be redirected back to the SIP network." 
This implies that User A has pre-knowledge that the call is going to route
to the PSTN and has the ability to chose the address to be used in the From
header. This is maybe reasonable when calling a telephone number but what if
User A makes a call to a SIP address and the called user has say forwarded
their calls to a telephone number. If User A used a SIP address in the From
header there would be no calling telephone number available when the call
hits a gateway.
Is there some way in which both the calling SIP address and SIP telephone
number can be carried in an INVITE so that a Gateway (or even a Proxy?)
could choose the appropriate calling identity to use?

Regards,

Clive Dellard
3G Networks
> BTexaCT
> * PP 2C59, Angel Centre,
      403 St. John Street,
      LONDON, EC1V 4PL.
> *  Office +44 20 7843 7084
> *  Mobile +44 7711 045507
*  +44 20 7843 6557
mailto:[email-masked]

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Simon Barber" <[email-masked]>
Date: Wed, 11 Oct 2000 17:06:40 -0700

This scenario is an excellent example of why we might want to allow multiple From:
headers, just as RFC822 allows for e-mail. A user could include both his sip address,
and a tel: url as from headers.

Why are multiple From: lines not allowed in SIP, and where would it cause problems?
(to allow backwards compatability we could specify an Also-From: header for multiple
entries).

equally why are multiple To: lines not allowed - so users can see that several people
were invited to a particular call? currently it is possible to invite several people
separately, invite a group list (group@domain), but not possible, like with e-mail,
to invite several people and have them all see who else was invited.

Proposed:

An

Also-To:

header and an

Also-From:

header. These are intended for display by the final UA, and possibly used to direct a
reply call - just like e-mail.

Simon Barber

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of [email-masked]
> Sent: Wednesday, October 11, 2000 9:17 AM
> To: [email-masked]
> Subject: [SIP] From header to ISUP CgPN mapping
>
>