Subject: Re: [SIP] Sip- Message OPTION

From: [email-masked]
Date: Thu, 2 Nov 2000 10:38:47 +0530

Maybe the one in the bis-draft would be of help:

A caller Alice can use an OPTIONS request to find out the capabilities of a
 potential callee Bob, with-out

“ringing” the designated address. Bob returns a description indicating that
 he is capable of receiving
audio encodings PCM mu-law (RTP payload type 0), 1016 (payload type 1), GSM
 (payload type 3), and
SX7300/8000 (dynamic payload type 99), and video encodings H.261 (payload
type 31) and H.263 (payload
type 34).

C->S: OPTIONS sip:[email-masked] SIP/2.0
Via: SIP/2.0/UDP cat.wonderland.com
From: Alice <sip:[email-masked]>
To: Bob <sip:[email-masked]>
Call-ID: [email-masked]
CSeq: 1 OPTIONS
Accept: application/sdp

S->C: SIP/2.0 200 OK
From: Alice <sip:[email-masked]>
To: Bob <sip:[email-masked]> ;tag=376364382
Call-ID: [email-masked]
Content-Length: 81
Content-Type: application/sdp
v=0
o=alice 3149329138 3149329165 IN IP4 24.124.37.3
s=Security problems
t=3149328650 0
c=IN IP4 24.124.37.3
m=audio 0 RTP/AVP 0 1 3 99
a=rtpmap:0 PCMU/8000
a=rtpmap:1 1016/8000
a=rtpmap:3 GSM/8000
a=rtpmap:99 SX7300/8000
m=video 0 RTP/AVP 31 34
a=rtpmap:31 H261/90000
a=rtpmap:34 H263/90000

Regds
Arjun
--
Arjun Roychowdhury @ Hughes Software Systems

Sandeep Sahai <[email-masked]> on 11/02/2000 05:13:30 AM

To:   "[email-masked]'" <[email-masked]>
cc:

Subject:  [SIP] Sip- Message OPTION

Hi,

Can any one tell me what is the sip-message for OPTION look like.

I was trying to find the same in the call flow diagram document , but I
cannot see an example for an OPTION sip message.

So, please let me an example of sip-message for OPTION.

Thanks

Sandeep Sahai
Ph:- 408-571-3388 (O)
       510-487-2121 (R)
Journey of thousand miles starts with single step.

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Billy Biggs <[email-masked]>
Date: Thu, 2 Nov 2000 00:16:42 -0600

Note that this should be cleaned up.  There is no Via or CSeq in the
response, the CSeq in the request starts at 1, the From has no tag, and there
is no Content-Length.

-- 
Billy Biggs, 3Com               Email: [email-masked]
http://www.div8.net/billy/      Phone: [email-masked]

---

From: "Thys Nel" <[email-masked]>
Date: Thu, 2 Nov 2000 08:47:44 +0200

Does anyone have examples of messages flows with OPTIONS processed by a
registrar server? The only example in the RFC is between 2 user agents, but
the RFC states that a registrar must also support it. I can't seem to find
any description of when a registrar should respond to an OPTIONS request.

Thys

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Billy Biggs
> Sent: 02 November 2000 8:17
> To: [email-masked]
> Cc: Sandeep Sahai; SIP List
> Subject: Re: [SIP] Sip- Message OPTION
>
>