Subject: RE: [SIP] OPTIONS and out-of-band Route.

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 7 Nov 2000 02:07:52 -0500

> -----Original Message-----
> From: Fairlie-Cuninghame, Robert [mailto:[email-masked]]
> Sent: Monday, November 06, 2000 10:53 PM
> To: [email-masked]
> Subject: [SIP] OPTIONS and out-of-band Route.
> 
> 
> 
> There's seems to be a lot of discussion lately about out-of 
> band Route in
> INVITE. Here's a another reason for correct processing of 
> "out-of-band"
> Route headers ("out-of-band" with respect to an INVITE 
> initiated call-leg): 
> 
> When a UAC makes a OPTIONS request before performing a full 
> INVITE, the UAS
> may include a Contact in the 200 OK which be used as the 
> direct destination
> to send the initial INVITE. If a proxy needs to be on the path of the
> initial INVITE (eg proxy is acting as ALG) then the call will 
> fail if the
> proxy and UAC doesn't take some additional action.
> 
> DOn't we need to add something such as the following to the spec?

Well, this is a symptom of a more general problem, which is what is the
meaning of Record-Routing in requests in general, beyond INVITE. I would
propose the following:

If a proxy inserts a record-route into a request, that means it wishes to
receive all subsequent requests, in both directions, that contain the same
value of the To, From, and Call-ID. 

I like this, since then it works for MESSAGE and SUBSCRIBE, which have
similar requirements.

Now, to handle your OPTIONS case:

If a UAC initiates a call to a host as the result of an OPTIONS query, it
SHOULD use the same Call-ID as was used in the OPTIONS query. Note that as a
result of standard Record-Routing rules, this INVITE will contain any
routing information learned from the OPTIONS response.

This is now much more general purpose.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Anders Kristensen <[email-masked]>
Date: Tue, 07 Nov 2000 13:46:01 +0100

I wonder if it might be troublesome to start record-routing on any
messages exchanged prior to an intial INVITE as this will often be what
service logic triggers on. The service logic and management of the
triggers might become more complex and more brittle if one has to be
ready to start record-routing on a wider variety of conditions.

Anders Kristensen