Subject: RE: [SIP] More Torture Test Messages Available

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Fri, 24 Nov 2000 01:15:50 -0800

Hi Neil,

> "Fairlie-Cuninghame, Robert" wrote:
> > 
> > The colon in the user part of Test 36 (the long telephone 
> subscriber) needs
> > to be quoted. Perhaps you could also put a similar long 
> telephone-subscriber
> > URL in the Contact - this would test whether the URL was correctly
> > reproduced if the call is accepted.
> 
> I think the ':' might be OK as it becomes part of a hname in 
> an escaped header as it follows a '?', i.e. from parsing it 
> into:
> 	%22Route:%20X%40Y%3bZ = [email-masked];user=phone
>         	       header = hvalue
> However this would then mean the following  ';' and '=' in the 
> hvalue need to be escaped.

No, this is not an escaped SIP header (per se), rather it is all just part
of a telephone subscriber user portion and as such it follows a different
set of rules.  Reread Section 2. You need to escape any characters that not
in the unreserved or user-unreserved sets (hname and hvalue have nothing to
do with it). Colon is such a character.

> Also we would back into the problem of escaped headers not being
> allowed in Request-URIs. I am a bit uncertain about this now.
> The spec indicates that they are not allowed (Table 2) and 
> should be removed by a proxy before futher processing (4.3).
> However there seems to be a feeling that this may not be
> desirable
> - should there be a spec change here?

Again, these are not escaped headers but merely part of the user part, they
are only inpreterpreted with respect to the tel: URL syntax and not the SIP
URL syntax.

I hope that clarifies things.

Robert.

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Neil Deason <[email-masked]>
Date: Fri, 24 Nov 2000 09:33:53 +0000

"Fairlie-Cuninghame, Robert" wrote:
> set of rules. 

Ooops I missed that rather important point, I'll change ':' ->
%3a.

Thanks,
Neil.
-- 
Ubiquity Software Corporation, UK        http://www.ubiquity.net