Subject: RE: [SIP] More Torture Test Messages Available

From: Peter Kjellerstedt <[email-masked]>
Date: Tue, 21 Nov 2000 20:08:49 +0100

In test30.txt if the Expires value is in absolute formate,
then a Date header should be supplied too. Otherwise a UA
that has no real-time clock will not be able to tell whether
this is in the future or past. Actually I think the Expires
value should be compared with the Date header if available
since the UA on the other end may have an incorrect notion
of time...

Also, I am still lacking a test for this kind of To/From header:

	To: sip:[email-masked] ;tag=[email-masked]

and make sure the tag does not end up as a URL parameter...

//Peter

> -----Original Message-----
> From: Neil Deason [mailto:[email-masked]]
> Sent: 21 November 2000 19:30
> To: Sip List
> Subject: [SIP] More Torture Test Messages Available
> 
> The proposed new Torture Test messages have been added to the 
> main SIP web site:
> 
> http://www.cs.columbia.edu/~hgs/sip/bakeoff/testmsg.html
> 
> The new ones are test21.txt onwards. They should also appear in 
> the new verion of the SIP Message Flows draft shortly.
> 
> SIP bakeoff entrants are strongly encouraged to run these tests. 
> In particular entrants to advanced scenario testing at bakeoffs 
> will be expected to have passed all torture tests. 
> 
> Comments, corrections etc welcome.
> Neil.
> -- 
> Ubiquity Software Corporation, UK        http://www.ubiquity.net

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Neil Deason <[email-masked]>
Date: Wed, 22 Nov 2000 13:51:00 +0000

> since the UA on the other end may have an incorrect notion

But this isn't a MUST so the test message is legal, bear in
mind these are torture tests not examples of good practice.

> and make sure the tag does not end up as a URL parameter...

Sorry I forgot to add that one but tests 37 and 38 are pretty 
similar to this although admittedly they are for a registrar 
not UAS.

Cheers,
Neil.