Subject: RE: [SIP] What am I doing wrong ?

From: Sekhar Banerjee <[email-masked]>
Date: Tue, 14 Nov 2000 15:07:17 -0800

Hi Vijay,

Sekhar Banerjee wrote:
> 
> Hi SIP Experts,
>         Here is a question that I have about a certain call flow that I am
> trying to implement. Please look at the call flows and let me know what is
> wrong in this picture.
> 
>      A                  Proxy                   B                       C
> 
>      INVITE------------>
>                                 INVITE---------->
>                                       <--------- 100 Trying
>                                       <--------- 180 Ringing
>         <----------------- 180 Ringing
>                                 CANCEL ---------->
>                                         <----------- 200 OK
>                                         <----------- 487
> 
>                                 INVITE ----------------------------->
>                                         <------------------------------
100
> Trying
>                                         <------------------------------
180
> Ringing
>         <----------------- 180 Ringing
>                                         <------------------------------
200
> OK
>         <----------------- 200 OK
> 
>         What I have noticed with the devices that I am testing this call
> flow is that somehow they dont like the 180/200 OK that come in from C. Is
> there a reason  for this ? I would love to know this.
>Vijay wrote :
>There is no reason why A should reject a 180/200 OK from C; since it never
>got a final response from B, a call leg has not yet been established at A.
>On getting a 200 OK from C, a call leg should be established at A.

>However, I do see a bug in your call flow; note your call flow:

>A         Proxy      B              C
>INV-------->
>           INV------>
>           <--------100
>           <--------180
><---------180
>           CANCEL----->
>           <-----------200 OK
>           <-----------487
>           INV--------------------->

>In your call flow, your proxy starts a second INVITE to C; it never sends
an
>ACK to B; it should.  Logically, B's INVITE is still pending and it will
>continue re-transmitting 487 until ACK'ed or maximum response
retransmission
>limit has reached (which is 7 for an INVITE, if I am not mistaken). 
    Well .... that was something that I forgot to put in the diagram. I do
finish the INVITE transaction with the ACK.   

>I also assume that the 200 OK from B->Proxy is for Cancel (you do not
indicate 
>this in your call flow).  If this is not a correct assumption and the 200
OK is 
>for the INVITE, and since you want to CANCEL the transaction, you should
ACK 
>the 200 OK and then send a BYE.
   Yes ... the 200 OK is for the cancel.

   But my concern is with the tags that get attached with the responses
comming in from the end devices. Could that be the problem. I mean just
because the first 180 ringing had a different tag in the To field  than in
the second 180 ringing. Is that significant enough ? 

Thanks

Sekhar 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Billy Biggs <[email-masked]>
Date: Tue, 14 Nov 2000 17:15:37 -0600

Sekhar Banerjee ([email-masked]):

>    But my concern is with the tags that get attached with the
> responses comming in from the end devices. Could that be the
> problem. I mean just because the first 180 ringing had a different
> tag in the To field  than in the second 180 ringing. Is that
> significant enough ? 

  The UA should have no problem seeing different tags on responses.

  If the UA can't handle it, it is broken.

-- 
Billy Biggs, 3Com               Email: [email-masked]
http://www.div8.net/billy/      Phone: [email-masked]

---

From: Vijay Gurbani <[email-masked]>
Date: Tue, 14 Nov 2000 17:56:46 -0600

Sekhar Banerjee wrote:
[...]
> the second 180 ringing. Is that significant enough ?

Not enough to make the UAC misbehave; the tags on the provisional responses
from different UASs will be different.  As I said earlier, the call leg has 
not yet been established until a final response arrives at the UAC.  The 200 
OK from C should be accepted by A.

- vijay
--
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184