Subject: [SIP] Contact header is a 200 response to SUBSCRIBE for IMPP

From: "Hisham Khartabil" <[email-masked]>
Date: Thu, 9 Nov 2000 11:40:57 +0200

Section 4.2 of the presence draft has the following examples:

SUBSCRIBE sip:[email-masked] SIP/2.0
Via: SIP/2.0/UDP userpc.example.com
To: sip:[email-masked]
From: sip:[email-masked]
Contact: sip:[email-masked]
Call-ID: [email-masked]
CSeq: 1 SUBSCRIBE
Content-Length: 0

SIP/2.0 200 OK
Via: SIP/2.0/UDP presenceserver.dynamicsoft.com
Via: SIP/2.0/UDP userpc.example.com
To: sip:[email-masked]
From: sip:[email-masked]
Contact: sip:[email-masked]
Record-Route: sip:[email-masked];maddr=presenceserver.dynamicsoft.com
Expires: 3600
Call-ID: [email-masked]
CSeq: 1 SUBSCRIBE
Content-Type: application/xpidf+xml
Content-Length: 287

<?xml version="1.0"?>
<!DOCTYPE presence
 PUBLIC "-//IETF//DTD RFCxxxx XPIDF 1.0//EN" "xpidf.dtd">
<presence>
 <presentity uri="sip:[email-masked];method="SUBSCRIBE">
  <atom id="779js0a98">
   <address uri="sip:[email-masked];method=INVITE">
    <status status="open"/>
   </address>
  </atom>
 </presentity>
</presence>

Then, it goes on to say:
"Notice that the response has mirrored many fields from the
request,including the To, From, Call-ID, CSeq, and Via headers. The PA has
also added a Contact header, providing an address where it can be reached.
The response also contains a Record-Route header. This header was presumably
inserted by the proxy (the address in the maddr header is that of a presence
server acting as a proxy), and is reflected in the 200 OK response. The
response also contains a presence document for the presentity, and a Contact
header. The Contact headers in a response to SUBSCRIBE list all the current
addresses which have been subscribed."

The example shows that the Contact header in the response does actually list
the current address which has been subscribed ([email-masked]).
But I fail to see where the Contact header that the PA added providing an
address where it can be reached.

Regards,
Hisham Khartabil
Hotsip Finland

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Hisham Khartabil" <[email-masked]>
Date: Tue, 21 Nov 2000 15:44:09 +0200

Hi,
I'm posting the following again since there was no reply the first time
around

Regards,
Hisham Khartabil
Hotsip Finland
www.hotsip.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Hisham Khartabil
Sent: Thursday, 9 November 2000 11:41 AM
To: [email-masked]
Subject: [SIP] Contact header is a 200 response to SUBSCRIBE for IMPP

SIP/2.0 200 OK

<?xml version="1.0"?>
<!DOCTYPE presence

Then, it goes on to say:

Regards,
Hisham Khartabil
Hotsip Finland