Subject: [SIP] Comments on 2806bis-00

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 01 Nov 2000 21:22:41 -0800

One very basic comment is that the current RFC 2806 does not follow the
normal URI syntax description rules. This is very confusing, as it leads
to duplicating the description of escaping, with different rules and, as
witnessed on this list a few months ago, weeks of confusion as the two
"worlds" are mentally merged. I would strongly recommend that the ABNF
be revised to conform to the standard way of specifying URL content.

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Sean Olson <[email-masked]>
Date: Fri, 03 Nov 2000 13:52:25 +0100

Another minor comment on RFC2806. The private-prefix syntax
is defined as below.

private-prefix        = (%x21-22 / %x24-27 / %x2C / %x2F / %x3A /
                        %x3C-40 / %x45-4F / %x51-56 / %x58-60 /
                        %x65-6F / %x71-76 / %x78-7E)
                        *(%x21-3A / %x3C-7E)
                        ; Characters in URLs must follow escaping rules
                        ; as explained in [RFC2396]

Missing from this private-prefix are the following US-ASCII letters.

I am assuming these are missing because they are valid
dtmf-digit characters and you want to avoid ambiguity with the
local-prefix (the global-prefix is unambiguous because of the
leading '+')

%x41 = 'A'
%x42 = 'B'
%x43 = 'C'
%x44 = 'D'
%x61 = 'a'
%x62 = 'b'
%x63 = 'c'
%x64 = 'd'

These likewise would have been omitted because of the
conflict with the 'pause' and 'wait-for-dial-tone'
that can also occur in the local-prefix.

%x50 = 'P'
%x57 = 'W'
%x70 = 'p'
%x77 = 'w'

This unfortunately is a bit limiting for the private prefix.
My suggestion is that rather than omitting these from the
private-prefix, that you require the private-prefix to
start with a special prefix as with the global-prefix.
For this purpose I would recommend "_" (%x5F).

The ABNF for private-prefix would then become:

private-prefix = "_" 1*(token-char)

This would be unambiguos and more flexible.
The exact prefix to the private-prefix is not important.
It could, for instance, also be "X-"|"x-". What is important
is that the letters a-d, p, and w are not excluded.

Regards,
Sean

--
Sean Olson <[email-masked]>