Subject: RE: [SIP] spaces in SIP-URL

From: "Snyder, Duke" <[email-masked]>
Date: Mon, 20 Nov 2000 21:04:38 -0500

Just to make sure I'm clear, is this true:
Both SIP-URL and URI (as in the contact, to, from headers) can not contain
spaces.  

		Henning wrote:
		URLs, SIP or otherwise, cannot have unescaped spaces. Never
have, never
		will.

		Anders Kristensen wrote:
		> 
		> [email-masked] wrote:
		> >
		> > you are pretty much on track....some additions are
		> >      between the user and the "@"
		> >      between the "@" and the host
		> >      between host and " : "
		> >      between ":" and port
		> >      between port and ";"
		> >      between ";" and url
		> >      and so on...you have left out separators. You can
have spaces or line
		> > folds between any 2 tokens , separators or otherwise.
		> 
		> Why do you think spaces here are legal? As far as I can
tell rfc 2396,
		> "Uniform Resource Identifiers (URI): Generic Syntax" seems
to clearly
		> spaces in URIs altogether. The comments on "implied *LWS"
in appendix B
		> of rfc 2543 doesn't change this.
		> 
		> Anders
		> 

		-- 
		Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

		_______________________________________________
		SIP mailing list
		[email-masked]
		http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Mon, 20 Nov 2000 21:08:58 -0500

>                 URLs, SIP or otherwise, cannot have unescaped spaces. Never

I'm sorry if my note was unclear, but the answer is that these URLs MUST
NOT contain unescaped spaces (%20 is obviously ok where it makes sense).