Subject: [SIP] Use of Record-Route and Contact Headers

From: "Phil Hoffer" <[email-masked]>
Date: Wed, 8 Nov 2000 11:56:43 -0000

Hi,

This will be the third time that I have posted this message, without
receiving a satisfactory reply.
Please gimme some feedback!

Thanks
Phil

----------------------------------------------------------------------------
--

Hi,

Table 4 of bis02 states that a Contact header can occur in the following
response types:

1xx
2xx
3xx
485 (Ambiguous)

However, Table 5 states that Record-Route can occur in the following
response types:

2xx
401 (Unauthorized)
484 (Address Incomplete)

I don't see how a response can include a Record-Route, if it can't contain a
Contact.
I believe that 401 and 484 should be added to the list of response types for
a Contact header.

What do you think?

Cheers
Phil

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Hisham Khartabil" <[email-masked]>
Date: Thu, 9 Nov 2000 11:48:31 +0200

I think the way it works is that if a Contact header has been omitted in a
response and there is a record-route, you would use the URI in the To:
field.

Regards,
Hisham
Hotsip Finland

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Phil Hoffer
Sent: Wednesday, 8 November 2000 1:57 PM
To: [email-masked]
Subject: [SIP] Use of Record-Route and Contact Headers

Hi,

Thanks
Phil

Hi,

1xx
2xx
3xx
485 (Ambiguous)

2xx
401 (Unauthorized)
484 (Address Incomplete)

What do you think?

Cheers
Phil

---

From: Sean Olson <[email-masked]>
Date: Thu, 09 Nov 2000 17:58:24 +0100

I must ask why you want to include a Contact: in either a
401 or a 484. In particular, I am very interested to know
what you would put in a Contact: that was returned in a 484?

(I agree in general that you should be able to use a Contact:
header anywhere you use a Record-Route:. I'm just curious
what applications you have in mind for these cases)

Regards
Sean Olson <[email-masked]>

---

From: "Phil Hoffer" <[email-masked]>
Date: Thu, 9 Nov 2000 17:19:40 -0000

> Sean Olson <[email-masked]

Hi Sean,

Well if you consult Tables 5 in the bis draft you will see that it
states that it is possible to include a Record-Route in both a 401
and a 484 response.

The whole essense of Record-Route is to allow proxies to stay in
the signalling loop, which can be optimised by the use of Contacts.
So the set of responses which can contain a Record-Route, must be
a subset of the repsonses which can contain a Contact.

In both cases, I can see that the Contact would allow the caller
to recontact the callee directly, with credentials in the case of
a 401 response, or a gateway with extra digits in the case of
a 484 response. In both of these cases there is a very good chance
that the callee will retry with the extra information.

In both cases, a proxy on the original path might include a 
Record-Route in order to stay in the signalling loop.

Hence, I think that Contacts in 401 and 484 should be added
to table 5.

Just trying to clarify the spec for the community of SIP developers.
My reward might be in heaven.  :)

HTH
Cheers
Phil