Subject: [SIP] New SUBSCRIBE/NOTIFY draft available

From: "Adam B. Roach" <[email-masked]>
Date: Wed, 22 Nov 2000 16:06:18 -0600 (CST)

A new SUBSCRIBE/NOTIFY draft (-02) has been submitted. Until it
appears on the IETF website, you may retreive a copy from:

http://ia.yimg.com/a/5e379c0a/h/57a388ad/draft-roach-sip-subscribe-notify-02.txt

Please send comments and replies to the [email-masked]
mailing list.

I believe that this draft incorporates all of the concerns which have
been raised with the -01 draft; please inform me if I've overlooked
anything. Changes include:

     - Multiple contacts per SUBSCRIBE message disallowed.

     - Contact header now required in NOTIFY messages.

     - Distinction between third party/call member events removed.

     - Distinction between call-related/resource-related events removed.

     - Clarified that subscribers must expect NOTIFY messages before
       the SUBSCRIBE transaction completes

     - Added immediate NOTIFY message after successful SUBSCRIBE;
       this solves a myriad of issues, most having to do with forking.

     - Added discussion of "undefined state" (before a NOTIFY arrives).

     - Added mechanism for notifiers to shorten/cancel outstanding
       subscriptions.

     - Removed open issue about appropriateness of new "489" response.

     - Removed all discussion of out-of-band subscriptions.

     - Added brief discussion of event state polling.

-- 
Adam Roach, Ericsson Inc. |  Ph: +1 972 583 7594 | 1010 E. Arapaho, MS L-04
[email-masked]   | Fax: +1 972 669 0154 | Richardson, TX 75081 USA

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Adam B. Roach" <[email-masked]>
Date: Wed, 22 Nov 2000 16:11:35 -0600 (CST)

>http://ia.yimg.com/a/5e379c0a/h/57a388ad/draft-roach-sip-subscribe-notify-02.txt

It has been brought to my attention that this link doesn't always
work; you may instead need to select the draft from this page:

http://briefcase.yahoo.com/bc/adamr?c&.flabel=fld6&.src=bc