Subject: [SIP] failure of proxy

From: "Samorezov Vladimir" <[email-masked]>
Date: Sat, 4 Nov 2000 12:42:07 +0300

Hi, all!
Could you help me in my SIPs study?
If proxy forwards a SIP request, it add Via header with its address. This ensures responses take the same path as the requests. OK!
If one proxy along the path is failure, what upstream proxy must do to route responses?   

Thank you!
Samorezov Vladimir.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 13 Nov 2000 09:11:58 -0500

> -----Original Message-----
> From: James Undery [mailto:[email-masked]]
> Sent: Wednesday, November 08, 2000 6:02 AM
> To: Jonathan Rosenberg
> Cc: [email-masked]
> Subject: Re: [SIP] failure of proxy
> 
> 
> 
> 
> Jonathan Rosenberg wrote:
> 
> >
> > For things to work consistently, the SRV lookup process 
> should be based on
> > the pseudo-random number generator I suggested in a 
> previous thread; thats
> > the one based on a hash of the Call-ID, amongst other 
> things. This gives us
> > consistent operation for SRV records in general.
> 
> As I replied in a previous thread (with a bad example) this 
> hash based method
> gives us nothing in general it only works if you locally 
> cache DNS for the life
> time of a transaction, for each transaction (hence truly 
> stateless proxy servers
> do not work ;^) ). The reason for this is simple  for the 
> hash method to work
> the result from the DNS query MUST be identical even in 
> ordering of the RRs each
> time.

OK, so my proposal is that a UA or proxy that does a DNS query should order
entries of equal priority and preference using some sorting rule,
alphabetical or whatever. We really need for this to work somehow.

 As an example of why this may not happen I'll admit my 
> short comings, the
> first time I implemented SRV lookups I was lazy I found the 
> lowest priority RRs
> and picked the first one. If I was writing a DNS server I may 
> expect other
> people to do this, and in a more thorough moment may decide 
> to shuffle the
> results my server returned for SRV records (this wouldn't 
> provide the same level
> of load balancing but could help).
> 
> Also it's possible the zone file might have changed.

In that case, I think it is reasonable that requests may go to different
places.

-JOnathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip