Subject: RE: [SIP] SIP ringback tone

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Mon, 13 Nov 2000 03:33:35 -0800

Henry,

Innovative ringback greetings definitely seem like a case for an early media
to me.

As an aside, many people still seem to erroroneously think that 183 Session
Progress should be used for early-media ring-back. 180 Ringing with SDP
should be used for ringback purposes, 183 with SDP should only be used for
call progress messages (ie, not alerting the user). I still think this needs
to be made clearer in the spec!

Cheers,

Robert.

-- My opinions are my own. I tried selling them once but everybody
	seems to already have one. -- 

> -----Original Message-----
> From: Henry Sinnreich [mailto:[email-masked]]
> Sent: Monday, November 13, 2000 6:18 AM
> To: [email-masked]; IETF SIP (E-mail)
> Subject: [SIP] SIP ringback tone
> 
> 
> The draft on "Ringback tones in SIP-Based Telephony" shows 
> impressive work
> on preserving legacy country specific ring back tones. I 
> wonder if we would
> not be better of by adding a
> 
> SIP Ringback Tone
> =================
> 
> With some optional fields where service providers could add innovative
> greetings.
> 
> Henry
> 
> Henry Sinnreich
> WorldCom
> 400 International Parkway,
> Richardson, Texas, 75081
> 
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: David Shrader <[email-masked]>
Date: Mon, 13 Nov 2000 08:53:57 -0500

Robert,

I don't agree that 183 with SDP should only be a call progress message. It
is a perfectly reasonable usage to support ringback. This is especially
necessary when interworking with the PSTN where ringback is delivered
inband. If you implement a system that works with the PSTN, I think we
shouldn't require it to support two modes of operation. It seems reasonable
that the use of 183 masks whether I'm going to the PSTN or another SIP
endpoint identified by a telephone number and allows the person or network
being called to provide whatever inband indication it chooses.

David

----------------------------
David Shrader
Master Consultant, Inc.
[email-masked]
http://www.EyeForTheFuture.com

> From: "Fairlie-Cuninghame, Robert" <[email-masked]>
> Date: Mon, 13 Nov 2000 03:33:35 -0800
> To: "'Henry Sinnreich'" <[email-masked]>
> Cc: "[email-masked]'" <[email-masked]>
> Subject: RE: [SIP] SIP ringback tone
> 
> Henry,
>