Subject: [SIP] the parser

From: "kajun Robert" <[email-masked]>
Date: Wed, 22 Nov 2000 18:26:48 -0800

hi,
   I don't know what the parser should do and it seems that the parser has muddled me. Can you help me? I think it should check the message byte-by-byte to ensure that every character has fallen into a specific field, such as unreserved filed, DIGIT filed etc. Also the parser can find the syntax error besides the characters falling into some fields. For example, the parser should find the errors such as "%4q", 101.3332.3.5 (the Ipv4address) and so on in the Request-URL, although the characters are allowed to appear in the message. 
   Is that true? Also I am not sure the @ character can be escaped. If it can be escaped, the parser would not have mechanism to distinguish the one that the Spec requests with the one that the user's own escaped character? 
   Thanks.
   Robert Kajun

________________________________________________________________________
Get Your Free International E-mail from Langoo.com at http://www.langoo.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Arun Kumar Chippada <[email-masked]>
Date: Wed, 22 Nov 2000 23:00:03 -0500 (EST)

Dear All,

We want to know whether it is possible to run a SIP Proxy Server and a
SIP User Agent on the same machine. Has anyone ever tried to do this? 

Arun.

---

From: "Jo Hornsby" <[email-masked]>
Date: Thu, 23 Nov 2000 09:29:28 -0000

> SIP User Agent on the same machine. Has anyone ever tried to do this? 

Yes -- it is possible.  In general they are going to have to listen
on different ports.  (I say in general because its possible to have an
application that functions as a UA for one transaction, and a
Proxy for another.)

 - Jo.

---

From: Arun Kumar Chippada <[email-masked]>
Date: Thu, 23 Nov 2000 14:19:14 -0500 (EST)

We are running the SIP Proxy Server and the SIP User Agent on the same
machine. We are using the Columbia University's sipd as our proxy server
and their sipua as the user agent. The sipd is listening on the default
port 5060. The sipua is started on port 5444. We verified that they are
listening properly like this on 2 different ports using "netstat -a"

Then we  tried to register a user with user name "chippada" and domain
name "cse.msu.edu" sending the register request from the sipua to
sipd. The machine that we are running the sipd as well as the sipua has IP
address "10.0.0.16" and name "johan.cse.msu.edu"

So we have the following session using the sipua and the output printed by
the sipua.

sipua> register sip:[email-masked] sip:10.0.0.16
Registering to server as sip:[email-masked] at sip:10.0.0.16 with
contact sip:[email-masked]:5444
REGISTER sip:10.0.0.16 SIP/2.0
Via: SIP/2.0/UDP johan.cse.msu.edu:5444; branch=4044117737-0
From: sip:[email-masked]
To: sip:[email-masked]
CSeq: 1 REGISTER
Call-ID: [email-masked]
Expires: 3600
Contact: sip:[email-masked]:5444
Content-Length: 0

975005101.235 ReceiveUDP(): received UDP packet (length 299) from
10.0.0.16:1052:
SIP/2.0 482 Loop detected
Via: SIP/2.0/UDP johan.cse.msu.edu:5444; branch=4044117737-0
From: sip:[email-masked]
To: sip:[email-masked]
Call-ID: [email-masked]
Cseq: 1 REGISTER
Date: Thu, 23 Nov 2000 18:45:01 GMT
Server: Columbia-SIP-Server/1.0
Content-Length: 0 

We are thinking that the sipua is able to contact the sipd but the sipd is
not registering the user  and instead sending the message "Loop Detected".
Does this have to do something with running the user agent and the
proxy server on the same machine? Or are we doing something wrong in the
register request?

Thankyou,
Arun.

---

From: Kundan Singh <[email-masked]>
Date: Thu, 23 Nov 2000 14:29:30 -0500 (EST)

Hi Arun,

We have found and fixed this problem a couple of weeks ago.
I will directly contact you soon regarding the new version.

Also, please do not use the SIP list for discussion
related to a specific implementation.

--
Kundan Singh     http://www.cs.columbia.edu/~kns10

---

From: Sean Olson <[email-masked]>
Date: Sun, 26 Nov 2000 10:29:14 +0100

This is purely an implementation choice (obviously). There are so many
variables that enter into this choice that it is impossible to state
a definitive answer. I fall in the camp of doing as little as possible in
the parser, but there are good reasons for doing strict syntax checking
as you mention for some applications.

The "@" character should not be escaped. Escaping this character changes
the semantics of the URL.

My two cents
--
Sean Olson <[email-masked]>

---

From: Sean Olson <[email-masked]>
Date: Sun, 26 Nov 2000 10:30:53 +0100

Yes and Yes. You can choose different ports for each server or
you can do some clever magic to run both on the same port. I
leave it as an excercise for the reader to figure that one out.