Subject: RE: [SIP] SIP Registration minimal interval?

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 21 Nov 2000 04:44:35 -0500

> -----Original Message-----
> From: Baniel Uri-CUB001 [mailto:[email-masked]]
> Sent: Monday, November 20, 2000 12:41 PM
> To: [email-masked]'
> Subject: [SIP] SIP Registration minimal interval?
> 
> 
> Hi
> Is there any 'floor limitation' on the registration interval? 
> I mean, let's say the registrar asks the client to register 
> every 20 minutes.
> Can the client decide to register every 1 minute? If YES, do 
> we have any way to prevent malicious or badly configured 
> client from overloading the network?

Yes, you would call the protocol police. I'll look the number up and send it
to you :)

Seriously, there is nothing a protocol can do to stop users from sending
messages. Thats not a SIP thing, its an IP thing.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Tue, 21 Nov 2000 09:27:12 -0500

> messages. Thats not a SIP thing, its an IP thing.

At least in the United States, interfering with the operation of a
computer system can be a federal offense, so you can indeed call the FBI
as the "protocol police". Yahoo and others did when they were on the
receiving end of various DDOS attacks.
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs