Subject: [SIP] Help with installation of sipd

From: Tajindrapal Singh <[email-masked]>
Date: Fri, 3 Nov 2000 18:22:37 -0500 (EST)

Hi,
   We are trying to install sipd (columbia release) on a linux box. But, before compiling sipd server, do we need to install the LDAP (Umich distribution)? If so then I guess we need root access for installation of LDAP??

   In the README.build of sipd there is an example for configuring  as follows:

  ./configure --with-db=/proj/irt-gc4/cinema/sun5 \
              --with-ldap=/proj/irt-gc4/cinema/sun5

 Now, we are not sure as to what should be in the sun5 directory? Should there be the sources for LDAP and berkely db? OR Is it the executables that needs to be present in this directory?

Any help and suggestions will be greatly appreciated.

Thanks
T.Singh

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Lennox <[email-masked]>
Date: Mon, 6 Nov 2000 11:44:47 -0500 (EST)

>    We are trying to install sipd (columbia release) on a linux box. But, before compiling sipd server, do we need to install the LDAP (Umich distribution)? If so then I guess we need root access fo…

No -- all you need is write access to a directory where you can install ldap
binaries.

>  Now, we are not sure as to what should be in the sun5 directory? Should there be the sources for LDAP and berkely db? OR Is it the executables that needs to be present in this Any?

That should be the root of the installation directory for ldap and Berkeley
DB.   I.e., on our platform, the directory /proj/irt-gc4/cinema/sun5/lib
contains libdb.a, liblber.a, and libldap.a, and
/proj/irt-gc4/cinema/sun5/include contains db.h, lber.h, and ldap.h (and
other support files).

-- 
Jonathan Lennox
[email-masked]