Subject: [SIP] Via processing rules

From: "Hisham Khartabil" <[email-masked]>
Date: Wed, 22 Nov 2000 16:25:21 +0200

Hi,

section 6.46.3 in rfc2543bis says:

Via header fields in responses are processed by a proxy or UAC according to
the following rules:
1. The first Via header field should indicate the proxy or client processing
this response. If it does not, discard the message. Otherwise, remove this
Via field.
2. If there is no second Via header field, this response is destined for
this client. Otherwise, use this Via field as the destination, as described
in Section 6.46.5.

is that implying that a UAC has to forward the request, even if it is an end
user?

Regards,
Hisham Khartabil
Hotsip Finland
www.hotsip.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Jo Hornsby" <[email-masked]>
Date: Wed, 22 Nov 2000 14:32:21 -0000

> Via header fields in responses are processed by a proxy or UAC 
> according to the following rules:
> 1. The first Via header field should indicate the proxy or client 
> processing this response. If it does not, discard the message.
> Otherwise, remove this Via field.
> 2. If there is no second Via header field, this response is destined
> for this client. Otherwise, use this Via field as the destination,
> as described in Section 6.46.5.
> 
> is that implying that a UAC has to forward the request, even if 
> it is an end user?

(I think you mean response?)

I don't see how, unless a UAC received a response that had more
than one Via.  In such a case, either the UAC wasn't behaving
as a UAC (i.e., it was a proxy) when it sent the corresponding
request; or something downstream has gone ka ka.

 - Jo.

---

From: "Hisham Khartabil" <[email-masked]>
Date: Wed, 22 Nov 2000 16:43:10 +0200

Sorry, I did mean response.

I think the text should explicitly say that in this situation, something
downstream has gone ka ka (well, not exactly that:-) )  and how to handle
this message.  Discard it, perhaps.

Regards,
Hisham

-----Original Message-----
From: Jo Hornsby [mailto:[email-masked]]
Sent: Wednesday, 22 November 2000 4:32 PM
To: Hisham Khartabil; [email-masked]
Subject: RE: [SIP] Via processing rules

 - Jo.

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Wed, 22 Nov 2000 10:03:01 -0500

> this message.  Discard it, perhaps.

Sorry, but unless we want a 400-page spec, the spec won't be able to
spell out every possible error situation that anybody can dream up,
particularly since error handling is up to the implementation. Some will
be very lenient (or just sloppy), others will be flagging the slightest
violation and send along bake-off invitations.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs