Subject: RE: [SIP] Contact header is a 200 response to SUBSCRIBE for IMPP

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 22 Nov 2000 03:52:55 -0500

> -----Original Message-----
> From: Hisham Khartabil [mailto:[email-masked]]
> Sent: Tuesday, November 21, 2000 8:44 AM
> To: [email-masked]
> Subject: RE: [SIP] Contact header is a 200 response to SUBSCRIBE for
> IMPP
> 
> 
> Hi,
> I'm posting the following again since there was no reply the 
> first time
> around
> 
> Regards,
> Hisham Khartabil
> Hotsip Finland
> www.hotsip.com
> 
> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Hisham Khartabil
> Sent: Thursday, 9 November 2000 11:41 AM
> To: [email-masked]
> Subject: [SIP] Contact header is a 200 response to SUBSCRIBE for IMPP
> 
> Section 4.2 of the presence draft has the following examples:
> 
> SUBSCRIBE sip:[email-masked] SIP/2.0
> Via: SIP/2.0/UDP userpc.example.com
> To: sip:[email-masked]
> From: sip:[email-masked]
> Contact: sip:[email-masked]
> Call-ID: [email-masked]
> CSeq: 1 SUBSCRIBE
> Content-Length: 0
> 
> 
> 
> SIP/2.0 200 OK
> Via: SIP/2.0/UDP presenceserver.dynamicsoft.com
> Via: SIP/2.0/UDP userpc.example.com
> To: sip:[email-masked]
> From: sip:[email-masked]
> Contact: sip:[email-masked]
> Record-Route: 
> sip:[email-masked];maddr=presenceserver.dynamicsoft.com
> Expires: 3600
> Call-ID: [email-masked]
> CSeq: 1 SUBSCRIBE
> Content-Type: application/xpidf+xml
> Content-Length: 287
> 
> <?xml version="1.0"?>
> <!DOCTYPE presence
>  PUBLIC "-//IETF//DTD RFCxxxx XPIDF 1.0//EN" "xpidf.dtd">
> <presence>
>  <presentity uri="sip:[email-masked];method="SUBSCRIBE">
>   <atom id="779js0a98">
>    <address uri="sip:[email-masked];method=INVITE">
>     <status status="open"/>
>    </address>
>   </atom>
>  </presentity>
> </presence>
> 
> 
> Then, it goes on to say:
> "Notice that the response has mirrored many fields from the
> request,including the To, From, Call-ID, CSeq, and Via 
> headers. The PA has
> also added a Contact header, providing an address where it 
> can be reached.
> The response also contains a Record-Route header. This header 
> was presumably
> inserted by the proxy (the address in the maddr header is 
> that of a presence
> server acting as a proxy), and is reflected in the 200 OK 
> response. The
> response also contains a presence document for the 
> presentity, and a Contact
> header. The Contact headers in a response to SUBSCRIBE list 
> all the current
> addresses which have been subscribed."
> 
> The example shows that the Contact header in the response 
> does actually list
> the current address which has been subscribed 
> ([email-masked]).
> But I fail to see where the Contact header that the PA added 
> providing an
> address where it can be reached.

Err, we have inconsistent text here on what the meaning of Contact header is
in the 200 response. The problems relate to the dual usage of SUBSCRIBE to
have INVITE-like record-routing semantics, and REGISTER like informational
semantics. 

There are two choices:

1. We go all the way to INVITE like semantics, so that the Contact in the
response is the PA address. The Contact address in the SUBSCRIBE itself is
therefore not mirrored.
2. We maintain a hybrid, and instead of having the PA insert a Contact into
the response, the PA itself "record-routes", even though its not a proxy. 

I'd prefer (1) at this point, especially now that we have dropped the
multiple Contacts in SUBSCRIBE.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Hisham Khartabil" <[email-masked]>
Date: Wed, 22 Nov 2000 11:28:05 +0200

I wasn't aware the "multiple contacts" has been dropped from SUBSCRIBE. Why
was the dropped?
Even then, why wouldn't the 200 responses contain the contacts of the
individual subscriptions (registration like)?

I agree with option 1 though. Knowing where to directly contact the PA is
much more useful than getting a response with contacts you subscribed to
(they should be stored somewhere on the client anyway)

Hisham

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Jonathan Rosenberg
Sent: Wednesday, 22 November 2000 10:53 AM
To: 'Hisham Khartabil'; [email-masked]
Subject: RE: [SIP] Contact header is a 200 response to SUBSCRIBE for IMPP

There are two choices:

-Jonathan R.
---