Subject: [SIP] SIP End-2-End Security

From: "Tom Tang" <[email-masked]>
Date: Mon, 13 Nov 2000 14:01:07 -0800

Hello :

   I am wondering what mechanisms companies are planning to 
 deploy for SIP security.  I've been hearing PGP and TLS 
 mainly, but I didn't see any postings for extensions to 
 either protocols.  Please tell me if I've skipped over some
 draft. Thanks.

 - Tom Tang

Tom Tang
IP Unity
1575 McCandless Drive
Milpitas, CA 95035
(408) 957-0800 x154 (w)
(408) 957-0823 (f) 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Michael Thomas <[email-masked]>
Date: Tue, 14 Nov 2000 07:58:22 -0800 (PST)

You need to be careful about what you mean by "end
to end".  Proxy-routed e-2-e traffic cannot use
TLS. Only an application layer protocol such as
PGP can do that, and you still probably want to
use hopwise crypto to protect the outer headers
from tampering and snooping.

If you're talking about hopwise crypto -- which
may lead to an end to end security association
with the two UA's -- TLS and IPsec are the usual
suspects. TLS doesn't work for UDP, so IPsec is
somewhat more general.

	      Mike