Subject: [SIP] Sip Grammars out there?

From: David Frascone <[email-masked]>
Date: Wed, 15 Nov 2000 14:22:50 -0600

Has anyone out there written a sip parser in yacc/bison?  I'm trying to find
a free grammar for it if anyone has.

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "M. Ranganathan" <[email-masked]>
Date: Wed, 15 Nov 2000 16:40:14 -0500

6‹riÇºÖ§¶ZèºÚn¶V§‚æ z+#jö’µ¬ºw#¥–›¢w¨ºØ§jfµêèlzKjghréžžØ§‚+ZØ¶Ø§‚+Z¦šè½ç_¢ºnnXœé^jÇˆ·¥•·¢žØi¹¹bqÚ&j)ßç‘jx
«âtZÚ±Ê'{
èµáÚ±©ò¢w¨ºÛaz·°®+mzv¬ŠšZ®Ç«Š|šqÏÛŠÊ'"kkÊ)à¶‡âÖŸç ­©¦j·è®+b}©ò¢w¡jÄˆ>f¢–)à–+-HƒåŠËlmée•¦ìr‰¡¶ÚþX¬¶ÆÞ–YZnÇ(›ùšŠYšŸùb²Ø§~ìŠ“jx«ajsHI0½©ÜyÓ^·
+’)àMç!ž‰h‚'¬º.§]4êÞjàëŠ÷’¶Š|÷mj+az»º¸m<÷ÔÞ—}5÷¾wë®kô×ŸtÓÝö

---

From: jimmy Zhang <[email-masked]>
Date: Wed, 15 Nov 2000 14:49:48 -0800

Just curioius DFA version of the parser is faster than the NFA version
of the parser, which one could be faster? by how much?

"M. Ranganathan" wrote:

> Not yacc but antlr (output language is java). Stay tuned... I will put
> one out in a matter of 2 weeks  (I am documenting it and getting it
> approved for public release).   It will be in th public domain (free).
>
> Ranga.
>
>
> David Frascone wrote:
>
> --
> M.Ranganathan
> NIST Advanced Networking Technologies Group,
> 100 Bureau Drive, Stop 8920, Gaithersburg, MD 20899.
> Tel: 301 975 3664 Fax: 301 590 0932
>
>

--

Jimmy zhang ([email-masked])

Software Engineer