Subject: RE: [SIP] SIP ringback tone

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Mon, 13 Nov 2000 09:04:42 -0800

The way the spec is written at the moment (see Section 7.1 - it changed
recently), a UAC should be able to accept any 1xx response (other than 100)
with SDP as indicating early media. eg 183, 182, 181 or 180. Obviously they
must have different meanings or there is no reason to have the different
response codes (COMET aside). Both the expired 183 draft (explicitly) and
the bis-02 draft (inferred) say that 183 indicates call progress events
_other_ than user alerting (eg "queued message", "please wait, verifying" or
"enter pin number" voice messages) --- yet the mechanism is the same for 180
and 183. [I just think it should be made clearer in the 183 description.]

I don't understand your point about requiring support for two mechanisms and
that it "masks whether I'm going to the PSTN or another SIP endpoint
identified by a telephone number". How so? And more importantly, why is this
necessary ?

In fact I would say the opposite is true. A SIP client that is not PSTN
centric and doesn't bother with early media playback should not have to know
that 183 is actually ringback on a PSTN SIP client. The client should simply
know that a received 180 indicates user alerting, 182 is queued and 183 is
some other call progress event.

Regards,

Robert.

-- My opinions are my own. I tried selling them once but everybody
	seems to already have one. -- 
> -----Original Message-----
> From: David Shrader [mailto:[email-masked]]
> Sent: Monday, November 13, 2000 9:54 PM
> To: Fairlie-Cuninghame, Robert
> Cc: SIP List
> Subject: Re: [SIP] SIP ringback tone
> 
> 
> Robert,
> 
> I don't agree that 183 with SDP should only be a call 
> progress message. It
> is a perfectly reasonable usage to support ringback. This is 
> especially
> necessary when interworking with the PSTN where ringback is delivered
> inband. If you implement a system that works with the PSTN, I think we
> shouldn't require it to support two modes of operation. It 
> seems reasonable
> that the use of 183 masks whether I'm going to the PSTN or another SIP
> endpoint identified by a telephone number and allows the 
> person or network
> being called to provide whatever inband indication it chooses.
> 
> David
> 
> ----------------------------
> David Shrader
> Master Consultant, Inc.
> [email-masked]
> http://www.EyeForTheFuture.com
> 
> > From: "Fairlie-Cuninghame, Robert" <[email-masked]>
> > Date: Mon, 13 Nov 2000 03:33:35 -0800
> > To: "'Henry Sinnreich'" <[email-masked]>
> > Cc: "[email-masked]'" <[email-masked]>
> > Subject: RE: [SIP] SIP ringback tone
> > 
> > Henry,
> > 
> > Innovative ringback greetings definitely seem like a case 
> for an early media
> > to me.
> > 
> > As an aside, many people still seem to erroroneously think 
> that 183 Session
> > Progress should be used for early-media ring-back. 180 
> Ringing with SDP
> > should be used for ringback purposes, 183 with SDP should 
> only be used for
> > call progress messages (ie, not alerting the user). I still 
> think this needs
> > to be made clearer in the spec!
> > 
> > Cheers,
> > 
> > Robert.
> > 
> > -- My opinions are my own. I tried selling them once but everybody
> > seems to already have one. --
> > 
> >> -----Original Message-----
> >> From: Henry Sinnreich [mailto:[email-masked]]
> >> Sent: Monday, November 13, 2000 6:18 AM
> >> To: [email-masked]; IETF SIP (E-mail)
> >> Subject: [SIP] SIP ringback tone
> >> 
> >> 
> >> The draft on "Ringback tones in SIP-Based Telephony" shows
> >> impressive work
> >> on preserving legacy country specific ring back tones. I
> >> wonder if we would
> >> not be better of by adding a
> >> 
> >> SIP Ringback Tone
> >> =================
> >> 
> >> With some optional fields where service providers could 
> add innovative
> >> greetings.
> >> 
> >> Henry
> >> 
> >> Henry Sinnreich
> >> WorldCom
> >> 400 International Parkway,
> >> Richardson, Texas, 75081
> >> 
> >> 
> >> 
> >> _______________________________________________
> >> SIP mailing list
> >> [email-masked]
> >> http://lists.bell-labs.com/mailman/listinfo/sip
> >> 
> > 
> > _______________________________________________
> > SIP mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/sip
> > 
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Alan Johnston <[email-masked]>
Date: Wed, 15 Nov 2000 10:25:57 -0600

Robert,

In actual implementations, often a 183 will actually be sent during ringing, due
to the fact that often a gateway will be unable to determine definitively if
ringing or some other information is being sent in-band.  My concern is that
this reading will cause gateway vendors to assume that ringing is taking place,
send a 180 with SDP.  Then, the User Agent may also assume that ringing is
taking place, not play the early media stream to the user. (The bis spec
currently only says SHOULD.)  If the call then receives treatment, the user will
then have not idea why the call failed.

I agree that a User Agent should not have to know that it is talking to a
gateway to the PSTN.  What it does need to know is that media described in the
SDP of a 183 response MUST be played to the user, or the final outcome of a call
may not be known. (Since 183 is a new response code, there aren't any backwards
compatibility issues here, are there?)

Thanks,
Alan.