Subject: [SIP] SIP negotiation

From: Baniel Uri-CUB001 <[email-masked]>
Date: Fri, 3 Nov 2000 13:25:07 -0600

Sorry for the basic question.. but:

How can two SIP end points negotiate QoS, Bandwidth, vocoders ? I mean how it is done as part of the call setup? how it may be done during the call?
What headers are used for that (SIP headers?, SDP headers?)

Thanks

Uri

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 7 Nov 2000 03:01:37 -0500

> -----Original Message-----
> From: Baniel Uri-CUB001 [mailto:[email-masked]]
> Sent: Friday, November 03, 2000 2:25 PM
> To: [email-masked]
> Subject: [SIP] SIP negotiation
> 
> 
> How can two SIP end points negotiate QoS, Bandwidth, vocoders 
> ? 

QoS, bandwidth, and other media stream reservations are handled via QoS
reservation protocols like RSVP. The relationship with SIP signaling is
loose. Worst case, there is a temporal correlation in the two. For more
info, check out the famed "manyfolks" draft:

http://search.ietf.org/internet-drafts/draft-manyfolks-sip-resource-01.txt

As for codecs, its part of the standard SDP usage defined in the appendix B
to RFC2543.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com