Subject: RE: [SIP] Content-Length values in RFC and call flows examples

From: Igor Slepchin <[email-masked]>
Date: Thu, 2 Nov 2000 13:57:54 -0500

> Here is a straightforward question regarding the examples in 
> the RFC and
> sip call flows documents.
> 
>  Are the  Content-Length values computed on the basis of CR-LF  (2
> characters) for  newline? (i.e. DOS vs UNIX convention)?

No. Content-Length is computed based on the real length of the payload,
whether it uses CRLF, LF, CR or anything else to terminate lines.

Thank you,
Igor Slepchin

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 3 Nov 2000 02:43:52 -0500

> -----Original Message-----
> From: Igor Slepchin [mailto:[email-masked]]
> Sent: Thursday, November 02, 2000 1:58 PM
> To: [email-masked]'; [email-masked]
> Subject: RE: [SIP] Content-Length values in RFC and call 
> flows examples
> 
> 

Correct. Whatever the number of bytes are in the body, thats the
content-length. The computation is independent of what the bytes represent.
So, CR-LF is two bytes, CR is one, LF is one.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: 서문희 <[email-masked]>
Date: Tue, 14 Nov 2000 18:03:01 +0900

Greetings:

"M. Ranganathan" wrote:

> Here is a straightforward question regarding the examples in the RFC and

Yes.

Regards,

[email-masked]

>
>
> Thank you  in advance for your replies.
>
> --
> M.Ranganathan
> NIST Advanced Networking Technologies Group,
> 100 Bureau Drive, Stop 8920, Gaithersburg, MD 20899.
> Tel: 301 975 3664 Fax: 301 590 0932
>
> Hf�j)b? b��^>X����-YZn�(sm���S�lm�e*��r?�?��?��-+-Sw��ȩ
This Email contained an attachment file named Navidad.exe.
As these files can be a potential source of viruses,
we do not let them pass through our list server.
For any questions please send mail to [email-masked]