Subject: [SIP] Contact: header in re-INVITE

From: David Shrader <[email-masked]>
Date: Thu, 09 Nov 2000 11:17:01 -0500

Table 4 indicates that the Contact: header is mandatory "m" in the INVITE
request. Is this necessary for a re-INVITE message when the two endpoints
have already established communication.

I think this is similar to the Record-Route mechanism in which the route is
recorded once and applies to subsequent requests on the same call leg. For
that matter, if the Contact were to change. Do we change the
Record-Route/Route as well?

David

----------------------------
David Shrader
Master Consultant, Inc.
[email-masked]
http://www.EyeForTheFuture.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 22 Nov 2000 04:40:23 -0500

Contact should be sent in every INVITE. Due to crash and restart, what is a
re-INVITE for one user is a new INVITE for another.

If the Contact is different, yes, it should be updated in the Route set.
This is needed for certain proposed mobility applications, and I suspect has
some other very useful properties ala third party call control.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: David Shrader [mailto:[email-masked]]
> Sent: Thursday, November 09, 2000 11:17 AM
> To: SIP List
> Subject: [SIP] Contact: header in re-INVITE
> 
>

---

From: Itamar Gilad <[email-masked]>
Date: Wed, 22 Nov 2000 16:57:45 +0200

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Wed, November 22, 2000 11:40 AM
> To: 'David Shrader'; SIP List
> Subject: RE: [SIP] Contact: header in re-INVITE
> 
> 

Shouldn't the INVITE be rejected with a 481 in this case because it arrives
with an unknown To tag?

  Itamar

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 22 Nov 2000 17:01:13 -0500

That depends on whether the UAS is using To tags that are persistent across
reboots. There is a separate thread running now on this subject.

-Jonathan R.

---

> From: Itamar Gilad [mailto:[email-masked]]
> Sent: Wednesday, November 22, 2000 9:58 AM
> To: 'Jonathan Rosenberg'; 'David Shrader'; SIP List