Subject: RE: referred-by syntax (was RE: [SIP] (no subject))

From: [email-masked]
Date: Wed, 1 Nov 2000 17:44:39 +0530

Robert,
if you have the new ordering/syntax done already,
would you mind posting them right away so we could plough in the correct
version right away ?

Thanks
Arjun

--
Arjun Roychowdhury @ Hughes Software Systems

"Robert Sparks" <[email-masked]> on 10/31/2000 11:11:29 PM

To:   "Jonathan Rosenberg" <[email-masked]>, Ashok I Roy/HSSBLR,
      [email-masked]
cc:

Subject:  RE: referred-by syntax (was RE: [SIP] (no subject))

nod - we agreed to that (and altering the syntax to remove
the ordering dependency between "scheme" and "ref") in an
earlier thread.

I plan to get -02 out (which reflects that suggestion) this
week.

RjS

> > URL parameters are _definitely_ allowed. If your URL has a
> > semicolon in it,
> > it is required to be bracketed with <>, so you don't have the
> > ambiguity you
> > suspected.
>
> I agree thats what you should do, but thats not what the grammar says.
The
> grammar says these are just URLs. To allow for the brackets, they
> need to be
> name-addr or addr-spec.
>
> -Jonathan R.
> ---
> Jonathan D. Rosenberg                       72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
> http://www.dynamicsoft.com
>

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Robert Sparks" <[email-masked]>
Date: Mon, 6 Nov 2000 08:53:20 -0600

It's going to be a few more days before I can get the next
revision of the REFER draft out. Until then, here's what
list discussion has guided the Referred-By syntax into.

The motivations for change were

1) Allow URLs containing semicolons to be parsed correctly. This 
   introduced changing the referrer-url from SIPURL to name-addr |
   addr-spec. Allowing the referrenced URL to be separated is a
   little more difficult since it is not necessarily a SIP URL.
   This syntax attempts to resolve the problem by wrapping the URL
   with <> and requiring any <>s appearing in the URL to be escaped.

2) Allow the parameters to be completely unordered. This requires
   more text to augment the ABNF.

-------------------
     Referred-By      = ("Referred-By" | "b") ":"          referrer-url  
                                                  *(   ";" referenced-url 
                                                     | ";" ref-signature  )
     referrer-url     = ( name-addr | addr-spec )
     referenced-url   = "ref" "=" "<" URL ">" 
     ref-signature    = signature-scheme *( ";" sig-scheme-params ) 
     signature-scheme = "scheme" "=" token 
     sig-scheme-parms = token "=" ( token | quoted-string ) 

A Referred-By header MUST contain exactly one referenced-url. 
A Referred-By header MUST contain either zero or one ref-signature.
Any occurences of "<" or ">" within the URL value in referenced-url
must be escaped.

------------

RjS