Subject: RE: [SIP] More Torture Test Messages Available

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Tue, 21 Nov 2000 21:26:57 -0800

The colon in the user part of Test 36 (the long telephone subscriber) needs
to be quoted. Perhaps you could also put a similar long telephone-subscriber
URL in the Contact - this would test whether the URL was correctly
reproduced if the call is accepted.

Cheers,

Robert.

> -----Original Message-----
> From: Neil Deason [mailto:[email-masked]]
> Sent: Wednesday, November 22, 2000 2:30 AM
> To: Sip List
> Subject: [SIP] More Torture Test Messages Available
> 
> 
> The proposed new Torture Test messages have been added to the 
> main SIP web site:
> 
> http://www.cs.columbia.edu/~hgs/sip/bakeoff/testmsg.html
> 
> The new ones are test21.txt onwards. They should also appear in 
> the new verion of the SIP Message Flows draft shortly.
> 
> SIP bakeoff entrants are strongly encouraged to run these tests. 
> In particular entrants to advanced scenario testing at bakeoffs 
> will be expected to have passed all torture tests. 
> 
> Comments, corrections etc welcome.
> Neil.
> -- 
> Ubiquity Software Corporation, UK        http://www.ubiquity.net
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Neil Deason <[email-masked]>
Date: Wed, 22 Nov 2000 14:20:46 +0000

> reproduced if the call is accepted.

Actually looking more closely at the URL in the Request URI of 
test36.txt ...

sip:+1-972-555-2222;phone-context=name%40domain;new=user?%22Route:%20X%40Y%3bZ=[email-masked];user=phone

I think the ':' might be OK as it becomes part of a hname in 
an escaped header as it follows a '?', i.e. from parsing it 
into:
	%22Route:%20X%40Y%3bZ = [email-masked];user=phone
        	       header = hvalue
However this would then mean the following  ';' and '=' in the 
hvalue need to be escaped.

Also we would back into the problem of escaped headers not being
allowed in Request-URIs. I am a bit uncertain about this now.
The spec indicates that they are not allowed (Table 2) and 
should be removed by a proxy before futher processing (4.3).
However there seems to be a feeling that this may not be
desirable
- should there be a spec change here?

Cheers,
Neil.