Subject: Re: [SIP] Deleting media streams

From: Vladislav Zubarev <[email-masked]>
Date: Mon, 06 Nov 2000 17:20:51 -0800

What if the other party wishes still to receive media stream, is there any way
we can get
one-way stream, I mean the situation when one sends re-INVITE with RTP port set
to 0
for some particular m= line, however another party replies with SDP with valid
ports ?
Do we get one-way stream in this case ?
Thanx.

Jonathan Rosenberg wrote:

>
> -----Original Message-----
> From: Vladislav Zubarev [mailto:[email-masked]]
> Sent: Tuesday, October 31, 2000 3:48 PM
> To: [email-masked]
> Subject: [SIP] Deleting media streams
>
> >Hello,
> >    I have a question about deleting media stream procedure, described in a
> new SIP draft
> >(section B. 5).
> >
> >Let's say we opened two media streams, so now we send re-INVITE with SDP,
> where one of the
> >"m="
> >
> >lines contains RTP port set to 0 - we would like to delete this particular
> media stream.
> >
> >My question is what should we expect in 200 OK's SDP: should it contain the
> same "m=" line
> >with
> >
> >RTP port set to 0 or this "m=" line should be missing at all ?
>
> Same m line with port 0.
>
> There must always be the same number of m lines in the request as in the
> response.
>
> -Jonathan R.
>
> ---
> Jonathan D. Rosenberg                       72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
> http://www.dynamicsoft.com

--
Vladislav Zubarev        mailto:[email-masked]
Software Engineer
Vovida Networks, Inc.    http://www.vovida.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 7 Nov 2000 01:37:53 -0500

-----Original Message-----
>Sent: Monday, November 06, 2000 8:21 PM
>To: Jonathan Rosenberg; [email-masked]
>Subject: Re: [SIP] Deleting media streams
>
>
>What if the other party wishes still to receive media stream, is there any
way we can get 
>one-way stream, I mean the situation when one sends re-INVITE with RTP port
set to 0 
>for some particular m= line, however another party replies with SDP with
valid ports ? 
>Do we get one-way stream in this case ? 

No. In the case of a stream deletion, the response should always have a port
of zero as well.

If a UA wants to change a stream to send only or recv-only, it can do that
by changing the sdp attribute for directions.

-Jonathan R.

-----Original Message----- 
From: Vladislav Zubarev [mailto:[email-masked]] 
Sent: Tuesday, October 31, 2000 3:48 PM 
To: [email-masked] 
Subject: [SIP] Deleting media streams 

new SIP draft 
where one of the 
media stream. 

same "m=" line 
Same m line with port 0. 

---

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip