Subject: [SIP] What SIP doesn't tell you how to do.

From: Brian S <[email-masked]>
Date: Mon, 27 Nov 2000 08:29:31 -0800 (PST)

Apparently SIP doesn't tell you how to do any of the
following as well:

1. Be professional.
2. Show others common courtesy.
3. Switch to decaf.

BTW- He never asked how to do anything, just if it
could be done.

-----Original Message-----
From: Jonathan Rosenberg
[mailto:[email-masked]]
Sent: Wednesday, November 22, 2000 10:59 AM
To: 'Sanjiv Deshpande'; [email-masked]
Subject: RE: [SIP] multiple location

SIP is just a protocol. Thats it. Its a tool. If you
want device A to call
device B, it tells you how to do that. Like all tools,
you can use them in
many different ways. When you buy a hammer in Home
Depot, does it tell you
whether to use your left hand or right? How many
fingers to grip with it?
The size of the nails to use with it? Of course not. 

However, for some reason that I cannot fathom, many
people seem to believe
the opposite is true for protocols; that is, protocols
need to insist on how
syntax and semantics AND how they are applied to solve
real world problems.
This approach just results in systems that are useful
to no one. Would you
buy a hammer that said "for nails of length 1 inch
only?" I doubt it.

So, to be specific, SIP doesn't tell you how to do any
of the following:

1. the color of the phones that use SIP
2. the GUI for SIP calls
3. how you build a network of proxy servers
4. whether a phone can make calls while its in a call
5. qualifications for human beings to make use of SIP
softphones (i.e., IQ
levels, height, or what have you).
6. how many simultaneous calls the device can be in

Thanks,
Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle
Rock Ave.
Chief Scientist                             First
Floor
dynamicsoft                                 East
Hanover, NJ 07936
[email-masked]                     FAX:  
(973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE:
(973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Sanjiv Deshpande
[mailto:[email-masked]]
> Sent: Wednesday, November 22, 2000 11:36 AM
> To: [email-masked]
> Subject: [SIP] multiple location
> 
> 
> 
> 
> 
> 
> Q:
> INVITE Sent by UAC got forked and reached two UAS1
and UAS2 , 
>  the UAC decided
> to talk to UAS1. Is it possible that UAS2 (Assuming
it is a 
> client also) can
> make a call to someone else.
> 
> 
> What I wanted to know is, A user can be contacted at
multiple 
> location if one of
> the location answers a CALL is it possible for
somebody else 
> on behalf of that
> user make CALLS or receive CALLS....
> 
> 
> Thanks
> Sanjiv.
> 
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henry Sinnreich <[email-masked]>
Date: Mon, 27 Nov 2000 15:34:24 -0600

We should all thank Jonathan for answering countless questions on this
list - acting as a volunteer help desk for everybody!

Henry

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Brian S
Sent: Monday, November 27, 2000 10:30 AM
To: [email-masked]
Subject: [SIP] What SIP doesn't tell you how to do.

1. Be professional.

-----Original Message-----
From: Jonathan Rosenberg

Thanks,
Jonathan R.

---

and UAS2 ,
it is a
multiple
somebody else