Subject: [SIP] Multi-proxy authentication deadlock

From: Alexandre Charest <[email-masked]>
Date: Wed, 22 Nov 2000 08:20:56 -0500

In (expired) ID draft-sparks-sip-multiproxy-auth-00:

"A UAC should be prepared to terminate the deadlock situation caused by a
proxy in the chain that expires a challenge after its first successful
response."
Can somebody give an example of call flow resulting in such a deadlock? I
tried many scenarios and I can't figure out what is meant.
Thanks.

Alexandre Charest
Software Designer
Mediatrix Telecom Inc. (www.mediatrix.com)
tél:(819) 829-8749 #275
fax: (819) 829-5100

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 22 Nov 2000 17:09:33 -0500

Hmm; I could not create the case either. The case that I thought would cause
a deadlock does not, in fact. 

Robert?

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Alexandre Charest [mailto:[email-masked]]
> Sent: Wednesday, November 22, 2000 8:21 AM
> To: [email-masked]
> Subject: [SIP] Multi-proxy authentication deadlock
> 
>