Subject: [SIP] IANA SIP header registration

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 02 Nov 2000 12:04:38 -0800

IANA has agreed to register SIP header field names and compact forms to
minimize the chance for collisions. I've put together an initial list
for RFC2543 and draft-ietf-sip-rfc2543bis, session timers and 100rel,
but headers from other drafts need to be added. The current list is at
http://www.cs.columbia.edu/sip/headers.txt.

Please send me corrections and additions.

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Sean Olson <[email-masked]>
Date: Fri, 03 Nov 2000 08:35:47 +0100

Does this mean open season on compact forms? I really hope not.
In fact, I wish they would go away altogether. I don't want to re-open
this debate, but I would like to dam the flood of new compact forms.

Am I the only one who feels this way?
/sean

---

From: Bertil Engelholm <[email-masked]>
Date: Fri, 03 Nov 2000 09:33:22 +0100

Definitely not, I would also like them to disappear.
Atleast not creating new ones. The gain compared to
the rest of the message contents are not that much.

To write 't:' instead of 'to:' or 'v:' instead of 'via:'
doesn't really help much. I don't want to restart this 
discussion either only give indication that you are
not the only one. I wonder if there are anyone at all
using the compact form. 

/Bertil

-- 
Bertil Engelholm
AXE Research and Development        voice : +46 8 727 3499
SIP Security                        Fax   : +46 8 647 8276
S-126 25 Stockholm Sweden           E-mail:
[email-masked]

---

From: "Robert Sparks" <[email-masked]>
Date: Fri, 3 Nov 2000 09:23:21 -0600

Currently, draft-ietf-sip-guidelines-00 says

   Extensions that define new headers SHOULD define a compact form
   representation if the non-compact header is more than four
   characters. Header names SHOULD use ASCII characters. Header names
   are always case insensitive. Header values are generally case
   sensitive, with the exception of domain names which MUST be case
   insensitive.

RjS

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Bertil Engelholm
> Sent: Friday, November 03, 2000 2:33 AM
> To: [email-masked]
> Subject: Re: [SIP] IANA SIP header registration
>
>

---

From: Sean Olson <[email-masked]>
Date: Fri, 03 Nov 2000 16:45:19 +0100

Thanks for pointing this out. What is the guideline
for when we exhaust the 26 single-letter forms?
Do we go to two-letter forms, three-letter forms, etc.?
What is the point of diminishing returns here?

/sean

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 03 Nov 2000 13:49:41 -0800

The IANA registration simply registers existing formats and makes no
statement as to whether compact forms are good, bad or indifferent. I
agree that anything but single-letter abbreviations are useless and that
those should be reserved to standards-track documents.