Subject: [SIP] Caller Preferences and MESSAGE method

From: "Sriram Parameswar" <[email-masked]>
Date: Wed, 8 Nov 2000 19:51:04 -0600

Hi,

I think there is definite value in adding the MESSAGE method to the
draft-ietf-sip-callerprefs-02. I see *all three* headers being of value to
the MESSAGE method i.e. Accept-Contact, Reject-Contact and
Request-Disposition.

Some examples:

1. The sender of the IM could require that his Message be delivered only to
a device with a class = "business".
   This could use the Accept-Contact header.
2. If you want to save your buddy valuable air-time charges you could send
an IM with the following header
   Reject-Contact: sip:[email-masked];mobility="mobile" 
3. You could use the Request-Disposition to ensure that the Contact list
returned for the Message is tried sequentially.

Thanks and Regards,

Sriram Parameswar
Nortel Networks

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 10 Nov 2000 01:18:33 -0500

Caller preferences processing is really method independent. It would also be
useful for SUBSCRIBE. I'll be sure to update the doc to make this clearer.

-Jonathan R.

Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com
  
-----Original Message-----
From: Sriram Parameswar [mailto:[email-masked]]
Sent: Wednesday, November 08, 2000 8:51 PM
To: [email-masked]'
Cc: Jonathan Rosenberg (E-mail)
Subject: [SIP] Caller Preferences and MESSAGE method

Hi, 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip