Subject: [SIP] Inviting users to join a centralized conference

From: Tan Ya-Ching <[email-masked]>
Date: Thu, 23 Nov 2000 12:26:41 +0100

Hi,

In your I-D draft-rosenberg-sip-conferencing-models-00, you omitted to mention the possibility of inviting a user to join a centralized conference by sending the SIP REFER to the conference server. i.e. If user A wishes to invite user B to join, A could send the conference server a REFER :

REFER sip:[email-masked] SIP/2.0
From: sip:[email-masked]
To: sip:[email-masked]
Refer-To: sip:[email-masked]

The conference server can then decide whether to send an INVITE to user B depending on some criteria (eg. the number of participants, current resources, etc). In this way, we can avoid ringing user B if say the conference is already full.

Was this omission intentional ?

Ya-Ching Tan
________________________________________________________
ICM N MC MI E7		Tel.:	+49 89 722 36147
Hofmannstr. 51		Email:	[email-masked]
81359 Munich		
Germany

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 23 Nov 2000 16:04:47 -0500

No, the omission was not intentional, and can be done as well. I can include
in the next version of the document.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Tan Ya-Ching [mailto:[email-masked]]
> Sent: Thursday, November 23, 2000 6:27 AM
> To: 'Jonathan Rosenberg'; 'Henning G. Schulzrinne'
> Cc: [email-masked]'
> Subject: [SIP] Inviting users to join a centralized conference
> 
> 
> Hi,
> 
> In your I-D draft-rosenberg-sip-conferencing-models-00, you 
> omitted to mention the possibility of inviting a user to join 
> a centralized conference by sending the SIP REFER to the 
> conference server. i.e. If user A wishes to invite user B to 
> join, A could send the conference server a REFER :
> 
> The conference server can then decide whether to send an 
> INVITE to user B depending on some criteria (eg. the number 
> of participants, current resources, etc). In this way, we can 
> avoid ringing user B if say the conference is already full.
>