Subject: Re: [SIP] new torture tests

From: "Keith Robinson" <[email-masked]>
Date: Tue, 14 Nov 2000 16:14:27 +0000

I am not suggesting that it is legal to put unencoded spaces in the Request-URI;
I realise this is strictly illegal. The
point I am making is that if a parser knows it has got the Request-URI because
it is the text that lies between the Method and SIP-Version
elements it  can remove all unencoded spaces precisely because of the rule that
URIs cannot contain unencoded white spaces. If a
parser can do this without jeopardising the rest of the lexical analysis then it
would be harsh to determine that it is in error if it does not
return a 400 response but goes onto handle the request in a normal and correct
manner.

The type of parser that MUST return an error is one that is checking the output
of proxies/agents to make sure they do format messages strictly, i.e., checking
message generation as opposed to message parsing.

Anders Kristensen <[email-masked]> on 14/11/2000 14:18:50

                                                              

 To:      Neil Deason <[email-masked]>                  
                                                              
 cc:      Keith Robinson/MAIN/MC1@MCMAIN, Sip List            
          <[email-masked]>                           

 Subject: Re: [SIP] new torture tests                         

Neil Deason wrote:
>
> Keith Robinson wrote:
> >
> > Message 2:
> >
> > It is possible to parse this messge correctly even though it is strictly
> > illegal.
>
> If you are clever enough you can parse anything ;)
> But is a fair point that following the "be liberal on what
> you accept .." is good and responding 400 to this would be
> harsh.

I don't know about that. I believe it is the case that URLs can *never*
contain unencoded space characters. If this is true then the test seems
very reasonable.

--
Anders Kristensen

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Tue, 14 Nov 2000 19:25:36 -0800

> 
> 12d) Same as 12c but with this Contact header:
> 
> Contact: <sip:[email-masked]>;user=phone
> 
Can we add a torture test with a more taxing telephone subscriber
Request-URI. It is important that proxies and clients process these
correctly (even if they just ignore them or return a 404 Not Found).

INVITE
sip:+1-972-555-2222;phone-context=name%40domain;new=user?%22Route:%20X%40Y%3
bZ=[email-masked];user=phone SIP/2.0

Cheers,

Robert

---

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Tue, 14 Nov 2000 20:30:13 -0800

> bZ=[email-masked];user=phone SIP/2.0
Actually, I think the colon after Route needs to be quoted as well.

Robert.

---

From: Peter Kjellerstedt <[email-masked]>
Date: Wed, 15 Nov 2000 17:29:01 +0100

> -----Original Message-----
> From: Neil Deason [mailto:[email-masked]]
> Sent: 13 November 2000 18:56
> To: Sip List
> Subject: [SIP] new torture tests
> 
> The following are 15 new proposed torture test messages 
> based on the bis draft. None of them should cause good 
> implementations to crash. Recommended responses to the 
> illegal messages are given where needed.
> 
> I would greatly appreciate any additions/corrections to be
> made quickly so we can try to get these folded into a new 
> release of the call flows draft before the next bakeoff.
> 
> Cheers,
> Neil.

One test I realized is missing when I was at the last bake-off
is one that tests the following kind of To/From header:

	To: sip:[email-masked] ;tag=[email-masked]

and makes sure the tag does not end up as a URL parameter.

I had not considered this legal before I got one like that 
sent to me (and studied the 2543 document for some time...)

//Peter