Subject: [SIP] SIP Headers versus message contents.

From: "M. Ranganathan" <[email-masked]>
Date: Thu, 16 Nov 2000 10:30:47 -0500

N¬ŠÇè®Ø^uë"‚w«²‡Ò ò-ŠÃNM«.‚¬¶*'~Šëy×¢²	ì¡Ú'¶š.Ç¨žgŸ¢¶¬’)à¶¬¢wˆjf›ŠÚnÏ9^u¼…ìÉ"™ë,j¬ÁêÞuë"‚w!ôˆ=©e£¢·b}÷«z{dŠwl¡ø^i×«±©ÝìÆ×§²*'…æz»-¡·šu×jÇ¯‰×§qç[ÊØ^¦W†ŠÚ¡÷±µéìŠ‰Ý­§í¦º)¢Æ¥±Ú²ØZ¶Ë›²éž¶§yç_¢¹ž²Æ yÊ'µéí±©Ý¾'½êìhZ+{¦¦W…ë¦g¬±¨r‰íz{lq©ãºË[y£²Æ x*'µéí²šuêÚ•¸žµ©hž
'y8ZžKjx1§©Ú¶§4„“ÛÚÇ5ëp¢¹"žÞrè–ˆ"zÁ«¢êuÓ@næ®¸¯y+h§ÏvÐf¢¶«±»«€ÀöÓÏ}MéwÓ_{ç~ºàV±ßMy÷M=ß

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Thu, 16 Nov 2000 10:43:37 -0500

"M. Ranganathan" wrote:
> 
>  This is  for the designers of SIP .    ( It is NOT a suggestion for
> re-deisgn so dont pounce on me for asking this one) :
> 
> I am a bit puzzled by the way SIP messages were designed.   If
> SIP allows for different kinds of headers and new  extension headers
> to be added  (as evidenced by the plethora  of extension draft
> proposals),  does that subsume the need for message contents (and
> vice-versa) ?  For example the sdp message contents can just be a
> MessageContents header (albiet a long one).

The division roughly reflects a division between what describes sessions
as a whole (headers) and what describes sessions in their data stream
details (body). This makes it easier, for example, to upgrade to a new
session description format, without changing the software in proxies. In
practice, the idea is that proxies and redirect servers should keep
their hands and noses out of the message body, while being free to
inspect and, with restrictions, modify the headers. NATs, as usual,
break this model, but then NATs are warts on the Internet architecture,
so this is no surprise.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip