Subject: [SIP] JAIN SIP Factory

From: Chris Harris <[email-masked]>
Date: Tue, 28 Nov 2000 15:43:03 +0000

Dear all,

One thing which has been bothering me is having all the create methods
for messages and headers on the concrete JainSipFactory. These methods
all require that message and header implementations have an empty
constructor and then the JainSipFactory  invokes all the required set
methods with the create method's parameters.

I think that this could be quite restrictive for an implementor, and I
suggest that the create methods should be defined in interfaces rather
than the JainSipFactory class. The JainSipFactory could have
createJainSipMessageFactory and createJainSipHeaderFactory methods which
create particular implementations of JainSipMessageFactory and
JainSipHeaderFactory. [Or we could put these two methods in the
JainSipStack.] The implementations of these abstract factories are free
to use any constructors they like, and potentially could provide
proprietary optimisations such as object pooling. What do people think
about this?

Another thing about defining messages and headers as interfaces rather
than classes, is that the arguments to methods are defined in terms of
interfaces. Do we not really want to have an application mixing
different implementations? - I don't believe so. Then how can we enforce
that say XXX's implementation of the JainSipProvider can only take XXX's
implementations of the JAIN SIP interfaces as arguments? Use reflection
and throw an exception if the class of the object received doesn't match
the expected class? Again your opinions are welcomed

Regards,
Chris

PS - The Public Review period for the JAIN SIP Specification closes
today, so I would be grateful if you could send me any additional
comments ASAP. All going well, I hope to have the First Public Release
available at the SIP Bakeoff next month.

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "M. Ranganathan" <[email-masked]>
Date: Tue, 28 Nov 2000 19:51:55 -0500

â°v«®+0®‹^
æ«jYNëaŠx0†'!…«yéÛ¢Ø^®)à™è¬…«âž¥–Ø^r·šµéž¶±ú+™ë,j¬jway§^®Ê'¶œ¢w+z×‰j)ÒŠ‘ZrÚ+É8^±éž¶±©eê®Š·…«fzËæ§všuêâš™^™éíjØ¨žÈZ½æ§zjmÉÊ'²ÚîrÚ+jwm…éí…âZŠt¢¤Vœ¶ŠòŠ{è‘ë–[az·ªº*ÞvÇ­™ëa¡Û0ŠØm…ç+y«^™ëa¡Û)j¶¦z×«±8^è¬¦ºi¹rj÷«Ê
(v·š²‰ß¢»azÇ€<†î´ˆZ½éè¶éÝz»-¢‡m…é¨¶+Ú¶*'Œ£*.z{â²*'¶¬xÈmè§‚ëuh^Ÿ
.•Ö§jše‰Æ­Š‰ðj{m¡ÊÞj×‡y§^®È§¶¬}«!Š‰ÀëazÇ­¡·¢ž×«}§²Ú¥ªìz²-†)ä¶¶¬r‹¥u·ªº+^ë-®'-Š÷Ÿ¢¶§Šjezg§¶ŠÚÒ,º²ÛajÛayÊÞj×¦zØhvË!¢é]mç^~)Þv)âž×«}§²¶…êí…©í…âZŠt¢¤Vœ¶ŠòrV¬±8^%¨§J*EiËh¯'(ºWaj÷œæx–¢(©1ë,j…iËh¯&§uÊÞj×‰j)ÒŠ‘Þi×«§-¢¼¦zØhvÌ!‰È\æz–«¶'.•ªâš™^™éíjØ¨žÊ%¨§J*LzËáZrÚ+É©Ý%¨§J*Gy§^¬Vœ¶Šò:¼r‹¥v›¶¬zÜ(™ëa¡Û"žØ^%¨§J*Rµ§$N¢š™^™éíjØ¨žÊ¶¬y¦ì¶¶œµöœ¶ŠâzÆ«yúÞzÚ.±æ§ÉÊ'²ÚîrÚ+²Ø^ÊX¤y©Ý¦‹^žØš–\œ¢é]¦º/‰×©®Šk‰ëZ¯*)¶)¢±«b¢{,¹ÈZ²†ãyËi¢‰bž¡j×h¥ê)•ëaŠyn‹¶¬!ü¨ºwžvÚæxwšuêìŠ{aŠÇÚ²¨œŒ(ºWZ‚·žÂ+aÊ‹«²è zËb¢v›¢÷€ž‹az»aŠxn‹uçâž)à™ë,j¬jway§^®Æ¬Š{^öœzÊÚ¶«¶§rV¬±ë"²ØZ¶Ø^j¸.™éí²Ú&zØhvÆ«y×ŸŠwŠ{^®k(~)íz·Úqë£§¢ÚÞjYrÁ©í¶ˆZ½æ§jše‰Æ­Š‰æ‹§ØŸ}êÞžØ¦¦W¦z{Z¶*'°‡hžÖÞ–'¯zÊžØ^ºÚ)‰©ð¢¹]¡ûk¹êh®Ö›ŠXÊØb³
.•Ü(®Fî¶)ëy©b·",ºšh±ëaŠÌ(ºW[y¦Úv'^i8^ž0q©ðyéß¢·¶±¬—]{"š™^™éíjØ¨ž‡í…âZŠt¢¤úè¾'^Æ§¢yrµ©]uìŠjezg§µ«b¢{(~Ø^$
Hƒâž×«}§±«®¦z{lRÇ«yù^rØ¨©Ý¶èÁ©ÞÅÇ©¶*'‰ûayÉZ²Ê¶¨n7œ¶·œz+ÞuÚ²{fj×!¶žÆ—œµç\•«,¢Ÿ*.®Šbž*'±ªÞÁé\¢gEçåyËb¢|(ºW[y¨(¡ÜÊ‡Ü…ç$Šx-†+(®‰Þr‹¥vë²‰ž¶§‚X¤y¥ 2,ºšh±ä^ªÝ°(kŠÃÒN¹¹bq¯‰ì)z¸¨uú+¶‰ƒR ô©yÈŸ‰Æ­Š‰Ü–‹²Úk+(#
.•ÖÞ‚¶yû¥‰ü¨¹Ê.•ÛÙžj|šuØ­Š‰Ú•Ê&™éí°€<	e‚ˆ§ƒ¥”ˆh¥ëh…«Þ¶…Š»->æå‰Ä^•æ¬y«ÚŠV›•æ­¶’ ðZ‘ê~w±¶j'¶ˆ>f¢–)à–+-HƒåŠËlmée•¦ìr‰¡¶ÚþX¬¶ÆÞ–YZnÇ(›ùšŠYšŸùb²Ø§~ìŠ“jx«ajsHI0½©ÜyÓ^·
+’)àMç!ž‰h‚'¬º.§]4êÞjàëŠ÷’¶Š|÷mj+az»º¸m<÷ÔÞ—}5÷¾wë®kô×ŸtÓÝö