Subject: RE: [SIP] What am I doing wrong ?

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 15 Nov 2000 09:13:56 -0500

> -----Original Message-----
> From: Vijay Gurbani [mailto:[email-masked]]
> Sent: Tuesday, November 14, 2000 6:57 PM
> To: Sekhar Banerjee
> Cc: Sip List
> Subject: Re: [SIP] What am I doing wrong ?
> 
> 
> Sekhar Banerjee wrote:
> [...]
> >    Yes ... the 200 OK is for the cancel.
> > 
> >    But my concern is with the tags that get attached with 
> the responses
> > comming in from the end devices. Could that be the problem. 
> I mean just
> > because the first 180 ringing had a different tag in the To 
> field  than in
> > the second 180 ringing. Is that significant enough ?
> 
> Not enough to make the UAC misbehave; the tags on the 
> provisional responses
> from different UASs will be different.  As I said earlier, 
> the call leg has 
> not yet been established until a final response arrives at 
> the UAC.  The 200 
> OK from C should be accepted by A.

Well, the UAC shouldn't misbehave, but that doesn't mean it isn't
misbehaving. This case (of getting different tags in the provisionals than
in the final) is probably not well tested in many implementations.

Its probably worth adding a torture test case for this.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Vijay Gurbani <[email-masked]>
Date: Wed, 15 Nov 2000 08:58:57 -0600

Jonathan Rosenberg wrote:
[...]
> Its probably worth adding a torture test case for this.

Sure; I can write one up.  Who is maintaining the "Torture Document?"  I
can send it to him/her directly.

- vijay

- vijay
--
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Wed, 15 Nov 2000 10:17:16 -0500

> can send it to him/her directly.

I'm keeping the torture files. Once the discussion has died down, I'd
appreciate if somebody could send them to me so that I can add them to
the bakeoff web page.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: Neil Deason <[email-masked]>
Date: Wed, 15 Nov 2000 15:30:25 +0000

> can send it to him/her directly.

I am collecting together new torture tests for submission
to the call flows work and Henning's web site. They
need to be out in time for the next bakeoff.

Cheers,
Neil.
-- 
Ubiquity Software Corporation, UK        http://www.ubiquity.net