Subject: RE: [SIP] New Section 6.34 (was: Record-Route consensus)

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 22 Nov 2000 18:12:25 -0500

> -----Original Message-----
> From: Billy Biggs [mailto:[email-masked]]
> Sent: Wednesday, November 22, 2000 6:10 PM
> To: Jonathan Rosenberg
> Cc: Jo Hornsby; [email-masked]; [email-masked]
> Subject: Re: [SIP] New Section 6.34 (was: Record-Route consensus)
> 
> 
> Jonathan Rosenberg ([email-masked]):
> 
> > 5. (this one is my own) The request URI should refer to the resource
> > for whom the message is destined
> > 
> > The solutions proposed are either to have the UAS and UAC construct
> > the Route differently (as is done in the current bis), else 
> Jo's text
> > here where this information is carried somehow as 
> parameters. I think
> > this is a big hack, and quite a pain. When a proxy receives a
> > re-INVITE, it will have a hard time knowing which direction the
> > re-INVITE is going, and consequently, which of the pieces of info to
> > extract for processing purposes.
> 
> 
>   The proxy should look at the To and the From to tell direction,
> instead of doing this ugly hack! [1]
> 
>   The only note then is that if a UA calls itself through a
> Record-Route'ing outbound proxy, then the tags it inserts had 
> better be
> different.  [I think you've heard that argument before!]
> 
> 
>   Still, bis shouldn't talk about any of this.  Keep the spec really
> simple, and let proxies which need to keep state figure out how to
> record-route to their advantage.  Jo's text is pretty much on 
> the mark.
> 
> 
>  [1]  Or, it can always just look at which address is at the 
> end of the
>       Route...  Regardless, your suggestion is an ugly hack.

Billy, I prefer to hold list discussions based on technical issues rather
than name calling.

Proxies route based on request URIs. I'll say it again. Proxies route based
on request URIs. As such, it is really important that the request URI,
without needing to examine the To/From, by itself, indicate the resource to
whom the request is targeted. 

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Billy Biggs <[email-masked]>
Date: Wed, 22 Nov 2000 17:24:10 -0600

Jonathan Rosenberg ([email-masked]):

> Billy, I prefer to hold list discussions based on technical issues
> rather than name calling.

  I apologize.  I was very, very unnecessarily harsh.

> Proxies route based on request URIs. I'll say it again. Proxies route
> based on request URIs. As such, it is really important that the
> request URI, without needing to examine the To/From, by itself,
> indicate the resource to whom the request is targeted. 

  Say my proxy inserts as a record route:
     <sip:[email-masked]>

  When a re-INVITE comes in, is it really addressed to
[email-masked]?  No.  The request is actually addressed to some
state value for the active call inside the 3com.com proxy.  To me, it
would be much better for the proxy to use:
     <sip:[email-masked]>

  Which correctly identifies this state key.  It's not like the proxy
needs to look up and see how to route the message to
[email-masked].  This routing is handled by the Route.  No?

-- 
Billy Biggs, 3Com               Email: [email-masked]
http://www.div8.net/billy/      Phone: [email-masked]