Subject: Re: [SIP] Sip- Message OPTION

From: [email-masked]
Date: Thu, 2 Nov 2000 12:09:06 +0530

Well,
Its in the examples section and the intro text for Section 16 says:

"In the following examples, we often omit the message body and the
corresponding Content-Length and
Content-Type headers for brevity." (BTW, responses has a C-Len).

And I dont think the From needs a tag to be correct, does it ?

Further, I dont see the problem of using CSeq 1. This OPTIONS message may
well be sent from alice to bob
even if they are not in a call. So 1 seems ok.

So I guess only Via needs to be added, in this list.

Regds
Arjun

--
Arjun Roychowdhury @ Hughes Software Systems

Billy Biggs <[email-masked]> on 11/02/2000 11:46:42 AM

To:   archow
cc:   Sandeep Sahai <[email-masked]>, SIP List <[email-masked]>

Subject:  Re: [SIP] Sip- Message OPTION

  Note that this should be cleaned up.  There is no Via or CSeq in the
response, the CSeq in the request starts at 1, the From has no tag, and
there
is no Content-Length.

> C->S: OPTIONS sip:[email-masked] SIP/2.0
> Via: SIP/2.0/UDP cat.wonderland.com
> From: Alice <sip:[email-masked]>
> To: Bob <sip:[email-masked]>
> Call-ID: [email-masked]
> CSeq: 1 OPTIONS
> Accept: application/sdp
>
> S->C: SIP/2.0 200 OK
> From: Alice <sip:[email-masked]>
> To: Bob <sip:[email-masked]> ;tag=376364382
> Call-ID: [email-masked]
> Content-Length: 81
> Content-Type: application/sdp
>
> v=0
> o=alice 3149329138 3149329165 IN IP4 24.124.37.3
> s=Security problems
> t=3149328650 0
> c=IN IP4 24.124.37.3
> m=audio 0 RTP/AVP 0 1 3 99
> a=rtpmap:0 PCMU/8000
> a=rtpmap:1 1016/8000
> a=rtpmap:3 GSM/8000
> a=rtpmap:99 SX7300/8000
> m=video 0 RTP/AVP 31 34
> a=rtpmap:31 H261/90000
> a=rtpmap:34 H263/90000

--
Billy Biggs, 3Com               Email: [email-masked]
http://www.div8.net/billy/      Phone: [email-masked]

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 3 Nov 2000 02:39:21 -0500

All servers (UAS, registrar) should answer a OPTIONS with a 200 OK with the
following headers added to the response: Allow, listing the supported
methods, Accept, listing the support MIME types, and Supported, listing the
supported extensions. A UAS could also insert SDP listing its codecs. How
such SDP is formatted has never been defined, and to my knowledge, no one is
yet doing this. We'll define something in bis.

As an example for a registrar response to OPTIONS:

SIP/2.0 200 OK
From: sip:[email-masked]
To: sip:registardomain.com;tag=9378asd0asd7asd
Call-ID: [email-masked]
CSeq: 1 REGISTER
Via: SIP/2.0/UDP host.company.com
Accept: application/cpl+xml
Allow: OPTIONS, REGISTER, CANCEL
Supported: pref
Content-Length: 0

This registar supports uploads of CPL, and also the caller preferences
extension.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Thys Nel [mailto:[email-masked]]
> Sent: Thursday, November 02, 2000 1:48 AM
> To: 'Billy Biggs'; [email-masked]
> Cc: 'Sandeep Sahai'; 'SIP List'
> Subject: RE: [SIP] Sip- Message OPTION
> 
> 
> Does anyone have examples of messages flows with OPTIONS 
> processed by a
> registrar server? The only example in the RFC is between 2 
> user agents, but
> the RFC states that a registrar must also support it. I can't 
> seem to find
> any description of when a registrar should respond to an 
> OPTIONS request.
> 
> Thys
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Billy Biggs
> > Sent: 02 November 2000 8:17
> > To: [email-masked]
> > Cc: Sandeep Sahai; SIP List
> > response, the CSeq in the request starts at 1, the From has
> > no tag, and there
> > is no Content-Length.
> >

---

From: "Agarwal, Aseem" <[email-masked]>
Date: Fri, 3 Nov 2000 10:19:48 -0800

Hi Jonathan,
  The draft (bis-2 section 4.2.3) says:
"The response MAY contain a message body indicating the capabilities
of the end system ..." 

  This gives an idea that OPTIONS should be relevant only for a UAS,
since only a UAS can respond with the capabilities of the logged in
users. The example given in section 16.8, also seems to suggest the
same. 
  However, theoretically, it is possible for a user to register
his media capabilities as well in the REGISTER message with the
Registrar. But I see this as a more dynamic thing which can 
potentially change from a call to call. So, what is the usage of
supporting OPTIONS at a Registrar server ? Kindly clarify.

-regards,
aseem

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Thursday, November 02, 2000 11:39 PM
To: 'Thys Nel'; 'Billy Biggs'; [email-masked]
Cc: 'Sandeep Sahai'; 'SIP List'
Subject: RE: [SIP] Sip- Message OPTION

SIP/2.0 200 OK

-Jonathan R.

---

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 7 Nov 2000 03:05:24 -0500

> From: Agarwal, Aseem [mailto:[email-masked]]
> Sent: Friday, November 03, 2000 1:20 PM
> To: 'SIP List'
> Cc: 'Jonathan Rosenberg'

That is not usage for a registrar. A SIP request addressed to a registrar
(sip:dynamicsoft.com) would not contain SDP in the response. A SIP request
addressed to an end user (sip:[email-masked]) would possibly
contain SDP in the response. I will clarify in the spec.

-Jonathan R.

---