Subject: [SIP] Multiple headers of a given type.

From: "M. Ranganathan" <[email-masked]>
Date: Thu, 23 Nov 2000 21:01:09 -0500

ée¡8b²+«az»"š™^ªç¬¶*'9ö¥–Ø^Hƒáy§^®È§¶›ŠÇhréžžÜ!‰È\jv©¥æ«šémŠ™^¶)ž²)ÚEê®zËEë)¢{ŠÞÅ©©•åHÆ§jš^j¹®–Ø©•ëb™ë!MÆ§jš^j¹®–Ø©•ëb™ëµÆî´TN1Æ§jš^jº'—*'qæ§u3œjv©¥æ«¢yr¢w!ûaz·¢±«ZnW¢žØ^v‡.™éí‚+âžaŠÈ§~ŠæjØ¨œˆZ½é¢²Ç¦Wš±é^¶g¤žŒÖ©¢Z ‰ë¢ºÞvéÝj{fj)S…©ä± j·lE©àhÄZž§jØZœÒLojwt×­ÂŠäŠxyÈg¢Z ‰ë®‹©×Mº·š¸:â½ä­¢Ÿ=ÛAšŠØ^®Æî®ÛO=õ7¥ßM}ïúëZÇ}5çÝ4÷}

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 23 Nov 2000 21:29:58 -0500

Since a comma separated list of values (indicated in BNF with #) is
identical to multiple headers of the same name, any header whose BNF starts
with # can appear more than once. 

-Jonathan R.
  
-----Original Message-----
>From: M. Ranganathan [mailto:[email-masked]]
>Sent: Thursday, November 23, 2000 9:01 PM
>To: [email-masked]
>Subject: [SIP] Multiple headers of a given type.
>
>
>Hello! 
>This is a rather simple question. Of all the SIP headers in the bis
document, which can 
>appear multiple times in a Request / Response ?  (For example,  VIA can
appear multiple 
>times, ACCEPT can appear multiple times etc. but FROM can appear only once
and TO can 
>appear only once. ) If there is a table in the document giving this
information  I have 
>missed,  please let me know (and apologies for redundant mail). 
>Thanks. 
>Regards 
>Ranga. 
-- 
M.Ranganathan
NIST Advanced Networking Technologies Group,
100 Bureau Drive, Stop 8920, Gaithersburg, MD 20899. 
Tel: 301 975 3664 Fax: 301 590 0932

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Snyder, Duke" <[email-masked]>
Date: Fri, 24 Nov 2000 08:17:01 -0500

1.  What is the preferred method (single header with multiple elements or
multiple headers with a single element).
2.  I assume you can get a mixture (multiple via headers, some with multiple
elements).
3.  Can a server, when resending, change the format (change the list format
to the multiple header format).  The server I'm writing decodes them but
encodes them the same way, regardless of how they were received.  I don't
keep track of how they were initially received.
4. Why support both methods in the first place.  Backward compatibility?

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Thursday, November 23, 2000 9:30 PM
To: [email-masked]'; [email-masked]
Subject: RE: [SIP] Multiple headers of a given type.

-Jonathan R.
  
-----Original Message-----
document, which can 
appear multiple 
and TO can 
information  I have 

---

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 27 Nov 2000 00:38:07 -0500

> From: Snyder, Duke [mailto:[email-masked]]
> Sent: Friday, November 24, 2000 8:17 AM

There is none that is preferred. SIP does define a canonical form that is
used for authentication. My personal recommendation is to always generate
canonical form. Its in section 13.2 of rfc2543.

> 2.  I assume you can get a mixture (multiple via headers, 

Yes.

> keep track of how they were initially received.

Yes, it can change the format. However, if the request is authenticated,
you'd better spit it out in canonical form (and that had better be the form
it was received in).

> 4. Why support both methods in the first place.  Backward 

We lifted much of SIPs operation from HTTP, which does this as well.

-Jonathan R.
---