Subject: [SIP] Call-ID

From: "Voravit H." <[email-masked]>
Date: Tue, 14 Nov 2000 20:45:44 +0700

Dear all

	I am just a beginner of SIP. I am a bit confuse about Call-ID. I
am not sure that I clearly understand Call-ID or I miss understanding it.
	Is this example correct?

	Suppose that [email-masked] would like to invite [email-masked] then it
generates a INVITE request with a Call-ID as [email-masked].
	Then, if [email-masked] also want to invite [email-masked] then it generates
another INVITE request with another Call-ID such as [email-masked].

	Is it correct?

POP

---

From: "Mohammad Vakil" <[email-masked]>
Date: Tue, 14 Nov 2000 08:54:32 -0500

There are two scenarios.

1. If A does not want to conference in C rather maintain two seperate calls
with B and C, then you're correct, A should generate a different call-Id for
C. 

2. If A wants to bring C into a conference call on a call going on with B,
then it shouldn't generate a new call-id for C. A can invite C with a Also
header telling B is also in a call, so C can also establish a signalling
relationship with B.

Hope this help...

>  -----Original Message-----
> From: 	[email-masked]
> [mailto:[email-masked]] 
> Sent:	Tuesday, November 14, 2000 8:46 AM
> To:	[email-masked]
> Subject:	[SIP] Call-ID
> 
> 
> Dear all
> 
> 	I am just a beginner of SIP. I am a bit confuse about Call-ID. I am
> not sure that I clearly understand Call-ID or I miss understanding it.
> 	Is this example correct?
> 
> 	Suppose that [email-masked] would like to invite [email-masked] then it generates
> a INVITE request with a Call-ID as [email-masked].

---

From: Billy Biggs <[email-masked]>
Date: Tue, 14 Nov 2000 08:54:03 -0600

Mohammad Vakil ([email-masked]):

> 2. If A wants to bring C into a conference call on a call going on
> with B, then it shouldn't generate a new call-id for C. A can invite C
> with a Also header telling B is also in a call, so C can also
> establish a signalling relationship with B.

  Sorry, but the use of the Also header has been deprecated.  I doubt
you will find anyone who implements this or ever intends to.  It has
been deemed a "bad idea".

-- 
Billy Biggs, 3Com               Email: [email-masked]
http://www.div8.net/billy/      Phone: [email-masked]

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip