Subject: [SIP] 3PCC and the re-invite response

From: Gethin Liddell <[email-masked]>
Date: Thu, 30 Nov 2000 12:19:19 +0000

people,

i'm slightly concerened (maybe un-justifably) about the re-invite
working of the 3PCC draft.

my concern is that it is possible (is it not?) for the user agent
receiving the re-invite to change its SDP settings in its response as
follows:

 A                Controller            B
 |  INV held SDP     |                  |
 |<------------------|                  |
 |                   |                  |
 |  200 SDP A1       |                  |
 |-----------------> |  INV SDP A1      |
 |  ACK              |----------------->|
 |<----------------- |                  |
 |                   |  200 SDP B1      |
 |                   |<-----------------|
 |                   |                  |
 |                   |  ACK             |
 |  INV SDP B1       |----------------->|
 |<------------------|                  |
 |  200 OK SDP A2    |                  |
 |------------------>|                  |
 |  ACK              |                  |
 |<------------------|                  |
 |                                      |
 |               BROKEN RTP             |
 |                                      |
 |                                      |
 |                                      |

NOTE: A has returned different SDP in its two different 200 OK messages.

Why might it do this?  It might not but it is possible is it not.

perhaps we should mandate that an agent can only change its SDP for a
session in an INVITE not in a response (after the initial
INVITE/RESPONSE exchange of course)

what do we think?

-- 
Gethin Liddell
Ubiquity Software Corporation

http://www.ubiquity.net
mailto:[email-masked]

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Culpepper, Bert" <[email-masked]>
Date: Thu, 30 Nov 2000 09:50:35 -0600

You bring up a good point IMO.  Currently, a controller 
needs to check that A didn't change its SDP and if so, 
re-invite B.  Could end up in an awful loop with both UAs.

I agree that we need a way to guard against this situation. 
Your proposal seems reasonable to me.

Regards,

Bert

> -----Original Message-----
> From: Gethin Liddell [mailto:[email-masked]]
> Sent: Thursday, November 30, 2000 7:19 AM
> To: Sip Mail List
> Subject: [SIP] 3PCC and the re-invite response
> 
> 
> 
> people,
>