Subject: Re: [SIP] spaces in SIP-URL

From: [email-masked]
Date: Mon, 20 Nov 2000 12:21:09 +0530

you are pretty much on track....some additions are
     between the user and the "@"
     between the "@" and the host
     between host and " : "
     between ":" and port
     between port and ";"
     between ";" and url
     and so on...you have left out separators. You can have spaces or line
folds between any 2 tokens , separators or otherwise.

-ashok
------------
ashok i roy @hughes software systems
-------------

sreenivasa reddy D <[email-masked]> on 11/20/2000 05:17:32 PM

To:   sip <[email-masked]>
cc:    (bcc: Ashok I Roy/HSSBLR)

Subject:  [SIP] spaces in SIP-URL

Hi,
   In SIP-URL where spaces and line breaks are allowed.
   i have seen grammar in sip-rfc2543.what i feel is
   in between "sip:" and user,
                     user and password,
                     password and host.
                     host and port
                     port and url-parameter,
                     url parameters
                    url-parameter and header
                    headers.
                   Spaces are allowed.and where ever spaces are allowed
line breaks are also  allowed.
  i want to know whether  iam right or not.if iam wrong please tell me
correct
 one.
                     thanks,
regards
Sreenivasa Reddy.D

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Anders Kristensen <[email-masked]>
Date: Mon, 20 Nov 2000 11:47:32 +0100

> folds between any 2 tokens , separators or otherwise.

Why do you think spaces here are legal? As far as I can tell rfc 2396,
"Uniform Resource Identifiers (URI): Generic Syntax" seems to clearly
spaces in URIs altogether. The comments on "implied *LWS" in appendix B
of rfc 2543 doesn't change this. 

Anders

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Mon, 20 Nov 2000 09:22:40 -0500

URLs, SIP or otherwise, cannot have unescaped spaces. Never have, never
will.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs