Subject: Re: [SIP] Changing Codec

From: "Venkatesh Venkataramanan" <[email-masked]>
Date: Wed, 22 Nov 2000 15:51:31 +0530

But if this (re)INVITE fails, shouldn't the original media agreed upon
 prevail ? That's how I understand (re)INVITES(unlike what you mention about
 the remote UA tearing down the call). Please clarify.
 Venkatesh
> ----- Original Message -----
> From: "Billy Biggs" <[email-masked]>
> To: "Pascal Doré" <[email-masked]>
> Cc: "Mo Zonoun" <[email-masked]>; "SIP List"
> <[email-masked]>
> Sent: Wednesday, November 22, 2000 6:13 AM
> Subject: Re: [SIP] Changing Codec
>
>
> Pascal Doré ([email-masked]):
>
> > > How do you change codec in a SIP call without disconnecting the
> > > established call?
> >
> > (re)Invite with a new session description
>
>   Actually, it depends on if you are talking about send codec or receive
> codec.
>
>   If you want to change the codec you are sending, then as long as the
> other end indicated support, you can change any time you like.  For
> example, if I send you SDP that says:
>
>    m=audio 8552 RTP/AVP 0 1 2
>
>   Then you can freely switch between sending audio using codec 0, 1 or
> 2.  If you're feeling cruel, you can use a different codec for every
> packet.
>
>
>   If you want to change which codec you are receiving from the far end,
> the best you can do is offer a different set of choices using a
> re-INVITE.  So, first maybe you send:
>
>    m=audio 8552 RTP/AVP 0 1 2
>
>   And the far end is sending you codec 1, but you only want to receive
> codec 0, then you can always re-INVITE with:
>
>    m=audio 8552 RTP/AVP 0
>
>   And force it to use either codec 0 or nothing.  Be prepared though
> that if the remote end can't send codec 0, it might tear down the call
> (or at best audio won't flow).
>
> --
> Billy Biggs, 3Com               Email: [email-masked]
> http://www.div8.net/billy/      Phone: [email-masked]
>
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
>
>
>

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Billy Biggs <[email-masked]>
Date: Wed, 22 Nov 2000 09:32:53 -0600

>  But if this (re)INVITE fails, shouldn't the original media agreed
>  upon prevail ? That's how I understand (re)INVITES(unlike what you
>  mention about the remote UA tearing down the call). Please clarify.

  I think this was the intention of some folks on this list- that a
rejected re-INVITE means the old session stays up.

  However, I would be more inclined to accept the re-INVITE and shut
down the call.  The SDP was not malformed, and the remote side has
clearly changed its session and is now listening for a different codec.

  I don't have any implementation experience with multiple codecs
though (not with kphone).