Subject: Re: [sipcore] I-D Action:draft-ietf-sipcore-199-02.txt

From: Robert Sparks <[email-masked]>
Date: Tue, 12 Jan 2010 11:00:30 -0600

There are some nits in this version (spelling and long lines), but we  
can fix those after IETF LC.
I'll be issuing the LC request for it shortly.

Please consider this an early LC comment:
I still find this line objectionable:

"When the P-Early-Media header [RFC5009] is used, a UA MAY trigger  
different actions
depending on whether the header has been used for the terminated  
dialog."

I've commented before that this statement is insufficient to inform an  
implementer at all.
I really don't understand why it's here. The other text doesn't  
preclude different actions
if this header is present or not, so it's not relaxing a restriction  
elsewhere in the document.
I think you have the same specification (and less potential confusion)  
if you delete the sentence.

RjS

On Dec 9, 2009, at 3:00 PM, [email-masked] wrote:

> A New Internet-Draft is available from the on-line Internet-Drafts  
> directories.
> This draft is a work item of the Session Initiation Protocol Core  
> Working Group of the IETF.
>
>
> 	Title           : Response Code for Indication of Terminated Dialog
> 	Author(s)       : C. Holmberg
> 	Filename        : draft-ietf-sipcore-199-02.txt
> 	Pages           : 16
> 	Date            : 2009-12-09
>
> This specification defines a new SIP response code, 199 Early Dialog
> Terminated, which a SIP forking proxy and a UAS can use to indicate
> upstream towards the UAC that an early dialog has been terminated,
> before a final response is sent towards the UAC.
>
> Status of this Memo
>
> This Internet-Draft is submitted to IETF in full conformance with the
> provisions of BCP 78 and BCP 79.
>
> Internet-Drafts are working documents of the Internet Engineering
> Task Force (IETF), its areas, and its working groups.  Note that
> other groups may also distribute working documents as Internet-
> Drafts.
>
> Internet-Drafts are draft documents valid for a maximum of six months
> and may be updated, replaced, or obsoleted by other documents at any
> time.  It is inappropriate to use Internet-Drafts as reference
> material or to cite them other than as "work in progress."
>
> The list of current Internet-Drafts can be accessed at
> http://www.ietf.org/ietf/1id-abstracts.txt.
>
> The list of Internet-Draft Shadow Directories can be accessed at
> http://www.ietf.org/shadow.html.
>
> This Internet-Draft will expire on June 12, 2010.
>
> Copyright Notice
>
> Copyright (c) 2009 IETF Trust and the persons identified as the
> document authors.  All rights reserved.
>
> This document is subject to BCP 78 and the IETF Trust's Legal
> Provisions Relating to IETF Documents
> (http://trustee.ietf.org/license-info) in effect on the date of
> publication of this document.  Please review these documents
> carefully, as they describe your rights and restrictions with respect
> to this document.  Code Components extracted from this document must
> include Simplified BSD License text as described in Section 4.e of
> the Trust Legal Provisions and are provided without warranty as
> described in the BSD License.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-sipcore-199-02.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> <mime-attachment>_______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 12 Jan 2010 19:04:45 +0100

Hi,

>different actions depending on whether the header has been used for the terminated
>dialog."
>
>implementer at all. I really don't understand why it's here. The other text doesn't
>preclude different actions if this header is present or not, so it's not relaxing a restriction

I agree. I'll remove it.

Thanks for the comment!

Regards,

Christer

> https://www.ietf.org/mailman/listinfo/sipcore

_______________________________________________
sipcore mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sipcore