Subject: [sipcore] I-D Action:draft-ietf-sipcore-event-rate-control-02.txt

From: [email-masked]
Date: Fri, 8 Jan 2010 13:00:01 -0800 (PST)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Protocol Core Working Group of the IETF.

	Title           : Session Initiation Protocol (SIP) Event Notification Extension for Notification Rate Control
	Author(s)       : A. Niemi, et al.
	Filename        : draft-ietf-sipcore-event-rate-control-02.txt
	Pages           : 23
	Date            : 2010-01-08

This document specifies mechanisms for adjusting the rate of Session
Initiation Protocol (SIP) event notifications.  These mechanisms can
be applied in subscriptions to all SIP event packages.

Status of this Memo

This Internet-Draft is submitted to IETF in full conformance with the
provisions of BCP 78 and BCP 79.

Internet-Drafts are working documents of the Internet Engineering
Task Force (IETF), its areas, and its working groups.  Note that
other groups may also distribute working documents as Internet-
Drafts.

Internet-Drafts are draft documents valid for a maximum of six months
and may be updated, replaced, or obsoleted by other documents at any
time.  It is inappropriate to use Internet-Drafts as reference
material or to cite them other than as "work in progress."

The list of current Internet-Drafts can be accessed at
http://www.ietf.org/ietf/1id-abstracts.txt.

The list of Internet-Draft Shadow Directories can be accessed at
http://www.ietf.org/shadow.html.

This Internet-Draft will expire on July 12, 2010.

Copyright Notice

Copyright (c) 2010 IETF Trust and the persons identified as the
document authors.  All rights reserved.

This document is subject to BCP 78 and the IETF Trust's Legal
Provisions Relating to IETF Documents
(http://trustee.ietf.org/license-info) in effect on the date of
publication of this document.  Please review these documents
carefully, as they describe your rights and restrictions with respect
to this document.  Code Components extracted from this document must
include Simplified BSD License text as described in Section 4.e of
the Trust Legal Provisions and are provided without warranty as
described in the BSD License.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-sipcore-event-rate-control-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: <[email-masked]>
Date: Mon, 11 Jan 2010 08:32:38 +0100

As discussed in http://www.ietf.org/mail-archive/web/sipcore/current/msg01712.html the below updated version adopts the following proposal:
- making the Event header field optional for 2xx to NOTIFY, in a general use case, with or without rate control;
- for implementations supporting the functionality to update the previously agreed rate control in a 2xx response to NOTIFY, it's mandatory to support the inclusion of the Event header field.

The authors think this version is ready for WGLC.

Cheers,
Krisztian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext [email-masked]
Sent: Friday, January 08, 2010 13:00
To: [email-masked]
Cc: [email-masked]
Subject: [sipcore] I-D Action:draft-ietf-sipcore-event-rate-control-02.txt

This document specifies mechanisms for adjusting the rate of Session Initiation Protocol (SIP) event notifications.  These mechanisms can be applied in subscriptions to all SIP event packages.

Status of this Memo

This Internet-Draft is submitted to IETF in full conformance with the provisions of BCP 78 and BCP 79.

Internet-Drafts are working documents of the Internet Engineering Task Force (IETF), its areas, and its working groups.  Note that other groups may also distribute working documents as Internet- Drafts.

Internet-Drafts are draft documents valid for a maximum of six months and may be updated, replaced, or obsoleted by other documents at any time.  It is inappropriate to use Internet-Drafts as reference material or to cite them other than as "work in progress."

The list of current Internet-Drafts can be accessed at http://www.ietf.org/ietf/1id-abstracts.txt.

The list of Internet-Draft Shadow Directories can be accessed at http://www.ietf.org/shadow.html.

Copyright Notice

Copyright (c) 2010 IETF Trust and the persons identified as the document authors.  All rights reserved.

This document is subject to BCP 78 and the IETF Trust's Legal Provisions Relating to IETF Documents
(http://trustee.ietf.org/license-info) in effect on the date of publication of this document.  Please review these documents carefully, as they describe your rights and restrictions with respect to this document.  Code Components extracted from this document must include Simplified BSD License text as described in Section 4.e of the Trust Legal Provisions and are provided without warranty as described in the BSD License.

Below is the data which will enable a MIME compliant mail reader implementation to automatically retrieve the ASCII version of the Internet-Draft.

---

From: Michael Procter <[email-masked]>
Date: Mon, 11 Jan 2010 10:46:16 +0000

I have one comment left on this draft, which Sal asked me to raise on-list.

Section 6.3 defines how a notifier will pace notifications to ensure
they meet with the 'average-interval' specified by the subscriber.  I
have two problems with defining this.  Firstly I don't think we need
to define exactly how the average interval must be achieved, and
secondly even if I did, I don't think the formula specified is
particularly good for various scenarios.

If a subscriber has specific timing requirements that it wishes to be
met, it can advertise them with min-interval and max-interval.  The
average-interval should be viewed as no more than a hint for the
notifier.

Consequently, the notifier should have freedom to achieve an average
rate in the way it considers most effective, provided it meets the
constraints of min-interval and max-interval.

I would prefer that the mechanism for achieving a particular average
interval was left to the notifier's discretion and not specified in
this document.  I would be content if the given formula was described
as one way to achieve this and that an implementation may choose a
different approach if preferred.

Best regards,

Michael

---

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 13 Jan 2010 06:59:19 +0800

The document is fit to go to the IESG, with two minor exceptions.

Section 6.3:
      [OPEN ISSUE] Is the period value something we should be able to
      tune, or we can simply specify a reasonable period?

Should this issue be removed now?

Section 8.3: OLD:
   response to a NOTIFY request.  Implementations supporting the
   functionality to update the previously agreed minimum, maximum or
   average rate of notifications in a 200-class response to the NOTIFY
   request MUST support the inclusion of the Event header field.
NEW:
   response to a NOTIFY request.  A UA that wishes to update the value
   for minimum, maximum or average rate of notifications can do so by
   including all desired values for the rate control parameters in an 
   Event header in the 200-class response to a NOTIFY request.

The changed text didn't include the most important aspect of this text - which is that the _parameters_ are included.  Note that there is no normative requirement in my replacement - interoperability is not harmed by the omission of the header, or even the parameters.

--Martin

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Monday, 11 January 2010 6:33 PM
> To: [email-masked]
> Subject: Re: [sipcore] I-D Action:draft-ietf-sipcore-event-rate-
> control-02.txt
> 
> As discussed in http://www.ietf.org/mail-
> archive/web/sipcore/current/msg01712.html the below updated version
> adopts the following proposal:
> - making the Event header field optional for 2xx to NOTIFY, in a
> general use case, with or without rate control;
> - for implementations supporting the functionality to update the
> previously agreed rate control in a 2xx response to NOTIFY, it's
> mandatory to support the inclusion of the Event header field.
> 
> 	Title           : Session Initiation Protocol (SIP) Event
> Notification Extension for Notification Rate Control
> Initiation Protocol (SIP) event notifications.  These mechanisms can be
> applied in subscriptions to all SIP event packages.
> 
> Status of this Memo
> 
> Internet-Drafts are working documents of the Internet Engineering Task
> Force (IETF), its areas, and its working groups.  Note that other
> groups may also distribute working documents as Internet- Drafts.
> 
> time.  It is inappropriate to use Internet-Drafts as reference material
> or to cite them other than as "work in progress."
> 
> publication of this document.  Please review these documents carefully,
> as they describe your rights and restrictions with respect to this
> document.  Code Components extracted from this document must include
> Simplified BSD License text as described in Section 4.e of the Trust
> Legal Provisions and are provided without warranty as described in the
> BSD License.
> 
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 14 Jan 2010 13:38:23 +0200

Hi,

> The authors think this version is ready for WGLC.

you have received a few comments on this list. Additionally, we have 
requested feedback from the Geopriv WG:

http://www.ietf.org/mail-archive/web/geopriv/current/msg08252.html

Regarding the WGLC, we will be able to start it when the WGLC on the 
invfix draft is over. We are talking about February.

Cheers,

Gonzalo