Subject: [sipcore] rfc3261: sip-uri user parameter

From: Brett Tate <[email-masked]>
Date: Wed, 13 Jan 2010 14:29:41 -0800

Since we were unable to reach agreement on sip-implementors, I thought that I'd try sip-core.

https://lists.cs.columbia.edu/pipermail/sip-implementors/2010-January/024131.html

What does adding user=phone to sip-uri mean?

1) Whatever the owner of sip-uri's host wants it to mean; it isn't restricted to being a telephone-subscriber.  Thus okay to add user=phone when userinfo portion of sip-uri is "anonymous@", not present, and etcetera.

2) The userinfo portion of sip-uri contains telephone-subscriber (defined within rfc3966/rfc2806).

3) Another meaning.

Thanks,
Brett

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 13 Jan 2010 17:49:10 -0500

> 2) The userinfo portion of sip-uri contains telephone-subscriber (defined within rfc3966/rfc2806).

There are two questions lurking here:

- what normative requirements are there on the use of user=phone?
- what *should* user=phone mean?

IMO there is currently nothing of consequence that is required.

IMO there *ought* to be a requirement that:
if user=phone is present, then the user part MUST conform to the syntax 
of telephone-subscriber.

	Thanks,
	Paul