Subject: Re: [sipcore] rfc3265bis

From: "WORLEY, DALE R (DALE)" <[email-masked]>
Date: Wed, 7 Apr 2010 11:34:36 -0400

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Christer Holmberg [[email-masked]]

Of course, for resubscriptions we don't have the forking issue, but I still think we should have the same behavior, ie the NOTIFY acknowledges the resub.
_______________________________________________

rfc3265bis isn't particularly clear on the point, but it looks like the 200 response to the re-SUBSCRIBE extends the subscription expiration time known by the subscriber. So an intermediate element that tracks the subscription has to be watching for such responses, too.  Given that, the fact that sub-not suppresses the NOTIFY is not a problem.

Dale

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 7 Apr 2010 19:23:20 +0200

Hi,

>>Of course, for resubscriptions we don't have the forking issue, but I still think we should have the same >>behavior, ie the NOTIFY acknowledges the resub.
>>
>rfc3265bis isn't particularly clear on the point, but it looks like the 200 response to the re-SUBSCRIBE >extends the subscription expiration time known by the subscriber. So an intermediate element that tracks the >subscription has to be watching for such responses, too.  Given that, the fact that sub-not suppresses the >NOTIFY is not a problem.

Agree.

So, if we choose that way forward, we need to make sure it is explicitly indicated in 3265bis, or I am sure we will sooner or later end up with implementation issues.

Regards,

Christer