Subject: [sipcore] draft-ietf-sipcore-subnot-etags: When to include SIP-Etag in NOTIFY?

From: Christer Holmberg <[email-masked]>
Date: Wed, 7 Apr 2010 14:59:20 +0200

Hi,

When looking deeper into draft-ietf-sipcore-subnot-etags, we also found the following issue/question:

Figure1/Step 3 and Figure 3/Step 3 suggest that the subnot-etags compliant notifier includes the SIP-Etag in the NOT request even if the associated SUB request did not contain Suppress-If-Match. The overview text in section 3 also seems to indicate that SIP-Etag is inserted in every NOT, but that is also informative text only.

However, Section 6 only contains normative text about inclusion of the SIP-Etag in the following situations:

1. The NOT request is generated upon SIP SUB with condition (section 6.2); and

2. The NOT request is generated with state differential (section 6.4)

So, the question is: is a subnot-etags compliant notifier required to insert the SIP-Etag in *every* NOT request, or only in the cases explicitly described in Section 6?

Regards,

Christer

---

From: Dean Willis <[email-masked]>
Date: Wed, 7 Apr 2010 16:21:36 -0500

On Apr 7, 2010, at 7:59 AM, Christer Holmberg wrote:

>
>
> So, the question is: is a subnot-etags compliant notifier required  
> to insert the SIP-Etag in *every* NOT request, or only in the cases  
> explicitly described in Section 6?

I believe the answer is "always".

I also believe I just saw an Auth 48 request come out on this draft.  
Anybody else got a bug to fix?

--
Dean

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 7 Apr 2010 23:31:46 +0200

Hi,

>Anybody else got a bug to fix?

In 3265bis we are aiming at getting rid of the 202 response. The subnot draft defines another one, 204, but I guess it doesn't matter since only endpoints supporting the draft are going to send and receive it.

Regards,

Christer

---

From: Adam Roach <[email-masked]>
Date: Wed, 07 Apr 2010 16:40:25 -0500

> In 3265bis we are aiming at getting rid of the 202 response. The subnot draft defines another one, 204, but I guess it doesn't matter since only endpoints supporting the draft are going to send and…

We're getting rid of 202 because it is vestigial, meaningless, and often 
implemented incorrectly.

subnot-etag's use of 204 is critical for proper functioning of its 
mechanism.

/a