Subject: Re: [sipcore] FW: I-D Action:draft-jones-sip-options-ping-00.txt

From: Hadriel Kaplan <[email-masked]>
Date: Fri, 23 Apr 2010 13:05:31 -0400

I think if we just agree on a common explicit target username, then all those issues are avoided.  We'd just specify the user identifies a logical UA in the proxy/whatever, which is only there for pinging.  The purpose of the request would thus be explicit.

And there's no point in authenticating, since the 401 itself is a response, and besides the information returned is benign.

---

From: Victor Pascual Avila <[email-masked]>
Date: Fri, 23 Apr 2010 19:26:11 +0200

Dumb question: if nodes A and B were exchanging traffic over both UDP
and TCP, should they exchange "PING" messages for/over every
transport?

-Victor

On Fri, Apr 23, 2010 at 7:05 PM, Hadriel Kaplan <[email-masked]> wrote:
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>

-- 
Victor Pascual Ávila

---

From: "Paul E. Jones" <[email-masked]>
Date: Fri, 23 Apr 2010 13:59:32 -0400

Victor,

I suppose they could, but I wouldn't.  I'd configure the use of whatever transport made sense to ping the peer device, which might include Henry's infamous carrier pigeon.

Paul

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Victor Pascual Avila
> Sent: Friday, April 23, 2010 1:26 PM
> To: Hadriel Kaplan
> Cc: Michael Miller; Paul E. Jones; [email-masked]
> Subject: Re: [sipcore] FW: I-D Action:draft-jones-sip-options-ping-
> 00.txt
> 
> > I think if we just agree on a common explicit target username, then
> all those issues are avoided.  We'd just specify the user identifies a
> logical UA in the proxy/whatever, which is only there for pinging.  The
> purpose of the request would thus be explicit.
> >
> > And there's no point in authenticating, since the 401 itself is a
> response, and besides the information returned is benign.