Subject: [sipcore] draft-ietf-sipcore-reinvite-04: precondition

From: OKUMURA Shinji <[email-masked]>
Date: Thu, 03 Jun 2010 13:57:39 +0900

Hi all,

I have some questions about a behavior of UAs using a precondition.

Q1. Does the new behavior of a UAC have nothing to do with
    a precondition?

Q2. If a UAC receives a 4xx to reINVITE before the preconditons have been met,
    does the UAC send a new offer to synchronize both views?

Q3. In 3.3.  UAS Behavior
  "Therefore, it is RECOMMENDED that when a UAS decides to start using
   the new parameters for a stream for which all mandatory preconditions
   have been met, the UAS either sends media using the new parameters or
   sends a new offer where the precondition-related attributes for the
   stream have been removed.  As indicated above, the successful
   completion of an offer/answer exchange without preconditions
   indicates that the new parameters for the media stream are already
   considered to be in use."

    After preconditions have been met, precondition-related
    attributes in a SDP are unnecessary?  Does the UAC misunderstand
    that the preconditions have became unnecessary?

Regards,
Shinji

---

From: [email-masked]
Date: Thu, 3 Jun 2010 13:11:11 +0800

> Q1. Does the new behavior of a UAC have nothing to do with

If the UAS "conf" the precondition state, UAC should send a new Offer when 
it reach the confirmed state. 

Further, if the UAC has no way to reach the confirmed state, it can send 
CANCEL to the UAS.

> 
> Q2. If a UAC receives a 4xx to reINVITE before the preconditons havebeen 
met,
>     does the UAC send a new offer to synchronize both views?

Needn't.

The reason here is that the modification is not *in use*.

>     that the preconditions have became unnecessary?

No.

The precondition ability is express in support header.

And if the UA want to express precondition state re-enter to unmet 
state(such as in wireless access network, UA lose the wireless network 
resource which is needed for some of the media streams), UA can send a new 
Offer, expressing the related streams's precondition state as unsatisfied.

> 
> Regards,
> Shinji
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
> 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: OKUMURA Shinji <[email-masked]>
Date: Fri, 04 Jun 2010 11:01:15 +0900

Hi Gao,

I have thought about a precondition as below:
When UAs use a precondition, all SDP have precondition
attributes and all UPDATE are certainly belong to any one of
INVITE transaction.

But if a UA can send an UPDATE without a precondition,
it seems to be ambiguous whether the UPDATE occurs within an
INVITE transaction.

And your explanations seem to be a new usage of a precondition.

Regards,
Shinji

[email-masked]
Thu, 3 Jun 2010 13:11:11 +0800
>If the UAS "conf" the precondition state, UAC should send a
>new Offer when it reach the confirmed state. 
>
>Further, if the UAC has no way to reach the confirmed state,
>it can send CANCEL to the UAS.
>
>> Q2. If a UAC receives a 4xx to reINVITE before the
>>     preconditons have been met, does the UAC send a new
>>     offer to synchronize both views?
>
>Needn't.
>
>>     attributes in a SDP are unnecessary?
>>     Does the UAC misunderstand that the preconditions have
>>     became unnecessary?
>
>No.
>
>And if the UA want to express precondition state re-enter to
>unmet state(such as in wireless access network, UA lose the
>wireless network resource which is needed for some of the
>media streams), UA can send a new Offer, expressing the
>related streams's precondition state as unsatisfied.
>
>> 
>> Regards,
>> Shinji

---

From: [email-masked]
Date: Fri, 4 Jun 2010 13:04:15 +0800

> it seems to be ambiguous whether the UPDATE occurs within an

UPDATE and INVITE are two transactions.

---

From: "James M. Polk" <[email-masked]>
Date: Fri, 04 Jun 2010 14:30:47 -0500

>UPDATE and INVITE are two transactions.

but within the same dialog

>ZTE Information Security Notice: The information contained in this 
>mail is solely property of the sender's organization. This mail 
>communication is confidential. Recipients named above are obligated 
>to maintain secrecy and are not permitted to disclose the contents 
>of this communication to others.
>This email and any files transmitted with it are confidential and 
>intended solely for the use of the individual or entity to whom they 
>are addressed. If you have received this email in error please 
>notify the originator of the message. Any views expressed in this 
>message are those of the individual sender.
>[email-masked]://www.ietf.org/mailman/listinfo/sipcore

---

From: OKUMURA Shinji <[email-masked]>
Date: Mon, 07 Jun 2010 11:03:55 +0900

Hi,

I have additional questions.

Q4. If UAs use preconditons but any precondition is not
    "mandatory", is a behavior of both UAs the same as a
    case without a precondition?

Q5. In 3.3.  UAS Behavior
   The fact that all mandatory preconditions for the stream are met
   indicates that the new parameters for the media stream are ready to
   be used.  However, they will not actually be used until the UAS
   decides so.  During a session establishment, the UAS can wait before
   using the media parameters until the callee starts being alerted or
   until the callee accepts the session.  During a session modification,
   the UAS can wait until its user accepts the changes to the session.

    Why does the above behavior apply only to mandatory
    preconditions? I think this behavior can apply also to
    the case without a precondition.
    It seems to be an implementation matter.

Regards,
Shinji

>attributes and all UPDATE certainly belong to any one of
>INVITE transactions.
>

---

From: [email-masked]
Date: Tue, 8 Jun 2010 08:53:54 +0800

The semantics of "Suspending and Resuming Session Establishment" is just 
about mandatory preconditon.

Then, other preconditon without mandatory strongness can be handled as 
RFC3264's definition. That is just *in use* after O/A.

===================================
 Zip    : 210012
 Tel    : 87211
 Tel2   :(+86)-025-52877211
 e_mail : [email-masked]
===================================

OKUMURA Shinji <[email-masked]> 
发件人:  [email-masked]
2010-06-07 10:03

收件人
"[email-masked]" <[email-masked]>
抄送
[email-masked]
主题
Re: [sipcore] draft-ietf-sipcore-reinvite-04: precondition

Hi,

Q5. In 3.3.  UAS Behavior

Regards,
Shinji

---

From: [email-masked]
Date: Tue, 8 Jun 2010 08:57:40 +0800

//I once sent the mail at weekend, but the ML didn't dispatch the mail. 
So, I am resending it now.

The point here is whether this modification *in use* or not.

the use case talked here is about session modification with precondition.

If the modification *in use*, the UAS should send 2xx to this Re-INVITE.

If you think there's something not clear, feel free to comment.

Thanks,

Gao 

"James M. Polk" <[email-masked]> 
2010-06-05 03:30

收件人
[email-masked], OKUMURA Shinji <[email-masked]>
抄送
"[email-masked]" <[email-masked]>
主题
Re: [sipcore] draft-ietf-sipcore-reinvite-04: precondition