Subject: [sipcore] Proposed change to draft-ietf-sip-certs to allow SHA256

From: Cullen Jennings <[email-masked]>
Date: Tue, 15 Jun 2010 19:26:13 -0600

The draft-ietf-sip-certs has been sitting around for a long time in IESG review stage for a variety of reasons. In the time since the working group requested publication of this, it has become clear that SHA1 is not as strong a cryptographic hash as was believed when the WGLC was done.  There is a desire to have new protocols support SHA256 in case even more attacks on SHA1 are found. 

The draft currently has a "discuss" from the IESG asking us to move from SHA1 to SHA256. I think this is the right thing to do. This would involved defining a new algorithm for the SIP Identity signature and updating the crypto profiles in sip-certs to support SHA256 instead of SHA1. This is all trivial to do in the draft but is a technical change to the draft that I think folks need to be aware of the change in case there is some serious problem with this. In similar vain we would change the crypto from DES to AES. I talked to a few implementers to see if this posed problem but none of them saw this as an issues as the crypto libraries they were using already had SHA256 and AES for other reasons. The sizes of data that are being signed or encrypted are small so the RSA operations dominate the CPU processing and this change makes no significant change on performance of size. 

Every security person I have talked to thinks we need to move to something better than SHA1 so I don't see this as being very contentious. I plan to update the draft with this sometime soon. If you have objections to this plan, please let me know in the next week. 

Thanks, Cullen

---

From: Adam Roach <[email-masked]>
Date: Tue, 15 Jun 2010 20:55:49 -0500

> Every security person I have talked to thinks we need to move to something better than SHA1 so I don't see this as being very contentious. I plan to update the draft with this sometime soon. If you…

[as a participant]

I support a move to SHA256 for sip-certs.

/a

---

From: Brian Hibbard <[email-masked]>
Date: Wed, 16 Jun 2010 12:45:36 -0500

I think it's a good idea.  Various experts have been grumbling about SHA-1 inadequacies for years. 

On Jun 15, 2010, at 8:55 PM, Adam Roach wrote:

> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore