Subject: [sipcore] [Technical Errata Reported] RFC6228 (4886)

From: RFC Errata System <[email-masked]>
Date: Tue, 13 Dec 2016 08:06:11 -0800 (PST)

The following errata report has been submitted for RFC6228,
"Session Initiation Protocol (SIP) Response Code for Indication of Terminated Dialog".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6228&eid=4886

--------------------------------------
Type: Technical
Reported by: Brett Tate <[email-masked]>

Section: 5

Original Text
-------------
   If the Supported header field of an initial dialog initiation request
   does not contain a "199" option-tag, the UAC MUST NOT send a 199
   response on any early dialog associated with the request.

Corrected Text
--------------
   If the Supported header field of an initial dialog initiation request
   does not contain a "199" option-tag, the UAS MUST NOT send a 199
   response on any early dialog associated with the request.

Notes
-----
Changed "UAC" to "UAS" since the UAC does not send responses.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6228 (draft-ietf-sipcore-199-06)
--------------------------------------
Title               : Session Initiation Protocol (SIP) Response Code for Indication of Terminated Dialog
Publication Date    : May 2011
Author(s)           : C. Holmberg
Category            : PROPOSED STANDARD
Source              : Session Initiation Protocol Core RAI
Area                : Real-time Applications and Infrastructure
Stream              : IETF
Verifying Party     : IESG

---

From: "Ben Campbell" <[email-masked]>
Date: Tue, 13 Dec 2016 10:12:37 -0600

Hi, this seems like an editorial issue to me, in that I assume UAC was a 
typo. Do people think this will cause implementation errors? Or more to 
the point, has anyone experienced implementation errors due to this?

Thanks!

Ben.

---

From: Brett Tate <[email-masked]>
Date: Tue, 13 Dec 2016 11:33:43 -0500

Hi,

I agree that it is a typo.  However excluding the fix, I didn't find text
imposing the same mandate on the UAS.  Thus, I marked the errata type as
technical.

So far, I've only noticed the issue of UAS ignoring the mandate within
documentation instead of a deployed implementation.

> -----Original Message-----
> From: Ben Campbell [mailto:[email-masked]]
> Sent: Tuesday, December 13, 2016 11:13 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Re: [Technical Errata Reported] RFC6228 (4886)
>
the
> point, has anyone experienced implementation errors due to this?
>
> Thanks!
>
> Ben.
>
> > The following errata report has been submitted for RFC6228, "Session
> > Initiation Protocol (SIP) Response Code for Indication of Terminated
> > Dialog".
> >
> > use "Reply All" to discuss whether it should be verified or rejected.
> > When a decision is reached, the verifying party can log in to change
> > the status and edit the report, if necessary.
> >

---

From: "Ben Campbell" <[email-masked]>
Date: Tue, 13 Dec 2016 10:37:16 -0600

I see your point. I lean towards verifying the report.

Christer: thoughts?