Subject: [sipcore] SIP Push: Pull Request based on Ben's AD review

From: Christer Holmberg <[email-masked]>
Date: Sun, 26 Aug 2018 14:18:57 +0000

Hi,

Based on Ben's AD review, I have created a pull request.

https://github.com/cdh4u/draft-sip-push/pull/20

The following clarifications/modifications have been done:

-          s/awake/wake

-          Note that SIP UA vapid specific procedures are outside the scope of the document

-          Note that proxy needs to be between UA and home proxy in order to be able to match the R-URI of SIP requests with a binding contact

-          Clarification that R-URI matching is done against the contact in REGISTER request (but that the contact still need to be present in the REGISTER response)

-          Clarification that if a SIP UA has multiple bindings associated with a push notification subscription, it needs to send a binding refresh REGISTER for each of them when receiving a push notification

-          Clarification that the typical value of 2 seconds might be impacted by PNS- and network characteristics.

-          Modification of requirement to secure the SIP signalling

The following issues are yet not addressed in the PR:

-          The 556 response code has not been removed

-          The IANA policy is still Expert Review

The reason is because I still wait for some input from Ben in the e-mail thread.

In addition, I have not yet done any generic clean up/clarification.

Ben, please let me know if there is something I have forgotten :)

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 27 Aug 2018 16:03:33 +0000

Hi,

I have updated the pull request. Based on Ben's review, I did the following changes:

-          IANA policy is now "Specification Required"

-          Usage of 556 response code is optional (480 can be used instead).

Regards,

Christer

From: Christer Holmberg [mailto:[email-masked]]
Sent: 26 August 2018 17:19
To: [email-masked]; [email-masked]; [email-masked]; Ben Campbell <[email-masked]>
Subject: SIP Push: Pull Request based on Ben's AD review

Hi,

-          s/awake/wake

Regards,

Christer

---

From: Ben Campbell <[email-masked]>
Date: Mon, 27 Aug 2018 15:33:10 -0500

The pull request (is that a push-pull request :-) ) looks good to me.

I have one remaining question: I recall someone (I think it was Robert) asked about inbound mid-dialog requests, in particular, NOTIFY. Was that question resolved? I can imagine a client going to sleep during a long-lived dialog.

Thanks!

Ben.

> On Aug 26, 2018, at 9:18 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
> 
> Based on Ben’s AD review, I have created a pull request.
>

---

From: Robert Sparks <[email-masked]>
Date: Mon, 27 Aug 2018 16:57:11 -0500

> I have one remaining question: I recall someone (I think it was Robert) asked about inbound mid-dialog requests, in particular, NOTIFY. Was that question resolved? I can imagine a client going to s…
Yes, but based on your followup question to me offline, there is text 
that needs to change in the document.

Christer - if you read what you currently have written, no mid-dialog 
request is accounted for (and by implication allowed). Ben, at least, 
read it to mean you can't _use_ push on mid-dialog requests. I don't 
think that's what you had in mind.

I made a very quick attempt at an edit that would address this - let me 
know if I'm wrong about your intent.
See <https://github.com/cdh4u/draft-sip-push/pull/21>

RjS

> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: Ben Campbell <[email-masked]>
Date: Mon, 27 Aug 2018 17:04:33 -0500

> On Aug 27, 2018, at 4:57 PM, Robert Sparks <[email-masked]> wrote:
> 
> 
> 
> Yes, but based on your followup question to me offline, there is text that needs to change in the document.
> 
> Christer - if you read what you currently have written, no mid-dialog request is accounted for (and by implication allowed). Ben, at least, read it to mean you can't _use_ push on mid-dialog requests. I don't think that's what you had in mind.
> 

To be clear, I didn't necessarily read it as _forbidding_  sending a push notification on a mid-dialog request. But it does not specify that you can, either.

Ben.

> I made a very quick attempt at an edit that would address this - let me know if I'm wrong about your intent.

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 28 Aug 2018 17:47:40 +0000

Hi,

…

>Christer - if you read what you currently have written, no mid-dialog request is accounted for
>(and by implication allowed). Ben, at least, read it to mean you can't _use_ push on mid-dialog requests. I don't think that's what you had in mind.
>
>See <https://github.com/cdh4u/draft-sip-push/pull/21><https://github.com/cdh4u/draft-sip-push/pull/21>

As indicated in another mail, mid-dialog push notifications do not currently work, because they don’t contain the pn- parameters.

But, even if we would solve that, there is a need to request a push notification for every mid-dialog request. E.g., a VoIP scenario, the SIP UA will be awake during the session.

Regards,

Christer