Subject: [sipcore] I-D Action: draft-ietf-sipcore-rejected-00.txt

From: [email-masked]
Date: Tue, 21 Aug 2018 15:34:58 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Protocol Core WG of the IETF.

        Title           : A Session Initiation Protocol (SIP) Response Code for Rejected Calls
        Author          : Eric W. Burger
	Filename        : draft-ietf-sipcore-rejected-00.txt
	Pages           : 15
	Date            : 2018-08-21

Abstract:
   This document defines the 608 (Rejected) SIP response code.  This
   response code enables calling parties to learn their call was
   rejected by an intermediary and will not be answered.  As a 6xx code,
   the caller will be aware that future attempts to contact the same UAS
   will be likely to fail.  The present use case driving the need for
   the 608 response code is when the intermediary is an analytics
   engine.  In this case, the rejection is by a machine or other
   process.  This contrasts with the 607 (Unwanted) SIP response code,
   which a human at the target UAS indicated the call was not wanted.
   In some jurisdictions this distinction is important and may have
   additional requirements beyond the 607 response code.  Specifically,
   this document defines the use of the Call-Info header in 608
   responses to enable rejected callers to contact entities that blocked
   their calls in error.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-sipcore-rejected/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-sipcore-rejected-00
https://datatracker.ietf.org/doc/html/draft-ietf-sipcore-rejected-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Eric Burger <[email-masked]>
Date: Tue, 21 Aug 2018 21:16:54 -0400

Of interest to the STIR community, but please keep the discussion on the SIPCORE list.

Updated the Security Considerations section to reflect Tolga’s better articulation of the smurf attack and the vCard integrity / traceability attack. We don’t have a protocol method to address the vCard issue, but I will talk with the card people as there is a draft over there that is 30% of the solution.

Comments welcome.

> On Aug 21, 2018, at 6:34 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore