Subject: [sipcore] I-D Action: draft-ietf-sipcore-reason-q850-loc-07.txt

From: [email-masked]
Date: Fri, 15 Mar 2019 11:05:40 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Protocol Core WG of the IETF.

        Title           : ISUP Cause Location Parameter for the SIP Reason Header Field
        Author          : Roland Jesske
	Filename        : draft-ietf-sipcore-reason-q850-loc-07.txt
	Pages           : 7
	Date            : 2019-03-15

Abstract:
   The SIP Reason header field is defined for carrying ISUP (Integrated
   Services Digital Network User Part) cause values as well as SIP
   response codes.  Some services in SIP networks may need to know the
   ISUP location where the call was released in the PSTN network to
   correctly interpret the reason of release.  This document will update
   RFC3326.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-sipcore-reason-q850-loc/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-sipcore-reason-q850-loc-07
https://datatracker.ietf.org/doc/html/draft-ietf-sipcore-reason-q850-loc-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-sipcore-reason-q850-loc-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 15 Mar 2019 14:22:41 -0400

Is there a reason why isup-location-value is case sensitive? Most stuff 
in sip is not.

	Thanks,
	Paul

---

From: Adam Roach <[email-masked]>
Date: Fri, 15 Mar 2019 13:27:22 -0500

On 3/15/19 1:22 PM, Paul Kyzivat wrote:
> Is there a reason why isup-location-value is case sensitive? Most 
> stuff in sip is not. 

The initial draft was ambiguous, although the use of all-caps implied 
(to me, at least) an intention for case-sensitivity. I don't care how 
it's resolved, but it can't be ambiguous. It may well be that 
case-insensitivity is the right choice here.

(I note that we didn't try to use mnemonic tokens for cause-code; I 
suspect we could have simply defined location as an integer -- but I get 
the impression that we have implementations in the field already, so 
it's probably too late to make such a change.)

/a

---

From: Ben Campbell <[email-masked]>
Date: Mon, 18 Mar 2019 20:57:54 -0500

> On Mar 15, 2019, at 1:27 PM, Adam Roach <[email-masked]> wrote:
> 
>> Is there a reason why isup-location-value is case sensitive? Most stuff in sip is not.
> 
> 
> The initial draft was ambiguous, although the use of all-caps implied (to me, at least) an intention for case-sensitivity. I don't care how it's resolved, but it can't be ambiguous. It may well be that case-insensitivity is the right choice here.
> 
> (I note that we didn't try to use mnemonic tokens for cause-code; I suspect we could have simply defined location as an integer -- but I get the impression that we have implementations in the field already, so it's probably too late to make such a change.)

I would assume it to be the same as for 3326, which of course doesn’t say either. But doesn’t 3261 make all this sort of thing case-insensitive unless stated otherwise?  7.3.1 says "Unless otherwise stated in the definition of a particular header field, field values, parameter names, and parameter values are case-insensitive.“

Ben.

> 
> /a
> 
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore