Subject: [sipcore] I-D Action: draft-ietf-sipcore-sip-token-authnz-12.txt

From: [email-masked]
Date: Tue, 24 Mar 2020 11:56:10 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Protocol Core WG of the IETF.

        Title           : Third-Party Token-based Authentication and Authorization for Session Initiation Protocol (SIP)
        Authors         : Rifaat Shekh-Yusef
                          Christer Holmberg
                          Victor Pascual
	Filename        : draft-ietf-sipcore-sip-token-authnz-12.txt
	Pages           : 14
	Date            : 2020-03-24

Abstract:
   This document defines the "Bearer" authentication scheme for the
   Session Initiation Protocol (SIP), and a mechanism by which user
   authentication and SIP registration authorization is delegated to a
   third party, using the OAuth 2.0 framework and OpenID Connect Core
   1.0.  This document updates RFC 3261 to provide guidance on how a SIP
   User Agent Client (UAC) responds to a SIP 401/407 response that
   contains multiple WWW-Authenticate/Proxy-Authenticate header fields.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-sipcore-sip-token-authnz/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-sipcore-sip-token-authnz-12
https://datatracker.ietf.org/doc/html/draft-ietf-sipcore-sip-token-authnz-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-sipcore-sip-token-authnz-12

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Tue, 24 Mar 2020 15:00:28 -0400

All,

We believe that with this version we have addresses all the comments we
received and that the document is ready to move forward.
Please, take a look and let us know if you have any further comments.

Regards,
 Rifaat

On Tue, Mar 24, 2020 at 2:58 PM <[email-masked]> wrote:

>         Title           : Third-Party Token-based Authentication and
> Authorization for Session Initiation Protocol (SIP)
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 25 Mar 2020 09:19:42 -0400

> Please, take a look and let us know if you have any further comments.

This looks good to me!

	Thanks,
	Paul

> Regards,
>   Rifaat
> 
> 
> On Tue, Mar 24, 2020 at 2:58 PM <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> 
>              Title           : Third-Party Token-based Authentication
>     and Authorization for Session Initiation Protocol (SIP)
>     https://datatracker.ietf..org/doc/html/draft-ietf-sipcore-sip-token-authnz-12
>     <https://datatracker.ietf.org/doc/html/draft-ietf-sipcore-sip-token-authnz-12>
> 
>     until the htmlized version and diff are available at tools.ietf.org
>     <http://tools.ietf.org>.
> 
>     [email-masked] <mailto:[email-masked]>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 25 Mar 2020 13:22:53 +0000

Thank You, Paul.

Regards,

Christer

On 25/03/2020, 15.21, "sipcore on behalf of Paul Kyzivat" <[email-masked] on behalf of [email-masked]> wrote:

    This looks good to me!
    
    	Thanks,
    	Paul