Subject: Re: [Slim] Open Issues on draft-ietf-slim-negotiating-human-language

From: Randall Gellens <[email-masked]>
Date: Sun, 28 May 2017 15:15:11 -0700

I think the edits so far address #19, #27, 28 so they can be closed. 
#38, #39 are addressed in -09 so I will post that and those can be 
closed.  I think #26, #29, #32, #34, #35 were not accepted.

--Randy

At 11:25 AM -0700 4/25/17, Bernard Aboba wrote:

>  Currently 10 Issues remain open from IETF Last Call:
> 
> <https://trac.ietf.org/trac/slim/report/1>https://trac.ietf.org/trac/slim/report/1
>
>
>  These include:
> 
> <https://trac.ietf.org/trac/slim/report/1?sort=ticket&asc=1&page=1>Ticket<https://trac.ietf.org/trac/slim/report/1?sort=summary&asc=1&page=1>Summary<https://trac.ietf.org/trac/slim/report/1?sort=component&asc=1&page=1>Component<https://trac.ietf.org/trac/slim/report/1?sort=version&asc=1&page=1>Version<https://trac.ietf.org/trac/slim/report/1?sort=milestone&asc=1&page=1>Milestone<https://trac.ietf.org/trac/slim/report/1?sort=type&asc=1&page=1>Type<https://trac.ietf.org/trac/slim/report/1?sort=owner&asc=1&page=1>Owner<https://trac.ietf.org/trac/slim/report/1?sort=status&asc=1&page=1>Status<https://trac.ietf.org/trac/slim/report/1?sort=created&asc=1&page=1>Created<https://trac.ietf.org/trac/slim/ticket/27>#27<https://trac.ietf.org/trac/slim/ticket/27>The 
> cases in the "Silly states" section 5.4 are not all 
> silly.negotiating-human-language2.0<https://trac.ietf.org/trac/slim/milestone/milestone1>milestone1defect<mailto:[email-masked]>[email-masked] 
> 22, 
> 2017<https://trac.ietf.org/trac/slim/ticket/19>#19<https://trac.ietf.org/trac/slim/ticket/19>Use 
> Media Type registration 
> templatemultilangcontentenhancement<mailto:[email-masked]>[email-masked] 
> 17, 
> 2016<https://trac.ietf.org/trac/slim/ticket/28>#28<https://trac.ietf.org/trac/slim/ticket/28>Examples 
> section 5.5 requires 
> expansionnegotiating-human-language2.0<https://trac.ietf.org/trac/slim/milestone/milestone1>milestone1defect<mailto:[email-masked]>[email-masked] 
> 22, 
> 2017<https://trac.ietf.org/trac/slim/ticket/32>#32<https://trac.ietf.org/trac/slim/ticket/32>Audio/Video 
> Coordinationnegotiating-human-language2.0<https://trac.ietf.org/trac/slim/milestone/milestone1>milestone1defect<mailto:[email-masked]>[email-masked] 
> 22, 
> 2017<https://trac.ietf.org/trac/slim/ticket/34>#34<https://trac.ietf.org/trac/slim/ticket/34>Use 
> the Accept-Language 
> syntaxnegotiating-human-language2.0<https://trac.ietf.org/trac/slim/milestone/milestone1>milestone1defect<mailto:[email-masked]>[email-masked] 
> 22, 
> 2017<https://trac.ietf.org/trac/slim/ticket/35>#35<https://trac.ietf.org/trac/slim/ticket/35>Have 
> an attribute to abbreviate the bidirectionally-symmetric 
> casenegotiating-human-language2.0<https://trac.ietf.org/trac/slim/milestone/milestone1>milestone1defect<mailto:[email-masked]>[email-masked] 
> 22, 
> 2017<https://trac.ietf.org/trac/slim/ticket/38>#38<https://trac.ietf.org/trac/slim/ticket/38>Routing 
> out of 
> scopenegotiating-human-language1.0<https://trac.ietf.org/trac/slim/milestone/milestone1>milestone1defect<mailto:[email-masked]>[email-masked] 
> 25, 
> 2017<https://trac.ietf.org/trac/slim/ticket/39>#39<https://trac.ietf.org/trac/slim/ticket/39>Syntax 
> Collapsenegotiating-human-language1.0<https://trac.ietf.org/trac/slim/milestone/milestone1>milestone1defect<mailto:[email-masked]>[email-masked] 
> 25, 
> 2017<https://trac.ietf.org/trac/slim/ticket/26>#26<https://trac.ietf.org/trac/slim/ticket/26>Make 
> use of the asterisk modifier on media level with session scope also 
> for media level 
> purposesnegotiating-human-language2.0<https://trac.ietf.org/trac/slim/milestone/milestone1>milestone1enhancement<mailto:[email-masked]>[email-masked] 
> 22, 
> 2017<https://trac.ietf.org/trac/slim/ticket/29>#29<https://trac.ietf.org/trac/slim/ticket/29>Include 
> more fields for attribute registration from 4566bis
>
>  _______________________________________________
>  SLIM mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/slim

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
... Any resemblance between the above views and those of my
employer, my terminal, or the view out my window are purely
coincidental.  Any resemblance between the above and my own
views is non-deterministic.  The question of the existence of
views in the absence of anyone to hold them is left as an
exercise for the reader.  The question of the existence of the
reader is left as an exercise for the second god coefficient.
(A discussion of non-orthogonal, non-integral polytheism
is beyond the scope of this article.)

---

From: Gunnar Hellström <[email-masked]>
Date: Mon, 29 May 2017 20:49:23 +0200

> closed.  I think #26, #29, #32, #34, #35 were not accepted.
This is my view:

#26 can be left non-accepted if #34 is accepted. But if #34 is not 
accepted, we could need #26.
#29 is ok to not accept. All other aspects of the attribute 
registrations are solved.

#34: I have not seen anything about not accepting it, so I suggest to 
accept it.
#35 syntax for bidirectionally symmetric cases - will increase 
complexity - I would suggest to not accept it, but I cannot remember 
that we concluded that before.

#32 requires the two extensions about relative preference and 
simultaneity to be solved. We have not said that we would not accept 
#32.  I suggest that we accept it.

Gunnar

-- 
-----------------------------------------
Gunnar Hellström
Omnitor
[email-masked]
+46 708 204 288

---

From: Randall Gellens <[email-masked]>
Date: Mon, 29 May 2017 15:17:58 -0700

At 8:49 PM +0200 5/29/17, Gunnar Hellström wrote:

>>  I think the edits so far address #19, #27, 28 
>> so they can be closed. #38, #39 are addressed 
>> in -09 so I will post that and those can be 
>  #26 can be left non-accepted if #34 is accepted.

#26 can be done with an Informational draft that 
provides advice to implementers, as previously 
discussed.  #34 was discussed a long time ago and 
it was decided that we did not need to add 
complexity and that we would keep the more simple 
syntax.

>   But if #34 is not accepted, we could need #26.
>  #29 is ok to not accept. All other aspects of 
> the attribute registrations are solved.
>
>  #34: I have not seen anything about not 
> accepting it, so I suggest to accept it.
>  #35 syntax for bidirectionally symmetric cases 
> - will increase complexity - I would suggest to 
> not accept it, but I cannot remember that we 
> concluded that before.
>
>  #32 requires the two extensions about relative 
> preference and simultaneity to be solved. We 
> have not said that we would not accept #32.  I 
> suggest that we accept it.

We've repeatedly decided to not add relative 
preferences (nor any coordination between media) 
in this draft.  This can all be done in a 
subsequent draft.

--Randy

>>> use of the asterisk modifier on media level 
>>> with session scope also for media level 

-------------- Randomly selected tag: ---------------
I do not need to explain why I say things.  That's the interesting thing
about being the President.  Maybe somebody needs to explain to me why
they say something, but I don't feel like I owe anybody an explanation.
            --George W. Bush, in an interview with Bob Woodward.