Subject: [Slim] Ticket #35 Have an attribute to abbreviate the bidirectionally-symmetric case

From: Natasha Rooney <[email-masked]>
Date: Thu, 8 Jun 2017 17:19:59 +0000

Related draft: https://datatracker.ietf.org/doc/draft-ietf-slim-negotiating-human-language/<https://datatracker.ietf.org/doc/draft-ietf-slim-negotiating-human-language/?include_text=1>

Hi all,

Please review the below ticket and respond on-list to comments. We are working through our final tickets before progressing the draft.
https://trac.ietf.org/trac/slim/ticket/35

Natasha

Natasha Rooney | Internet Engineering Director | Internet and Web Team | Technology | GSMA | [email-masked]<mailto:[email-masked]> | +44 (0) 7730 219 765 | @thisNatasha | Skype: [email-masked]<mailto:[email-masked]>

This email and its attachments are intended for the above named only and may be confidential. If they have come to you in error you must take no action based on them, nor must you copy or show them to anyone; please reply to this email or call +44 207 356 0600 and highlight the error.

---

From: Gunnar Hellström <[email-masked]>
Date: Thu, 8 Jun 2017 20:38:34 +0200

Den 2017-06-08 kl. 19:19, skrev Natasha Rooney:
> Related draft: 
> https://datatracker.ietf.org/doc/draft-ietf-slim-negotiating-human-language/ 
> <https://datatracker.ietf.org/doc/draft-ietf-slim-negotiating-human-language/?include_text=1>
>
> Hi all,
>
> Please review the below ticket and respond on-list to comments. We are 
> working through our final tickets before progressing the draft.

It is a good goal and a good proposal. But it causes complications and 
increased complexity, so sadly, I propose to reject it.

The complications are:
1. We would need to introduce a rule to not use hlang-send and 
hlang-recv in a media description where the symmetric hlang is used. 
That would cause undefined preference situations between languages.

2. If the offer contains the symmetric hlang, and the answering party 
has settings for different preferences in the different directions, the 
answering party needs to make a logical analysis and respond with the 
asymmetric attributes. The offering party then also needs to analyze 
this answer in asymmetric attributes and compare to what it originally 
sent in symmetric to find out how to start the call.  These operations 
add complexity in an undesirable way.  Maybe not super complex, but 
anyway added complexity.

/Gunnar

>
> Natasha
>
> Natasha Rooney | Internet Engineering Director | Internet and Web Team 
> | Technology | GSMA | [email-masked] <mailto:[email-masked]> | +44 
> (0) 7730 219 765 | @thisNatasha | Skype: [email-masked] 
> <mailto:[email-masked]>
>
> This email and its attachments are intended for the above named only 
> and may be confidential. If they have come to you in error you must 
> take no action based on them, nor must you copy or show them to 
> anyone; please reply to this email or call +44 207 356 0600 and 
> highlight the error.
>
>
>
> _______________________________________________
> SLIM mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/slim

-- 
-----------------------------------------
Gunnar Hellström
Omnitor
[email-masked]
+46 708 204 288

---

From: Randall Gellens <[email-masked]>
Date: Fri, 9 Jun 2017 14:51:40 -0700

At 5:19 PM +0000 6/8/17, Natasha Rooney wrote:

>  Related 
> draft: <https://datatracker.ietf.org/doc/draft-ietf-slim-negotiating-human-language/?include_text=1>https://datatracker.ietf.org/doc/draft-ietf-slim-negotiating-human-language/
>
>  Hi all,
>
>  Please review the below ticket and respond on-list to comments. We 
> are working through our final tickets before progressing the draft.
> 
> <https://trac.ietf.org/trac/slim/ticket/35>https://trac.ietf.org/trac/slim/ticket/35
>

I think it's a bit late in the process for a change as large as this, 
because I am afraid we might have unanticipated consequences if we 
add a third attribute whose use precludes the other two.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
During Republican administrations since Hoover, unemployment increased
in more years (19) than it decreased (12).  By contrast, joblessness
declined in the vast majority of Democratic administration years--31
of 40.                --Michael Hout, L.A. Times op-ed, March 28, 2004.