Subject: [Slim] How to know modality in draft-ietf-slim-negotiating-human-language

From: Gunnar Hellström <[email-masked]>
Date: Fri, 28 Jul 2017 14:12:42 +0200

I remember a comment in one of the reviews (maybe from Adam ?) mentioning that it would be good if there was a simple way to decide if a language tag is a sign language or a written or spoken language.
We have not responded to that comment.

I know one application scanning the IANA language registry at startup for that purpose and scanning for the word "sign" in the tag description. But that might be seen as an inappropriate way to use IANA registers if it get used by every phone in the future.

What can we say about this review comment? Do we need to add a modality indication parameter in the syntax? Or shall we strictly limit audio to have spoken languages, video to have signed languages and text and webrtc data channels to have written languages? Or shall we leave this problem to implementation?

/Gunnar

-- 
-----------------------------------------
Gunnar Hellström
Omnitor
[email-masked]

---

From: Gunnar Hellström <[email-masked]>
Date: Sun, 30 Jul 2017 00:46:41 +0200

The review comment on this topic was from Dale Worley and is found in 
section B of:

https://www.ietf.org/mail-archive/web/slim/current/msg00766.html

by the sentence about specifying a view of the speaker in video: "

I think this mechanism needs to be described more exactly, and in
particular, it should not depend on the UA understanding which
language tags are spoken language tags."

It is this part we have not handled: " it should not depend on the UA understanding which language tags are spoken language tags"
That is a general issue, not really linked to the issue of the view of a speaker in the video stream.

Den 2017-07-28 kl. 14:12, skrev Gunnar Hellström:
> I remember a comment in one of the reviews (maybe from Adam ?) 
> mentioning that it would be good if there was a simple way to decide 
> if a language tag is a sign language or a written or spoken language.
> I know one application scanning the IANA language registry at startup 
> for that purpose and scanning for the word "sign" in the tag 
> description. But that might be seen as an inappropriate way to use 
> IANA registers if it get used by every phone in the future.
>
> What can we say about this review comment? Do we need to add a 
> modality indication parameter in the syntax? Or shall we strictly 
> limit audio to have spoken languages, video to have signed languages 
> and text and webrtc data channels to have written languages? Or shall 
> we leave this problem to implementation?
>
> /Gunnar
>
>

+46 708 204 288