Subject: Re: [Slim] How to know modality in draft-ietf-slim-negotiating-human-language

From: Randall Gellens <[email-masked]>
Date: Fri, 13 Oct 2017 04:41:49 -0700

At 2:12 PM +0200 7/28/17, Gunnar Hellström wrote:

>  I remember a comment in one of the reviews 
> (maybe from Adam ?) mentioning that it would be 
> good if there was a simple way to decide if a 
> language tag is a sign language or a written or 
> spoken language.
>  We have not responded to that comment.
>
>  I know one application scanning the IANA 
> language registry at startup for that purpose 
> and scanning for the word "sign" in the tag 
> description. But that might be seen as an 
> inappropriate way to use IANA registers if it 
> get used by every phone in the future.
>
>  What can we say about this review comment? Do 
> we need to add a modality indication parameter 
> in the syntax? Or shall we strictly limit audio 
> to have spoken languages, video to have signed 
> languages and text and webrtc data channels to 
> have written languages? Or shall we leave this 
> problem to implementation?

I think it exceeds the scope of the draft.  It 
reads to me as a request for functionality that 
is inherent in all uses of language tags, not 
just the applications of this draft.

>
>  /Gunnar
>
>
>  --
>  -----------------------------------------
>  Gunnar Hellström
>  Omnitor
>  [email-masked]
>
>  _______________________________________________
>  SLIM mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/slim

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
Peace:  In international affairs, a period of cheating between two
periods of fighting.

---

From: Randall Gellens <[email-masked]>
Date: Fri, 13 Oct 2017 05:01:06 -0700

At 12:46 AM +0200 7/30/17, Gunnar Hellström wrote:

>  The review comment on this topic was from Dale 
> Worley and is found in section B of:
>
> 
> <https://www.ietf.org/mail-archive/web/slim/current/msg00766.html>https://www.ietf.org/mail-archive/web/slim/current/msg00766.html
>
>  by the sentence about specifying a view of the speaker in video: "
>
>  I think this mechanism needs to be described more exactly, and in
>  particular, it should not depend on the UA understanding which
>  language tags are spoken language tags."
>
>  It is this part we have not handled: " it 
> should not depend on the UA understanding which 
> language tags are spoken language tags"
>  That is a general issue, not really linked to 
> the issue of the view of a speaker in the video 
> stream.

Dale's suggestion of clarifying that it is the 
use of the exact same language tag in both the 
audio and video stream, rather than just a spoken 
tag on the video stream, is a good one.  I'll add 
that.

>
>
>  Den 2017-07-28 kl. 14:12, skrev Gunnar Hellström:
>
>> (maybe from Adam ?) mentioning that it would 
>> be good if there was a simple way to decide if 
>> a language tag is a sign language or a written 
>> or spoken language.
>> in the syntax? Or shall we strictly limit 
>> audio to have spoken languages, video to have 
>> signed languages and text and webrtc data 
>> channels to have written languages? Or shall 
>> we leave this problem to implementation?
>>
>>  /Gunnar
>>
>
>  --
>  <mailto:[email-masked]>[email-masked]
>  +46 708 204 288
>

-------------- Randomly selected tag: ---------------
Why does every plane have two pilots? Really, you only need one pilot.
Let's take out the second pilot. Let the bloody computer fly it.
    --Michael O'Leary, Ryanair CEO, regards eliminating co-pilots in
      airline operations. Interview in Bloomberg Businessweek,
      2 September 2010

---

From: Gunnar Hellström <[email-masked]>
Date: Fri, 13 Oct 2017 14:21:38 +0200

Den 2017-10-13 kl. 14:01, skrev Randall Gellens:
>>  The review comment on this topic was from Dale Worley and is found 
>> in section B of:
>>
>>
>>  It is this part we have not handled: " it should not depend on the 
>> UA understanding which language tags are spoken language tags"
>>  That is a general issue, not really linked to the issue of the view 
>> of a speaker in the video stream.
>
> Dale's suggestion of clarifying that it is the use of the exact same 
> language tag in both the audio and video stream, rather than just a 
> spoken tag on the video stream, is a good one.  I'll add that.
<GH>We already have that as a valid combination. But you may if you want 
add that it is the way to know that video is used for a view of a 
talking person.
>>>  I remember a comment in one of the reviews (maybe from Adam ?) 
>>> mentioning that it would be good if there was a simple way to decide 
>>> if a language tag is a sign language or a written or spoken language.
>>>  I know one application scanning the IANA language registry at 
>>> startup for that purpose and scanning for the word "sign" in the tag 
>>> description. But that might be seen as an inappropriate way to use 
>>> IANA registers if it get used by every phone in the future.
>>>
>>>  What can we say about this review comment? Do we need to add a 
>>> modality indication parameter in the syntax? Or shall we strictly 
>>> limit audio to have spoken languages, video to have signed languages 
>>> and text and webrtc data channels to have written languages? Or 
>>> shall we leave this problem to implementation?
>>>
>>>  /Gunnar
>>>
>>
>>  --