Subject: Re: [Slim] Indication of modality alternatives in draft-ietf-slim-negotiating-human-language

From: Randall Gellens <[email-masked]>
Date: Fri, 13 Oct 2017 04:51:21 -0700

At 12:06 AM +0200 7/29/17, Gunnar Hellström wrote:

>  We have dealt with this topic before, but 
> rereading the draft indicates to me that we 
> still need some tuning of the wording so that 
> it is clear that the language indications for 
> the same direction for different media are 
> alternatives with no requirements that they 
> need to be provided together, so that it is 
> allowed to answer with just one media in each 
> direction having language indication.
>
>  Suggested wording changes to make this clear:
>
>  ---Change 1 in 5.2, first paragraph----------------
>  ------old text---------
>  This document defines two media-level attributes starting with
>     'hlang' (short for "human interactive language") to negotiate which
>     human language is selected for use in each interactive media stream.
>  ------------new text--------------------
>  This document defines two media-level attributes starting with
>     'hlang' (short for "human interactive language") to negotiate which
>     human language is selected for use in each 
> media stream used for interactive language 
> communication.
>  -------end of change 1-------

I don't see how changing "each interactive media 
stream" to "each media stream used for 
interactive language communication" improves 
anything.  The term "interactive" implies human 
interaction.

>
>  ----Change 2 in 5.2, third paragraph ------
>  ----old text------
>    In an answer, 'hlang-send' is the language the answerer will send if
>     using the media for language (which in most cases is one of the
>     languages in the offer's 'hlang-recv'), and 'hlang-recv' is the
>     language the answerer expects to receive in the media (which in most
>     cases is one of the languages in the offer's 'hlang-send').
>  -----new text----
>    In an answer, 'hlang-send' is the language the answerer will send if
>     using the media for language (which in most cases is one of the
>     languages in the offer's 'hlang-recv'), and 'hlang-recv' is the
>     language the answerer expects to receive in the media if
>     using the media for language (which in most
>     cases is one of the languages in the offer's 'hlang-send').
>  ----end of change 2-------------------------------

I'm OK adding "if using the media for language" to the second clause.

>
>
>  /Gunnar
>
>  --
>  -----------------------------------------
>  Gunnar Hellström
>  Omnitor
>  [email-masked]
>
>  _______________________________________________
>  SLIM mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/slim

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
The idea that people know what they want is wrong.
They need to be pulled through the Web.
      --Laura Jennings, Vice President, Microsoft Network

---

From: Gunnar Hellström <[email-masked]>
Date: Fri, 13 Oct 2017 14:57:07 +0200

Den 2017-10-13 kl. 13:51, skrev Randall Gellens:
>>  We have dealt with this topic before, but rereading the draft 
>> indicates to me that we still need some tuning of the wording so that 
>> it is clear that the language indications for the same direction for 
>> different media are alternatives with no requirements that they need 
>> to be provided together, so that it is allowed to answer with just 
>> one media in each direction having language indication.
>>
>>     human language is selected for use in each media stream used for 
>> interactive language communication.
> I don't see how changing "each interactive media stream" to "each 
> media stream used for interactive language communication" improves 
> anything.  The term "interactive" implies human interaction.
<GH>Yes, but human interaction can be to show things in video without 
being language communication.
What I am aiming at is to clearly indicate that the language indications 
are alternatives to select from. The wording "use in each interactive 
media stream" sounds to me that you MUST use all the agreed languages. 
That is the same mistake that you initially blamed the Lang SDP 
attribute to mean. We need to get away from that interpretation. My 
wording was intended to accomplish that, but it might have been too 
weak. The key word is "used" that is intended to mean that if a media 
stream is selected to be used for language communication then the agreed 
language is the one to be used.
So, I prefer my wording, or if you can create something even more clear 
that we are talking about alternatives to select from.

+46 708 204 288

---

From: Randall Gellens <[email-masked]>
Date: Fri, 13 Oct 2017 06:13:03 -0700

I think we've addressed the concerns that existed 
with earlier versions of the draft.

At 2:57 PM +0200 10/13/17, Gunnar Hellström wrote:

>>>      human language is selected for use in 
>>> each media stream used for interactive 
>>> language communication.
>>  I don't see how changing "each interactive 
>> media stream" to "each media stream used for 
>  <GH>Yes, but human interaction can be to show 
> things in video without being language 
> communication.
>  What I am aiming at is to clearly indicate that 
> the language indications are alternatives to 
> select from. The wording "use in each 
> interactive media stream" sounds to me that you 
> MUST use all the agreed languages. That is the 
> same mistake that you initially blamed the Lang 
> SDP attribute to mean. We need to get away from 
> that interpretation. My wording was intended to 
> accomplish that, but it might have been too 
> weak. The key word is "used" that is intended 
> to mean that if a media stream is selected to 
> be used for language communication then the 
> agreed language is the one to be used.
>  So, I prefer my wording, or if you can create 
> something even more clear that we are talking 
> about alternatives to select from.
>>
>>>

-------------- Randomly selected tag: ---------------
The old believe everything; the middle-aged suspect everything;
the young know everything.                        --Oscar Wilde

---

From: Gunnar Hellström <[email-masked]>
Date: Fri, 13 Oct 2017 15:32:55 +0200

Change 2 is fine and solves part of the problem.

But the current wording at my proposed change 1 still tells me that if I 
offer English text and English voice, it means that I have selected to 
use both, and even stronger if an answer contains English text and 
English voice, then both will be used in the session, exactly as you 
indicated was the problem with the Lang attribute. We need to get the 
possibility to select among alternatives clearly into the draft so that 
not next generation implementers also say that it is too vague about 
what it means.

The current wording at change one still says that each interactive 
stream is used.

How about:  "to negotiate which
      human language is selected for*possible *use in each interactive 
media stream."

/Gunnar

Den 2017-10-13 kl. 15:13, skrev Randall Gellens:
> I think we've addressed the concerns that existed with earlier 
> versions of the draft.
>
>>>> indicates to me that we still need some tuning of the wording so 
>>>> that it is clear that the language indications for the same 
>>>> direction for different media are alternatives with no requirements 
>>>> that they need to be provided together, so that it is allowed to 
>>>> answer with just one media in each direction having language 
>>>> indication.
>>>>
>>>>      human language is selected for use in each media stream used 
>>>> for interactive language communication.
>>  <GH>Yes, but human interaction can be to show things in video 
>> without being language communication.
>>  What I am aiming at is to clearly indicate that the language 
>> indications are alternatives to select from. The wording "use in each 
>> interactive media stream" sounds to me that you MUST use all the 
>> agreed languages. That is the same mistake that you initially blamed 
>> the Lang SDP attribute to mean. We need to get away from that 
>> interpretation. My wording was intended to accomplish that, but it 
>> might have been too weak. The key word is "used" that is intended to 
>> mean that if a media stream is selected to be used for language 
>> communication then the agreed language is the one to be used.
>>  So, I prefer my wording, or if you can create something even more 
>> clear that we are talking about alternatives to select from.
>>>
>>>>

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 13 Oct 2017 07:58:20 -0700

Gunnar said:

"to negotiate which human language is selected for possible use in each
interactive media stream"

[BA] Given that audio can be muted, video can be turned off, etc. aren't
media streams negotiated in SDP always for "possible" use?

On Fri, Oct 13, 2017 at 6:32 AM, Gunnar Hellström <
[email-masked]> wrote:

> offer English text and English voice, it means that I have selected to use
> both, and even stronger if an answer contains English text and English
> voice, then both will be used in the session, exactly as you indicated was
> the problem with the Lang attribute. We need to get the possibility to
> select among alternatives clearly into the draft so that not next
> generation implementers also say that it is too vague about what it means.
>
> The current wording at change one still says that each interactive stream
> is used.
>
>      human language is selected for* possible *use in each interactive
> media stream."
>
> /Gunnar
>
> I think we've addressed the concerns that existed with earlier versions of
> the draft.
>
>   We have dealt with this topic before, but rereading the draft indicates
> to me that we still need some tuning of the wording so that it is clear
> that the language indications for the same direction for different media
> are alternatives with no requirements that they need to be provided
> together, so that it is allowed to answer with just one media in each
>  I don't see how changing "each interactive media stream" to "each media
> stream used for interactive language communication" improves anything.  The
> term "interactive" implies human interaction.
>
> are alternatives to select from. The wording "use in each interactive media
> stream" sounds to me that you MUST use all the agreed languages. That is
> the same mistake that you initially blamed the Lang SDP attribute to mean.
> We need to get away from that interpretation. My wording was intended to
> accomplish that, but it might have been too weak. The key word is "used"
> that is intended to mean that if a media stream is selected to be used for
> language communication then the agreed language is the one to be used.
> [email-masked]
> +46 708 204 288
>
>

---

From: Gunnar Hellström <[email-masked]>
Date: Fri, 13 Oct 2017 20:21:40 +0200

Den 2017-10-13 kl. 16:58, skrev Bernard Aboba:
> Gunnar said:
>
> "to negotiate which human language is selected for possible use in 
> each interactive media stream"
>
> [BA] Given that audio can be muted, video can be turned off, etc. 
> aren't media streams negotiated in SDP always for "possible" use?
<GH>That may be true, but we are not talking about the media flow in the 
streams. We are talking about the use for language. Our draft must 
reflect clearly what the language negotiation result really means. To 
me,  "is selected for use in each interactive media stream" sounds as a 
promise that a negotiated language will actually be used. That means 
that if two media streams end up with negotiated languages in the same 
direction, then both must be provided together. According to the 
discussions in the WG, that is not the desired result. The desired 
result should be that the users can select between use of the negotiated 
languages and usually use just one in each direction.  We introduced 
"selected" some time ago, but it did not have the right effect.

I will try to come up with new wording proposals.

/Gunnar

>
> On Fri, Oct 13, 2017 at 6:32 AM, Gunnar Hellström 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     But the current wording at my proposed change 1 still tells me
>     that if I offer English text and English voice, it means that I
>     have selected to use both, and even stronger if an answer contains
>     English text and English voice, then both will be used in the
>     session, exactly as you indicated was the problem with the Lang
>     attribute. We need to get the possibility to select among
>     alternatives clearly into the draft so that not next generation
>     implementers also say that it is too vague about what it means.
>
>          human language is selected for*possible *use in each
>     interactive media stream."
>
>     /Gunnar
>
>
>>>>>       We have dealt with this topic before, but rereading the
>>>>>     draft indicates to me that we still need some tuning of the
>>>>>     wording so that it is clear that the language indications for
>>>>>     the same direction for different media are alternatives with
>>>>>     no requirements that they need to be provided together, so
>>>>>     that it is allowed to answer with just one media in each
>>>>>          human language is selected for use in each media stream
>>>>>     used for interactive language communication.
>>>>      I don't see how changing "each interactive media stream" to
>>>>     "each media stream used for interactive language communication"
>>>>     improves anything.  The term "interactive" implies human
>>>>     interaction.
>>>     indications are alternatives to select from. The wording "use in
>>>     each interactive media stream" sounds to me that you MUST use
>>>     all the agreed languages. That is the same mistake that you
>>>     initially blamed the Lang SDP attribute to mean. We need to get
>>>     away from that interpretation. My wording was intended to
>>>     accomplish that, but it might have been too weak. The key word
>>>     is "used" that is intended to mean that if a media stream is
>>>     selected to be used for language communication then the agreed
>>>      So, I prefer my wording, or if you can create something even
>>>     more clear that we are talking about alternatives to select from.
>>>>
>>>>>
>>>>>     [email-masked] <mailto:[email-masked]>
>>>>>
>>>>>     [email-masked] <mailto:[email-masked]>
>>>>>     <https://www.ietf.org/mailman/listinfo/slim>
>>>>
>>>>
>>>
>>>      --
>>>     [email-masked] <mailto:[email-masked]>
>>>      +46 708 204 288
>>
>>
>
>     -- 
>     [email-masked] <mailto:[email-masked]>
>     +46 708 204 288
>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/slim>
>
>

---

From: Brian Rosen <[email-masked]>
Date: Fri, 13 Oct 2017 14:31:51 -0400

Gunnar

Protocol documents are for engineers to write software/create hardware.  They don’t try to control user behavior.  I think in this case, you are trying to get the document to describe user behavior and not implementation software/hardware.

Although we do sometimes describe how we expect the protocol to be used by people, that is not normative, and we should be careful to not proscribe behavior.

Brian

> On Oct 13, 2017, at 2:21 PM, Gunnar Hellström <[email-masked]> wrote:
> 
>> "to negotiate which human language is selected for possible use in each interactive media stream"
>> 
>> [BA] Given that audio can be muted, video can be turned off, etc. aren't media streams negotiated in SDP always for "possible" use?
> <GH>That may be true, but we are not talking about the media flow in the streams. We are talking about the use for language. Our draft must reflect clearly what the language negotiation result really means. To me,  "is selected for use in each interactive media stream" sounds as a promise that a negotiated language will actually be used. That means that if two media streams end up with negotiated languages in the same direction, then both must be provided together. According to the discussions in the WG, that is not the desired result. The desired result should be that the users can select between use of the negotiated languages and usually use just one in each direction.  We introduced "selected" some time ago, but it did not have the right effect.   
> 
>> On Fri, Oct 13, 2017 at 6:32 AM, Gunnar Hellström <[email-masked] <mailto:[email-masked]>> wrote:
>> But the current wording at my proposed change 1 still tells me that if I offer English text and English voice, it means that I have selected to use both, and even stronger if an answer contains English text and English voice, then both will be used in the session, exactly as you indicated was the problem with the Lang attribute. We need to get the possibility to select among alternatives clearly into the draft so that not next generation implementers also say that it is too vague about what it means.
>> 
>> The current wording at change one still says that each interactive stream is used. 
>> 
>>      human language is selected for possible use in each interactive media stream."
>> 
>> /Gunnar
>> 
>> 
>>> I think we've addressed the concerns that existed with earlier versions of the draft. 
>>> 
>>>>>>   We have dealt with this topic before, but rereading the draft indicates to me that we still need some tuning of the wording so that it is clear that the language indications for the same direction for different media are alternatives with no requirements that they need to be provided together, so that it is allowed to answer with just one media in each direction having language indication. 
>>>>>> 
>>>>>>      human language is selected for use in each media stream used for interactive language communication. 
>>>>>  I don't see how changing "each interactive media stream" to "each media stream used for interactive language communication" improves anything.  The term "interactive" implies human interaction. 
>>>>  <GH>Yes, but human interaction can be to show things in video without being language communication. 
>>>>  What I am aiming at is to clearly indicate that the language indications are alternatives to select from. The wording "use in each interactive media stream" sounds to me that you MUST use all the agreed languages. That is the same mistake that you initially blamed the Lang SDP attribute to mean. We need to get away from that interpretation. My wording was intended to accomplish that, but it might have been too weak. The key word is "used" that is intended to mean that if a media stream is selected to be used for language communication then the agreed language is the one to be used. 
>>>>  So, I prefer my wording, or if you can create something even more clear that we are talking about alternatives to select from. 
>>>>> 
>>>>>> 
>>>>>>   https://www.ietf.org/mailman/listinfo/slim <https://www.ietf.org/mailman/listinfo/slim> 
>>>>> 
>>>>> 
>>>> 
>>>>  -- 
>> https://www.ietf.org/mailman/listinfo/slim <https://www.ietf.org/mailman/listinfo/slim>
>> 
>> 
> 
> -- 
> https://www.ietf.org/mailman/listinfo/slim <https://www.ietf.org/mailman/listinfo/slim>

---

From: Gunnar Hellström <[email-masked]>
Date: Sat, 14 Oct 2017 00:21:47 +0200

Den 2017-10-13 kl. 20:31, skrev Brian Rosen:
> Gunnar
>
> Protocol documents are for engineers to write software/create 
> hardware.  They don’t try to control user behavior.  I think in this 
> case, you are trying to get the document to describe user behavior and 
> not implementation software/hardware.
>
> Although we do sometimes describe how we expect the protocol to be 
> used by people, that is not normative, and we should be careful to not 
> proscribe behavior.
<GH>Our protocol needs to be well defined regardless if the source and 
sink of language is automata or humans.
As long as we can read the specification differently it is not well defined.
When I ask what the result of the negotiation really means, you use to 
say that it is alternative languages that the users are supposed to 
select from and use one or more in each direction.
I agree that that is a good result.
I think the wording still means that all negotiated languages should be 
used, and I want to avoid that interpretation.

(There is also use for a result saying that a couple of languages are 
desired together in the same direction, but it has been said many times 
that that is not the intention of the current draft, so that requires 
separate work. )

We are reasonably good now with change 2 implemented. The first section 
of 5.2, that change 1 aims at, may be seen as introductory and does 
maybe not need to be completely clarifying, if that requires too 
complicated wording. But it must not contradict the intention of the 
protocol.

Gunnar
>
> Brian
>
>> On Oct 13, 2017, at 2:21 PM, Gunnar Hellström 
>> <GH>That may be true, but we are not talking about the media flow in 
>> the streams. We are talking about the use for language. Our draft 
>> must reflect clearly what the language negotiation result really 
>> means. To me,  "is selected for use in each interactive media stream" 
>> sounds as a promise that a negotiated language will actually be used. 
>> That means that if two media streams end up with negotiated languages 
>> in the same direction, then both must be provided together. According 
>> to the discussions in the WG, that is not the desired result. The 
>> desired result should be that the users can select between use of the 
>> negotiated languages and usually use just one in each direction.  We 
>> introduced "selected" some time ago, but it did not have the right 
>> effect.
>>
>>> On Fri, Oct 13, 2017 at 6:32 AM, Gunnar 
>>> Hellström<[email-masked] 
>>> <mailto:[email-masked]>>wrote:
>>>
>>>     have selected to use both, and even stronger if an answer
>>>     contains English text and English voice, then both will be used
>>>     in the session, exactly as you indicated was the problem with
>>>     the Lang attribute. We need to get the possibility to select
>>>     among alternatives clearly into the draft so that not next
>>>     human language is selected for*possible*use in each interactive
>>>     media stream."
>>>
>>>     /Gunnar
>>>
>>>
>>>>>>>     wording so that it is clear that the language indications
>>>>>>>     for the same direction for different media are alternatives
>>>>>>>     with no requirements that they need to be provided together,
>>>>>>>     so that it is allowed to answer with just one media in each
>>>>>>     "each media stream used for interactive language
>>>>>>     communication" improves anything.  The term "interactive"
>>>>>>     implies human interaction.
>>>>>     indications are alternatives to select from. The wording "use
>>>>>     in each interactive media stream" sounds to me that you MUST
>>>>>     use all the agreed languages. That is the same mistake that
>>>>>     you initially blamed the Lang SDP attribute to mean. We need
>>>>>     to get away from that interpretation. My wording was intended
>>>>>     to accomplish that, but it might have been too weak. The key
>>>>>     word is "used" that is intended to mean that if a media stream
>>>>>     is selected to be used for language communication then the

---

From: Randall Gellens <[email-masked]>
Date: Fri, 13 Oct 2017 19:13:16 -0700

At 8:21 PM +0200 10/13/17, Gunnar Hellström wrote:

>>  "to negotiate which human language is selected 
>> for possible use in each interactive media 
>> stream"
>>
>>  [BA] Given that audio can be muted, video can 
>> be turned off, etc. aren't media streams 
>> negotiated in SDP always for "possible" use?
>>
>  <GH>That may be true, but we are not talking 
> about the media flow in the streams. We are 
> talking about the use for language. Our draft 
> must reflect clearly what the language 
> negotiation result really means. To me,  "is 
> selected for use in each interactive media 
> stream" sounds as a promise that a negotiated 
> language will actually be used.

I don't think it reads that way at all.

Further, the draft says, in 5.2:

    Note that media and language negotiation might result in more media
    streams being accepted than are needed by the users (e.g., if more
    preferred and less preferred combinations of media and language are
    all accepted).  This is not a problem.

This explicitly states that not all negotiated media will necessarily be used.

>  That means that if two media streams end up 
> with negotiated languages in the same 
> direction, then both must be provided together. 
> According to the discussions in the WG, that is 
> not the desired result. The desired result 
> should be that the users can select between use 
> of the negotiated languages and usually use 
> just one in each direction.  We introduced 

I think the wording is fine as it is.

>> Hellström 
>> <<mailto:[email-masked]>[email-masked]> 
>> wrote:
>>
>>  But the current wording at my proposed change 
>> 1 still tells me that if I offer English text 
>> and English voice, it means that I have 
>> selected to use both, and even stronger if an 
>> answer contains English text and English 
>> voice, then both will be used in the session, 
>> exactly as you indicated was the problem with 
>> the Lang attribute. We need to get the 
>> possibility to select among alternatives 
>> clearly into the draft so that not next 
>>>  I think we've addressed the concerns that 
>>> existed with earlier versions of the draft.
>>>
>>>>>>    We have dealt with this topic before, 
>>>>>> but rereading the draft indicates to me 
>>>>>> that we still need some tuning of the 
>>>>>> wording so that it is clear that the 
>>>>>> language indications for the same 
>>>>>> direction for different media are 
>>>>>> alternatives with no requirements that 
>>>>>> they need to be provided together, so that 
>>>>>> it is allowed to answer with just one 
>>>>>> media in each direction having language 
>>>>>> indication.
>>>>>>
>>>>>> each interactive media stream.
>>>   <GH>Yes, but human interaction can be to 
>>> show things in video without being language 
>>> communication.
>>>   What I am aiming at is to clearly indicate 
>>> that the language indications are 
>>> alternatives to select from. The wording "use 
>>> in each interactive media stream" sounds to 
>>> me that you MUST use all the agreed 
>>> languages. That is the same mistake that you 
>>> initially blamed the Lang SDP attribute to 
>>> mean. We need to get away from that 
>>> interpretation. My wording was intended to 
>>>   So, I prefer my wording, or if you can 
>>> create something even more clear that we are 
>>> talking about alternatives to select from.
>>>
>>>>
>>>>>
>>>>    <mailto:[email-masked]>[email-masked]
>>>>
>>>>    <mailto:[email-masked]>[email-masked]
>>>> 
>>>> <https://www.ietf.org/mailman/listinfo/slim>https://www.ietf.org/mailman/listinfo/slim
>>>>
>>>
>>>
>>>
>>>   --
>>>   <mailto:[email-masked]>[email-masked]
>>>   +46 708 204 288
>>>
>>
>>
>>
>>  --
>>  <mailto:[email-masked]>[email-masked]
>>  +46 708 204 288
>>
>>  <mailto:[email-masked]>[email-masked]
>> 
>> <https://www.ietf.org/mailman/listinfo/slim>https://www.ietf.org/mailman/listinfo/slim
>>
>>
>
>  --
>  <mailto:[email-masked]>[email-masked]
>  +46 708 204 288

-------------- Randomly selected tag: ---------------
And still I persist in wondering if folly must always
be man's nemesis.                    --Edgar Pangborn

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 13 Oct 2017 20:56:28 -0700

> This explicitly states that not all negotiated media will necessarily be used.

[BA] The text (and O/A SDP docs such as RFC 3264) does seem clear about this.

---

From: Gunnar Hellström <[email-masked]>
Date: Sat, 14 Oct 2017 10:58:33 +0200

In order to not create complicated sentences but still having the 
wording match our intentions, I want to change the proposed resolution 
for Issue # 46 Change 1 to:

------------new text--------------------
This document defines two media-level attributes starting with
'hlang' (short for "human interactive language") to negotiate which
human language is selected for *potential* use in each media stream.
-------end of change 1-------

That matches the "if" in paragraph 3, and it is also valid for both the 
offers and answers, while paragraph 3 is only for the answer.
Please accept it, it is of importance for proper understanding of our 
intentions.

/Gunnar

Den 2017-10-14 kl. 00:21, skrev Gunnar Hellström:
>> case, you are trying to get the document to describe user behavior 
>> and not implementation software/hardware.
>>
>> used by people, that is not normative, and we should be careful to 
>> not proscribe behavior.
> I think the wording still means that all negotiated languages should 
> be used, and I want to avoid that interpretation.
>
> desired together in the same direction, but it has been said many 
> times that that is not the intention of the current draft, so that 
> requires separate work. )
>
> We are reasonably good now with change 2 implemented. The first 
> section of 5.2, that change 1 aims at, may be seen as introductory and 
> does maybe not need to be completely clarifying, if that requires too 
>>> means. To me,  "is selected for use in each interactive media 
>>> stream" sounds as a promise that a negotiated language will actually 
>>> be used. That means that if two media streams end up with negotiated 
>>> languages in the same direction, then both must be provided 
>>> together. According to the discussions in the WG, that is not the 
>>> desired result. The desired result should be that the users can 
>>> select between use of the negotiated languages and usually use just 
>>> one in each direction.  We introduced "selected" some time ago, but 
>>> it did not have the right effect.
>>>
>>>>>>>>     with no requirements that they need to be provided
>>>>>>>>     together, so that it is allowed to answer with just one
>>>>>>>>     media in each direction having language indication.
>>>>>>>>
>>>>>>      <GH>Yes, but human interaction can be to show things in
>>>>>>     video without being language communication.
>>>>>>     word is "used" that is intended to mean that if a media
>>>>>>     stream is selected to be used for language communication then
>>>>>>     the agreed language is the one to be used.
>>>>>>>>     <mailto:[email-masked]>
>>>>>>>>

---

From: Randall Gellens <[email-masked]>
Date: Sat, 14 Oct 2017 05:00:38 -0700

At 10:58 AM +0200 10/14/17, Gunnar Hellström wrote:

>  In order to not create complicated sentences 
> but still having the wording match our 
> intentions, I want to change the proposed 
> resolution for Issue # 46 Change 1 to:
>
>       human language is selected for potential use in each media stream.
>  That matches the "if" in paragraph 3, and it is 
> also valid for both the offers and answers, 
> while paragraph 3 is only for the answer.
>  Please accept it, it is of importance for 
> proper understanding of our intentions.

The existing text is talking about which language 
is selected for use in a media stream should that 
media stream be used for interactive 
communication; the proposed wording instead talks 
about a language that may or may not be used in a 
media stream, which doesn't seem correct to me. 
Since we already have text (as noted earlier) 
that explicitly says that not all negotiated 
media streams need be used, I don't see a problem 
with leaving the text as is.

-------------- Randomly selected tag: ---------------
ondinnonk (ON-din-onk; Iroquoian; noun): the soul's innermost
benevolent desires.

---

From: Bernard Aboba <[email-masked]>
Date: Sat, 14 Oct 2017 10:52:41 -0700

Randall said:

"The existing text is talking about which language is selected for use in a
media stream should that media stream be used for interactive
communication; the proposed wording instead talks about a language that may
or may not be used in a media stream, which doesn't seem correct to me."

[BA] Yes, that is how it came across to me as well.

On Sat, Oct 14, 2017 at 5:00 AM, Randall Gellens <[email-masked]>
wrote:

>  In order to not create complicated sentences but still having the wording
>> match our intentions, I want to change the proposed resolution for Issue #
>> 46 Change 1 to:
>>
>>  ---Change 1 in 5.2, first paragraph----------------    ------old
>> text---------    This document defines two media-level attributes starting
>> with       'hlang' (short for "human interactive language") to negotiate
>> which       human language is selected for use in each interactive media
>> stream.    ------------new text--------------------    This document
>> defines two media-level attributes starting with       'hlang' (short for
>> "human interactive language") to negotiate which       human language is
>> selected for potential use in each media stream.
> The existing text is talking about which language is selected for use in a
> media stream should that media stream be used for interactive
> communication; the proposed wording instead talks about a language that may
> or may not be used in a media stream, which doesn't seem correct to me.
> Since we already have text (as noted earlier) that explicitly says that not
> all negotiated media streams need be used, I don't see a problem with
> leaving the text as is.
>
>
> --
> Randall Gellens

---

From: Gunnar Hellström <[email-masked]>
Date: Sat, 14 Oct 2017 23:47:03 +0200

I looked back to where we discussed this topic earlier.

It was on 1st of June this year.

At that time I proposed:

"This document defines two media-level attributes starting with
     'hlang' (short for "human interactive language") to negotiate which
     human language alternative(s) the users are prepared to use in each 
interactive media stream."

You (Randall) did not like "alternative(s)" and inserted instead the 
wording with "selected". But you missed to include "users are prepared 
to use" in the new version. Thereby it still looks as the users must use 
all languages the negotiation results in. You have agreed that that is 
not the intention. It is true that later paragraphs in 5.2 clarifies it, 
but I think it is important that also the first paragraph provides a 
true picture about what the negotiation is about.

It is the freedom to not use all negotiated languages that I want to 
have evident already from the first paragraph.

So, a new proposed wording for the sentence under discussion is:

"This document defines two media-level attributes starting with
     'hlang' (short for "human interactive language") to negotiate which
     human language the users are prepared to use in each interactive 
media stream.

If you want, you might fit in "selected" somewhere. The important fact 
is that already here we by the word "prepared" tell that they negotiate 
what they might use, and not what they must use.

OK?

Gunnar

Den 2017-10-14 kl. 19:52, skrev Bernard Aboba:
> Randall said:
>
> "The existing text is talking about which language is selected for use 
> in a media stream should that media stream be used for interactive 
> communication; the proposed wording instead talks about a language 
> that may or may not be used in a media stream, which doesn't seem 
> correct to me."
>
> On Sat, Oct 14, 2017 at 5:00 AM, Randall Gellens 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>          In order to not create complicated sentences but still having
>         the wording match our intentions, I want to change the
>         proposed resolution for Issue # 46 Change 1 to:
>
>         text---------    This document defines two media-level
>         attributes starting with       'hlang' (short for "human
>         interactive language") to negotiate which       human language
>         is selected for use in each interactive media stream.   
>         ------------new text--------------------    This document
>         defines two media-level attributes starting with       'hlang'
>         (short for "human interactive language") to negotiate which   
>          That matches the "if" in paragraph 3, and it is also valid
>         for both the offers and answers, while paragraph 3 is only for
>         the answer.
>          Please accept it, it is of importance for proper
>         understanding of our intentions.
>
>
>     The existing text is talking about which language is selected for
>     use in a media stream should that media stream be used for
>     interactive communication; the proposed wording instead talks
>     about a language that may or may not be used in a media stream,
>     which doesn't seem correct to me. Since we already have text (as
>     noted earlier) that explicitly says that not all negotiated media
>     streams need be used, I don't see a problem with leaving the text
>     as is.
>
>
>     -- 
>     Randall Gellens

---

From: Randall Gellens <[email-masked]>
Date: Sat, 14 Oct 2017 17:25:18 -0700

I really think the wording is fine as it is.  I don't see any 
implication that all streams will be used.  However, in an effort to 
move beyond what seems to me a silly argument, rather than try to 
come up with fancy wording that may say the wrong thing, we can 
simply ad a very clear and direct note.  I propose we add "(Note that 
not all streams will necessarily be used.)" to the text.  That is, we 
change the section from:

    This document defines two media-level attributes starting with
    'hlang' (short for "human interactive language") to negotiate which
    human language is selected for use in each interactive media stream.
    There are two attributes, one ending in "-send" and the other in
    "-recv", registered in Section 6.  Each can appear in offers and
    answers for media streams.

to:

    This document defines two media-level attributes starting with
    'hlang' (short for "human interactive language") to negotiate which
    human language is selected for use in each interactive media stream.
    (Note that not all streams will necessarily be used.)  There are two
    attributes, one ending in "-send" and the other in "-recv",
    registered in Section 6.  Each can appear in offers and answers for
    media streams.

-------------- Randomly selected tag: ---------------
Premature optimization is the root of all evil
                              --C. A. R. Hoare

---

From: Bernard Aboba <[email-masked]>
Date: Sat, 14 Oct 2017 20:35:43 -0700

Fine with me (though I agree it is not necessary).

> On Oct 14, 2017, at 5:25 PM, Randall Gellens <[email-masked]> wrote:
> 
> I really think the wording is fine as it is.  I don't see any implication that all streams will be used.  However, in an effort to move beyond what seems to me a silly argument, rather than try to come up with fancy wording that may say the wrong thing, we can simply ad a very clear and direct note.  I propose we add "(Note that not all streams will necessarily be used.)" to the text.  That is, we change the section from:
>

---

From: Randall Gellens <[email-masked]>
Date: Sat, 14 Oct 2017 23:53:05 -0700

-17 uploaded (with this change).

I think this closes all issues.

--Randall

At 8:35 PM -0700 10/14/17, Bernard Aboba wrote:

>> implication that all streams will be used.  However, in an effort 
>> to move beyond what seems to me a silly argument, rather than try 
>> to come up with fancy wording that may say the wrong thing, we can 
>> simply ad a very clear and direct note.  I propose we add "(Note 
>> that not all streams will necessarily be used.)" to the text. 
>> That is, we change the section from:
>>

-------------- Randomly selected tag: ---------------
Stolen Painting Found by Tree
--Newspaper headline