Subject: Re: [Slim] Simultaneity requirement in draft-ietf-slim-negotiating-human-language

From: Randall Gellens <[email-masked]>
Date: Fri, 13 Oct 2017 04:40:00 -0700

At 1:55 PM +0200 7/28/17, Gunnar Hellström wrote:

>  Rereading 
> draft-ietf-slim-negotiating-human-language-13, 
> I found a couple of minor issues. I bring them 
> up in separate mails.
>
>  1. The introduction says that we support 
> request of simultaneous text and voice, but 
> that is excluded from the protocol.

How can it be excluded?  This is supported by SIP 
and SDP.  An audio media stream plus a text media 
stream.

>
>  This is the sentence:
>
>  "Another example would be a user who is able to
>     speak but is deaf or hard-of-hearing and requires a voice stream plus
>     a text stream."
>
>  This looks as a need to specify that the user 
> wants to receive both voice and captions at the 
> same time,

I don't think it implies anything about captions. 
It says a voice stream plus a text stream.

>   but that is one of the requirements I have 
> tried to convince the group that we need, but 
> it has not been accepted. We have said that 
> specifying language in the same direction in 
> two media means that they are alternatives to 
> select from.
>
>  I suggest that the sentence is reworded to a 
> case that is supported by this change:
>  "Another example would be a user who is able to
>     speak but is deaf or hard-of-hearing and 
> requires to send spoken language in a voice 
> stream and receive
>     written language in a text stream."
>
>  /Gunnar
>
>
>  --
>  -----------------------------------------
>  Gunnar Hellström
>  Omnitor
>  [email-masked]
>
>  _______________________________________________
>  SLIM mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/slim

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
If there's a possibility that something might be controversial,
then why not eliminate it?
  --Wild Rose, Wis. district administrator, explaining why _Bury
  My Heart at Wounded Knee_ by Dee Brown was removed from schools.

---

From: Gunnar Hellström <[email-masked]>
Date: Fri, 13 Oct 2017 14:41:56 +0200

Den 2017-10-13 kl. 13:40, skrev Randall Gellens:
>>  Rereading draft-ietf-slim-negotiating-human-language-13, I found a 
>> couple of minor issues. I bring them up in separate mails.
>>
>>  1. The introduction says that we support request of simultaneous 
>> text and voice, but that is excluded from the protocol.
>
> How can it be excluded?  This is supported by SIP and SDP.  An audio 
> media stream plus a text media stream.
<GH> This is one of the shortcomings I have struggled all the time to 
get acceptance for to amend. We do not have any difference in specifying 
"I prefer strongly to receive both text and voice, both together are of 
value to me" vs "I can accept to receive either text or voice, or both 
if you want, you select."

The sentence in the intro indicated the first interpretation. Since we 
lack a way to differentiate that from the second, I prefer that we have 
a sentence aiming at the second interpretation. As seen at the end of 
this mail I have in the proposed edits made a slight change so that it 
aims at the second interpretation. I prefer to have that change made.

>>  This looks as a need to specify that the user wants to receive both 
>> voice and captions at the same time,
>
> I don't think it implies anything about captions. It says a voice 
> stream plus a text stream.

<GH> Right. Call it text then.   But the "plus" indicates simultaneity, 
and we have no way to indicate preference for simultaneity versus 
selection among alternatives.  That is why I have drafted 
draft-hellstrom-slim-modality-grouping-00
>
>>   but that is one of the requirements I have tried to convince the 
>> group that we need, but it has not been accepted. We have said that 
>> specifying language in the same direction in two media means that 
>> they are alternatives to select from.
>>
>>  I suggest that the sentence is reworded to a case that is supported 
>> by this change:
>>     speak but is deaf or hard-of-hearing and requires to send spoken 
>> language in a voice stream and receive
<GH>I still think this is needed to make the intro true.

+46 708 204 288

---

From: Randall Gellens <[email-masked]>
Date: Fri, 13 Oct 2017 19:20:22 -0700

Gunnar,

Your proposal is to change:

    and requires a voice stream plus
    a text stream

to:

    and requires a voice stream to send spoken language plus a text
    stream to receive written language

I don't have a problem with this change, but I don't see how it helps.

-------------- Randomly selected tag: ---------------
The last good thing written in C was Franz Schubert's Ninth Symphony.

---

From: Gunnar Hellström <[email-masked]>
Date: Sat, 14 Oct 2017 07:23:27 +0200

> I don't have a problem with this change, but I don't see how it helps.
<GH>The original wording can be read as if the streams would both be 
used for receiving language. The "plus" then tells me that both are 
provided simultaneously. Many users with low hearing prefer that. But we 
have no means to indicate that they are desired together.
This is in the introduction so we can take another example, and the 
change is about a case when the languages are used in different 
directions that the spec covers.

Gunnar