Subject: draft-ietf-smime-idea-04.txt: parameters question

From: William Whyte <[email-masked]>
Date: Thu, 25 May 2000 16:44:18 +0100

The IDEA in CMS draft specifies the parameters as follows:

  IDEA-CBCPar ::= SEQUENCE {
    IV  OCTET STRING OPTIONAL -- exactly 8 octets }

Is there a good reason for the SEQUENCE wrapping? We already 
have a CBCParameter structure defined in RFC 2630, and it
seems a shame to be inventing a slightly-differently-shaped
wheel.

Cheers,

William

---

From: Russ Housley <[email-masked]>
Date: Fri, 26 May 2000 14:33:20 -0400

I agree.  This was probably follows SKIPJACK.  In that case, they are 
including the SEQUENCE wrapper for compatibility with another 
environment.  Here, I am unaware of any compatibility requirement.

SKIPJACK uses:

         Skipjack-Parm ::= SEQUENCE { initialization-vector   OCTET STRING }

I suggest that IDEA should use:

         IDEA-CBC-IV ::=  OCTET STRING  -- must be 8 octets

Russ

P.S.  Authors, please consider this to be a Last Call comment.