Subject: Last Call: Use of the CAST-128 Encryption Algorithm in CMS to Proposed Standard

From: The IESG <[email-masked]>
Date: Fri, 16 Jun 2000 13:27:26 -0400

The IESG has received a request from the S/MIME Mail Security Working
Group to consider Use of the CAST-128 Encryption Algorithm in CMS
<draft-ietf-smime-cast-128-02.txt> as a Proposed Standard.

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action.  Please send any comments to the
[email-masked] or [email-masked] mailing lists by June 27, 2000.

Files can be obtained via
http://www.ietf.org/internet-drafts/draft-ietf-smime-cast-128-02.txt

---

From: "Blake Ramsdell" <[email-masked]>
Date: Mon, 19 Jun 2000 13:14:07 -0700

Two comments, don't know if they're major.

1. Section 3 does not list an SMIMECapability for key wrapping using IDEA,
only for symmetric encryption.  Don't know if that was intended.

2. I think that the example in section 3 should clarify that the
cast5CBCParameters are encoded with the iv omitted.

Blake

-----Original Message-----
From: The IESG [mailto:[email-masked]]
Sent: Friday, June 16, 2000 10:27 AM
Cc: [email-masked]
Subject: Last Call: Use of the CAST-128 Encryption Algorithm in CMS to
Proposed Standard

---

From: "Blake Ramsdell" <[email-masked]>
Date: Fri, 23 Jun 2000 13:14:46 -0700

So what's the difference between the CAST draft and the IDEA draft, then?
The IDEA draft specifies it, doesn't it?

Blake

-----Original Message-----
From: Jim Schaad [mailto:[email-masked]]
Sent: Friday, June 23, 2000 1:10 PM
To: Carlisle Adams; Blake Ramsdell
Cc: [email-masked]
Subject: RE: Last Call: Use of the CAST-128 Encryption Algorithm in CMS
to Proposed Standard

This is still my position.  If, for a D-H key, you make the statment that
CAST128 is supported as a bulk algorithm, then you must support the CAST128
wrap of CAST128 because that is the only way of doing it.

jim

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Carlisle Adams
> Sent: Tuesday, June 20, 2000 7:19 AM
> To: 'Blake Ramsdell'
> Cc: [email-masked]'
> Subject: RE: Last Call: Use of the CAST-128 Encryption Algorithm in CMS
> to Proposed Standard
>
>
> Hi Blake,
>
> Good to hear from you again!
>
> > ----------
> > From: 	Blake Ramsdell[SMTP:[email-masked]]
> > Sent: 	Monday, June 19, 2000 4:14 PM
> > To: 	[email-masked]'
> > Subject: 	RE: Last Call: Use of the CAST-128 Encryption Algorithm in
> > CMS to Proposed Standard
> >
> I suspect that you mean "CAST-128" above, rather than "IDEA"...
>
> In any case, I originally had both OIDs here (symm. encryption and key
> wrapping), but in a note posted on Nov. 18, 1999, Jim Schaad included the
> following comment:
>
> "2.  Section 3 Para 1.  You state that you must include the above OIDs in
> the symmetric algorithms section of capabilities, but only one of the oids
> is a symmetric algorithm.  At the
> current time we are "implying" the key wrap from the symmetric
> algorithm as
> only same key wrap is supported in CMS.  Please change to the correct OID
> reference."
>
> So, I took out the key wrap OID and left only the one for symmetric
> encryption.
>
> I guess it seemed clear to me that if you were only advertising your
> capabilities (in this case, symmetric algorithm and key length),
> an IV would
> be irrelevant and would therefore be omitted.  If you wish, however, I can
> add a sentence to this effect when the document has been approved
> and I get
> the 1-day window to send any tiny edits to the RFC editor.  Let me know if
> you really think this is necessary.
>
> Thanks for taking the time to look through this draft!
>
> Carlisle.
>
>