Subject: [Spasm] Review of draft-ietf-lamps-eai-addresses-00

From: Russ Housley <[email-masked]>
Date: Tue, 4 Oct 2016 15:44:44 -0400

I just read draft-ietf-lamps-eai-addresses-00, and I have a few comments.  I encourage others to read it and post their comments too.

Section 1 tells why an EAI cannot appear in a subjectAltName using the rfc822Name choice.  It should go on to say that this document specifies a way to carry EAI in otherName so that EAI can appear in a subjectAltName.  BTW, this also allows EAI to appear in issuerAltName.

Section 3, the first paragraph, should be restructured so that it is clear that smtputf8Name can appear as subjectAltName, issuerAltName, or anywhere else that GeneralName is used.  I suggest:

   The GeneralName structure is defined in [RFC5280], and it supports
   many different names forms.  GeneralName includes otherName for
   extensibility.  This section specifies the smtputf8Name name form,
   so that Internationalized Email addresses can appear in the
   subjectAltName of a certificate, the issuerAltName of a certificate,
   or anywhere else that GeneralName is used.

Section 3 says:

     smtputf8Name ::= UTF8String (SIZE (1..MAX))

The left hand side needs to begin with a capital letter.

In Section 5, please use allowed.example.com and excluded.example.com in Figure 1.

Please add an Appendix that contains the ASN.1 module.  It should contain:

The front matter for the module, including the IMPORTS for OTHER-NAME from RFC 5912.

 SmtpUtf8OtherNames OTHER-NAME ::= {
          on-smtputf8Name, … }

  on-smtputf8Name OTHER-NAME ::=
          { SmtpUtf8Name IDENTIFIED BY id-on-smtputf8Name }

   id-on-smtputf8Name OBJECT IDENTIFIER ::= { id-on XXX }

   SmtpUtf8Name ::= UTF8String (SIZE (1..MAX))

  END

---

From: Wei Chuang <[email-masked]>
Date: Thu, 6 Oct 2016 09:05:39 -0700

Russ,

Thanks for the feedback.  We can start a 01 draft to capture these changes.

-Wei

On Tue, Oct 4, 2016 at 12:44 PM, Russ Housley <[email-masked]> wrote:

> I just read draft-ietf-lamps-eai-addresses-00, and I have a few
> comments.  I encourage others to read it and post their comments too.
>
>
> Section 1 tells why an EAI cannot appear in a subjectAltName using the
> rfc822Name choice.  It should go on to say that this document specifies a
> way to carry EAI in otherName so that EAI can appear in a subjectAltName.
> BTW, this also allows EAI to appear in issuerAltName.
>
>
> Section 3, the first paragraph, should be restructured so that it is clear
> that smtputf8Name can appear as subjectAltName, issuerAltName, or anywhere
> else that GeneralName is used.  I suggest:
>
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm
>

---

From: Wei Chuang <[email-masked]>
Date: Thu, 27 Oct 2016 17:15:47 -0700

Russ:

> BTW, this also allows EAI to appear in issuerAltName.

Just double checking- Are you strongly in favor of EAI in issuerAltName?

-Wei

---

From: Russ Housley <[email-masked]>
Date: Thu, 27 Oct 2016 22:35:51 -0400

> Just double checking- Are you strongly in favor of EAI in issuerAltName?

Yes, I think that it should be supported in subjectAltName and issuerAltName.

Russ