Subject: Re: [Spasm] WG Last Call for draft-ietf-lamps-eai-addresses-02

From: Russ Housley <[email-masked]>
Date: Mon, 5 Dec 2016 12:01:20 -0500

There has only been one comment on the document so far.  WG Last Call ends on Friday.  Please review and post comments to the list.  And, if you think the document is ready, please say so.

Russ

On Nov 18, 2016, at 3:07 AM, Russ Housley <[email-masked]> wrote:

> This is the LAMPS WG Last Call for "Internationalized Email Addresses in X.509 Certificates” <draft-ietf-lamps-eai-addresses-02>.  Please review the document and send your comments to the list by 9 December 2016. 
> 
> Thanks,
> Russ

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 5 Dec 2016 19:56:24 +0000

I think it's fine, ready.

---

From: Jim Schaad <[email-masked]>
Date: Mon, 5 Dec 2016 15:09:07 -0800

The document is ready to go.  Here are a few random comments.

1.  For camel case convention, should it be smtpUtf8Name rather than
smptutf8Name?  I realize that you got the name from the ABNF rule so this is
a weak suggestion at best.

2.  The following sentence has me lost:

While some contexts such as certificate path validation in [RFC5280] specify
transforming to A-label, this document RECOMMENDS transforming to UTF-8
U-label even in place of those other specifications.

Specifically, the phrase "even in place of".   I think this is just a bad
grammar world.

3.  The example in figure 1 does not work correctly.  The excluded would be
ignored as it is not a subset of the permitted names and therefor the name
\u4E0D\[email-masked] is rejected as not being permitted.  You
probably want to change this to excluding "ignored.allowed.example.com".

4.  Section 6 - It would be reasonable to also indicate that it might take a
while to get take up on this while rfc822Name support is already existing.

5.  As previously noted, the ASN.1 module should be updated.

Jim

Typos & Grammar
s/fascilitate/facilitate/
s/In particular </In particular, </
s/Also sub-/Also, sub-/
s/U-label domain/U-label domains/
s/process process/process/
s/constaints/constraints/

I wanted to stick in lots of missing commas, but I will leave that for the
RFC Editor.

---

From: Sean Turner <[email-masked]>
Date: Tue, 6 Dec 2016 10:33:57 -0500

I reviewed the -00 version.  The resulting discussion and the revisions included in -01 resolved the issues I raised.  -02 just included the OIDs assigned by the designated expert.  I think this one is ready to be shipped to our AD.

spt

---

From: Wei Chuang <[email-masked]>
Date: Tue, 6 Dec 2016 17:03:50 -0800

Quick question:

> while to get take up on this while rfc822Name support is already existing.

Can you clarify what text is desired here?  i.e. what should the reader
should do?

-Wei

> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm
>

---

From: Jim Schaad <[email-masked]>
Date: Tue, 6 Dec 2016 17:55:48 -0800

From: Spasm [mailto:[email-masked]] On Behalf Of Wei Chuang
Sent: Tuesday, December 06, 2016 5:04 PM
To: Jim Schaad <[email-masked]>
Cc: SPASM <[email-masked]>; Russ Housley <[email-masked]>
Subject: Re: [Spasm] WG Last Call for draft-ietf-lamps-eai-addresses-02

Quick question:

On Mon, Dec 5, 2016 at 3:09 PM, Jim Schaad <[email-masked] <mailto:[email-masked]> > wrote:

3.  The example in figure 1 does not work correctly.  The excluded would be
ignored as it is not a subset of the permitted names and therefor the name
\u4E0D\[email-masked] <mailto:[email-masked]>  is rejected as not being permitted.  You
probably want to change this to excluding "ignored.allowed.example.com <http://ignored.allowed.example.com> ".

Can you clarify what text is desired here?  i.e. what should the reader should do?

[JLS] Looking at a sentence along the lines of “The use of rfc822Name rather than smtputf8Name is currently more likely to be supported.” Prior to the last sentence.

Looking at this more, I think that this might actually fit better into an implementation or deployment considerations rather than resource considerations.  

Looking at this section deeper, is this really a true statement?  What is the difference in terms of using a U-label rather than an A-label, does that change the resource consideration for pure ascii local-parts but with non-ascii server names?

-Wei

Jim

Typos & Grammar

_______________________________________________
Spasm mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/spasm

---

From: Wei Chuang <[email-masked]>
Date: Wed, 7 Dec 2016 09:54:18 -0800

On Tue, Dec 6, 2016 at 5:55 PM, Jim Schaad <[email-masked]> wrote:

>
>
>
>
> *From:* Spasm [mailto:[email-masked]] *On Behalf Of *Wei Chuang
> *Sent:* Tuesday, December 06, 2016 5:04 PM
> *To:* Jim Schaad <[email-masked]>
> *Cc:* SPASM <[email-masked]>; Russ Housley <[email-masked]>
> *Subject:* Re: [Spasm] WG Last Call for draft-ietf-lamps-eai-addresses-02
>
>
>
>
> [JLS] Looking at a sentence along the lines of “The use of rfc822Name
> rather than smtputf8Name is currently more likely to be supported.” Prior
> to the last sentence.
>

Got it.

>
>
> Looking at this more, I think that this might actually fit better into an
> implementation or deployment considerations rather than resource
> considerations.
>

How about making that section a deployment consideration then.

>
>
> Looking at this section deeper, is this really a true statement?  What is
> the difference in terms of using a U-label rather than an A-label, does
> that change the resource consideration for pure ascii local-parts but with
> non-ascii server names?
>

I see your point.  I can add a sentence mentioning that consideration as
well.

-Wei

---

From: Russ Housley <[email-masked]>
Date: Mon, 19 Dec 2016 16:59:31 -0500

Jim:

Please confirm that the most recent version resolves your concerns.  Wei posted a message saying how he intended to address your concerns, but I have not seen a message from you that they satisfy you.

Russ

---

From: Russ Housley <[email-masked]>
Date: Mon, 19 Dec 2016 18:09:16 -0500

> a weak suggestion at best.
Wei:

Jim made the above comment, and you were a bit to aggressive in trying to comply, and the ASN.1 module no longer compiles.  In ASN.1, type definitions are required to begin with a capital letter.  A single letter needs to be changed to resolve it.

In Appendix A:

OLD:

        smtpUtf8Name IDENTIFIED BY id-on-smtpUtf8Name

NEW:

        SmtpUtf8Name IDENTIFIED BY id-on-smtpUtf8Name

Further down in the module, this type is (correctly) defined.  It says:

    SmtpUtf8Name ::= UTF8String (SIZE (1..MAX))

A similar line appears in Section 3, but the case is incorrect.  Please make it match the ASN.1 module.

There are a whole bunch of places in the document where you talk about this type.  They also need to begin with a Capital letter.

Russ

---

From: Jim Schaad <[email-masked]>
Date: Mon, 19 Dec 2016 17:32:51 -0800

This seems reasonable.

From: Wei Chuang [mailto:[email-masked]] 
Sent: Wednesday, December 07, 2016 9:54 AM
To: Jim Schaad <[email-masked]>
Cc: SPASM <[email-masked]>; Russ Housley <[email-masked]>
Subject: Re: [Spasm] WG Last Call for draft-ietf-lamps-eai-addresses-02

On Tue, Dec 6, 2016 at 5:55 PM, Jim Schaad <[email-masked] <mailto:[email-masked]> > wrote:

From: Spasm [mailto:[email-masked] <mailto:[email-masked]> ] On Behalf Of Wei Chuang
Sent: Tuesday, December 06, 2016 5:04 PM
To: Jim Schaad <[email-masked] <mailto:[email-masked]> >
Cc: SPASM <[email-masked] <mailto:[email-masked]> >; Russ Housley <[email-masked] <mailto:[email-masked]> >
Subject: Re: [Spasm] WG Last Call for draft-ietf-lamps-eai-addresses-02

Got it.

 

 

I see your point.  I can add a sentence mentioning that consideration as well.

-Wei