Subject: [lamps] Adam Roach's Yes on draft-ietf-lamps-eai-addresses-15: (with COMMENT)

From: Adam Roach <[email-masked]>
Date: Tue, 09 Jan 2018 21:02:54 -0800

Adam Roach has entered the following ballot position for
draft-ietf-lamps-eai-addresses-15: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lamps-eai-addresses/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks for your work on this document. One thing I noticed is that the name for
what I presume is an early registration at IANA ("id-on-smtputf8Name") varies
from the final name used in this document ("id-on-smtputf8Mailbox"). I would
ask the authors and shepherd to please carefully review the final IANA
registrations upon document approval to ensure this is updated appropriately.

---

From: Russ Housley <[email-masked]>
Date: Wed, 10 Jan 2018 11:00:28 -0500

https://www.iana.org/assignments/smi-numbers/smi-numbers.xhtml#smi-numbers-1.3.6.1.5.5.7.8

At this point, the entry is already in the IANA registry.  I wonder if it is worth the confusion to change it.

Russ

---

From: Adam Roach <[email-masked]>
Date: Wed, 10 Jan 2018 10:08:10 -0600

> At this point, the entry is already in the IANA registry.  I wonder if it is worth the confusion to change it.

This one is, but the entry in "SMI Security for PKIX Module Identifier" 
is not. By my reading, the IANA actions for this document have not yet 
been performed.

I mean, if you want to change the document in the RFC to be 
"id-on-smtputf8Name", I don't see a problem with that either -- but I 
presume it was changed from "Name" to "Mailbox" for some reason, and 
Alexey would need to evaluate whether a change back would be a reversion 
of WG consensus.

/a

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 10 Jan 2018 16:09:48 +0000

Hi,

> At this point, the entry is already in the IANA registry.  I wonder if it is worth the confusion to change it.
If I understood Adam correctly, he is just asking for the label to be 
updated in the registry. That shouldn't be a big deal, right?

Best Regards,
Alexey

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 10 Jan 2018 16:12:11 +0000

Hi Adam,

On 10/01/2018 16:08, Adam Roach wrote:
>> At this point, the entry is already in the IANA registry.  I wonder 
>> if it is worth the confusion to change it.
>>
>> Russ
>>
>
> This one is, but the entry in "SMI Security for PKIX Module 
> Identifier" is not. By my reading, the IANA actions for this document 
> have not yet been performed.
>
> presume it was changed from "Name" to "Mailbox" for some reason,
This was done based on Ekr's review, as he found the difference 
confusing (I agree it was). These labels should only be used in 
documentation, I don't think they affect anything on the wire. For 
example OID is going to be encoded the same either way.

> and Alexey would need to evaluate whether a change back would be a 
> reversion of WG consensus.

I am happy to hear otherwise, but I think this is not a big deal either way.

---

From: Russ Housley <[email-masked]>
Date: Wed, 10 Jan 2018 16:17:43 -0500

> On Jan 10, 2018, at 11:08 AM, Adam Roach <[email-masked]> wrote:
> 
> This one is, but the entry in "SMI Security for PKIX Module Identifier" is not. By my reading, the IANA actions for this document have not yet been performed.

Sorry.  I misunderstood which object identifier you meant.

> I mean, if you want to change the document in the RFC to be "id-on-smtputf8Name", I don't see a problem with that either -- but I presume it was changed from "Name" to "Mailbox" for some reason, and Alexey would need to evaluate whether a change back would be a reversion of WG consensus.

The document current asks for the module object identifier to be id-mod-lamps-eai-addresses-2016, and it has been that way since draft-ietf-lamps-eai-addresses-02, but I have not objection to a change.

How about?

  LAMPS-SmtpUTF8Mailbox-2018
    { iso(1) identified-organization(3) dod(6)
      internet(1) security(5) mechanisms(5) pkix(7) id-mod(0)
      id-mod-lamps-SmtpUTF8Mailbox-2018(TBD) }

Do we need a new Internet-Draft of an RFC Ed note?

Russ

---

From: Adam Roach <[email-masked]>
Date: Wed, 10 Jan 2018 15:22:13 -0600

> Sorry.  I misunderstood which object identifier you meant.

You didn't -- you were right the first time. The mismatch I'm pointing 
to is the entry in the 1.3.6.1.5.5.7.8 table versus the value in the 
document. The only reason I mention the *other* table is to demonstrate 
that IANA has not done its final processing on this document, during 
which I expect IANA to fix the name in the 1.3.6.1.5.5.7.8 table. My 
comment was simply asking you to double-check that they do that correctly.

/a

---

From: Russ Housley <[email-masked]>
Date: Wed, 10 Jan 2018 16:52:54 -0500

> On Jan 10, 2018, at 4:22 PM, Adam Roach <[email-masked]> wrote:
> 
> You didn't -- you were right the first time. The mismatch I'm pointing to is the entry in the 1.3.6.1.5.5.7.8 table versus the value in the document. The only reason I mention the *other* table is to demonstrate that IANA has not done its final processing on this document, during which I expect IANA to fix the name in the 1.3.6.1.5.5.7.8 table. My comment was simply asking you to double-check that they do that correctly.

Good catch.  I suggest the following temporary text for the IANA Considerations section:

OLD

      The SmtpUTF8Mailbox otherName in the "PKIX Other Name Forms"
      registry (1.3.6.1.5.5.7.8).

NEW

      The SmtpUTF8Mailbox otherName in the "PKIX Other Name Forms"
      registry (1.3.6.1.5.5.7.8).

      {{ Note to IANA:  id-on-smtputf8Name was assigned based on an
      earlier version of this document.  Please change that entry to
      id-on-SmtpUTF8Mailbox. }}

Russ

---

From: Adam Roach <[email-masked]>
Date: Wed, 10 Jan 2018 15:58:22 -0600

>        id-on-SmtpUTF8Mailbox. }}

Perfect. Thanks!

/a