Subject: [lamps] Ben Campbell's Discuss on draft-ietf-lamps-eai-addresses-15: (with DISCUSS and COMMENT)

From: Ben Campbell <[email-masked]>
Date: Tue, 09 Jan 2018 19:51:04 -0800

Ben Campbell has entered the following ballot position for
draft-ietf-lamps-eai-addresses-15: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lamps-eai-addresses/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

This should be easy to resolve, after which I plan to ballot "yes":

It seems like this needs to update at least RFC 5280. Section 4 creates what I
assume to be a new requirement for all email address domains in X.509
certificates to conform to IDNA2008. That seems like a reasonable requirement,
but if we want people reading 5280 to know about that requirement, we need the
"updates" relationship.

Also, section explicitly says it updates a section of 5280.

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Editorial Comments and Nits:

- section 3:
--  Please proofread section 3 for missing articles.
-- please consider reformulating " ... subjectAltName MUST only be used when
..." in the form of "... MUST NOT be used unless..."  (MUST ONLY can be
ambiguous about whether you mean "MUST NOT unless" or "MUST do this and nothing
else.")

- 4: "... (and avoids any "mappings" mentioned in that document)"
s/avoids/avoid

---

From: Russ Housley <[email-masked]>
Date: Wed, 10 Jan 2018 11:03:24 -0500

Please see draft-ietf-lamps-rfc5280-i18n-update, which is already in the RFC Editor's queue waiting for this document to catch up.

Russ

---

From: Ben Campbell <[email-masked]>
Date: Wed, 10 Jan 2018 11:00:50 -0600

> On Jan 10, 2018, at 10:03 AM, Russ Housley <[email-masked]> wrote:
> 

I assume that your point is that both of these updates are already in draft-ietf-lamps-rfc5280-i18n-update?

If so, then perhaps the language in section 1, 4, and 6 should be updated to indicate that draft-ietf-lamps-rfc5280-i18n-update makes those updates, rather than this document?

Thanks!

Ben.

---

From: Russ Housley <[email-masked]>
Date: Wed, 10 Jan 2018 15:55:32 -0500

> On Jan 10, 2018, at 12:00 PM, Ben Campbell <[email-masked]> wrote:
> 

There were multiple internationalization updates needed to RFC 5280.  You will see that draft-ietf-lamps-rfc5280-i18n-update includes things that are  related to IDNA2008 and also points to this document for EAI.  Of course, this document is a normative reference.  I do not think a reader will be confused.

> If so, then perhaps the language in section 1, 4, and 6 should be updated to indicate that draft-ietf-lamps-rfc5280-i18n-update makes those updates, rather than this document?

I am not opposed to a note, but I think that putting it in three places would be overkill.

Russ

---

From: Ben Campbell <[email-masked]>
Date: Wed, 10 Jan 2018 14:59:09 -0600

> On Jan 10, 2018, at 2:55 PM, Russ Housley <[email-masked]> wrote:
> 
> 

I don’t think it needs 3 notes to say these things are done in draft-ietf-lamps-rfc5280-i18n-update. But it probably should avoid text that suggests the update is done by _this_ draft. That currently occurs in at least those 3 places.

I will clear my discuss based on the updates already existing in draft-ietf-lamps-rfc5280-i18n-update. But I’d still like to see the clarification.

Thanks!

Ben.

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 11 Jan 2018 14:43:27 +0000

Hi Ben,
I just reread section 4 and 6 of draft-ietf-lamps-eai-addresses-15. They define extra requirements which are incorporated by reference into draft-ietf-lamps-rfc5280-i18n-update-04. So this makes me think that draft-ietf-lamps-eai-addresses-15 should also say "Updates: 5280". I think this would be the easiest change.

Either way, I don't think readers of draft-ietf-lamps-rfc5280-i18n-update-04 will be confused (whether they find it through Updates: 5280 header or directly), because draft-ietf-lamps-eai-addresses-15 is a normative reference.

On Wed, Jan 10, 2018, at 5:00 PM, Ben Campbell wrote:
> If so, then perhaps the language in section 1, 4, and 6 should be 
> updated to indicate that draft-ietf-lamps-rfc5280-i18n-update makes 
> those updates, rather than this document?

---

From: Ben Campbell <[email-masked]>
Date: Thu, 11 Jan 2018 08:59:51 -0600

> On Jan 11, 2018, at 8:43 AM, Alexey Melnikov <[email-masked]> wrote:
> 
> Hi Ben,

I agree that if there are updates in *-addresses that are not in *-updates that *-addresses should also update 5280.
> Either way, I don't think readers of draft-ietf-lamps-rfc5280-i18n-update-04 will be confused (whether they find it through Updates: 5280 header or directly), because draft-ietf-lamps-eai-addresses…

I could see an argument that the updates tag in *-updates covers everything, but I think that connection is tenuous that people will likely miss it.