Subject: [lamps] CAA Semantics for S/MIME

From: Wayne Thayer <[email-masked]>
Date: Wed, 16 May 2018 01:00:11 +0000

There is a vigorous discussion about CAA and S/MIME certificates happening
over on the mozilla.dev.security.policy list [1]. It has been proposed that
this issue could be addressed as part of rfc6844bis, but I'm reading the
LAMPS recharter as being too narrow in scope to permit this. Does this work
need to be deferred to a future LAMPS recharter?

- Wayne

[1]
https://groups.google.com/d/msg/mozilla.dev.security.policy/NIc2Nwa9Msg/RGx4A5HBBAAJ

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 15 May 2018 21:23:52 -0400

I think the work would need to be deferred because it will take us a little
while to work out what to do....

But I have changed my mind on this. There is definitely a role for CAA in
client cert issue. I would strongly recommend a different tag but there is
certainly a role there.

On Tue, May 15, 2018 at 9:00 PM, Wayne Thayer <[email-masked]> wrote:

> [1] https://groups.google.com/d/msg/mozilla.dev.security.
> policy/NIc2Nwa9Msg/RGx4A5HBBAAJ
>
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm
>
>

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 18 May 2018 10:45:07 -0700

I agree that this is out of the proposed charter. If the WG wants to add it
as a charter item now, that seems fine.

-Ekr

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 18 May 2018 23:24:05 -0400

Perhaps we could have a side discussion about this at the London CABForum
meeting if folk are there.

On Fri, May 18, 2018 at 1:45 PM, Eric Rescorla <[email-masked]> wrote:

> I agree that this is out of the proposed charter. If the WG wants to add
> it as a charter item now, that seems fine.
>
> -Ekr
>
>
>> There is a vigorous discussion about CAA and S/MIME certificates
>> happening over on the mozilla.dev.security.policy list [1]. It has been
>> proposed that this issue could be addressed as part of rfc6844bis, but I'm
>> reading the LAMPS recharter as being too narrow in scope to permit this.
>> Does this work need to be deferred to a future LAMPS recharter?
>>
>> - Wayne
>>
>> [1] https://groups.google.com/d/msg/mozilla.dev.security.policy/
>> NIc2Nwa9Msg/RGx4A5HBBAAJ
>>

---

From: Ryan Sleevi <[email-masked]>
Date: Sat, 19 May 2018 00:03:28 -0400

Seems like it would be better discussed in a place with open access and
participation? To avoid capture by CAs by having a diverse set of views
represented?

---

From: Tim Hollebeek <[email-masked]>
Date: Wed, 23 May 2018 16:50:45 +0000

(chair hat off)

The charter issue seems to me like a simple enough issue that we should be able to resolve it here on the list.  I was actually the one who suggested it should be handled in 6844bis over on m.d.s-p, and was surprised when Wayne correctly pointed out it is out of scope.  I think we should take this opportunity to fix the charter to include it.  This seems like the most appropriate forum for that work.  It doesn’t smell like a CABF thing.  Though coordination would be useful so we produce something they can easily consume.

-Tim

From: Spasm [mailto:[email-masked]] On Behalf Of Ryan Sleevi
Sent: Saturday, May 19, 2018 12:03 AM
To: Phillip Hallam-Baker <[email-masked]>
Cc: SPASM <[email-masked]>; Eric Rescorla <[email-masked]>; Wayne Thayer <[email-masked]>
Subject: Re: [lamps] CAA Semantics for S/MIME

Seems like it would be better discussed in a place with open access and participation? To avoid capture by CAs by having a diverse set of views represented?

On Fri, May 18, 2018 at 11:24 PM Phillip Hallam-Baker <[email-masked] <mailto:[email-masked]> > wrote:

Perhaps we could have a side discussion about this at the London CABForum meeting if folk are there.

On Fri, May 18, 2018 at 1:45 PM, Eric Rescorla <[email-masked] <mailto:[email-masked]> > wrote:

I agree that this is out of the proposed charter. If the WG wants to add it as a charter item now, that seems fine.

-Ekr

On Tue, May 15, 2018 at 6:00 PM, Wayne Thayer <[email-masked] <mailto:[email-masked]> > wrote:

There is a vigorous discussion about CAA and S/MIME certificates happening over on the mozilla.dev.security.policy list [1]. It has been proposed that this issue could be addressed as part of rfc6844bis, but I'm reading the LAMPS recharter as being too narrow in scope to permit this. Does this work need to be deferred to a future LAMPS recharter?

- Wayne

[1] https://groups.google.com/d/msg/mozilla.dev.security.policy/NIc2Nwa9Msg/RGx4A5HBBAAJ

_______________________________________________
Spasm mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/spasm

_______________________________________________
Spasm mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/spasm

_______________________________________________
Spasm mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/spasm