Subject: [lamps] Adam Roach's Yes on draft-ietf-lamps-rfc5751-bis-10: (with COMMENT)

From: Adam Roach <[email-masked]>
Date: Mon, 02 Jul 2018 13:52:37 -0700

Adam Roach has entered the following ballot position for
draft-ietf-lamps-rfc5751-bis-10: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lamps-rfc5751-bis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks to everyone who put work into updating this document. I have one comment
that is either substantive or me just being confused, and several editorial
nits.

---------------------------------------------------------------------------

§3.5.3.2:

>  The values to be placed in the micalg parameter SHOULD be from the
>  following:
>
>   Algorithm Value Used
>   MD5       md5
>   SHA-1     sha-1
>   SHA-224   sha-224
>   SHA-256   sha-256
>   SHA-384   sha-384
>   SHA-512   sha-512
>   Any other (defined separately in algorithm profile or "unknown" if
>             not defined)

The example then goes on to demonstrate the use of "micalg=sha-1".  This is
probably a misunderstanding on my part, but I thought that this document was
intending to mark MD5 and SHA-1 as historic for digesting content (cf. §1.7
and §B.1). Wouldn't that mean they should be annotated as deprecated in some
way here? I would have also expected the example to use sha-256 or sha-512.

---------------------------------------------------------------------------

§2.2:

>  -  .  SHOULD support RSASSA-PSS with SHA-256.

There appears to be an extra "." at the beginning of this bullet

---------------------------------------------------------------------------

§3.1:

>  S/MIME is used to secure MIME entities.  A MIME message is composed
>  of a MIME header and a MIME body, the body can consist of a single
>  part or of multiple parts.

Nit: "...MIME body. The body can..."

---------------------------------------------------------------------------

§3.3:

>  The
>  Enveloped-Only structure does not support authenticated symmetric
>  algorithms, use the .Authenticated Enveloped structure for these
>  algorithms.

Two nits: "...symmetric algorithms. Use the Authenticated..."
                                  ^        ^
---------------------------------------------------------------------------

§6:

>  S/MIME implementations almost universally use ephemeral-static rather
>  than static-static key agreement and do not use a shared secret for
>  encryption, this means that the first precondition is not met.

Nit: "...encryption. This means..."

---

From: Jim Schaad <[email-masked]>
Date: Tue, 3 Jul 2018 08:27:24 -0700

> -----Original Message-----
> From: Adam Roach <[email-masked]>
> Sent: Monday, July 2, 2018 1:53 PM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Russ Housley
> <[email-masked]>; [email-masked]; [email-masked];
> [email-masked]
> Subject: Adam Roach's Yes on draft-ietf-lamps-rfc5751-bis-10: (with
> COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> Thanks to everyone who put work into updating this document. I have one
> comment that is either substantive or me just being confused, and several
> editorial nits.
> 
> probably a misunderstanding on my part, but I thought that this document
> was intending to mark MD5 and SHA-1 as historic for digesting content (cf.
> §1.7 and §B.1). Wouldn't that mean they should be annotated as deprecated
> in some way here? I would have also expected the example to use sha-256
> or sha-512.

In terms of the content of the table, this table is the only registry that exists for the values to be placed here.  This means that I have not removed any of the "historical" values as I believe that they need to be part of the table.  In terms of the following example, it is one of the examples that I did not re-generate as part of this document and thus is still setup with a micalg of sha-1.  While I could re-generate this example, it is correct as it is and has been validated.  I cannot have that same assurance if it is replaced.

Fixed

Fixed

Fixed, but hard to figure out for non-monospaced fonts.

Fixed

---

From: Adam Roach <[email-masked]>
Date: Tue, 3 Jul 2018 11:10:19 -0500

Jim --

Thanks for the quick response. Comments inline.

On 7/3/18 10:27 AM, Jim Schaad wrote:
> In terms of the content of the table, this table is the only registry that exists for the values to be placed here.  This means that I have not removed any of the "historical" values as I believe that they need to be part of the table.

Sure; I didn't expect to see them removed. I expected them to be 
annotated in some way; something like:

   Algorithm Value Used
   MD5*      md5
   SHA-1*    sha-1
   SHA-224   sha-224
   SHA-256   sha-256
   SHA-384   sha-384
   SHA-512   sha-512

   *Note: MD5 and SHA-1 are historic and no longer considered secure.
    See section B.1 for details.

>    In terms of the following example, it is one of the examples that I did not re-generate as part of this document and thus is still setup with a micalg of sha-1.  While I could re-generate this example, it is correct as it is and has been validated.  I cannot have that same assurance if it is replaced.

I have a lot of sympathy for the challenges involved with generating 
correct examples. At the same time, I think it's  problematic to publish 
a document that deprecates an algorithm while simultaneously 
demonstrating its use. On the balance between these two factors, I think 
this document really needs to be updated so that the examples are 
consistent with the text.

/a

---

From: Jim Schaad <[email-masked]>
Date: Tue, 3 Jul 2018 09:43:36 -0700

> Sent: Tuesday, July 3, 2018 9:10 AM
> To: Jim Schaad <[email-masked]>; 'The IESG' <[email-masked]>
> Cc: [email-masked]; 'Russ Housley'
> <[email-masked]>; [email-masked]; [email-masked]
> Subject: Re: Adam Roach's Yes on draft-ietf-lamps-rfc5751-bis-10: (with
> COMMENT)
> 
> Jim --
> 
> >> The example then goes on to demonstrate the use of "micalg=sha-1".
> >> This is probably a misunderstanding on my part, but I thought that
> >> this document was intending to mark MD5 and SHA-1 as historic for
> digesting content (cf.
> >> §1.7 and §B.1). Wouldn't that mean they should be annotated as
> >> deprecated in some way here? I would have also expected the example
> >> to use sha-256 or sha-512.
> > In terms of the content of the table, this table is the only registry that exists
> for the values to be placed here.  This means that I have not removed any of
> the "historical" values as I believe that they need to be part of the table.
> 
> Sure; I didn't expect to see them removed. I expected them to be annotated
> in some way; something like:
> 
> 
>    Algorithm Value Used
>    MD5*      md5
>    SHA-1*    sha-1
>    SHA-224   sha-224
>    SHA-256   sha-256
>    SHA-384   sha-384
>    SHA-512   sha-512

That makes sense.  Done

> 
> >    In terms of the following example, it is one of the examples that I did not
> re-generate as part of this document and thus is still setup with a micalg of
> sha-1.  While I could re-generate this example, it is correct as it is and has
> been validated.  I cannot have that same assurance if it is replaced.
> 

Ok - I will put this on my list.  It is not a simple think to do.