Subject: [lamps] Call for adoption of draft-housley-cms-mts-hash-sig

From: Tim Hollebeek <[email-masked]>
Date: Sat, 14 Jul 2018 16:03:10 +0000

The recently approved LAMPS WG Charter adds this work item:

5. Specify the use of hash-based signatures with the Cryptographic Message
Syntax (CMS).  Hash-based signature use small private and public keys, and
they have low computational cost; however, the signature values are quite
large.  For this reason they might not be used for signing X.509
certificates or S/MIME messages; however, sine hash-based signature
algorithms are secure even if a large-scale quantum computer is invented.
The low computational cost for signature verification makes hash-based
signatures attractive in the Internet of Things environments, and the
quantum resistance makes them attractive for the distribution of software
updates.

It has been suggested that the WG adopt draft-housley-cms-mts-hash-sig as
the starting point for this work.  Since Russ Housley is the author of this
draft, Tim Hollebeek will judge consensus for this discussion.  Please voice
your support or concerns on the list.

---

From: "Dr. Pala" <[email-masked]>
Date: Tue, 17 Jul 2018 09:15:32 -0600

I support the adoption of this draft.

On 7/14/18 10:03 AM, Tim Hollebeek wrote:
> 5. Specify the use of hash-based signatures with the Cryptographic
> Message Syntax (CMS).  Hash-based signature use small private and
> public keys, and they have low computational cost; however, the
> signature values are quite large.  For this reason they might not be
> used for signing X.509 certificates or S/MIME messages; however, sine
> hash-based signature algorithms are secure even if a large-scale
> quantum computer is invented.  The low computational cost for
> signature verification makes hash-based signatures attractive in the
> Internet of Things environments, and the quantum resistance makes them
> attractive for the distribution of software updates.
>
>  
>
> It has been suggested that the WG adopt draft-housley-cms-mts-hash-sig
> as the starting point for this work.  Since Russ Housley is the author
> of this draft, Tim Hollebeek will judge consensus for this
> discussion.  Please voice your support or concerns on the list.
>

-- 
Best Regards,
Massimiliano Pala, Ph.D.
OpenCA Labs Director
OpenCA Logo

---

From: Sean Leonard <[email-masked]>
Date: Thu, 19 Jul 2018 15:17:48 -0400

Substantively: good start and therefore I support adoption of this draft.

Typo: s/sine/since

Sean

> On Jul 14, 2018, at 12:03 PM, Tim Hollebeek <[email-masked]> wrote:
> 
> 5. Specify the use of hash-based signatures with the Cryptographic Message Syntax (CMS).  Hash-based signature use small private and public keys, and they have low computational cost; however, the signature values are quite large.  For this reason they might not be used for signing X.509 certificates or S/MIME messages; however, sine hash-based signature algorithms are secure even if a large-scale quantum computer is invented.  The low computational cost for signature verification makes hash-based signatures attractive in the Internet of Things environments, and the quantum resistance makes them attractive for the distribution of software updates.
> 
>  
> 
> It has been suggested that the WG adopt draft-housley-cms-mts-hash-sig as the starting point for this work.  Since Russ Housley is the author of this draft, Tim Hollebeek will judge consensus for this discussion.  Please voice your support or concerns on the list.
> 
>  
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm

---

From: Sean Turner <[email-masked]>
Date: Thu, 19 Jul 2018 15:43:18 -0400

> On Jul 14, 2018, at 12:03, Tim Hollebeek <[email-masked]> wrote:
> 

Support adoption will review.

spt