Subject: Re: [lamps] Call for adoption of draft-housley-hash-of-root-key-cert-extn

From: "Salz, Rich" <[email-masked]>
Date: Sat, 14 Jul 2018 16:18:03 +0000

>It has been suggested that the WG adopt draft-housley-hash-of-root-key-cert-extn as the starting point for this work.

SET did this for their root a long time ago.  Maybe re-use the OID?

At any rate, I support this.

---

From: Russ Housley <[email-masked]>
Date: Sat, 14 Jul 2018 14:28:15 -0400

Rich:

Thanks for the support.

> At any rate, I support this.

I looked at this, and they used a cumbersome syntax.

hashedRootKey EXTENSION ::= {               -- Only in root certificates
   SYNTAX         HashedRootKeySyntax
   CRITICAL       TRUE
   IDENTIFIED BY id-set-hashedRootKey
}

HashedRootKeySyntax ::= RootKeyThumb

RootKeyThumb ::= SEQUENCE {
   rootKeyThumbprint  DD { SubjectPublicKeyInfo{{SupportedAlgorithms}} }
}

Where DD expands to a CMS DigestedData.

I think you will find the syntax in the Internet-Draft much more straightforward.

Russ

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 15 Jul 2018 16:10:31 +0000

Thanks for digging it up.  I agree, the draft syntax makes a lot of sense, my concern is gone. :)

SET convoluted; who would have thought?

---

From: Sean Turner <[email-masked]>
Date: Thu, 19 Jul 2018 15:46:00 -0400

> On Jul 14, 2018, at 12:18, Salz, Rich <rsalz=[email-masked]> wrote:
> 

Yep me too: support..

spt

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 19 Jul 2018 16:09:18 -0400

I've read  andI support this one for adoption. .

Tim

On Thu, Jul 19, 2018 at 3:46 PM, Sean Turner <[email-masked]> wrote:

> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm
>