Subject: [lamps] [Technical Errata Reported] RFC8398 (5418)

From: RFC Errata System <[email-masked]>
Date: Wed, 11 Jul 2018 12:46:08 -0700 (PDT)

The following errata report has been submitted for RFC8398,
"Internationalized Email Addresses in X.509 Certificates".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5418

--------------------------------------
Type: Technical
Reported by: Belyavskiy Dmitry <[email-masked]>

Section: Appendix B

Original Text
-------------
   This non-normative example demonstrates using SmtpUTF8Mailbox as an
   otherName in GeneralName to encode the email address
   "[email-masked]".

      The hexadecimal DER encoding of the email address is:
      A022060A 2B060105 05070012 0809A014 0C12E880 81E5B8AB 40657861
      6D706C65 2E636F6D

      The text decoding is:
        0  34: [0] {
        2  10:   OBJECT IDENTIFIER '1 3 6 1 5 5 7 0 18 8 9'
       14  20:   [0] {
       16  18:     UTF8String [email-masked]'
             :     }
             :   }

                                 Figure 2

   The example was encoded on the OSS Nokalva ASN.1 Playground and the
   above text decoding is an output of Peter Gutmann's "dumpasn1"
   program.

Corrected Text
--------------
   This non-normative example demonstrates using SmtpUTF8Mailbox as an
   otherName in GeneralName to encode the email address
   "u+533Bu+751F@u+5927u+5B66.example.com".

   The hexadecimal DER encoding of the block is:
   a0330608 2b060105 05070809 a0270c25 c3a5c28c c2bbc3a7 c294c29f 
   40c3a5c2 a4c2a7c3 a5c2adc2 a62e6578 616d706c 652e636f 6d

   The text decoding is:
     2  51: [0] {
     4   8:   OBJECT IDENTIFIER '1 3 6 1 5 5 7 8 9'
    14  39:   [0] {
    16  37:     UTF8String '..@...example.com'
          :     }
          :   }

                                 Figure 2

   The example was encoded on the OSS Nokalva ASN.1 Playground and the
   above text decoding is an output of Peter Gutmann's "dumpasn1"
   program.

Notes
-----
The OID used in Appendix B does not match the OID for id-on-SmtpUTF8Mailbox defined in "Appendix A.  ASN.1 Module" and is not mentioned anywhere in the RFC.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8398 (draft-ietf-lamps-eai-addresses-18)
--------------------------------------
Title               : Internationalized Email Addresses in X.509 Certificates
Publication Date    : May 2018
Author(s)           : A. Melnikov, Ed., W. Chuang, Ed.
Category            : PROPOSED STANDARD
Source              : Limited Additional Mechanisms for PKIX and SMIME
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Wei Chuang <[email-masked]>
Date: Wed, 11 Jul 2018 14:49:16 -0700

Hi all,

I agree with the errata report.  Background is that I've already been
discussing with Dmitry the bug, and suggested he file the errata so we can
make the change.  The bug is in the SmtpUTF8Mailbox OID
<https://www.iana.org/assignments/smi-numbers/smi-numbers.xhtml#smi-numbers-1.3.6.1.5.5.7.8>
in the example <https://tools.ietf.org/html/rfc8398#appendix-B> found in
the Appendix.  I also agree with him that we can update the email address
to be consistent with the earlier example on page 6 in case the original is
confusing.

-Wei

On Wed, Jul 11, 2018 at 12:46 PM RFC Errata System <
[email-masked]> wrote:

> The OID used in Appendix B does not match the OID for
> id-on-SmtpUTF8Mailbox defined in "Appendix A.  ASN.1 Module" and is not
> mentioned anywhere in the RFC.
>
> Instructions:
> -------------

---

From: Russ Housley <[email-masked]>
Date: Thu, 19 Jul 2018 08:51:35 -0400

It looks like you should approve this errata.  Do you need anything else from the WG?

Russ

> From: Wei Chuang <weihaw=[email-masked]>
> Subject: Re: [lamps] [Technical Errata Reported] RFC8398 (5418)
> Date: July 11, 2018 at 5:49:16 PM EDT
> To: [email-masked]
> Cc: [email-masked], Russ Housley <[email-masked]>, SPASM <[email-masked]>, [email-masked], Alexey Melnikov <[email-masked]>, Dmitry Belyavsky <[email-masked]>, [email-masked]
> 
> Hi all,
> 
> I agree with the errata report.  Background is that I've already been discussing with Dmitry the bug, and suggested he file the errata so we can make the change.  The bug is in the SmtpUTF8Mailbox OID <https://www.iana.org/assignments/smi-numbers/smi-numbers.xhtml#smi-numbers-1.3.6.1.5.5.7.8> in the example <https://tools.ietf.org/html/rfc8398#appendix-B> found in the Appendix.  I also agree with him that we can update the email address to be consistent with the earlier example on page 6 in case the original is confusing.
> 
> -Wei
> 
> On Wed, Jul 11, 2018 at 12:46 PM RFC Errata System <[email-masked] <mailto:[email-masked]>> wrote:
> http://www.rfc-editor.org/errata/eid5418 <http://www.rfc-editor.org/errata/eid5418>
> 
> Reported by: Belyavskiy Dmitry <[email-masked] <mailto:[email-masked]>>
> 
> Section: Appendix B
> 
> Original Text
> -------------
>    "[email-masked] <mailto:[email-masked]>".
> 
>        16  18:     UTF8String [email-masked] <http://example.com/>'
>              :     }
>              :   }
> 
>                                  Figure 2
> 
>    "u+533Bu+751F@u+5927u+5B66.example.com <http://5b66.example.com/>".
> 
>     16  37:     UTF8String '..@...example.com <http://example.com/>'
>           :     }
>           :   }
> 
>                                  Figure 2
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm

---

From: Wei Chuang <[email-masked]>
Date: Thu, 19 Jul 2018 10:14:38 -0700

Apologies as I'm new to the errata process.  Do I get nominated to be a
errata verifier? as there appears to be a login page before I can review
which it sounds like the WG sets up.

The documentation here <https://www.rfc-editor.org/how-to-verify/> says
"The verifying party (or stream-specific party) is determined by the stream
that produced the RFC: IETF, IAB, IRTF, or Independent Submission" which I
assume is the WG.

-Wei

On Thu, Jul 19, 2018 at 5:51 AM Russ Housley <[email-masked]> wrote:

> *From: *Wei Chuang <weihaw=[email-masked]>
> *Subject: **Re: [lamps] [Technical Errata Reported] RFC8398 (5418)*
> *Date: *July 11, 2018 at 5:49:16 PM EDT
> *To: [email-masked]
> *Cc: [email-masked], Russ Housley <[email-masked]>, SPASM <
> [email-masked]>, [email-masked], Alexey Melnikov <[email-masked]>,
> Dmitry Belyavsky <[email-masked]>, [email-masked]
>
> Hi all,
>
>>        16  18:     UTF8String [email-masked]'
>>              :     }
>>              :   }
>>
>>                                  Figure 2
>>

---

From: Russ Housley <[email-masked]>
Date: Thu, 19 Jul 2018 13:37:54 -0400

Wei:

No, but the WG is providing input to the errata reviewer, who is the Area Director.

Russ

> On Jul 19, 2018, at 1:14 PM, Wei Chuang <[email-masked]> wrote:
> 
> Apologies as I'm new to the errata process.  Do I get nominated to be a errata verifier? as there appears to be a login page before I can review which it sounds like the WG sets up.
> 
> The documentation here <https://www.rfc-editor.org/how-to-verify/> says "The verifying party (or stream-specific party) is determined by the stream that produced the RFC: IETF, IAB, IRTF, or Independent Submission" which I assume is the WG.
> 
> -Wei
> 
> On Thu, Jul 19, 2018 at 5:51 AM Russ Housley <[email-masked] <mailto:[email-masked]>> wrote:
>> From: Wei Chuang <weihaw=[email-masked] <mailto:weihaw=[email-masked]>>
>> To: [email-masked] <mailto:[email-masked]>
>> Cc: [email-masked] <mailto:[email-masked]>, Russ Housley <[email-masked] <mailto:[email-masked]>>, SPASM <[email-masked] <mailto:[email-masked]>>, [email-masked] <mailto:[email-masked]>, Alexey Melnikov <[email-masked] <mailto:[email-masked]>>, Dmitry Belyavsky <[email-masked] <mailto:[email-masked]>>, [email-masked] <mailto:[email-masked]>
>> 
>> Hi all,
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/spasm <https://www.ietf.org/mailman/listinfo/spasm>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/spasm <https://www.ietf.org/mailman/listinfo/spasm>