Subject: [lamps] Need SHA-3 text strings, add to draft-ietf-lamps-pkix-shake?

From: Sean Leonard <[email-masked]>
Date: Thu, 28 Mar 2019 18:05:30 +0100

I have a need to identify SHA-3 algorithms by text strings. For example: SHA3-256, SHA3-512, etc.

There is an IANA registry aptly named “Hash Function Textual Names”: <https://www.iana.org/assignments/hash-function-text-names/hash-function-text-names.xhtml>.

How do I add the SHA-3 algorithms to Hash Function Textual Names? The registry says that registration requires a standards-track RFC that updates RFC 3279. Yep, that’s what it says.

draft-turner-lamps-adding-sha3-to-pkix
became
draft-ietf-lamps-pkix-shake

which is now in last call. But draft-ietf-lamps-pkix-shake says “Four other hash function instances, SHA3-224, SHA3-256, SHA3-384, and SHA3-512 are also defined but are out of scope for this document.” So I am not sure where to go for this request. Suggestions? And what about adding textual names for SHAKE-128 and SHAKE-256? (Which are not in-scope for my particular need, but there there nonetheless.)

Thanks,

Sean

---

From: Russ Housley <[email-masked]>
Date: Thu, 28 Mar 2019 13:09:04 -0400

The working group decided to not proceed with draft-turner-lamps-adding-sha3-to-pkix

Russ

> On Mar 28, 2019, at 1:05 PM, Sean Leonard <[email-masked]> wrote:
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm