Subject: [lamps] RFC 5480 clarification for KeyUsages: keyEncipherment and dataEncipherment

From: Sean Turner <[email-masked]>
Date: Sat, 23 Mar 2019 23:19:00 +0100

Hi!

RFC 5480 enumerates the KeyUsage values that are included for an EC key:
https://tools.ietf.org/html/rfc5480#section-3
But, we neglected to mention keyEncipherment and dataEncipherment.  Does that mean these values MAY be included, MUST NOT be included, or something else?  And, is this worth spinning a short draft to clarify RFC 5480?

spt

---

From: Russ Housley <[email-masked]>
Date: Sun, 24 Mar 2019 02:33:13 -0400

> But, we neglected to mention keyEncipherment and dataEncipherment.  Does that mean these values MAY be included, MUST NOT be included, or something else?  And, is this worth spinning a short draft…

My understanding is that the algorithms in RFC 5480 are key agreement and digital signature algorithms, so neither keyEncipherment and dataEncipherment are appropriate.  I read it as these bits MUST NOT be set.

Russ

---

From: Jim Schaad <[email-masked]>
Date: Sun, 24 Mar 2019 08:48:59 +0100

> -----Original Message-----
> From: Spasm <[email-masked]> On Behalf Of Russ Housley
> Sent: Sunday, March 24, 2019 7:33 AM
> To: Sean Turner <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [lamps] RFC 5480 clarification for KeyUsages: keyEncipherment
> and dataEncipherment
> 
> Sean:
> >
> > But, we neglected to mention keyEncipherment and dataEncipherment.
> Does that mean these values MAY be included, MUST NOT be included, or
> something else?  And, is this worth spinning a short draft to clarify RFC
5480?
> 
> My understanding is that the algorithms in RFC 5480 are key agreement and
> digital signature algorithms, so neither keyEncipherment and
> dataEncipherment are appropriate.  I read it as these bits MUST NOT be
set.

My reading is that if nothing is said, then nothing is said.  I would agree
that these bits make no sense in general, but this is a public key so there
may be an algorithm which uses the EC key and does keyEncipherment.  In this
case it would be appropriate to have them set.  Think of an algorithm
identifier which is KeyAgree+KDF+KeyWrap as a single OID.  These two bits
however were created for algorithms which the IETF has never looked at
using.

Jim

> 
> Russ
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm