Subject: [lamps] I-D Action: draft-ietf-lamps-cms-shakes-08.txt

From: [email-masked]
Date: Fri, 08 Mar 2019 05:54:18 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Limited Additional Mechanisms for PKIX and SMIME WG of the IETF.

        Title           : Use of the SHAKE One-way Hash Functions in the Cryptographic Message Syntax (CMS)
        Authors         : Panos Kampanakis
                          Quynh Dang
	Filename        : draft-ietf-lamps-cms-shakes-08.txt
	Pages           : 16
	Date            : 2019-03-08

Abstract:
   This document describes the conventions for using the SHAKE family of
   hash functions with the Cryptographic Message Syntax (CMS) as one-way
   hash functions with the RSA Probabilistic signature and ECDSA
   signature algorithms, as message digests and message authentication
   codes.  The conventions for the associated signer public keys in CMS
   are also described.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lamps-cms-shakes/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-lamps-cms-shakes-08
https://datatracker.ietf.org/doc/html/draft-ietf-lamps-cms-shakes-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lamps-cms-shakes-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Fri, 8 Mar 2019 14:07:05 +0000

This version of the draft address two minor nits in the draft:
- id-shake128-len and id-shake256-len still left over from previous versions of the draft were replace by id-shake128 and id-shake256 with 32 and 64bytes output lengths. Russ H. caught this last week. 
- an inconsistency about the KMAC OIDs optional parameters in sections 3 and 4.4. 

It should cover all feedback we have received as well.

Panos

-----Original Message-----
From: Spasm <[email-masked]> On Behalf Of [email-masked]
Sent: Friday, March 08, 2019 8:54 AM
To: [email-masked]
Cc: [email-masked]
Subject: [lamps] I-D Action: draft-ietf-lamps-cms-shakes-08.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Spasm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spasm