Subject: [lamps] Mirja Kühlewind's No Objection on draft-ietf-lamps-hash-of-root-key-cert-extn-05: (with COMMENT)

From: Mirja Kühlewind via Datatracker <[email-masked]>
Date: Wed, 22 May 2019 10:35:22 -0700

Mirja Kühlewind has entered the following ballot position for
draft-ietf-lamps-hash-of-root-key-cert-extn-05: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lamps-hash-of-root-key-cert-extn/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Why is the intended status informational? Unfortunately, this is not further
explained in the shepherd write-up. What was the discussion in the group and
why was informational selected? As this doc defines a protocol extension,
informational does not seem appropriate for me. Should it be experimental
instead?

Quick question/comment: The document mentions two “error” cases where a new
self-signed certificate needs to be deployed. If that is an option that always
need to be taken into account, the benefits of this mechanism are less clear to
me. What is the exact attack scenarios this mechanism tries to protect?

---

From: Russ Housley <[email-masked]>
Date: Wed, 22 May 2019 14:13:18 -0400

> informational does not seem appropriate for me. Should it be experimental

This document was originally expected to be published on the Independent Stream, but the Security Area Director at the time asked the ISE to send the document to the LAMPS WG. Since it was already submitted to the Independent Stream for publication as Informational RFC, the topic never came up about a different publication status.

The LAMPS WG discussion started here: https://mailarchive.ietf.org/arch/msg/spasm/o7aDwt5VMXCyL5UeLHrZxrdQjaA <https://mailarchive.ietf.org/arch/msg/spasm/o7aDwt5VMXCyL5UeLHrZxrdQjaA>

> me. What is the exact attack scenarios this mechanism tries to protect?

Deploying a new self-signed certificate is a much more complex task.  While this is the fallback situation if things go wrong, the deployment of replacement self-signed certificate is much simpler when things work.

Russ