Subject: Re: [lamps] LAMPS at IETF 105

From: "Dr. Pala" <[email-masked]>
Date: Thu, 2 May 2019 11:04:39 -0600

Hi Russ, Tim, all,

On the Composite Crypto discussion at the last IETF, I think we will be 
ready to present on the unified draft proposal that we would like to 
discuss in LAMPS and, if we are ready, look into asking for adoption of 
the document.

Cheers,
Max

On 4/23/19 5:10 PM, Russ Housley wrote:
> In the last few days before IETF 104, we got a flurry of requests to present in the LAMPS WG.  In an effort to learn about them sooner, we are asking whether anyone has topics to discuss in July at IETF 105.  The IESG is going through the re-charter process, so we can assume that the header protection work item will be approved by the time that we meet in July.
>
> Russ & Tim
>
-- 
Best Regards,
Massimiliano Pala, Ph.D.
OpenCA Labs Director
OpenCA Logo

---

From: Russ Housley <[email-masked]>
Date: Thu, 2 May 2019 14:07:16 -0400

Max:

Do you believe that the current charter covers you proposed way forward?

Russ

> On May 2, 2019, at 1:04 PM, Dr. Pala <[email-masked]> wrote:
> 
> Hi Russ, Tim, all,
> 
> On the Composite Crypto discussion at the last IETF, I think we will be ready to present on the unified draft proposal that we would like to discuss in LAMPS and, if we are ready, look into asking for adoption of the document.
> 
> Cheers,
> Max
> 
>

---

From: "Dr. Pala" <[email-masked]>
Date: Thu, 2 May 2019 12:53:45 -0600

Hi Russ,

I was just reviewing it [*] and I do not think it does. I was thinking 
that if the WG will be interested in the adoption of the document, then 
we will have to explicitly add a new entry to the list of items in the 
Charter.

I am thinking that the entry might look like the following (but not 
proposing the re-chartering before the group reviews the combined draft):

    Specify the use of composite signatures and keys for PKIX. In recent years,
    the crypto communities have been very active in identifying new public key
    algorithms with different security properties and performances (e.g., ECC,
    Hash-Based, etc.). However, it is not always easy to establish if a new
    algorithm has been studied enough or if (and when) an old algorithm might
    fall apart. An example of this uncertainty, today, is related to quantum-resistant
    algorithms vs. "traditional" ones. The possibility for combining algorithms
    with different properties provides support for less risky transitioning strategies
    for deploying new algorithms by enabling deferred algorithm agility.

This is just an example of the required additional item for the charter 
to get the work in scope, I guess :D

Cheers,
Max

[*] = https://datatracker.ietf.org/doc/charter-ietf-lamps/

On 5/2/19 2:07 PM, Russ Housley wrote:
>> On May 2, 2019, at 1:04 PM, Dr. Pala <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> Hi Russ, Tim, all,
>>
>> On the Composite Crypto discussion at the last IETF, I think we will 
>> be ready to present on the unified draft proposal that we would like 
>> to discuss in LAMPS and, if we are ready, look into asking for 
>> adoption of the document.
>>
>> Cheers,
>> Max
>>
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm
-- 
Best Regards,
Massimiliano Pala, Ph.D.
OpenCA Labs Director
OpenCA Logo

---

From: Russ Housley <[email-masked]>
Date: Thu, 2 May 2019 15:05:19 -0400

Max:

Please start a separate thread, with an appropriate subject line to talk about the addition to the LAMPS charter that you are suggesting.  I do not want anyone to miss it because of the subject line.

Rus

> On May 2, 2019, at 2:53 PM, Dr. Pala <[email-masked]> wrote:
> 
> Hi Russ,
> 
> I was just reviewing it [*] and I do not think it does. I was thinking that if the WG will be interested in the adoption of the document, then we will have to explicitly add a new entry to the list of items in the Charter. 
> 
> I am thinking that the entry might look like the following (but not proposing the re-chartering before the group reviews the combined draft):
> 
> This is just an example of the required additional item for the charter to get the work in scope, I guess :D
> 
> Cheers,
> Max
> 
> 
> 
> [*] = https://datatracker.ietf.org/doc/charter-ietf-lamps/ <https://datatracker.ietf.org/doc/charter-ietf-lamps/>
>>> On May 2, 2019, at 1:04 PM, Dr. Pala <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Hi Russ, Tim, all,
>>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/spasm <https://www.ietf.org/mailman/listinfo/spasm>
> -- 
> Best Regards,
> Massimiliano Pala, Ph.D.
> OpenCA Labs Director

---

From: "Dr. Pala" <[email-masked]>
Date: Thu, 2 May 2019 13:55:05 -0600

Hi all,

as per Russ request, I am re-posting the message with a more specific 
Subject (so that people do not miss it) :D

----- ORIGINAL MESSAGE [$] -----

Hi Russ,

I was just reviewing the charter [*] and I do not think it supports the 
Composite Crypto work. I was thinking that if the WG will be interested 
in the adoption of the document, then we will have to explicitly add a 
new entry to the list of items in the Charter. From the last meeting, it 
seemed that there were no major objections to working on this proposal, 
but no official voting was requested  at that time (it was too early, I 
think :D).

For the charter, I am thinking that the new entry might look like the 
following (but not proposing the re-chartering before the group reviews 
the combined draft):

    when deploying new algorithms by enabling deferred algorithm agility.

This is just an example of the required additional item for the charter 
to get the work in scope, I guess :D Please let me know what you think...

Cheers,
Max

[$] = Small Editorial changes applied

-- 
Best Regards,
Massimiliano Pala, Ph.D.
OpenCA Labs Director
OpenCA Logo